Subject: Re: [IPsec] Clarifications and Implementation Guidelines for using TCP Encapsulation in IKEv2 draft

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 3 May 2020 15:49:14 -0700

On Wed, Apr 29, 2020 at 10:54:26PM +0300, Yoav Nir wrote:
> [With chair hat on]
> 
> Yes, the charter says that we are to make a guidance document. If the working group feels that it’s better to put the specification and guidance in a single document, we can work on that and clear it with the ADs. 
> 
> Charters can be modified.

FWIW I don't see a particular need to recharter to do an 8229bis.

-Ben

---

From: "Valery Smyslov" <[email-masked]>
Date: Mon, 4 May 2020 09:07:08 +0300

Hi Ben,

> > Yes, the charter says that we are to make a guidance document. If the
> working group feels that it’s better to put the specification and guidance in a
> single document, we can work on that and clear it with the ADs.
> >

Can you please clarify for those of us who (like me) are not native speakers:
do you think that the current charter allows to do an 8229bis without need to recharter
or do you think there is no need to do an 8229bis and thus no need to recharter?

Thank you,
Valery.

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 8 May 2020 17:00:12 -0700

> or do you think there is no need to do an 8229bis and thus no need to recharter?

Sorry!  I think that the current charter allows us to do an 8229bis without
additional rechartering.

-Ben

---

From: Tero Kivinen <[email-masked]>
Date: Sun, 10 May 2020 14:20:07 +0300

Benjamin Kaduk writes:
> Sorry! I think that the current charter allows us to do an 8229bis
> without additional rechartering.

Good.

I myself think it is better to do bis documents than just
clarification guidelines as splitting things to multiple documents do
make things harder to implement.

Also I think that currently everything in the draft is really a
clarification to the original document, i.e. something that the
original document should have already said more clearly, and in some
cases there are new rules to be added to the processing of the
packets.

There are no real implementation guidelines in the current draft,
i.e., something that would say something like "when doing xxx, it is
often good idea to do yyy also", or "to implement zzz, algorithm like
aaa is good, but others can also be used". I.e., cases where there are
multiple ways of doing same thing, and any of them can be used, but
some of them has been found to be better than others.

Because of this I think it would be quite natural to start making the
bis document instead of clarification document if authors are willing
to work on such draft too...
-- 
[email-masked]