Subject: [IPsec] Some cosmetic cleanup to IPTFS draft.

From: Christian Hopps <[email-masked]>
Date: Wed, 25 Nov 2020 08:35:23 -0500

Hi Folks,

Valery has indicated in private thread as a pre-WGLC comment, that as the IP-TFS encapsulation can be used for purposes other than IP-TFS we should mention that, and rename a couple items so that future derivative work doesn't seem "hackish".

These changes don't change the draft or functionality.

Here are the following cosmetic changes Valery and I agreed on:

Title would change to:

   "IP Traffic Flow Security using Aggregation and Fragmentation"

ESP type name "IPTFS_PROTOCOL" would change to "AGGFRAG_PROTOCOL"

IKEv2 notification name would change from "USE_IPTFS" to "USE_AGGFRAG"

An additional short section would be added:

** Non-TFS Uses
    Other non-TFS uses of the aggregation and fragmentation encapsulation have been identified, such as increased performance through packet aggregation, as well as handling MTU issues using fragmentation. These uses are not defined here, but are also not restricted by this document.

Does anyone have any objections to these changes?

Thanks,
Chris.

---

From: Paul Wouters <[email-masked]>
Date: Wed, 25 Nov 2020 09:21:32 -0500

No objection from me although not a great fan of “AGGFRAG” :)

Paul

Sent from my iPhone

> On Nov 25, 2020, at 08:35, Christian Hopps <[email-masked]> wrote:
> 
> AGGFRAG

---

From: "Valery Smyslov" <[email-masked]>
Date: Wed, 25 Nov 2020 17:29:12 +0300

Hi Paul,

> No objection from me although not a great fan of “AGGFRAG” :)

Just for clarification: me too. But it serves its purpose :-)
Can you suggest better variant?

Regards,
Valery.

> _______________________________________________
> IPsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipsec