Subject: [IPsec] I-D Action: draft-ietf-ipsecme-ikev1-algo-to-historic-00.txt

From: [email-masked]
Date: Wed, 28 Apr 2021 08:41:20 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Security Maintenance and Extensions WG of the IETF.

        Title           : Deprecation of IKEv1 and obsoleted algorithms
        Author          : Paul Wouters
	Filename        : draft-ietf-ipsecme-ikev1-algo-to-historic-00.txt
	Pages           : 7
	Date            : 2021-04-28

Abstract:
   Internet Key Exchange version 1 (IKEv1) is deprecated.  Accordingly,
   IKEv1 has been moved to Historic status.  A number of old algorithms
   that are associated with IKEv1, and not widely implemented for IKEv2
   are deprecated as well.  This document adds a Status column to the
   IANA IKEv2 Transform Type registries.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ipsecme-ikev1-algo-to-historic/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ipsecme-ikev1-algo-to-historic-00
https://datatracker.ietf.org/doc/html/draft-ietf-ipsecme-ikev1-algo-to-historic-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Paul Wouters <[email-masked]>
Date: Wed, 28 Apr 2021 11:48:59 -0400 (EDT)

On Wed, 28 Apr 2021, [email-masked] wrote:

> Subject: [IPsec] I-D Action: draft-ietf-ipsecme-ikev1-algo-to-historic-00.txt

Looks like the datatracker email does not post the diff between
different document names :P

The diff is:

https://tools.ietf.org/rfcdiff?url1=draft-pwouters-ikev1-ipsec-graveyard-06.txt&url2=https://www.ietf.org/archive/id/draft-ietf-ipsecme-ikev1-algo-to-historic-00.txt

Basically, it removes the IANA request to close the IKEv1 registries,
changes draft name / title to avoid "graveyard" and lists some items
as bullet points and sections, and changes some subjective wording to
more objective language.

I'm not saying this is ready for WGLC, but ....

Paul