Subject: RE: [IPTEL] A proposal for moving iptel forward

From: "Roy, Radhika R, ALASO" <[email-masked]>
Date: Tue, 26 Feb 2002 12:27:28 -0500

In addition, I have to a little more.

In TRIP, the LS <-> LS communications are in INTER-Domain mode.

In TRIP-GW, the GW <-> LS communications are in INTRA-Domain mode.

So, the TRIP-GW (or TRIP-Lite) spec MUST differentiate the above two modes of communications clearly removing all ambiguities.

People will also appreciate if the TRIP-GW spec clearly specifies what needs to be done in the situation where there can be many LSs and GWs in a given ITAD (or in a given domain -> INTRA-Domain).

Best regards,

Radhika R. Roy
[email-masked]

-----Original Message-----
From: Roy, Radhika R, ALASO 
Sent: Tuesday, February 26, 2002 10:27 AM
To: Hussein F. Salama
Cc: Jonathan Rosenberg; Peterson, Jon; list iptel
Subject: RE: [IPTEL] A proposal for moving iptel forward

Inline [RRR]

-----Original Message-----
From: Hussein F. Salama [mailto:[email-masked]]
Sent: Monday, February 25, 2002 3:06 PM
To: Roy, Radhika R, ALASO
Cc: Jonathan Rosenberg; Peterson, Jon; list iptel
Subject: Re: [IPTEL] A proposal for moving iptel forward

"Roy, Radhika R, ALASO" wrote:

> By the way, we have also submitted a draft for adding the GW identification (GW ID) in J. Rosenberg, et. al.'s TRIP-GW draft.

Why isn't the TRIP Identifier of the Open Header sufficient?

[RRR] The definition of the TRIP identifier is as follows:

   "TRIP Identifier:
   This 4-octet unsigned integer indicates the TRIP Identifier of the
   sender. The TRIP Identifier MUST uniquely identify this LS within its
   ITAD. A given LS MAY set the value of its TRIP Identifier to an IPv4
   address assigned to that LS. ..."

So, it identifies the LS, not the gateway (GW). So, it is believed that a GW ID is needed, and the TRIP standard needs to be enhanced to differentiate between the LS ID and the GW ID.

Hussein

>
> This is in addition to the CIC.
>
> I think that we can complete the discussion via emails for this.
>
> Radhika R. Roy
> [email-masked]
>
> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Saturday, February 23, 2002 8:39 AM
> To: Peterson, Jon
> Cc: list iptel
> Subject: Re: [IPTEL] A proposal for moving iptel forward
>
> "Peterson, Jon" wrote:
> >
>
> > > With advocates in each camp (primarily the authors). We made an
> > attempt
> > > to get around this impasse through requirements work, but there was
> > not
> > > sufficient working group effort expended to bear fruit in that
> > > direction. So, the result has been no progress.
> > >
> >
> > One hates to be a naysayer, but I find myself saying nay nonetheless, if
> > only because I feel that discussion of the trunk-group model we were
> > batting
> > around was fairly lively before we all fell into the Abyss of Bis.
> >
> > In any event, I did take some time to put together an I-D summarizing
> > what I
> > perceived to be the results of that discussion - but if the group is
> > really
> > happy with the current proposals, then I won't be disappointed if the
> > I-D is
> > ignored. I certainly know that we'd like to close this WG.
>
> Jon, please feel free to submit the draft. The decision I am asking for
> is not to take the draft as is, but rather to accept is as a work item,
> and work on it under the assumption of a trip framework.
> Addition/removal of attributes, address families, models for trunk
> groups, and so on, are exactlly the things we need to finish fleshing
> out. I suspect that is the stuff of your draft, and such things would be
> most appreciated.
>
> -Jonathan R.
>
> --
> Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
> Chief Scientist                         First Floor
> dynamicsoft                             East Hanover, NJ 07936
> [email-masked]                 FAX: (973) 952-5050
> http://www.jdrosen.net                  PH:  (973) 952-5000
> http://www.dynamicsoft.com
> _______________________________________________
> IPTEL mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/iptel
> _______________________________________________
> IPTEL mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/iptel

--
Hussein F. Salama
Cisco Systems
Mail Stop SJC-24/3, 170 W. Tasman Drive, San Jose, CA 95134
Voice: +1 (408) 527-7147, Fax: +1 (408) 527-7147

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel
_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: "Hussein F. Salama" <[email-masked]>
Date: Tue, 26 Feb 2002 10:24:07 -0800

> In TRIP, the LS <-> LS communications are in INTER-Domain mode.

No, two LSs may be in the same ITAD.

> In TRIP-GW, the GW <-> LS communications are in INTRA-Domain mode.

This is not what the draft recommends. Check Section 4.9 and Figure 5.

Thanks.

Hussein