Subject: RE: [IPTEL] A proposal for moving iptel forward

From: "Ignacio M Sierra Ruiz" <[email-masked]>
Date: Fri, 22 Feb 2002 09:43:25 +0100

yea

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: "Roy, Radhika R, ALASO" <[email-masked]>
Date: Tue, 26 Feb 2002 14:36:54 -0500

inline [RRR]

-----Original Message-----
From: Hussein F. Salama [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 1:24 PM
To: Roy, Radhika R, ALASO
Cc: Jonathan Rosenberg; Peterson, Jon; list iptel
Subject: Re: [IPTEL] A proposal for moving iptel forward

"Roy, Radhika R, ALASO" wrote:

> In addition, I have to a little more.
>
> In TRIP, the LS <-> LS communications are in INTER-Domain mode.

No, two LSs may be in the same ITAD.

[RRR] Yes. However, the spec is SILENT about the INTRA-Domain LSs communications. (Probably, it has been left for the I-TRIP) I believe that the semantics of the GW-ID have not been addressed. 

[RRR] Our main focus should the TRIP-GW proposal. In this context, this proposal needs to be enhanced. I wish I would suggest some texts for enhancements, if time permits.

>
> In TRIP-GW, the GW <-> LS communications are in INTRA-Domain mode.

This is not what the draft recommends. Check Section 4.9 and Figure 5.

[RRR] Yes, I saw it. Are you saying the same semantics for the GW-ID and LS-ID can be used leaving no room for ambiguities? Even if you allow to do so, the texts need to be rewritten in the TRIP-GW proposal, I believe.

[RRR] (However, a little more extra work may be needed, if the spec likes to address the situations where there are many GWs and LSs in a domain. For example, how GWs will choose their respective LSs, etc. [may pre-provisioned in absence of discovery, etc.])

Thanks.

Hussein

>
>
> So, the TRIP-GW (or TRIP-Lite) spec MUST differentiate the above two modes of communications clearly removing all ambiguities.
>
> People will also appreciate if the TRIP-GW spec clearly specifies what needs to be done in the situation where there can be many LSs and GWs in a given ITAD (or in a given domain -> INTRA-Domain).
>
> Best regards,
>
> Radhika R. Roy
> [email-masked]
>
> -----Original Message-----
> From: Roy, Radhika R, ALASO
> Sent: Tuesday, February 26, 2002 10:27 AM
> To: Hussein F. Salama
> Cc: Jonathan Rosenberg; Peterson, Jon; list iptel
> Subject: RE: [IPTEL] A proposal for moving iptel forward
>
> Inline [RRR]
>
> -----Original Message-----
> From: Hussein F. Salama [mailto:[email-masked]]
> Sent: Monday, February 25, 2002 3:06 PM
> To: Roy, Radhika R, ALASO
> Cc: Jonathan Rosenberg; Peterson, Jon; list iptel
> Subject: Re: [IPTEL] A proposal for moving iptel forward
>
> "Roy, Radhika R, ALASO" wrote:
>
> > By the way, we have also submitted a draft for adding the GW identification (GW ID) in J. Rosenberg, et. al.'s TRIP-GW draft.
>
> Why isn't the TRIP Identifier of the Open Header sufficient?
>
> [RRR] The definition of the TRIP identifier is as follows:
>
>    "TRIP Identifier:
>    This 4-octet unsigned integer indicates the TRIP Identifier of the
>    sender. The TRIP Identifier MUST uniquely identify this LS within its
>    ITAD. A given LS MAY set the value of its TRIP Identifier to an IPv4
>    address assigned to that LS. ..."
>
> So, it identifies the LS, not the gateway (GW). So, it is believed that a GW ID is needed, and the TRIP standard needs to be enhanced to differentiate between the LS ID and the GW ID.
>
> Hussein
>
> >
> > This is in addition to the CIC.
> >
> > I think that we can complete the discussion via emails for this.
> >
> > Radhika R. Roy
> > [email-masked]
> >
> > -----Original Message-----
> > From: Jonathan Rosenberg [mailto:[email-masked]]
> > Sent: Saturday, February 23, 2002 8:39 AM
> > To: Peterson, Jon
> > Cc: list iptel
> > Subject: Re: [IPTEL] A proposal for moving iptel forward
> >

---

From: "Roy, Radhika R, ALASO" <[email-masked]>
Date: Tue, 26 Feb 2002 14:40:47 -0500

Inline [RRR]

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 12:21 PM
To: Roy, Radhika R, ALASO
Cc: Hussein F. Salama; Peterson, Jon; list iptel
Subject: Re: [IPTEL] A proposal for moving iptel forward

"Roy, Radhika R, ALASO" wrote:
> So, it identifies the LS, not the gateway (GW). 

No.

LS is a logical element that participates in TRIP. With TRIP-GW, that
element is the gateway, and therefore the gateway is an LS. You are
confusing logical roles with physical implementations. 

[RRR] I would agree with this, if it is clarified in the text. So far, I have not seen this clarification in the spec. (Did I miss it?)

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com
_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel