Subject: Re: [Iptel] Finalizing trunk-group I-D

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 06 Jan 2005 14:44:02 -0600

Shan Lu wrote:
> Vijay,
> 
> I like your proposal in spirit, but am weary of the (over)use of
> "anonymous". 

Shan Lu:

Sorry for the delayed response.  Please see inline.

> For everybody's benefit, you propose the following format when
> calling party number is absent:
> 
> Contact: <sip:anonymous;phone-context=example.com;tgrp=[email-masked]>,
> 
> where the origination TG is "foo".
[...]
> OTOH, what we want is to convey to the recipient of Contact header the
> following: the SIP URI userinfo in Contact is a "quasi-" tel URI in that any
> subsequent fields following the first semi-colon must be treated as tel URI
> parameters, including ";tgrp=". 
> 
> I believe a keyword different than "anonymous" serves this purpose better.
> For example, we don't have to consider the subtle difference between
> "presentation restricted" and "address unavailable". My suggestion is
> "telurifmt", i.e.:
> 
> Contact: <sip:telurifmt;tgrp=[email-masked]>.

Personally, I have no problem with this; however, I am a
little confused...I believe that we were avoiding registering
a new token with IANA, hence "anonymous" was suggested since its use
and semantics are well established in the field.

Using "telurifmt" puts us back to the same place: what if
"telurifmt" actually means something to someone?

If you don't think this will be a problem, then I am more
inclined to proceed on it and close this issue down.

Thanks,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and Services
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216

_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

---

From: "Shan Lu" <[email-masked]>
Date: Fri, 7 Jan 2005 09:59:51 -0500

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of Vijay K. Gurbani
>Sent: Thursday, January 06, 2005 3:44 PM
>To: Shan Lu
>Cc: 'IETF IPTEL WG'; [email-masked]
>Subject: Re: [Iptel] Finalizing trunk-group I-D
>
>
<snip>
>and semantics are well established in the field.

True. But none of existing usages carries the same semantic we want for
tgrp. Worse, they could interfere with each other.
   
>inclined to proceed on it and close this issue down.

Pick your favorite poison :-). My vote is for a new keyword different than
"anonymous".

Thanks, Shan Lu