Subject: RE: [Iptel] The 'npdi' parameter

From: "Yu, James" <[email-masked]>
Date: Tue, 24 Jan 2006 10:38:24 -0500

Paul's answer is correct.   If a sip URI does not carry the phone number
(e.g., sip:[email-masked]), npdi is meaningless in the sip URI.    If
the sip URI carries the phone numbers (e.g., with user=phone), then all
the tel URI parameters including the npdi, rn and other could be
included in the user part of that sip URI.

James

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Paul Kyzivat
Sent: Tuesday, January 24, 2006 10:28 AM
To: Miguel Garcia
Cc: [email-masked]
Subject: Re: [Iptel] The 'npdi' parameter

Miguel,

Doesn't all the syntax that applies to tel URIs also apply to sip/sips 
URIs with user=phone? Does that have to be restated for each new 
extension to tel?

	Paul

Miguel Garcia wrote:
> Hi:
> 
> I was reading the Number Portability parameters for the Tel URI, 
> draft-ietf-iptel-tel-np-08.txt, and I have no problem with the draft 
> itself. But I was wondering if the 'npdi' parameter should be also 
> defined for SIP URIs that carry telephone numbers.
> 
> Let's assume I have a SIP UA that encodes E.164 numbers as SIP URIs, 
> perhaps with the "user=dialstring" defined in 
> draft-rosen-iptel-dialstring-02.txt. If a node does an NP translation,

> we don't have the means to indicate that the query to the NPDB has
taken 
> place. But if the E.164 number is encoded as a tel URI there is.
> 
> In my opinion this claims for the npdi parameter to be applicable to
SIP 
> URIs as well. Any thoughts?
> 
> /Miguel
> 

_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 26 Jan 2006 23:01:05 -0500

Miguel's example, though, talks about user=dialstring. I don't think the 
npdi actually makes much sense for dialstrings.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 27 Jan 2006 10:14:45 -0500

> npdi actually makes much sense for dialstrings.

I agree it doesn't make too much sense for user=dialstring. But it does 
make sense for user=phone.

	Paul