Subject: Re: [Iptel] draft-rosen-iptel-dialstring-05

From: "Stastny Richard" <[email-masked]>
Date: Wed, 28 Feb 2007 15:36:05 +0100

Brian,
 
what is the current status of this draft?
the ID database shows still the 04 version
 
An this is still in IESG evaluation
 
Richard

________________________________

Von: Brian Rosen [mailto:[email-masked]]
Gesendet: Fr 20.10.2006 23:23
An: [email-masked]
Betreff: [Iptel] draft-rosen-iptel-dialstring-05

I have submitted an update to -dialstring.  Until it appears in the
archives, you may pick up a copy from:
http://www.brianrosen.net/internet-drafts/draft-rosen-iptel-dialstring-05.tx
t

an .html is also available.

The changes in this version are:
1. After lengthy discussion, I changed the position of the phone-context
parameter to match what a tel uri with a phone-context parameter looks like
when converted to a sip URI.  This means it goes before the '@'
2. I created an ABNF description of this, defining a new "dialstring"
alternative for 'user-info' in a sip URI.
3. I expanded the definition of the dialstring syntax to include "*" and "#"
(as well as E and F)
4. I added a SHOULD NOT use a dialstring as an AoR in a Register

Hopefully, this resolves all issues, and the draft is ready for the IESG to
progress

Brian

_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

---

From: "Brian Rosen" <[email-masked]>
Date: Wed, 28 Feb 2007 09:45:23 -0500

Funny thing, I just asked the shepherding AD what I should do to get it done
and got the reply 2 minutes ago.

I will have a new version out today that fixes the ABNF as Paul suggests and
has what I hope is acceptable compromise language on the conversion of a
dialstring to a telephone number URI (tel: or sip/sips:).

Brian

> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]]
> Sent: Wednesday, February 28, 2007 9:36 AM
> To: Brian Rosen; [email-masked]
> Subject: Re: [Iptel] draft-rosen-iptel-dialstring-05
> 
> Brian,
>

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 28 Feb 2007 16:12:27 +0100

Thank you
I hope this will be finished soon
Richard

Von: Brian Rosen [mailto:[email-masked]]
Gesendet: Mi 28.02.2007 15:45
An: Stastny Richard; [email-masked]
Betreff: RE: [Iptel] draft-rosen-iptel-dialstring-05

Brian