Subject: [Iptel] [Editorial Errata Reported] RFC3966 (4376)

From: RFC Errata System <[email-masked]>
Date: Tue, 26 May 2015 08:47:37 -0700 (PDT)

The following errata report has been submitted for RFC3966,
"The tel URI for Telephone Numbers".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3966&eid=4376

--------------------------------------
Type: Editorial
Reported by: OKUMURA Shinji <[email-masked]>

Section: 3

Original Text
-------------
phonedigit           = DIGIT / [ visual-separator ]
phonedigit-hex       = HEXDIG / "*" / "#" / [ visual-separator ]

Corrected Text
--------------
phonedigit           = DIGIT / visual-separator;
phonedigit-hex       = HEXDIG / "*" / "#" / visual-separator;

Notes
-----
An optional and alternative rule is typically meaningless.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3966 (draft-ietf-iptel-rfc2806bis-09)
--------------------------------------
Title               : The tel URI for Telephone Numbers
Publication Date    : December 2004
Author(s)           : H. Schulzrinne
Category            : PROPOSED STANDARD
Source              : IP Telephony
Area                : Real-time Applications and Infrastructure
Stream              : IETF
Verifying Party     : IESG

---

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 26 May 2015 16:11:04 +0000

This errata should be rejected.

- Jason

On 5/26/15, 11:47 AM, "RFC Errata System" <[email-masked]>
wrote:

>_______________________________________________
>Iptel mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/iptel
>

---

From: OKUMURA Shinji <[email-masked]>
Date: Wed, 27 May 2015 20:30:37 +0900

Hi,

phonedigit is used in an extension rule.

   extension            = ";ext=" 1*phonedigit

if the original definition is correct, I think a following
description is valid.

tel:1234;ext=;phone-context=example.com

May an extension number be an empty string?

At the very start what is the reason why visual-separator became an 
optional rule?
according to the document history,

RFC2806
   phonedigit            = DIGIT / visual-separator

draft-ietf-iptel-rfc2806bis-01
   phonedigit            =  DIGIT [ visual-separator ]
   phonedigit-hex        =  HEXDIG [ visual-separator ]

draft-ietf-iptel-rfc2806bis-02
   phonedigit            =  DIGIT / [ visual-separator ]
   phonedigit-hex        =  HEXDIG / "*" / "#" / [ visual-separator ]

Anydody know the intent of this fix?

Regards,
Shinji