Subject: Re: [Iptel] [Editorial Errata Reported] RFC3966 (4376)

From: Paul Kyzivat <[email-masked]>
Date: Fri, 05 Jun 2015 11:08:37 -0400

On 5/27/15 7:30 AM, OKUMURA Shinji wrote:
> Hi,
>
> phonedigit is used in an extension rule.
>
>     extension            = ";ext=" 1*phonedigit
>
> if the original definition is correct, I think a following
> description is valid.
>
> tel:1234;ext=;phone-context=example.com
>
> May an extension number be an empty string?

That would be bad.

But your errata fix isn't sufficient for extension because it would 
allow an extension including only visual-separators. ISTM that to 
complete the fix the rule for extension also needs to be changed to:

   extension            = ";ext=" *phonedigit DIGIT *phonedigit

> At the very start what is the reason why visual-separator became an
> optional rule?

I don't know. It certainly seems to have been a mistake.

> according to the document history,
>
> RFC2806
>     phonedigit            = DIGIT / visual-separator
>
> draft-ietf-iptel-rfc2806bis-01
>     phonedigit            =  DIGIT [ visual-separator ]
>     phonedigit-hex        =  HEXDIG [ visual-separator ]
>
> draft-ietf-iptel-rfc2806bis-02
>     phonedigit            =  DIGIT / [ visual-separator ]
>     phonedigit-hex        =  HEXDIG / "*" / "#" / [ visual-separator ]

	Thanks,
	Paul

> Anydody know the intent of this fix?
>
> Regards,
> Shinji
>
>> This errata should be rejected.
>>
>> - Jason
>>
>>
>>
>> On 5/26/15, 11:47 AM, "RFC Errata System" <[email-masked]>
>> wrote:
>>
>>> The following errata report has been submitted for RFC3966,
>>> "The tel URI for Telephone Numbers".
>>>
>>> --------------------------------------
>>> You may review the report below and at:
>>> http://www.rfc-editor.org/errata_search.php?rfc=3966&eid=4376
>>>
>>> --------------------------------------
>>> Type: Editorial
>>> Reported by: OKUMURA Shinji <[email-masked]>
>>>
>>> Section: 3
>>>
>>> Original Text
>>> -------------
>>> phonedigit           = DIGIT / [ visual-separator ]
>>> phonedigit-hex       = HEXDIG / "*" / "#" / [ visual-separator ]
>>>
>>>
>>> Corrected Text
>>> --------------
>>> phonedigit           = DIGIT / visual-separator;
>>> phonedigit-hex       = HEXDIG / "*" / "#" / visual-separator;
>>>
>>>
>>> Notes
>>> -----
>>> An optional and alternative rule is typically meaningless.
>>>
>>> Instructions:
>>> -------------
>>> This erratum is currently posted as "Reported". If necessary, please
>>> use "Reply All" to discuss whether it should be verified or
>>> rejected. When a decision is reached, the verifying party (IESG)
>>> can log in to change the status and edit the report, if necessary.
>>>
>>> --------------------------------------
>>> RFC3966 (draft-ietf-iptel-rfc2806bis-09)
>>> --------------------------------------
>>> Title               : The tel URI for Telephone Numbers
>>> Publication Date    : December 2004
>>> Author(s)           : H. Schulzrinne
>>> Category            : PROPOSED STANDARD
>>> Source              : IP Telephony
>>> Area                : Real-time Applications and Infrastructure
>>> Stream              : IETF
>>> Verifying Party     : IESG
>>>
>>> _______________________________________________
>>> Iptel mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/iptel
>>>
>
> _______________________________________________
> Iptel mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iptel
>

---

From: OKUMURA Shinji <[email-masked]>
Date: Mon, 08 Jun 2015 19:11:46 +0900

Hi Paul,

>   extension            = ";ext=" *phonedigit DIGIT *phonedigit

I see, and IIUC this is reducible as below.

   extension            = ";ext=" *visual-separator DIGIT *phonedigit

The two are equivalent, but from a parser implementor's perspective
the latter is better (I think).

Regards,
Shinji

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 08 Jun 2015 10:22:51 -0400

> the latter is better (I think).

I agree the two are equivalent. I think one can argue about which is 
easier to understand. But for clarity I do think the same construction 
ought to be used in both the definition of extension and 
global-number-digits. For an errata I think it is preferable to minimize 
the changes to the text, so I think I favor using the form currently 
used in global-number-digits.

(If there was to be another bis, then that would be a good time to 
change it. And then, I think I would define a new rule for this 
construction, that would then be used in both global-number-digits and 
extension.)

	Thanks,
	Paul

---

From: OKUMURA Shinji <[email-masked]>
Date: Tue, 09 Jun 2015 16:11:39 +0900

Paul Kyzivat wrote:
>easier to understand.

I would like to add one more thing. According to the former, it is hard
to determine whether a first DIGIT is phonedigit or DIGIT.

>But for clarity I do think the same construction 

I agree with you.

>construction, that would then be used in both global-number-digits and 

I quite agree.

Regards,
Shinji