Subject: RE: [Isis-wg] BCP for building Integrated IS-IS Network

From: DAUVERGNE Emmanuel CNET/DAC/ISS <[email-masked]>
Date: Fri, 14 Jan 2000 17:27:42 +0100

I'm not an MPLS expert, but I'm also thinking about the following drawback
(in multi-level) :

o Complexity in MPLS environnement : Inability to setup an LSP between two
PE located in different L1-areas (stub areas). 

As Henk mentionned for MED calculation, this issue is solved with
route-leaking concept. 

Manu

> ----------
> De : 	Danny McPherson[SMTP:[email-masked]]
> Répondre à : 	[email-masked]
> Date :	vendredi 14 janvier 2000 03:33
> A :	[email-masked]
> Cc :	[email-masked]; [email-masked]
> Objet :	Re: [Isis-wg] BCP for building Integrated IS-IS Network 
> 
> 
> I agree with Henk's comments.  
> 
> We run a single area L2-only domain with a couple hundred routers, other 
> places I've worked had 350+ in a single domain.  The primary reasons for
> not 
> introducing hierarchy are those Henk mentioned:
> 
> o Inability to derive accurate BGP MED values  
> o L1 routers defaulting to closest L2 router can result in sub-optimal
> routing.
> o Troubleshooting is a bit more complex
> 
> The ability to route leak does make a multi-level IS-IS network more 
> appealing, though it's certainly not worth the complexity trade-offs at
> this 
> point, or anywhere in the foreseeable future.
> 
> I didn't see Henk mention it, but it would perhaps also seem that while a 
> multi-level network is a bit more protected against potential of
> instabilities 
> introduced by link oscillation, a single level network should converge 
> slightly faster, though the gain is probably negligible.
> 
> As for the SPF runtimes, they don't seem at all concerning in our network 
> today.  We use two different vendor implementations and SPF runtimes seem
> to 
> be ~200 microseconds per node.  We don't have any NBMA stuff or
> psuedonodes 
> though, so the size of the LSDB is probably pretty small in comparison to 
> other networks.
> 
> -danny
> 
> 
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://external.juniper.net/mailman/listinfo/isis-wg
> 

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Tony Przygienda <[email-masked]>
Date: Fri, 14 Jan 2000 17:07:18 -0500

DAUVERGNE Emmanuel CNET/DAC/ISS wrote:

1. Ran's comment on the issues being worth written down is good but I assume
    I cannot interpret that as equal to volunteering to do it ;-) ??

> PE located in different L1-areas (stub areas).

2. there is some current thinking by the usual suspects how to solve the problem. I expect
some kind of solution to gel.

        thanks

    -- tony