Subject: [Isis-wg] ask a question .

From: Jorge <[email-masked]>
Date: Wed, 12 Jan 2000 18:37:59 +0530

Hi, everyone
        I am a new member of IS-IS Group. Now i am engaged in the work of implementation for IS-IS over IPv4. i am a newcomer for IS-IS procotol,My dout is that going through all of IS-IS document,i cann't find the content for how the IS-IS over IPv4 protocol supporting the X.25 ,Frame-Relay ,multi-link access network.who can  give me some advice for it, i will very appreciated.you know ,i am eager to get those answer.Thanks in advance.

HuaWei Development Facility of CHINA 
Future Software Private Limited
480-481,Mount Road,Nandanam,
Chennai-600 -35.Inida

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Alex Zinin <[email-masked]>
Date: Wed, 12 Jan 2000 19:15:56 +0300

Other people will add some input here
if my answer is not complete.

One way of dealing with NBMA media
is assigning the VCs to logical point-to-point
or multipoint interfaces. IS-IS is then
enabled on the logical rather then physical
interfaces, but transmission of a packet
over a logical interface results in sending
the packet through the physical one.
Sending an IP packet over a p-t-p interface
is simple, since the layer-2 details are
either not necessary (in case of physical links)
or predetermined (in case of logical links).
Having split the VCs you basically represent
an NBMA cloud as a set of p-t-p links.

Another way (also used for multipoint logical
interfaces) is treating the NBMA cloud as a
broadcast media. This requires providing (manually
or dynamically as in the case of FR) the information
on which VCs should multicast packets be sent over.
So, the router replicates the IP packets and
sends the copies over each involved VCs.
This, of course, implies that you have your VCs
fully meshed.

Regards,
Alex.

Wednesday, January 12, 2000, 4:07:59 PM, Jorge <[email-masked]> wrote:

J> Hi, everyone
J>         I am a new member of IS-IS Group. Now i am engaged in the work of implementation for IS-IS over IPv4. i am a newcomer for IS-IS procotol,My dout is that going through all of IS-IS
J> document,i cann't find the content for how the IS-IS over IPv4 protocol supporting the X.25 ,Frame-Relay ,multi-link access network.who can  give me some advice for it, i will very appreciated.you
J> know ,i am eager to get those answer.Thanks in advance.

J> HuaWei Development Facility of CHINA 
J> Future Software Private Limited
J> 480-481,Mount Road,Nandanam,
J> Chennai-600 -35.Inida

J> _______________________________________________
J> Isis-wg mailing list  -  [email-masked]
J> http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Wed, 12 Jan 2000 11:32:57 -0500

>This, of course, implies that you have your VCs

This should be done with great care (or not at all).
In general, it's important to send routing protocol
traffic the same way data would be sent, as much as
possible.  Otherwise, you run the risk of thinking there
is a data connection where there is none, or of incomplete
distribution of routing information.

In particular, pay careful attention to IS-IS's transitivity
requirement for broadcast networks -- that is, if A can hear
B and B can hear C, then A must be able to hear C.  This rule
would be easy to violate in a misprovisioned NBMA network, and
would probably lead to serious connectivity problems.

Regareds,
Jeff

>J>         I am a new member of IS-IS Group. Now i am engaged in the work
of implementation for IS-IS over IPv4. i am a newcomer for IS-IS
procotol,My dout is that going through all of IS-IS
>J> document,i cann't find the content for how the IS-IS over IPv4 protocol
supporting the X.25 ,Frame-Relay ,multi-link access network.who can  give
me some advice for it, i will very appreciated.you
>J> http://external.juniper.net/mailman/listinfo/isis-wg
____________________________________________________________________

  Jeff Learman                           Internet:     [email-masked]
  Engineering Manager                    Voice:     (734)-975-7323
  ONE (Open Networks Engineering, Inc)   Fax:       (734)-975-6940
  2725 South Industrial Pkwy, Suite 100
  Ann Arbor, MI  48104  USA
____________________________________________________________________