Subject: [Isis-wg] Clarification With respect to ISIS MIB

From: navaneeth K <[email-masked]>
Date: Thu, 3 Feb 2000 10:44:42 -0800

Hi,

I have few doubts on the MIB for IS-IS. 

1.	Some tables have got objects, Operstate and ExistState. For Ex, isisSysTable has
IsisSysOperState and isisSysExistState. What is the significance of these two objects
and how do they differ. Is ExistState equivalent to AdminStatus?, "Setting it off make the
Router forget all current states". Does it mean clearing all the databases of IS-IS and making the 
Protocol down. Please clarify.

2.	I am not clear about the correlation between the objects and isisSysNextCircIndex and isisCircIndex.

3.	 isisCircTable has an object "isisManAdjNeighNSAP" . What is the purpose of this object.
Where it is used?

4.	Could you explain the object "isisIPRouteForw" in isisIPDestTable.

5. What do the circuit types StaticIn and StaticOut stand for in isisCirctype?

6. What are the MeshGroup entires used for? How do we use this?

Thanks 
Regards
-vani

------
Navaneeth.

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Thu, 3 Feb 2000 09:50:15 -0500

> Protocol down. Please clarify.

There are three types of things in mib speak
	Does this object exist?  (Exist state)
	Do I want this object active?  (Admin State)
	Is this object operating? (Oper State)
We are currently using OperState in many spots
where we should be using AdminState, but that is
another story.

ExistState is used to help clarify the steps
in creating a new item.  If Isis had a SystemAdminState,
and you set it to Down, you would hope that configuration,
such as system id, would be remembered when SystemAdminState
was reset to Up.  However, seting isisSysExistState
to isisSysExistState_destroy should clear setting
such as isisSysID.

> 2.	I am not clear about the correlation between the 
> objects and isisSysNextCircIndex and isisCircIndex.

I is useful to have a circuit Index that is unique
within the instance of Isis.  The variable 
isisSysNextCircIndex is a system wide variable 
that can be used with an SNMP convention called 
TestAndIncr to provide the "next" value.  It 
works like the roll of numbers you see at the bakery:
you tear off the next number, and you will be the
only person in the shop with that number.

> What is the purpose of this object.

If you wish to have a configured adjacency,
rather than one created by the exchange of 
hello messages, this variable holds the 
SystemId of the other side which you would
otherwise discover in the hello packets.  

> 4.	Could you explain the object "isisIPRouteForw" in 

This looks like a "next hop" description.

> 5. What do the circuit types StaticIn and StaticOut stand for 

These look like simplex (one way) circuits.

> 6. What are the MeshGroup entires used for? How do we use this?

There is a draft describing their use...

	draft-balay-katz-parker-mesh-00.txt