Subject: RE: [Isis-wg] Clarification on ISIS SPF algorithm

From: Navaneeth K <[email-masked]>
Date: Fri, 21 Apr 2000 14:50:53 +0530

Hi Henk,

Thanks for your reply.
 I just want to confirm this.
	 LAN nbrs will be loaded to TENT from Adjacency table as well as from the 
pseudonode LSP. In the second loading, since the Nbr is already present it 
wont be loaded (normal LAN scenario)
	Eventhough this is done as a pre-caution, it is unnecessary operation most 
of the time.

  Thanks
Navaneeth

  Under buggy conditions on a LAN. Should never happen though.

  Another example might be when you configure your routers to model
 a Frame-relay, ATM or X25 cloud as a LAN. On those NBMA WAN technologies
 it is more likely that when some links fail, the resulting topology
 might be a partial mesh. Note that even if you do the trick that
 you quote, routing is still broken. IMHO on NBMA networks you need to
 configure all VCs as p2p links.

    Hope this helps,

         Henk.

> Hi,
>
> This doubt is regarding the SPF algorithm mentioned in RFC 1195
>
> The section 8 under STEP 0:
>
> Says:
>
> " Now add systems to which the local router does not have adjacencies, 
but
> which are mentioned in neighbouring pseudonode LSPs.The adjacency for 
such
> systems is set to that of the Designated router"
>
> What does it exactly mean? When is possible that a router does not have
> adjacency to a system mentioned in a neighbour's pseudonode LSP?
>
> Please clarify.
>
> Thanx and regards
> Navaneeth.
>
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://external.juniper.net/mailman/listinfo/isis-wg
> 

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Henk Smit <[email-masked]>
Date: Fri, 21 Apr 2000 10:45:32 -0700 (PDT)

That is an implementation decision.
 The one implementation I am familiar with only looks at the content
 of the LSPs during SPF, and tries to find the relevant adjacencies
 in the adjacency database later.

     Henk.

> 	 LAN nbrs will be loaded to TENT from Adjacency table as well
> as from the pseudonode LSP. In the second loading, since the Nbr is
> already present it wont be loaded (normal LAN scenario)
> 	Eventhough this is done as a pre-caution, it is unnecessary
> operation most of the time.
> 
>   Thanks
> Navaneeth