Subject: [Isis-wg] Doubt reg system type usage in Integ. ISIS

From: SelvarajR <[email-masked]>
Date: Fri, 7 Apr 2000 18:00:11 +0530

Hi

The Integ,ISIS MIB draft has specified three values for system type( L1(1) or L2(2) or L1AndL2 (3) ) in the system table
But the Hello PDU transmission is based on whether system Type is 
L1 (1) ,or
L2 (3) and manualCircL2Only( TRUE/FALSE)

Here, if the system type is L1AndL2 ( 3 ) then  no Hello be sent.

The system type object in the MIB shall be defined to take only two values, L1 (1) or L2 (2). No L1AndL2 ( 3 ).

I hope the MIB Draft is still Valid..

How can we handle this anomaly?

SELVA

---

From: Jeff Parker <[email-masked]>
Date: Fri, 7 Apr 2000 10:01:42 -0400

> Hi
> 
> The Integ,ISIS MIB draft has specified three values for 
> system type( L1(1) or L2(2) or L1AndL2 (3) ) in the system table
> The system type object in the MIB shall be defined to take 
> only two values, L1 (1) or L2 (2). No L1AndL2 ( 3 ).
> 

Selva -
	As you know, L2 in line 7 above means L1AndL2.  

	The current MIB work reflects many changes that have
been deployed since the original version of 10589 was written.  
This is one place where existing practice and the document
conflict.  When implementing a system, you may decide if 
you wish to implement the a system that supports system
type of L2 only.  If not, you need not vary your implementation
of the Hello Transmission.  If you would like to support
L2 only systemType, you will need to change the algorithm
in the Hello PDU transmission in the obvious fashion.  

- jeff parker

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: SelvarajR <[email-masked]>
Date: Fri, 7 Apr 2000 20:38:14 +0530

Hi Jeff,

Thank U

Thers is one mistake in my last mail. The  line number 7  should have been 
"L2 (2) and manualCircL2Only( TRUE/FALSE)"
I'm sorry. That what I like to convey is, setting 3 to system type object in system table will case problem during Hello transmission.

OK , anyhow I accept ur suggestion that the implementation should decide over the algorithm.

SELVA

-----Original Message-----
From:	Jeff Parker [SMTP:[email-masked]]
Sent:	Friday, April 07, 2000 7:32 PM
To:	[email-masked]; 'ISIS-WG'
Subject:	RE: Doubt reg system type usage in Integ. ISIS

Selva -

- jeff parker