Subject: RE: [Isis-wg] Doubt on IS-IS

From: SelvarajR <[email-masked]>
Date: Sat, 27 May 2000 10:52:52 +0530

Except resolving tie does the SNPA is useful for any other purpose that 
can't be done using System ID.
Also for breaking Tie,  if there are two string(or value) that can be 
compared then that's enough.
But those string(or value) necessarily not be the SNPA.

In case of Integrated ISIS while the protocol runs over IP , I feel it is 
little bit inefficient to get the MAC address from the Ethernet header.

Pls clarify if wrong.

SELVA

-----Original Message-----
From:	DAUVERGNE Emmanuel FTRD/DAC/ISS 
[SMTP:[email-masked]]
Sent:	Friday, May 26, 2000 9:42 PM
To:	Vani Sree K
Cc:	[email-masked]
Subject:	RE: [Isis-wg] Doubt on IS-IS

...and this MAC address (SNPA) is used in the DIS election : (if no 
priority
imposed) choose the highest one.

Regards,
Manu

-----Message d'origine-----
De: Jeff Learman [mailto:[email-masked]]
Date: vendredi 26 mai 2000 17:38
A: Vani Sree K
Cc: [email-masked]
Objet: Re: [Isis-wg] Doubt on IS-IS

Vani,

While it is true that a LAN IIH carries a system ID,
the Intermediate System Neighbors option in a LAN IIH
carries the MAC address of the neighbor, not the system
ID.  The MAC address of the neighbor is obtained from
the Ethernet header of the IIH received from the neighbor.
See ISO 10589:1992 Section 9.5, Intermediate System Neighbours,
on page 50.

Regards,
Jeff

Vani Sree K wrote:

> Hi,
>
> In the Intermediate system Neighbors option of LAN Hello,  the code value
> carries the 6 Octet Mac Address. (10589, 1992)
> My doubt is whether it is the Mac Address of the interface from which the
> Hello is sent or System Id of the Intermediate system. (Assuming one of
the
> Mac address is system Id).
> (In one of the Cisco document of IS-IS, it has been stated that the
>  "SystemID is usually the MAC identifier of an interface on the device.
The
> IS Nbrs CLV lists the system Ids of all neighbors from whom a Hello has
> been heard within the last Hold time..")
>
> While creating new adjacencies, the NeigbourSNPA Address is set to the 
MAC
> source address of the PDU.
> It means,  the source MAC address is got from the Ethernet header.?
>
> Please  correct me.
>
> Thanks
> -vani
>
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://external.juniper.net/mailman/listinfo/isis-wg

____________________________________________________________________

  Jeff Learman                           Internet:     [email-masked]
  Engineering Manager                    Voice:     (734)-975-7323
  ONE (Open Networks Engineering, Inc)   Fax:       (734)-975-6940
  2725 South Industrial Pkwy, Suite 100
  Ann Arbor, MI  48104  USA
____________________________________________________________________

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Jorge" <[email-masked]>
Date: Sat, 27 May 2000 11:34:05 +0530

I also agree  with most of  what Mr/Miss SELVA say . for actually now integrated Is-Is communication with IP layer only through Raw socket API , can somebody tell me how i can get the Ethernet header from raw socket  with the condition that i won't encapsulate Is-Is packet with Ethernet header myself ( And also i can't make assumption that another implementation for integrated is-is  will encapsulate Is-Is packet with Ethernet header in raw socket ) .

---

From: Henk Smit <[email-masked]>
Date: Sat, 27 May 2000 12:21:03 +0200 (MEST)

> little bit inefficient to get the MAC address from the Ethernet header.

  Yes, this is wrong.
 There is a relatively new draft proposal to define an IP encapsulation
 for IS-IS. But integrated ISIS, as defined in rfc1195, uses the same
 encapsulation as ISIS defined in ISO/IEC DIS 10589.

  IS-IS packets are encapsulated directly in the data-link layer.
 No IP headers anywhere ......

       Henk.

---

From: Henk Smit <[email-masked]>
Date: Sat, 27 May 2000 12:23:23 +0200 (MEST)

> I also agree with most of what Mr/Miss SELVA say . for actually now
> integrated Is-Is communication with IP layer only through Raw socket
> API , can somebody tell me how i can get the Ethernet header from raw
> socket with the condition that i won't encapsulate Is-Is packet with
> Ethernet header myself ( And also i can't make assumption that another
> implementation for integrated is-is will encapsulate Is-Is packet with
> Ethernet header in raw socket ) .

  These are all clearly *implementation* questions.
 The answers depend on the OS you use.

       Henk.

---

From: Jeff Learman <[email-masked]>
Date: Tue, 30 May 2000 14:16:46 -0400

In addition to resolving the tie for Designated IS, the SNPA address
in the LAN IIH is used to govern the adjacency transition from
"initializing" to "up".  You don't transition the adjacency for a
neigboring IS to "up" until you see your MAC address in the neighbor's
IIH (in the Intermediate System Neighbors option).  Note that if
your IS has multiple LAN interfaces on the same LAN, you will have
multiple adjacencies for each neighbor IS, and each adjacency's
state is independently controlled by the presence of its MAC
address in the neighbor's IIH.

Concerning implementation issues, most UNIX systems, including Solaris
and AIX, support DLPI (Data Link Provider Interface), a STREAMS-based
interface to the data link layer.  This interface provides all
necessary link and MAC layer addressing information.

At 10:52 AM 5/27/00 +0530, SelvarajR wrote:
>Attachment Converted: "c:\eudora\attach\RE [Isis-wg] Doubt on IS-IS"
>

---

From: Tony Przygienda <[email-masked]>
Date: Fri, 26 May 2000 23:17:30 -0700

> I also agree  with most of  what Mr/Miss SELVA say . for actually now integrated Is-Is communication with IP layer only through Raw socket API , can somebody tell me how i can get the Ethernet head…

look @ the ISIS over IPv4 draft ...

    thanks

    -- tony