Subject: [Isis-wg] Doubt on IS-IS

From: Vani Sree K <[email-masked]>
Date: Fri, 26 May 2000 10:27:07 +0530

Hi,

In the Intermediate system Neighbors option of LAN Hello,  the code value 
carries the 6 Octet Mac Address. (10589, 1992)
My doubt is whether it is the Mac Address of the interface from which the 
Hello is sent or System Id of the Intermediate system. (Assuming one of the 
Mac address is system Id).
(In one of the Cisco document of IS-IS, it has been stated that the 
 "SystemID is usually the MAC identifier of an interface on the device. The 
IS Nbrs CLV lists the system Ids of all neighbors from whom a Hello has 
been heard within the last Hold time..")

While creating new adjacencies, the NeigbourSNPA Address is set to the MAC 
source address of the PDU.
It means,  the source MAC address is got from the Ethernet header.?

Please  correct me.

Thanks
-vani

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Rajesh Saluja" <[email-masked]>
Date: Fri, 26 May 2000 09:16:30 -0400

LAN Hello carries the system ID.

-Rajesh

--

-------------------------------------------------------------
Rajesh Saluja
Nortel Networks Inc 600 Technology Park Billerica, MA  01821
Ph: (978) 288-7791      Fax: (978) 670-8760
--------------------------------------------------------------

---

From: Jeff Learman <[email-masked]>
Date: Fri, 26 May 2000 11:37:44 -0400

Vani,

While it is true that a LAN IIH carries a system ID,
the Intermediate System Neighbors option in a LAN IIH
carries the MAC address of the neighbor, not the system
ID.  The MAC address of the neighbor is obtained from
the Ethernet header of the IIH received from the neighbor.
See ISO 10589:1992 Section 9.5, Intermediate System Neighbours,
on page 50.

Regards,
Jeff

> It means,  the source MAC address is got from the Ethernet header.?

____________________________________________________________________

  Jeff Learman                           Internet:     [email-masked]
  Engineering Manager                    Voice:     (734)-975-7323
  ONE (Open Networks Engineering, Inc)   Fax:       (734)-975-6940
  2725 South Industrial Pkwy, Suite 100
  Ann Arbor, MI  48104  USA
____________________________________________________________________