Subject: RE: [Isis-wg] Doubt on IS-IS

From: DAUVERGNE Emmanuel FTRD/DAC/ISS <[email-masked]>
Date: Fri, 26 May 2000 18:11:33 +0200

...and this MAC address (SNPA) is used in the DIS election : (if no priority
imposed) choose the highest one.

Regards,
Manu

-----Message d'origine-----
De: Jeff Learman [mailto:[email-masked]]
Date: vendredi 26 mai 2000 17:38
À: Vani Sree K
Cc: [email-masked]
Objet: Re: [Isis-wg] Doubt on IS-IS

Vani,

While it is true that a LAN IIH carries a system ID,
the Intermediate System Neighbors option in a LAN IIH
carries the MAC address of the neighbor, not the system
ID.  The MAC address of the neighbor is obtained from
the Ethernet header of the IIH received from the neighbor.
See ISO 10589:1992 Section 9.5, Intermediate System Neighbours,
on page 50.

Regards,
Jeff

Vani Sree K wrote:

> Hi,
>
> In the Intermediate system Neighbors option of LAN Hello,  the code value
> carries the 6 Octet Mac Address. (10589, 1992)
> My doubt is whether it is the Mac Address of the interface from which the
> Hello is sent or System Id of the Intermediate system. (Assuming one of
the
> Mac address is system Id).
> (In one of the Cisco document of IS-IS, it has been stated that the
>  "SystemID is usually the MAC identifier of an interface on the device.
The
> IS Nbrs CLV lists the system Ids of all neighbors from whom a Hello has
> been heard within the last Hold time..")
>
> While creating new adjacencies, the NeigbourSNPA Address is set to the MAC
> source address of the PDU.
> It means,  the source MAC address is got from the Ethernet header.?
>
> Please  correct me.
>
> Thanks
> -vani
>
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://external.juniper.net/mailman/listinfo/isis-wg

____________________________________________________________________

  Jeff Learman                           Internet:     [email-masked]
  Engineering Manager                    Voice:     (734)-975-7323
  ONE (Open Networks Engineering, Inc)   Fax:       (734)-975-6940
  2725 South Industrial Pkwy, Suite 100
  Ann Arbor, MI  48104  USA
____________________________________________________________________

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Tony Przygienda <[email-masked]>
Date: Sat, 27 May 2000 21:29:56 +0200 (MEST)

> > I also agree with most of what Mr/Miss SELVA say . for actually now
> > integrated Is-Is communication with IP layer only through Raw socket
> > API , can somebody tell me how i can get the Ethernet header from raw
> > socket with the condition that i won't encapsulate Is-Is packet with
> > Ethernet header myself ( And also i can't make assumption that another
> > implementation for integrated is-is will encapsulate Is-Is packet with
> > Ethernet header in raw socket ) .
> 
>  These are all clearly *implementation* questions.
>   The answers depend on the OS you use.
>
>          Henk.

Correct, however nothings' wrong with posting implementation qeustions 
on this list ;-)

Henk was right in the other mail as well, there is the IPv4 encaps draft
and one of the reasons for it was the difficulty to get mac header in many 
environments. Observe however that today's deployment occurs without IPv4
encaps pretty much. If you primarily want to play with ISIS without the 
realities of the market-place and only
care to have it talk to e.g. gated, IPv4 encaps is nice since it let's you
forget most of those ethernet header problems which are not easily 
taken care of on any Unix platform and in fact imply writing your own
encaps and lots of toying around wiht things like SOCK_PACKET stuff. 

		-- tony