Subject: [Isis-wg] router ID for IS-IS

From: newbie <[email-masked]>
Date: Mon, 12 Jun 2000 13:59:50 -0700 (PDT)

Hi:

What does IS-IS use for router ID? NSAP's systme ID?
most of vendor uses MAC address for NSAP system ID,
but what about there is no ethernet card in the
router? what is the role of loopback address in the
IS-IS?

thanks

__________________________________________________
Do You Yahoo!?
Yahoo! Photos -- now, 100 FREE prints!
http://photos.yahoo.com

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Rajesh Saluja" <[email-masked]>
Date: Mon, 12 Jun 2000 17:45:25 -0400

> router? what is the role of loopback address in the

It need not be MAC address. It is basically 1 to 8 octets long value (
almost all implementations use 6 octets ) which should be unique in a
routing domain. 
People use loopback address so as to have reachability to a router till
there is at least one physical interface to reach the router. ( eg : in
BGP next hop ). IS-IS treats loopback address as just another
reachability information.

Hope it helps.

Regards,
Rajesh