Subject: Re: [Isis-wg] Areas in ISIS

From: Mike Shand <[email-masked]>
Date: Mon, 19 Jun 2000 14:56:44 +0100

At 15:40 19/06/2000 +0100, Metz, E.T. wrote:
>Hi all,
>
>is it possible to have an ISIS network with different areas, but without an
>explicit backbone area?
>
>I thought it could be done because the L1/L2 routers in each of the areas
>will form (L2) adjacencies and exchange routing info. So even without a real
>backbone area, traffic will still flow between differents areas.
>
>Is the above correct? Does it make any sense?

Yes, no problem. All that is required is that there is a connected L2 path 
linking all the areas. In paritcular if areas A and C are connected through 
area B, there must be a connected path of L2 routers through B.

         Mike

>cheers,
>         Eduard
>
>_______________________________________________
>Isis-wg mailing list  -  [email-masked]
>http://external.juniper.net/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Dave Katz <[email-masked]>
Date: Mon, 19 Jun 2000 13:26:29 -0700 (PDT)

This isn't "physically distinct" in the sense that L1 traffic can traverse
some of the same links that make up the L2 topology, but it is important
to think of the L2 topology as distinct when you design your network, or
you can end up in a world of hurt.  In particular, if areas A, B, and C
are connected through a loop, and there are parts of area B that depend
on those L1L2 links for L1 connectivity, a break of the path through
area B could not be healed via A and C.

In the topology you describe, I would visualize the L2 path as being
on the edge of area B, as it (at least to me) presents the weaknesses
of the topology more clearly.

--Dave

   X-Sender: [email-masked]
   X-Mailer: QUALCOMM Windows Eudora Pro Version 4.2.2 
   Date: Mon, 19 Jun 2000 14:56:44 +0100
   From: Mike Shand <[email-masked]>
   Mime-Version: 1.0
   Content-Type: text/plain; charset="us-ascii"; format=flowed
   Sender: [email-masked]
   Errors-To: [email-masked]
   X-Mailman-Version: 1.0rc3
   Precedence: bulk
   List-Id: IETF IS-IS working group <isis-wg.external.juniper.net>
   X-BeenThere: [email-masked]

	    Mike

---

From: Mike Truskowski <[email-masked]>
Date: Mon, 19 Jun 2000 18:14:31 PDT

I think that you are saying that if you build heirarchically
then OSPF and ISIS topologies are the same...  
AREA0 is equivalent to all those L2 adjacencies...  And I 
agree...but the difference is shown by a little different
topology...

In ospf, if A is the area0 and B and C are cascading with
a virtual link from C to A.. then all traffic from C to B
goes thru A...

But in ISIS with A being L2/L1 cascaded to B cascaded to C
as in above... with L2 connectivity to from A thru B to C,
then  traffic from C to B merely goes directly to B and
never is seen by A...  As long as the "loop" is never
completed then the topology is fine...

The major weakness I see with ISIS in this sense is that 
a L1 instance must choose the "closest" L2 router 
which may not be the best L2.

Mike

---

From: Mike Shand <[email-masked]>
Date: Tue, 20 Jun 2000 08:02:19 +0100

>of the topology more clearly.

Dave,
         I couldn't agree more. The difference between IS-IS and OSPF is 
not primarily one of network design, but one of nomenclature. i.e. in IS-IS 
you still need to design a 'backbone', but the backbone isn't named as a 
single area (0) as it is in OSPF. In fact it isn't named at all. Its just 
defined by the connected set of L2 routers. In some designs that will 
correspond to a single L1 area, but in others it may traverse (or as you 
rightly point out ,it is better to think of it as skirting around the edge 
of) multiple L1 areas.

         Mike