Subject: RE: [Isis-wg] Areas in ISIS

From: "Metz, E.T." <[email-masked]>
Date: Tue, 20 Jun 2000 20:50:38 +0100

Small question (related to below), if you do create a separate backbone
(physically, or at least similar to OSPF area 0), is it then needed or
advantagous to have L1 routing in this area. Instead of just L2?

cheers,
	Eduard

> ----------
> From: 	Mike Shand[SMTP:[email-masked]]
> Sent: 	dinsdag 20 juni 2000 20:34
> To: 	Metz, E.T.; Dave Katz; [email-masked]'
> Cc: 	[email-masked]; [email-masked]
> Subject: 	RE: [Isis-wg] Areas in ISIS
> 
> At 20:14 20/06/2000 +0100, Metz, E.T. wrote:
> >ps. Mike (Shand) an ISIS backbone will never correspond to a L1 area
> would
> >it? It needs to be L2 or L1/L2 at least.
> 
> Were running into terminological inexactitudes here :-)
> 
> Yes it does need to be L2, but one way of designing an IS-IS network is to
> 
> make an area of L1/L2 routers which constitutes the backbone and then hang
> 
> all the other areas off this one. Of course you need at least one L1/L2 
> router in each of those areas, so the backbone (in the sense we were 
> talking before, i.e. the set of connected L2 routers - or the distribution
> 
> domain of L2 LSPs) spans multiple areas. But it does look rather like the 
> OSPF case, where the backbone is a single area (0 in that case).
> 
> Mike (S)
> 
> 

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Abe Martey <[email-masked]>
Date: Wed, 21 Jun 2000 09:05:14 -0700

> advantagous to have L1 routing in this area. Instead of just L2?

You could have a physical area x designated as the "core" of the
backbone..and all routers in this area don't have to run L1. Actually
they shouldn't since it'll be a resource waste....however your
"true" isis backbone will extend to the L1L2 border routers of the 
various other areas.

  [L1]=====[L1L2]=====[L2]=====[L2]======[L1L2]======[L1]
  
  |---area 1----|     |--area x---|      |----Area 2----|
           |----------isis backbone-----------|

Cheers.

- abe

-- 

==.==.==.==.==
Abe Martey
San Jose, CA
408 527 9149

---

From: Mike Truskowski <[email-masked]>
Date: Wed, 21 Jun 2000 9:44:15 PDT

Ugh... I think this might be a little confusing....

No doubt that this will work but ...

Area X "must" have a contiguous space of L2 or L2/L1 
connected to each Area N...  In other words, 
Assuming that the Area N's are only connected thru 
Area X, then there must be a set of L2 instances w/i
area X that connect Area N to Area M....

Hence, the L2(/L1) routers in area X and the L1/L2 routers in
Area N form the backbone...  The L1's are not part of the 
backbone.

The L2's are analogus to ospf's area 0.  Not the L1's.

Personally, I try to stay far away from this.

mike

---

From: Jeff Learman <[email-masked]>
Date: Mon, 26 Jun 2000 12:22:11 -0400

For CLNP, you would need to run L1 as well as L2.  Otherwise,
you wouldn't be able to manage the routers in Area 0.
When a packet arrives in Area 0, the L1 FDB would
be consulted, but would be empty or missing, causing the
packet to be dropped.

I suspect the same might be true for IP traffic.

>           |----------isis backbone-----------|
____________________________________________________________________

  Jeff Learman                           Internet:     [email-masked]
  Engineering Manager                    Voice:     (734)-975-7323
  ONE (Open Networks Engineering, Inc)   Fax:       (734)-975-6940
  2725 South Industrial Pkwy, Suite 100
  Ann Arbor, MI  48104  USA
____________________________________________________________________

---

From: Naiming Shen <[email-masked]>
Date: Mon, 26 Jun 2000 15:39:53 -0700

For IP, level-1 routes can be imported into level-2 domain on the
L12 routers. This is done by default on some of the popular ISIS
implementations.

 ]
 ]For CLNP, you would need to run L1 as well as L2.  Otherwise,
 ]you wouldn't be able to manage the routers in Area 0.
 ]When a packet arrives in Area 0, the L1 FDB would
 ]be consulted, but would be empty or missing, causing the
 ]packet to be dropped.
 ]
 ]I suspect the same might be true for IP traffic.
 ]
 ]At 09:05 AM 6/21/00 -0700, Abe Martey wrote:
 ]>
 ]>
 ]>On Tue, Jun 20, 2000 at 08:50:38PM +0100, Metz, E.T. wrote:
 ]>> Small question (related to below), if you do create a separate backbone
 ]>> (physically, or at least similar to OSPF area 0), is it then needed or
 ]>> advantagous to have L1 routing in this area. Instead of just L2?
 ]>
 ]>You could have a physical area x designated as the "core" of the
 ]>backbone..and all routers in this area don't have to run L1. Actually
 ]>they shouldn't since it'll be a resource waste....however your
 ]>"true" isis backbone will extend to the L1L2 border routers of the 
 ]>various other areas.
 ]>
 ]>  [L1]=====[L1L2]=====[L2]=====[L2]======[L1L2]======[L1]
 ]>  
 ]>  |---area 1----|     |--area x---|      |----Area 2----|
 ]>           |----------isis backbone-----------|
 ]>
 ]>
 ]>Cheers.
 ]>
 ]>- abe
 ]>
 ]>> 
 ]>> cheers,
 ]>> 	Eduard
 ]>> 
 ]>> > ----------
 ]>> > From: 	Mike Shand[SMTP:[email-masked]]
 ]>> > Sent: 	dinsdag 20 juni 2000 20:34
 ]>> > To: 	Metz, E.T.; Dave Katz; [email-masked]'
 ]>> > Cc: 	[email-masked]; [email-masked]
 ]>> > Subject: 	RE: [Isis-wg] Areas in ISIS
 ]>> > 
 ]>> > At 20:14 20/06/2000 +0100, Metz, E.T. wrote:
 ]>> > >ps. Mike (Shand) an ISIS backbone will never correspond to a L1 area
 ]>> > would
 ]>> > >it? It needs to be L2 or L1/L2 at least.
 ]>> > 
 ]>> > Were running into terminological inexactitudes here :-)
 ]>> > 
 ]>> > Yes it does need to be L2, but one way of designing an IS-IS network
 ]is to
 ]>> > 
 ]>> > make an area of L1/L2 routers which constitutes the backbone and then
 ]hang
 ]>> > 
 ]>> > all the other areas off this one. Of course you need at least one L1/L2 
 ]>> > router in each of those areas, so the backbone (in the sense we were 
 ]>> > talking before, i.e. the set of connected L2 routers - or the
 ]distribution
 ]>> > 
 ]>> > domain of L2 LSPs) spans multiple areas. But it does look rather like
 ]the 
 ]>> > OSPF case, where the backbone is a single area (0 in that case).
 ]>> > 
 ]>> > Mike (S)
 ]>> > 
 ]>> > 
 ]>> 
 ]>> _______________________________________________
 ]>> Isis-wg mailing list  -  [email-masked]
 ]>> http://external.juniper.net/mailman/listinfo/isis-wg
 ]>
 ]>-- 
 ]>
 ]>
 ]>==.==.==.==.==
 ]>Abe Martey
 ]>San Jose, CA
 ]>408 527 9149
 ]>
 ]>_______________________________________________
 ]>Isis-wg mailing list  -  [email-masked]
 ]>http://external.juniper.net/mailman/listinfo/isis-wg
 ]>
 ]>
 ]____________________________________________________________________
 ]
 ]  Jeff Learman                           Internet:     [email-masked]
 ]  Engineering Manager                    Voice:     (734)-975-7323
 ]  ONE (Open Networks Engineering, Inc)   Fax:       (734)-975-6940
 ]  2725 South Industrial Pkwy, Suite 100
 ]  Ann Arbor, MI  48104  USA
 ]____________________________________________________________________
 ]
 ]_______________________________________________
 ]Isis-wg mailing list  -  [email-masked]
 ]http://external.juniper.net/mailman/listinfo/isis-wg

- Naiming

---

From: Alex Zinin <[email-masked]>
Date: Tue, 27 Jun 2000 08:13:16 -0700

Also, IP forwarding doesn't care about route types. L1 or L2, it just
looks for the best match in the very (and single, which is important)
routing table.