Subject: Re: [Isis-wg] router ID for IS-IS

From: Danny McPherson <[email-masked]>
Date: Mon, 12 Jun 2000 20:39:42 -0600

> I was wondering if anybody uses ISIS router ID ( which is 1 to 8 bytes
> long ) same as BGP router ID ( which is 4 bytes long )?

While it could be 1-8 octets in length, nobody ever uses anything other than 6 
octets for sysid.

> The same router
> ID for BGP and OSPF is very helpful when you import routes from BGP into
> OSPF routing domain. I am not sure if anybody distributes BGP routes
> into IISIS domain in the field? 

Usually not intentionally, and even if unintentionally, not for very long ;-)

A common practice is for service providers to map the loopback IP address of the router to the sysid (4 octets -> 6 octets, padded), this eases management overhead, especially when using automated tools.  For example, a router with a IP loopback address of 192.168.56.1 would have a sysid value of 1921.6805.6001.  
Though this is a bit more intuitive, it's little more.

-danny

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Tue, 13 Jun 2000 09:20:04 -0400

> I was wondering if anybody uses ISIS router ID ( which is 
> 1 to 8 bytes long ) same as BGP router ID ( which is 4 bytes 
> long )? 

Sorry that I continued this confussion.

There are two IDs at issue here: the 6 byte System ID, 
and the 4 byte Router ID used, for example, in Traffic
Engineering.  I think mostt of the posts on this thread
were really about the System ID: I confused things
by talking reading the words, rather than the intent
of the posting.  

- jeff parker
- Lucent Technology

---

From: Radia Perlman - Boston Center for Networking <[email-masked]>
Date: Tue, 13 Jun 2000 11:00:46 -0400 (EDT)

I never thought the variable length system ID was a good idea.
Just one of these design by committee things added trying to be
fancy, at the expense of ugliness and little or no
functionality. Especially since it's the kind of thing that can
cause serious problems if anyone really did try to make routers
use different sizes. It might be nice someday to rewrite the spec and
take out things like that.

Radia

---

From: newbie <[email-masked]>
Date: Tue, 13 Jun 2000 08:55:10 -0700 (PDT)

The role of IS-IS is the same as OSPF. If someone
wants to redistribute BGP routes into OSPF, then there
will be some cases one wants to redistribute BGP into
IS-IS.

-newbie

--- Rajesh Saluja <[email-masked]> wrote:
> 
> Jeff Parker wrote:
> 
> > If you use the same router ID that BGP and OSPF
> > use, then you may be able to share some
> information
> > between the protocols.
> > 
> > This doesn't really answer your question, but
> > does suggest that you define some answer
> > common to all protocols you support.
> 
> Jeff,
> long ) same as BGP router ID ( which is 4 bytes long
> )? The same router
> Regards,
> Rajesh

__________________________________________________
Do You Yahoo!?
Yahoo! Photos -- now, 100 FREE prints!
http://photos.yahoo.com