Subject: RE: [Isis-wg] Areas in ISIS

From: Jeff Learman <[email-masked]>
Date: Mon, 26 Jun 2000 12:18:37 -0400

It's not important to avoid loops of areas.  This does not contradict
what Mike Shand said.

Another way to think of it is that, for robustness, you want to make sure
that your backbone is constructed in a way so that no single link or
router failure could partition the backbone.  Likewise, each area should
be constructed so that no single link or router failure can partition the
area.  In Mike's example, the backbone wouldn't be partitioned, but the
area would.

As Mike says, you need to carefully plan the toplogy of your "Level 2
subdomain", as it's called in ISO 10589, just as you carefully plan
the topology of each area.  When showing a graphic of the whole topology,
it's usually a good idea to render the L2 links in a special color,
so that it jumps out even though it's not physically separate from
the rest of the network.

Of course, this highlighting is unnecessary if you always plan an
"Area 0" containing most (but not all!) of your Level 2 backbone.
The rest of the L2 backbone would be the one-hop links from the Area
0 routers to the L2 routers in the other areas.  For robustness, you
would want at least two L2 routers in each area, each with its own link
to a different router in Area 0.  But as soon as you depart from this
plan (by chaining subtended areas, for example), then you need to
look at your L2 backbone and make sure it is contiguous (even in the
event of a link or router failure).

Regards,
Jeff

At 08:14 PM 6/20/00 +0100, you wrote:
>
>Thanks for the clarifications ... 
>
>As for the situation I was thinking of, this was indeed the case where you
>have multiple areas and the backbone is formed of the "edges" of the areas
>and the links between the areas. I didn't really think of a "chain" of
>areas, the loop issue is although interesting.
>
>I like the concept of this "virtual backbone" is ISIS, although in
>(re)designing networks you'll probably have to clearly keep in mind to keep
>the backbone contiguos and avoid chains (loops) of areas. While in OSPF this
>is more or less forced upon th designer due to the explicit area 0 that has
>to present, and to which all other areas should connect.
>
>cheers,
>	Eduard
>
>
>ps. Mike (Shand) an ISIS backbone will never correspond to a L1 area would
>it? It needs to be L2 or L1/L2 at least.
>
>> ----------
>> From: 	Mike Shand[SMTP:[email-masked]]
>> Sent: 	dinsdag 20 juni 2000 9:02
>> To: 	Dave Katz
>> Cc: 	[email-masked]; [email-masked]
>> Subject: 	Re: [Isis-wg] Areas in ISIS
>> 
>> At 13:26 19/06/2000 -0700, Dave Katz wrote:
>> >This isn't "physically distinct" in the sense that L1 traffic can
>> traverse
>> >some of the same links that make up the L2 topology, but it is important
>> >to think of the L2 topology as distinct when you design your network, or
>> >you can end up in a world of hurt.  In particular, if areas A, B, and C
>> >are connected through a loop, and there are parts of area B that depend
>> >on those L1L2 links for L1 connectivity, a break of the path through
>> >area B could not be healed via A and C.
>> >
>> >In the topology you describe, I would visualize the L2 path as being
>> >on the edge of area B, as it (at least to me) presents the weaknesses
>> >of the topology more clearly.
>> 
>> Dave,
>>          I couldn't agree more. The difference between IS-IS and OSPF is 
>> not primarily one of network design, but one of nomenclature. i.e. in
>> IS-IS 
>> you still need to design a 'backbone', but the backbone isn't named as a 
>> single area (0) as it is in OSPF. In fact it isn't named at all. Its just 
>> defined by the connected set of L2 routers. In some designs that will 
>> correspond to a single L1 area, but in others it may traverse (or as you 
>> rightly point out ,it is better to think of it as skirting around the edge
>> 
>> of) multiple L1 areas.
>> 
>>          Mike
>> 
>> 
>> 
>> _______________________________________________
>> Isis-wg mailing list  -  [email-masked]
>> http://external.juniper.net/mailman/listinfo/isis-wg
>> 
>
>_______________________________________________
>Isis-wg mailing list  -  [email-masked]
>http://external.juniper.net/mailman/listinfo/isis-wg
>
>
____________________________________________________________________

  Jeff Learman                           Internet:     [email-masked]
  Engineering Manager                    Voice:     (734)-975-7323
  ONE (Open Networks Engineering, Inc)   Fax:       (734)-975-6940
  2725 South Industrial Pkwy, Suite 100
  Ann Arbor, MI  48104  USA
____________________________________________________________________

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Mike Truskowski <[email-masked]>
Date: Mon, 26 Jun 2000 11:12:52 PDT

Somehow I'm lost here...  I thought we were talking about 
what is the backbone...  Another way to look at this is
to consider it from the L1 router view point...in ISIS.
I have a hard time following the discussion when scalability
and topologies get in the way...

How does a L1 router choose an external path...  By closest
L2 router.  How does a router in one area talk to another in
a different area?  By L2 path.

Hence, the backbone must be the set of all L2 routers with  
external reachability....  irregardless of connectability

Now if you want any2any reachability...then the set of L2
routers must be contiguous... so connect the L2 routers like
connecting dots in a drawing.

Now, do you want to talk topology?  Avoiding loops are 
important.  That is why heirarchical networks are easier
to maintain and scale...  Further, loops just cause more
L2 paths to maintain.  So avoid loops.

And network reliability and robustness... well you can 
build a network with single L1/L2 paths between areas...
when a L2 path goes down then part of the network goes 
down...  you can help the reliability if there are
redundant paths out of an area to the backbone....

miket