Subject: [Isis-wg] Complete sequence number packets

From: "Ashish Mehta" <[email-masked]>
Date: Thu, 05 Oct 2000 20:45:55 GMT

Hi all,

I am new member of this mailing list and had some issues with the
complete sequence number PDU received from Juniper box. As per ISO 10589
standard, the SourceID in the CSNP header is ID Length + 1, where Source
ID is the system ID of Intermidiate System(with zero Cicuit ID)
generating this Sequence Number PDU.

I have set up the following ISO NET address on the interface
configured for ISIS 49.0001.00a0.c96b.c490.00. When I receive the packet
I get following from the SourceID.

srcid[0]
0x0
srcid[1]
0xa0
srcid[2]
0xc9
srcid[3]
0x6b
srcid[4]
0xc4
srcid[5]
0x90
srcid[6]
0x2

If you see the last byte is 0x2 insted of 0x0.
An update on this issue will be appreciated.

Thanks.

-Ashish

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at 
http://profiles.msn.com.

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Tony Li <[email-masked]>
Date: Thu, 5 Oct 2000 15:21:29 -0700 (PDT)

Sounds to me like the guy who did Juniper's IS-IS implementation bcopy'ed
the system ID and forgot to zero the circuit ID.  Not too surprising, I
know him and he's an idiot.  ;-)

In any case, this is clearly a case for Juniper technical support, not an
IETF issue.

Thanks,
Tony

Ashish Mehta writes:
 | Hi all,
 | 
 | I am new member of this mailing list and had some issues with the
 | complete sequence number PDU received from Juniper box. As per ISO 10589
 | standard, the SourceID in the CSNP header is ID Length + 1, where Source
 | ID is the system ID of Intermidiate System(with zero Cicuit ID)
 | generating this Sequence Number PDU.
 | 
 | I have set up the following ISO NET address on the interface
 | configured for ISIS 49.0001.00a0.c96b.c490.00. When I receive the packet
 | I get following from the SourceID.
 | 
 | srcid[0]
 | 0x0
 | srcid[1]
 | 0xa0
 | srcid[2]
 | 0xc9
 | srcid[3]
 | 0x6b
 | srcid[4]
 | 0xc4
 | srcid[5]
 | 0x90
 | srcid[6]
 | 0x2
 | 
 | If you see the last byte is 0x2 insted of 0x0.
 | An update on this issue will be appreciated.
 | 
 | Thanks.
 | 
 | -Ashish
 | 
 | _________________________________________________________________________
 | Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.
 | 
 | Share information about yourself, create your own public profile at 
 | http://profiles.msn.com.
 | 
 | 
 | 
 | _______________________________________________
 | Isis-wg mailing list  -  [email-masked]
 | http://external.juniper.net/mailman/listinfo/isis-wg
 | 
 | _______________________________________________
 | Isis-wg-external mailing list
 | [email-masked]
 | http://mailist.procket.com/mailman/listinfo/isis-wg-external