Subject: Re: [Isis-wg] I/E bit in TLV-135

From: stefano previdi <[email-masked]>
Date: Wed, 15 Nov 2000 21:53:33 +0100

At 05:14 14/11/2000, [email-masked] wrote:
>Still don't understand. By reading the draft, up/down bit indicates a route
>has traversed from L2 to L1.

more precisely it indicates that the prefix went from a 
upper level to a lower level.

> But how a router distinguish internal/external
>routes? 

it doesn't. TLV-135 doesn't have any I/E bit.

>If a router leaned both internal and external routes to same
>destination with same up/down bit, how does it select one? Just
>based on metric?

Again: TLV-135 doesn't make any difference between "internal" 
and "external". 

s.

>Bob
>
>At 04:50 PM 11/10/2000 +0100, stefano previdi wrote:
>At 16:34 10/11/2000, Rick Han wrote:
>>Hi, I have a question about TLV-135 (described in
>>draft-ietf-isis-traffic-02.txt). How does TLV-135 indicate the metric
>>type (internal/external)?
>
>it doesn't.
>
>If you refer to the use of I/E bit in draft-ietf-isis-domain-wide,
>keep in mind that we have the up/down bit for that.
>
>> Is there a bit in the 4-byte metric field
>>reserved for metric-type?
>
>no.
>
>Note that to my knowledge thare are no implementations that really use
>I/E bit in TLV-128/130. Therefore the interest of having similar bit
>in TLV-135 was quite limited....
>
>s.
>
>_______________________________________________
>Isis-wg mailing list  -  [email-masked]
>http://external.juniper.net/mailman/listinfo/isis-wg 

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: [email-masked]
Date: Mon, 13 Nov 2000 23:14:46 -0500

Still don't understand. By reading the draft, up/down bit indicates a route
has traversed from L2 to L1. But how a router distinguish internal/external
routes? If a router leaned both internal and external routes to same
destination with same up/down bit, how does it select one? Just
based on metric?

Bob

it doesn't.

no.

s.