Subject: RE: [Isms] proposal comparison I-D

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 15 Feb 2005 11:22:02 -0800

Hi David Harrington and David Perkins,

My concerns that this WG may fail are based on:
(a) some WG participants (but not most) will meet in person in
    early March at IETF 62; 
(b) minutes from IETF face-to-face meetings are usually very 
    slow to appear;
(c) other members of this mailing list won't know what concensus,
    if any, was reached at IETF 62 until mid-March;
(d) revising the WG charter based entirely on email threads 
    (without a new version of the EUSM proposal per suggestions
    of the evaluation team) seems dubious.

Chairs - is the IESG likely to accept a recharter without
any I-D to point at documenting the "decision about approach"?
Is the evaluation I-D itself sufficient?  

The changes that were suggested to EUSM are certainly not 
cosmetic.

Again - I hope this working group succeeds - I really believe
that this is the 'last chance' for SNMPv3 to start getting
_deployed_ by customers.  Proprietary HTTP, CLI, OASIS WSDM, 
and too many other choices are already competing here (and they
can all use TLS).

My colleagues in the network printer industry (working on
IEEE/ISTO PWG standards) keep telling me that their upper
management say "SNMP is dead".  The development funds seem
to be going toward Web solutions:  
(a) Proprietary HTTP forms/etc.; or 
(b) SOAP over HTTP (OASIS WSDM, etc.).
And proprietary HTTP solutions are the only ones currently
shipping from any printer vendor.  This is not good.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

-----Original Message-----
From: David B Harrington [mailto:[email-masked]]
Sent: Monday, February 14, 2005 9:44 PM
To: 'McDonald, Ira'; 'Juergen Quittek'; [email-masked]
Subject: RE: [Isms] proposal comparison I-D

Hi Ira,

Juergen said the document was submitted today, and it was apparently
received before the cutoff time, since it is now reflected on the
charter page. 

Based on the charter deadlines, the WG still has through March to make
a "decision about which solution approach the WG will focus its
efforts on." We also have until the end of March to recharter to
include publication goals or shutdown if no consensus on a technical
direction is reached by this time.

I think we will be able to reach consensus on a technical direction by
that time. While there are benefits to the TLSM proposal, I have no
issue with it being put aside to focus on the EUSM model. The TLSM
approach can always be written as a future alternative if desired. The
EUSM model, with the eval-team suggested changes to make it more
modular, should be flexible enough to meet the needs of many industry
segments.

David Harrington
[email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of McDonald, Ira
> Sent: Monday, February 14, 2005 7:32 PM
> To: 'Juergen Quittek'; [email-masked]
> Subject: RE: [Isms] proposal comparison I-D
> 
> Hi,
> 
> Well written document!  I liked the architectural perspective
> on the three ISMS proposals.  
> 
> But the revised I-D cutoff for IETF 62 passed today.  That 
> means an I-D publication blackout until mid-March.  
> 
> So it's difficult to see how this working group doesn't fail.  
> Are the minutes of the ISMS WG meeting at IETF 62 to constitute 
> the sole proof that the WG has 'selected' a proposal by the 
> end-of-March?  Especially in light of the evaluation team's
> recommendation that EUSM be substantially modified to add 
> features from both of the other proposals?
> 
> All - please read the evaluation team's short cogent document
> soon - please minimize email rhetoric on second-order features
> and stick to the architectural guidance on first-order features
> in the evaluation I-D.
> 
> Cheers,
> - Ira
> 
> Ira McDonald (Musician / Software Architect)
> Blue Roof Music / High North Inc
> PO Box 221  Grand Marais, MI  49839
> phone: +1-906-494-2434
> email: [email-masked]
> 
> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Juergen Quittek
> Sent: Monday, February 14, 2005 11:49 AM
> To: [email-masked]
> Subject: [Isms] proposal comparison I-D
> 
> 
> Dear all,
> 
> The evaluation team has completed its work.
> It took longer than expected (as so many IETF tasks),
> but now they delivered us a comparison of the three proposals
> and give a recommendation on how the WG should proceed.
> 
> I thank all team members for their excellent work, and
> Randy and Lakshminath for acting as document editors.
> 
> The I-D was just submitted today.  For all who do not want
> to wait until it gets posted officially by the end of the
> week, I put a copy at:
> 
> <ftp://ftp.netlab.nec.de/pub/internet-drafts/draft-ietf-isms-p
> roposal-compar
> ison-00.txt>
> 
> Please have a look at it and let's start a (certainly
> controversial) discussion on it as soon as possible.
> 
> The recommendations in section 3 provide a lot
> of useful input to shaping a WG agenda.
> 
> Thanks,
> 
>     Juergen
> -- 
> Juergen Quittek        [email-masked]       Tel: +49 
> 6221 90511-15
> NEC Europe Ltd.,       Network Laboratories        Fax: +49 
> 6221 90511-55
> Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   
> http://www.netlab.nec.de
> 
> _______________________________________________
> Isms mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isms
> 
> _______________________________________________
> Isms mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isms
> 

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

---

From: "David B Harrington" <[email-masked]>
Date: Tue, 15 Feb 2005 15:00:27 -0500

Hi,

Regarding pronouncements that SNMP is dead - I've heard it so many
times in the IETF, but so seldom from buying customers, that I don't
put a lot of stock in such pronouncements. Which is not to say that
valid criticisms of SNMP shouldn't be paid attention to; SNMP has been
around for a long time and is used in ways it was not designed for,
and hasn't kept up with related advances in technology.

I think it is important to recognize that management interfaces for
printers are normally for element management, not network, service, or
business process management. Generally one does not need to compare
the status of the paper tray across printers. For monitoring a
specific device status, a CLI or web-based interface is typically
fine. SNMP isn't required for that use-case (although traps could
certainly be useful).

While many TLS-based management interfaces are available, most do not
have what has really made SNMP successful - a vendor-neutral schema
for management data, widely-deployed industry-standard data models for
consistency across multiple vendors' products, a widely-deployed
vendor-neutral protocol for remote data manipulation, and a wide
selection of value-add applications capable of monitoring (and
sometimes managing) network/service/business functionality and not
just individual devices. Leveraging TLS could certainly be a good
thing, it also introduces problems that would need to be resolved
(just as all the proposals will introduce problems to be resolved).

Regarding whether we fail or not, consdier this:
A) Bert Wijnen will be among the missing at IETF62, and his opinion
will probably carry a great deal of weight in deciding whether our
consensus on direction justifies being rechartered.
B) the chairs can turn around the minutes very quickly when necessary.
C) consensus is determined by the whole WG, not just meeting
attendees; while face-to-face contact can help bring people together
for negotiating positions and reaching compromise, the mailing list is
required to determine WG consensus.
D) our goal is to decide on a direction, not to have a finished
document by the end of March. I think it would make a lot of sense to
recharter without having the EUSM republished first (although having
an updated revision would be nice).

I look rather optimistically at what this WG has achieved so far, and
what we will yet achieve. 

David Harrington
[email-masked]

> From: McDonald, Ira [mailto:[email-masked]] 
> Sent: Tuesday, February 15, 2005 2:22 PM
> To: [email-masked]'; McDonald, Ira; 'Juergen Quittek'; 
> [email-masked]

---

From: Ken Hornstein <[email-masked]>
Date: Tue, 15 Feb 2005 15:23:33 -0500

>The changes that were suggested to EUSM are certainly not 

Well ... here's my interpretation of the mandate set before us from the
IESG.

We have to decide on a _single_ technical direction by the March
meeting.  In my mind, if the WG accepts the evaluation team's
recommendations (EUSM with the suggested changes), that to me is
clearly a single direction.  We definately don't have to have the
protocol all hashed out.

Clear enough?

--Ken