Subject: RE: [Isms] Wehn the network doesn't.

From: "Blumenthal, Uri" <[email-masked]>
Date: Sun, 8 May 2005 06:32:17 -0400

David> Hi, If DTLS has significant session setup requirements,
    David> then the USM/UDP might still be a better choice for
    David> troubleshooting. We should consider the applicability of
    David> various solutions for troubleshooting a broken network, and
    David> for managing a non-broken network.

> I'd really like it if someone would work on some requirements for SNMP
> security when the network is down/broken. 

Let me mention that the original SNMP design was based on the concept of
"got to deal with broken networks". It's precisely the network
reliability and usage of SNMP for non-firefighting purposes that (IMHO)
allows this WG to exist.

> What do you want to be able to do? 

Probably access devices in trouble[d location] securely, ask it
questions, MAYBE also set some simple parameters - but today it's
usually done via CLI in the unlikely case network turns ugly...

> Is being able to push out updates for a few users
> while the network is functioning enough? 

I think - quite enough.

> Is keeping long-lived sessions alive enough?

I think - enough.

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

---

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 9 May 2005 17:43:44 -0700

Hi Sam,

Well - we just talked right past each other.  Your reply below
is exactly what I what I was trying to say.

The goal of the ISMS WG is to finally make SNMP usable and
useful and _used_ by operators and administrators, by overcoming
the high cost of unique security mechanisms.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Sam Hartman [mailto:[email-masked]]
> Sent: Monday, May 09, 2005 5:44 PM
> To: McDonald, Ira
> Cc: Wes Hardaker; [email-masked]
> Subject: Re: [Isms] Wehn the network doesn't.
> 
> 
> >>>>> "McDonald," == McDonald, Ira <[email-masked]> writes:
> 
>     McDonald,> CLIs over Telnet or out-of-band dialup always have been
>     McDonald,> the main method used to fix broken large networks.
>     McDonald,> SNMP never has been accepted by the operators as a
>     McDonald,> viable solution.  That's the problem that ISMS WG is
>     McDonald,> supposed to be addressing.
> 
> No, that's not our goal.  Our goal is the create a security model for
> SNMP that will meet the security and operational needs of the operator
> community.
> 
> I find nothing in the charter of the working group that states which
> uses of SNMP the operators actually want.
> 
> 
> As such, the question of which use cases we care about seem entirely
> within scope.
>