Subject: [Isms] #30: do we need to check whether securityParameters parses correctly?

From: "David B Harrington" <[email-masked]>
Date: Thu, 13 Oct 2005 18:08:11 -0400

#30: If we actually do not extract anything from securityParameters,
do we need to check whether this field parses correctly?

David Harrington
[email-masked]

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 14 Oct 2005 14:13:09 -0700

Hi -

> From: "David B Harrington" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, October 13, 2005 3:08 PM
> Subject: [Isms] #30: do we need to check whether securityParameters parsescorrectly?
>

> do we need to check whether this field parses correctly?
...

Yes, within whatever constraints are extablished by the security model.
If the security model says it needs to be a zero-length OCTET STRING,
then implementations need to enforce that.  If we give it more content / 
structure, then those too need to be enforced.

Randy