Subject: RE: [Isms] Latest draft of TLS w/ SRP

From: "Khanh Nguyen \(khanhvn\)" <[email-masked]>
Date: Mon, 31 Oct 2005 12:31:44 -0800

I think it's too late now to go back to the SSH vs TLS discussion.  But
if we do decide to reconsider, I definitely go with TLS+SRP.

I believe SRP is the ideal authentication method for SNMP because the
passwords can be used for not only client (manager) but also server
(agent) authentication, so you don't need PKI, Kerberos, or other
heavy-weight infrastructure for server auth.  Unfortunately SRP has
never been seriously considered here.

I think the reason SSH is more in demand in the survey is because
operators are more familiar with it, not because of its technical
superiority.

Khanh

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of McDonald, Ira
> Sent: Monday, October 31, 2005 8:45 AM
> To: [email-masked]'; McDonald, Ira; [email-masked]
> Subject: RE: [Isms] Latest draft of TLS w/ SRP
> 
> Hi,
> 
> Well - certainly many routers and middleboxes support _some_ 
> form of some protocol they call 'SSH'.  But it's noteworthy 
> that SSH2 (the current version) is still in the RFC Editor's 
> queue.  And that SSH1 and SSH2 (specifically the modules from 
> SSH Communications Security Corp who hold the trademark on 
> 'SSH' in many countries) do NOT interoperate.
> 
> The quality of open source implementations of SSH is vastly 
> inferior to the open source implementations of TLS, as has 
> been noted on this mailing list.
> 
> The fairly arbitrary choice of SSH over TLS forced the ISMS 
> WG move to SNMP over TCP connections (with all the attendant 
> vulnerabilities of TCP and of long-term connections).
> 
> A TLS choice would have permitted the use of DTLS (also now 
> in the RFC Editor's queue as Proposed Standard), which would 
> have allowed ISMS to use UDP (the traditional SNMP transport).
> 
> Cheers,
> - Ira
> 
> 
> Ira McDonald (Musician / Software Architect) Blue Roof Music 
> / High North Inc PO Box 221  Grand Marais, MI  49839
> phone: +1-906-494-2434
> email: [email-masked]
> 
> > -----Original Message-----
> > From: David B Harrington [mailto:[email-masked]]
> > Sent: Sunday, October 30, 2005 6:42 PM
> > To: 'McDonald, Ira'; [email-masked]
> > Subject: RE: [Isms] Latest draft of TLS w/ SRP
> > 
> > 
> > Hi Ira,
> > 
> > Did I miss something? What arguments against using TLS?
> > 
> > I thought we simply decided that SSH seemed to be more in demand by 
> > operators for network management purposes.
> > 
> > dbh
> > 
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]] On Behalf Of McDonald, Ira
> > > Sent: Sunday, October 30, 2005 11:11 AM
> > > To: [email-masked]
> > > Subject: [Isms] Latest draft of TLS w/ SRP
> > > 
> > > Hi,
> > > 
> > > Although this ISMS WG has now turned away from TLS to SSH 
> (unwisely 
> > > IMHO), to set the record straight, the work on TLS w/ SRP is very 
> > > much alive and well.  The latest draft is:
> > > 
> > >   Using SRP for TLS Authentication, October 6 2005
> > >   ftp://ftp.ietf.org/internet-drafts/draft-ietf-tls-srp-10.txt
> > > 
> > > Given that the IESG is very unlikely to approve SNMP over SSH 
> > > without a mandatory IANA-registered port, arguments against using 
> > > TLS for ISMS seem dubious to me.
> > > 
> > > Whatever security protocol is used below the SNMP 
> application layer, 
> > > the SAs (security associations) at the lower layer (SSH, TLS, 
> > > whatever) and the SNMP layer will have to be securely 
> > > cryptographically bound or else the SSH SA MUST require strong 
> > > mutual authentication or else active man-in-the-middle 
> attacks will 
> > > be trivially easy.
> > > 
> > > Cheers,
> > > - Ira
> > > 
> > > 
> > > Ira McDonald (Musician / Software Architect) Blue Roof 
> Music / High 
> > > North Inc PO Box 221  Grand Marais, MI  49839
> > > phone: +1-906-494-2434
> > > email: [email-masked]
> > > 
> > > _______________________________________________
> > > Isms mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/isms
> > > 
> > 
> > 
> 
> _______________________________________________
> Isms mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isms
> 

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

---

From: "David B Harrington" <[email-masked]>
Date: Mon, 31 Oct 2005 16:08:11 -0500

Hi,

I agree. 

We chose to work on SSH because operators indicated a preference, not
because there was a recognized technical superiority of one solution
over the other. The existence of an SSH solution does not preclude a
TLS solution. From the charter:

"In order to leverage the authentication information already
accessible
at managed devices, the new security model will use the SSH protocol
for message protection, and RADIUS for AAA-provisioned user
authentication and authorization. However, the integration of a
transport mapping security model into the SNMPv3 architecture should
be
defined such that it is open to support potential alternative
transport
mappings to protocols such as BEEP and TLS."

In addition to expressed operator preference, we have volunteers
willing to edit the documents needed to describe an SSH solution. 

If Ira and others want a TLS+SRP solution, then feel free to start
editing the documents needed to describe a TLS+SRP solution.

David Harrington
[email-masked]

> From: Khanh Nguyen (khanhvn) [mailto:[email-masked]] 
> Sent: Monday, October 31, 2005 3:32 PM
> To: McDonald, Ira; [email-masked]; [email-masked]