Subject: [Isms] #11: zero-length OCTET STRING, or ASN.1 NULL for msgSecurityParameters?

From: "David B Harrington" <[email-masked]>
Date: Thu, 13 Oct 2005 17:53:18 -0400

#11: If we eliminate all msgSecurityParameters, should the
msgSecurityParameters field in the SNMPv3 message simply be a
zero-length OCTET STRING, or should it be an ASN.1 NULL?

David Harrington
[email-masked]

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 14 Oct 2005 12:55:35 -0700

Hi -

> From: "David B Harrington" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, October 13, 2005 2:53 PM
> Subject: [Isms] #11: zero-length OCTET STRING,or ASN.1 NULL for msgSecurityParameters?
>
...

Unless folks want to re-open RFC 3412, it will have to be a zero-length
OCTET STRING, since that's the only thing permitted by the ASN.1 there.

Randy