Subject: RE: [Isms] #1: is it important to support anonymous user access to SNMP?

From: "Nelson, David" <[email-masked]>
Date: Thu, 13 Oct 2005 17:33:27 -0400

Dave Harrington writes...

> From draft-hardaker-snmp-session-sm-03.txt: "SNMP message exchange
> that is authenticated and even private when the session initiator or
> responder is anonymous."
> 
> This is a new feature provided by SBSM. Can we establish consensus
> that a) this is needed or b) this is not needed?

I may be particularly obtuse on this point, but I fail to see how a
truly anonymous entity can ever be authenticated.  Private, yes.  But
authenticated?

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

---

From: "David T. Perkins" <[email-masked]>
Date: Thu, 13 Oct 2005 23:27:11 -0700 (PDT)

HI,

What anonymous user means is the following...
1) the identity of a command generator (an SNMP management app)
   is not verified (and is unknown)
2) the identity of the command responder (an SNMP agent)
   is authenticated
3) the integrity (and timeliness) of the SNMP messages is
   verified
Optionally, the messages are encrypted.

This capability allows "authentic management information" to
be obtained from an anonymous identity. There are many 
real-world examples of this usage pattern. I believe that
it is more important to be able to have encrypted and
integrity checked messages instead of just integrity checked
messages. This capability allows authentic message
exchange with a "new identity" without any configuration
of the SNMP agent's configuration. This is a VERY
GOOD THING.

In the other direction, what anonymous user means is the following...
1) the identity of a notification receiver is not verified
2) the identity of a notification generator (an agent)
   is authenticated
3) the integrity (and timeliness) of SNMP messages is
   verified.
Optionally, the messages are encrypted.

This capability allows "authentic management information"
to be sent via a notification to an anonymous identity.
I believe that this could be quite problematic to implement,
and I can't think of any the real-world cases for this.
Also, a new receiver requires an update of configuration
of the SNMP agent to specify a transport address.

> truly anonymous entity can ever be authenticated.  Private, yes.  But

Regards,
/david t. perkins

---

From: "David T. Perkins" <[email-masked]>
Date: Fri, 14 Oct 2005 07:27:14 -0700 (PDT)

HI,

I noticed a small, yet important typo. Also, an example....

> be obtained from an anonymous identity. There are many 
              ^^^^ should be "by"
> messages. This "anonymous user" allows authentic message
A very common use case is making network status available to
anyone. "Anonymous user" means that the info is authentic.