Subject: [Isms] Question regarding SNMPv3 engine-id discovery process

From: "Tammy Alper" <[email-masked]>
Date: Mon, 19 Mar 2007 10:40:59 +0200

Hello,

I have a question regarding the SNMPv3 engine-id discovery process:

Suppose an SNMP engine wants to discover a remote engine-id value,

for the purpose of sending an Inform message to the remote engine.

After sending the discovery packet to the requested target and upon 

receiving an incoming packet:

Should the (UDP) port also be used (in addition to IP address) for 

matching response to the request in this case?

In other words - when a cache is used to store remote engine-ids
information,

should the mapping be of the form:      engine-id --> ip-address
or 

                                                        engine-id -->
ip-address, UDP port

In case the SNMP engine supports second option, if the remote engine-id

sends a response to the discovery packet from a port different from the
port

on which it got the request, the SNMP engine will ignore the response
and

the discovery process will fail. Hence the importance of
interoperability in 

this case. 

Thank you

Tammy Alper

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

---

From: "Wijnen, Bert \(Bert\)" <[email-masked]>
Date: Thu, 22 Mar 2007 13:00:35 +0100

Inline 

> -----Original Message-----
> From: Tammy Alper [mailto:[email-masked]] 
> Sent: maandag 19 maart 2007 9:41
> To: [email-masked]
> Subject: [Isms] Question regarding SNMPv3 engine-id discovery process
> 
> Hello,
> 
> In other words - when a cache is used to store remote 
> engine-ids information,
> 
> should the mapping be of the form:      engine-id -> ip-address
>         or                              engine-id -> ip-address, UDP
port

I myself would save it WITH the UDP port included.
However, and SNMP engine MIGHT be listening to multiple UDP and/or
TCP ports, in which case multiple entries can be stored in your cache.

>  
> 
> In case the SNMP engine supports second option, if the remote 
> engine-id sends a response to the discovery packet from a port 
> different from the port on which it got the request, the SNMP
> engine will ignore the response and the discovery process will
> fail. Hence the importance of interoperability in this case. 
> 
Yep... that is possible. 
I don't think (but would have to go search if I am correct) 
we have specified this detail in our documents.

A possible solution is, that

- you send a GET to Ipadddress, port nnn
- you get response from same Ipaddress, port mmmm

So you could store in your cache both port numbers.

Hope this helps.
Bert

> Tammy Alper
Bert