Subject: [its] Open WAVE implementation: looking for contributors

From: "Konstantin A. Khait" <[email-masked]>
Date: Fri, 27 Sep 2013 13:06:16 +0400

Ladies and gentlemen,

My name is Konstantin Khait, chief engineer in Componentality Oy, member of Linux Foundation and Automotive Grade Linux SC. We're doing open HW and SW solutions for automotive multimedia, navigation and communication.

Currently we launch the initiative to create reference OSS implementation of IEEE 1609, WAVE. WAVE is a fresh and rapidly institutionalizing standard for vehicle to vehicle and vehicle to infrastructure communication, now becoming the main and "must have" approach in ITS, collision prevention and road automation areas. Componentality Oy is willing to provide a hardware platform supporting IEEE 802.11p radio and do coordination of development efforts. However, we need your architectural, engineering and intellectual resources to make this asset together. WAVE is big enough, relatively complex and multifunctional, so only joint community may guarantee it being done in a reasonable time frame and with automotive quality. Fortunately, when we do it, we all will have the most needed asset in V2X and probably it becomes an industrial reference and standard for a long time.

In the timeframe since January when we joined AGL to now we did a lot of consultations with key market players to understand the potential of such solution. Now we know that almost every company working on V2X/ITS solutions demands for such solution. We offer making it together.

Componentality is open for the dialog of what and how to be done for that. By default, we assume to create an OSS Linux stack available for everybody under GPL license. It is what we start since October 1st. If it will be some contributor with any special legal requirements, we're ready to re-review licensing approach and... all other organizational aspects. We plan to make this job done by April, 2014. Now we form the team and WELCOME TO JOIN US!

Simply write me if you have any comments, questions or you want to participate. Hope, later AGL will establish some mailing list, forum and other infrastructure for us.

And thank you all, even who deleted this email before reading :)

Kostia

-----

-----

Konstantin A. Khait

Componentality Oy

Tel: +358(0)465662016

+7(921)9005780

Skype: kostia.khait

E-Mail: [email-masked]

53100 Finland

Ratakatu 47

Lappeenranta

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 27 Sep 2013 11:30:30 +0200

Thanks for the post.

I am interested to hear others' opinions, what do you think?

For me...

At my work place, and at other places I learned, there are some 
implementations of 802.11p driver in linux.  They are for various linux 
kernel versions.  They are derivations from the Atheros 802.11a driver. 
  They implement various features of 802.11p (OCB, 48 1s ESSID, 5.9GHz 
freq range, etc).

However, we dont know yet how to distribute that widely.  Licensing 
scheme questions were made.

We have strong interest in distributing that as wide as possible under 
the best licensing scheme which favors wide deployment and respects 
contributors interests.

For IP handovers particular to 802.11p there is this UMIP distribution, 
whose main maintainer is interested in integrating features as well.

Yours,

Alex

Le 27/09/2013 11:06, Konstantin A. Khait a écrit :
> Ladies and gentlemen,
>
> My name is Konstantin Khait, chief engineer in Componentality Oy, member
> of Linux Foundation and Automotive Grade Linux SC. We're doing open HW
> and SW solutions for automotive multimedia, navigation and communication.
>
> Currently we launch the initiative to create reference OSS
> implementation of IEEE 1609, WAVE. WAVE is a fresh and rapidly
> institutionalizing standard for vehicle to vehicle and vehicle to
> infrastructure communication, now becoming the main and "must have"
> approach in ITS, collision prevention and road automation areas.
> Componentality Oy is willing to provide a hardware platform supporting
> IEEE 802.11p radio and do coordination of development efforts. However,
> we need your architectural, engineering and intellectual resources to
> make this asset together. WAVE is big enough, relatively complex and
> multifunctional, so only joint community may guarantee it being done in
> a reasonable time frame and with automotive quality. Fortunately, when
> we do it, we all will have the most needed asset in V2X and probably it
> becomes an industrial reference and standard for a long time.
>
> In the timeframe since January when we joined AGL to now we did a lot of
> consultations with key market players to understand the potential of
> such solution. Now we know that almost every company working on V2X/ITS
> solutions demands for such solution. We offer making it together.
>
> Componentality is open for the dialog of what and how to be done for
> that. By default, we assume to create an OSS Linux stack available for
> everybody under GPL license. It is what we start since October 1st. If
> it will be some contributor with any special legal requirements, we're
> ready to re-review licensing approach and... all other organizational
> aspects. We plan to make this job done by April, 2014. Now we form the
> team and WELCOME TO JOIN US!
>
> Simply write me if you have any comments, questions or you want to
> participate. Hope, later AGL will establish some mailing list, forum and
> other infrastructure for us.
>
> <http://www.indiegogo.com/projects/celebrity-open-multimedia-gateway-for-in-vehicle-multimedia-and-navigation/x/4193057>
>
> -----
> Konstantin A. Khait
> Componentality Oy
> Tel: +358(0)465662016
>         +7(921)9005780
> Skype: kostia.khait
> E-Mail: [email-masked] <mailto:[email-masked]>
> 53100 Finland
> Ratakatu 47
> Lappeenranta
>
>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: "Konstantin A. Khait" <[email-masked]>
Date: Fri, 27 Sep 2013 13:56:08 +0400

Hi Alexandru,

Our current vision is following.

1. We are in similar position: we build 802.11p equipment based on Atheros and have a custom fork of "a" driver converted to "p". It supports all features assumed by standard, but everything on higher levels is custom (although open source) and based on generic TCP/IP.

2. Our business model is in packaging SW to a system and sell the device. Firmware itself (based on OpenWrt Linux) is free and published for everybody. We distribute our changes under LGPL where original license doesn't assume anything stronger. But it is because we don't make money on generic 802.11p, but on hardware and its customization for ITS and fleet management projects.

3. So, if you want to share your 802.11p implementation widely, I think LGPL or MIT license should be the best option.

4. Actually we see that 802.11p is not enough to have up to date V2X asset required for the market. As soon as WAVE standard now released, people don't want using custom solutions anymore. There are some options there, but IEEE 1609 is a good choice. It is a standard in USA and many people in Europe support it as well.

5. However, IEEE 1609 is rather big thing, it is hard for SME to make and maintain it and there're nobody willing now to put it to OSS domain. Community is only an approach to go and we want to build it, possibly under AGL shield.

6. Definitely nobody in the community want to release their efforts for free. Therefore we assume GPL which lets them to be referred and earn on customization, adaption and support. For us it still doesn't matter as we work in hardware and systems field. We even ready to close this license limiting it by AGL/IETF, but personally I wouldn't want to go this way because it corrupts the idea of OSS.

Thanks,

Kostia

-----

-----

Konstantin A. Khait

Componentality Oy

Tel: +358(0)465662016

+7(921)9005780

Skype: kostia.khait

53100 Finland

Ratakatu 47

Lappeenranta

> implementations of 802.11p driver in linux. В They are for various linux

> kernel versions. В They are derivations from the Atheros 802.11a driver.

> В  They implement various features of 802.11p (OCB, 48 1s ESSID, 5.9GHz

> However, we dont know yet how to distribute that widely. В Licensing

>> В  В  В  В  +7(921)9005780

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 27 Sep 2013 15:08:29 +0200

Le 27/09/2013 11:56, Konstantin A. Khait a écrit :
> 1. We are in similar position: we build 802.11p equipment based on
> Atheros and have a custom fork of "a" driver converted to "p". It
> supports all features assumed by standard,

One particular feature of the 802.11p we wondered about was whether the 
implementation would implement sending the 802.11p's "Time 
Advertisement" frame, which seems to be optional in the IEEE spec.

I could explain why, if you wish; but is it implemented?

Alex
PS: for standards-related work I can send you privately the IEEE 802.11p 
spec.

> but everything on higher
> levels is custom (although open source) and based on generic TCP/IP.
> 2. Our business model is in packaging SW to a system and sell the
> device. Firmware itself (based on OpenWrt Linux) is free and published
> for everybody. We distribute our changes under LGPL where original
> license doesn't assume anything stronger. But it is because we don't
> make money on generic 802.11p, but on hardware and its customization for
> ITS and fleet management projects.
> 3. So, if you want to share your 802.11p implementation widely, I think
> LGPL or MIT license should be the best option.
> 4. Actually we see that 802.11p is not enough to have up to date V2X
> asset required for the market. As soon as WAVE standard now released,
> people don't want using custom solutions anymore. There are some options
> there, but IEEE 1609 is a good choice. It is a standard in USA and many
> people in Europe support it as well.
> 5. However, IEEE 1609 is rather big thing, it is hard for SME to make
> and maintain it and there're nobody willing now to put it to OSS domain.
> Community is only an approach to go and we want to build it, possibly
> under AGL shield.
> 6. Definitely nobody in the community want to release their efforts for
> free. Therefore we assume GPL which lets them to be referred and earn on
> customization, adaption and support. For us it still doesn't matter as
> we work in hardware and systems field. We even ready to close this
> license limiting it by AGL/IETF, but personally I wouldn't want to go
> this way because it corrupts the idea of OSS.
>
> Thanks,
> Kostia
>
>
> -----
>
>
>
> -----
> Konstantin A. Khait
> Componentality Oy
> Tel: +358(0)465662016
>         +7(921)9005780
> Skype: kostia.khait

---

From: "Konstantin A. Khait" <[email-masked]>
Date: Fri, 27 Sep 2013 17:40:30 +0400

Alex, do you mean this spec: http://standards.ieee.org/findstds/standard/802.11p-2010.html ?

-----

-----

Konstantin A. Khait

Componentality Oy

Tel: +358(0)465662016

+7(921)9005780

Skype: kostia.khait

53100 Finland

Ratakatu 47

Lappeenranta

>>> В В They implement various features of 802.11p (OCB, 48 1s ESSID, 5.9GHz

>>>> В В В В В В В В +7(921)9005780

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 27 Sep 2013 15:52:43 +0200

Le 27/09/2013 15:40, Konstantin A. Khait a écrit :
> Alex, do you mean this spec:
> http://standards.ieee.org/findstds/standard/802.11p-2010.html ?

Yes I meant that 802.11p-2010!  I see it now available at no charge.

And, is "Time Advertisement" frame implemented at your site?

Alex

---

From: "Dr. Hans-Joachim Fischer" <[email-masked]>
Date: Fri, 27 Sep 2013 16:02:37 +0200

This version is out of date. The latest version of IEEE 802.11 
(including the .p features) is from 2012.

Hans-Joachim

-- 
------------------------------------------------------------------------------
ESF online-news:    http://fischer-tech.eu/Feeds/esf.rss
C-ITS online news:  http://its-standards.info/Feeds/cits.rss
------------------------------------------------------------------------------
The information contained in this message is confidential and may be legally privileged. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, dissemination, or reproduction is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.
------------------------------------------------------------------------------
Dr. Hans-Joachim Fischer
ESF GmbH
Fichtenweg 9
89143 Blaubeuren
+49 (7344) 175340
+49 (7344) 919123 (Fax)
http://fischer-tech.eu : Main web of ESF GmbH
http://its-standards.eu : News on cooperative ITS standardization
http://its-testing.org : International consultancy for cooperative ITS
------------------------------------------------------------------------------

---

From: "Konstantin A. Khait" <[email-masked]>
Date: Fri, 27 Sep 2013 18:03:38 +0400

Regarding Time Advertisement I need to check with our guys who drive FlexRoad program. Will be back with this info.

Thanks,

Kostia

-----

-----

Konstantin A. Khait

Componentality Oy

Tel: +358(0)465662016

+7(921)9005780

Skype: kostia.khait

53100 Finland

Ratakatu 47

Lappeenranta

> Yes I meant that 802.11p-2010! В I see it now available at no charge.

---

From: "Konstantin A. Khait" <[email-masked]>
Date: Fri, 27 Sep 2013 18:07:00 +0400

I don't have it in my PC, but we did a comparison when it was released. It seems no technical differences there, it just aligns terminology to IEEE 1609. Please correct me if I am wrong.

-----

-----

Konstantin A. Khait

Componentality Oy

Tel: +358(0)465662016

+7(921)9005780

Skype: kostia.khait

53100 Finland

Ratakatu 47

Lappeenranta

>>>> PS: for standards-related work I can send you privately the IEEE

>>>> 802.11p

>>>>> make money on generic 802.11p, but on hardware and its

>>>>> customization for

>>>>> 3. So, if you want to share your 802.11p implementation widely, I

>>>>> think

>>>>> people don't want using custom solutions anymore. There are some

>>>>> options

>>>>> there, but IEEE 1609 is a good choice. It is a standard in USA and

>>>>> many

>>>>> and maintain it and there're nobody willing now to put it to OSS

>>>>> domain.

>>>>> 6. Definitely nobody in the community want to release their efforts

>>>>> for

>>>>> free. Therefore we assume GPL which lets them to be referred and

>>>>> earn on

>>>>>> implementations of 802.11p driver in linux. В They are for various

>>>>>> linux

>>>>>> kernel versions. В They are derivations from the Atheros 802.11a

>>>>>> driver.

>>>>>> В В They implement various features of 802.11p (OCB, 48 1s ESSID,

>>>>>> 5.9GHz

>>>>>> We have strong interest in distributing that as wide as possible

>>>>>> under

>>>>>> For IP handovers particular to 802.11p there is this UMIP

>>>>>> distribution,

>>>>>>> My name is Konstantin Khait, chief engineer in Componentality Oy,

>>>>>>> member

>>>>>>> of Linux Foundation and Automotive Grade Linux SC. We're doing

>>>>>>> open HW

>>>>>>> and SW solutions for automotive multimedia, navigation and

>>>>>>> communication.

>>>>>>> Componentality Oy is willing to provide a hardware platform

>>>>>>> supporting

>>>>>>> IEEE 802.11p radio and do coordination of development efforts.

>>>>>>> However,

>>>>>>> we need your architectural, engineering and intellectual

>>>>>>> resources to

>>>>>>> multifunctional, so only joint community may guarantee it being

>>>>>>> done in

>>>>>>> a reasonable time frame and with automotive quality. Fortunately,

>>>>>>> when

>>>>>>> we do it, we all will have the most needed asset in V2X and

>>>>>>> probably it

>>>>>>> In the timeframe since January when we joined AGL to now we did a

>>>>>>> lot of

>>>>>>> such solution. Now we know that almost every company working on

>>>>>>> V2X/ITS

>>>>>>> that. By default, we assume to create an OSS Linux stack

>>>>>>> available for

>>>>>>> everybody under GPL license. It is what we start since October

>>>>>>> 1st. If

>>>>>>> it will be some contributor with any special legal requirements,

>>>>>>> we're

>>>>>>> ready to re-review licensing approach and... all other

>>>>>>> organizational

>>>>>>> aspects. We plan to make this job done by April, 2014. Now we

>>>>>>> form the

>>>>>>> participate. Hope, later AGL will establish some mailing list,

>>>>>>> forum and

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 27 Sep 2013 16:17:30 +0200

Le 27/09/2013 16:07, Konstantin A. Khait a écrit :
> I don't have it in my PC, but we did a comparison when it was released.
> It seems no technical differences there, it just aligns terminology to
> IEEE 1609. Please correct me if I am wrong.

I tend to agree.  There seem to be no differences between 802.11p-2010 
and the 802.11p parts of 802.11-2012.

IEEE in 2012 put out a single 802.11 document covering all 'a, b... p, 
n'.  That document is 15mbyte/2800 pages.  That's why I still read the 
802.11p-2010 document which is 700kbyte/50pages.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 27 Sep 2013 16:37:31 +0200

Sure, thank you, please check with the guys driving FlexRoad.

Let me explain why I am asking.

The reason I am asking is because we are writing in private a draft
about IP/80211p and I dont know what to write about the "Time
Advertisement" message.  Apparently it's not really needed, unless maybe
for IP handovers.

In our lab we did not implement "TA" message.  Because the spec says it
is optional.  Its main purpose seems to deliver time value, whereas
vehicles may get their time elsewhere (GNSS/Galileo, GSM, etc.).  Worse,
if one wants to do it should be in the driver, which requires strong
skill in low level developments.  Under these conditions, it appears
easier to just not implement "TA".

But, when performing an IP handover between two Road Side Units, the
Mobile Node needs to evaluate the power level of the surrounding RSUs,
to select the candidate RSU.  And these RSUs don't emit Beacon messages
and dont reply to 'scans' (.11p is 'OCB' - outside the context of a
BSS).  For the mobile it's thus impossible to evaluate the candidate RSU
to which to attach, at reasonable vehicle speeds.

Because of those two reasons we preferred the RSUs to send periodic RAs
at high frequency, instead of "TA", and use the RadioTap header
associated to that RA to indicate its power level.  It's strange,
because neither RA nor "TA" dont contain a value saying "Power Level",
yet we need one of them to do a handover.

And RAs at high frequency are contrary to IP specifications (RFC number
here).

Thus the dilemma: "TA" messages are not implemented, high-periodicity
RAs are against RFCs, which makes that the mobile can't perform IP
handover between RSUs.

Not sure whether I am clear.

If we knew for example that someone implemented TAs and used them to
help handovers then we'd invite that person to co-author that document.

Alex

Le 27/09/2013 16:03, Konstantin A. Khait a écrit :
> Regarding Time Advertisement I need to check with our guys who drive
>  FlexRoad program. Will be back with this info.
>
> Thanks, Kostia
>
> -----
>
>
>
> ----- Konstantin A. Khait Componentality Oy Tel: +358(0)465662016
> +7(921)9005780 Skype: kostia.khait E-Mail: [email-masked]
> <mailto:[email-masked]> 53100 Finland Ratakatu 47
> Lappeenranta
>
>
>>> ----- Konstantin A. Khait Componentality Oy Tel:
>>> +358(0)465662016 В  В  В  В  +7(921)9005780 Skype: kostia.khait
>>> <mailto:[email-masked]> 53100 Finland Ratakatu 47
>>> Lappeenranta
>>>
>>>
>>>>> 1. We are in similar position: we build 802.11p equipment
>>>>> based on Atheros and have a custom fork of "a" driver
>>>>> converted to "p". It supports all features assumed by
>>>>> standard,
>>>
>>>> One particular feature of the 802.11p we wondered about was
>>>> whether the implementation would implement sending the
>>>> 802.11p's "Time Advertisement" frame, which seems to be
>>>> optional in the IEEE spec.
>>>
>>>> Alex PS: for standards-related work I can send you privately
>>>> the IEEE 802.11p spec.
>>>
>>>>> but everything on higher levels is custom (although open
>>>>> source) and based on generic TCP/IP. 2. Our business model is
>>>>> in packaging SW to a system and sell the device. Firmware
>>>>> itself (based on OpenWrt Linux) is free and published for
>>>>> everybody. We distribute our changes under LGPL where
>>>>> original license doesn't assume anything stronger. But it is
>>>>> because we don't make money on generic 802.11p, but on
>>>>> hardware and its customization for ITS and fleet management
>>>>> projects. 3. So, if you want to share your 802.11p
>>>>> implementation widely, I think LGPL or MIT license should be
>>>>> the best option. 4. Actually we see that 802.11p is not
>>>>> enough to have up to date V2X asset required for the market.
>>>>> As soon as WAVE standard now released, people don't want
>>>>> using custom solutions anymore. There are some options there,
>>>>> but IEEE 1609 is a good choice. It is a standard in USA and
>>>>> many people in Europe support it as well. 5. However, IEEE
>>>>> 1609 is rather big thing, it is hard for SME to make and
>>>>> maintain it and there're nobody willing now to put it to OSS
>>>>> domain. Community is only an approach to go and we want to
>>>>> build it, possibly under AGL shield. 6. Definitely nobody in
>>>>> the community want to release their efforts for free.
>>>>> Therefore we assume GPL which lets them to be referred and
>>>>> earn on customization, adaption and support. For us it still
>>>>> doesn't matter as we work in hardware and systems field. We
>>>>> even ready to close this license limiting it by AGL/IETF, but
>>>>> personally I wouldn't want to go this way because it corrupts
>>>>> the idea of OSS.
>>>>>
>>>>> Thanks, Kostia
>>>>>
>>>>>
>>>>> -----
>>>>>
>>>>>
>>>>>
>>>>> ----- Konstantin A. Khait Componentality Oy Tel:
>>>>> +358(0)465662016 В В В В В В В В +7(921)9005780 Skype:
>>>>> kostia.khait E-Mail: [email-masked]
>>>>> <mailto:[email-masked]> 53100 Finland Ratakatu 47
>>>>> Lappeenranta
>>>>>
>>>>>
>>>>>> Thanks for the post.
>>>>>
>>>>>> At my work place, and at other places I learned, there are
>>>>>> some implementations of 802.11p driver in linux. В They are
>>>>>> for various linux kernel versions. В They are derivations
>>>>>> from the Atheros 802.11a driver. В В They implement various
>>>>>> features of 802.11p (OCB, 48 1s ESSID, 5.9GHz freq range,
>>>>>> etc).
>>>>>
>>>>>> However, we dont know yet how to distribute that widely. В
>>>>>> Licensing scheme questions were made.
>>>>>
>>>>>> We have strong interest in distributing that as wide as
>>>>>> possible under the best licensing scheme which favors wide
>>>>>> deployment and respects contributors interests.
>>>>>
>>>>>> distribution, whose main maintainer is interested in
>>>>>> integrating features as well.
>>>>>
>>>>>> Yours,
>>>>>
>>>>>> Alex
>>>>>
>>>>>>> My name is Konstantin Khait, chief engineer in
>>>>>>> Componentality Oy, member of Linux Foundation and
>>>>>>> Automotive Grade Linux SC. We're doing open HW and SW
>>>>>>> solutions for automotive multimedia, navigation and
>>>>>>> communication.
>>>>>>>
>>>>>>> Currently we launch the initiative to create reference
>>>>>>> OSS implementation of IEEE 1609, WAVE. WAVE is a fresh
>>>>>>> and rapidly institutionalizing standard for vehicle to
>>>>>>> vehicle and vehicle to infrastructure communication, now
>>>>>>> becoming the main and "must have" approach in ITS,
>>>>>>> collision prevention and road automation areas.
>>>>>>> Componentality Oy is willing to provide a hardware
>>>>>>> platform supporting IEEE 802.11p radio and do
>>>>>>> coordination of development efforts. However, we need
>>>>>>> your architectural, engineering and intellectual
>>>>>>> resources to make this asset together. WAVE is big
>>>>>>> enough, relatively complex and multifunctional, so only
>>>>>>> joint community may guarantee it being done in a
>>>>>>> reasonable time frame and with automotive quality.
>>>>>>> Fortunately, when we do it, we all will have the most
>>>>>>> needed asset in V2X and probably it becomes an industrial
>>>>>>> reference and standard for a long time.
>>>>>>>
>>>>>>> In the timeframe since January when we joined AGL to now
>>>>>>> we did a lot of consultations with key market players to
>>>>>>> understand the potential of such solution. Now we know
>>>>>>> that almost every company working on V2X/ITS solutions
>>>>>>> demands for such solution. We offer making it together.
>>>>>>>
>>>>>>> Componentality is open for the dialog of what and how to
>>>>>>> be done for that. By default, we assume to create an OSS
>>>>>>> Linux stack available for everybody under GPL license. It
>>>>>>> is what we start since October 1st. If it will be some
>>>>>>> contributor with any special legal requirements, we're
>>>>>>> organizational aspects. We plan to make this job done by
>>>>>>> April, 2014. Now we form the team and WELCOME TO JOIN
>>>>>>> US!
>>>>>>>
>>>>>>> Simply write me if you have any comments, questions or
>>>>>>> you want to participate. Hope, later AGL will establish
>>>>>>> some mailing list, forum and other infrastructure for
>>>>>>> us.
>>>>>>>
-----
>>>>>>> Konstantin A. Khait Componentality Oy Tel:
>>>>>>> +358(0)465662016 В В В В В В В В +7(921)9005780 Skype:
>>>>>>> kostia.khait E-Mail: [email-masked]
>>>>>>> <mailto:[email-masked]> 53100 Finland Ratakatu
>>>>>>> 47 Lappeenranta
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________ its
>>>>>>> mailing list [email-masked]
>>>>>> _______________________________________________ its mailing
>>>>>> list [email-masked]
>>>> _______________________________________________ its mailing
>>>> list [email-masked] https://www.ietf.org/mailman/listinfo/its
>
>
>> _______________________________________________ its mailing list
>> [email-masked] https://www.ietf.org/mailman/listinfo/its