Subject: [ipwave] I-D Action: draft-ietf-ipwave-ipv6-over-80211ocb-15.txt

From: [email-masked]
Date: Tue, 13 Feb 2018 05:37:55 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Wireless Access in Vehicular Environments WG of the IETF.

        Title           : Transmission of IPv6 Packets over IEEE 802.11 Networks operating in mode Outside the Context of a Basic Service Set (IPv6-over-80211-OCB)
        Authors         : Alexandre Petrescu
                          Nabil Benamar
                          Jerome Haerri
                          Jong-Hyouk Lee
                          Thierry Ernst
	Filename        : draft-ietf-ipwave-ipv6-over-80211ocb-15.txt
	Pages           : 39
	Date            : 2018-02-13

Abstract:
   In order to transmit IPv6 packets on IEEE 802.11 networks running
   outside the context of a basic service set (OCB, earlier "802.11p")
   there is a need to define a few parameters such as the supported
   Maximum Transmission Unit size on the 802.11-OCB link, the header
   format preceding the IPv6 header, the Type value within it, and
   others.  This document describes these parameters for IPv6 and IEEE
   802.11-OCB networks; it portrays the layering of IPv6 on 802.11-OCB
   similarly to other known 802.11 and Ethernet layers - by using an
   Ethernet Adaptation Layer.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ipwave-ipv6-over-80211ocb/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ipwave-ipv6-over-80211ocb-15
https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-ipv6-over-80211ocb-15

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-ipv6-over-80211ocb-15

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Russ Housley <[email-masked]>
Date: Tue, 13 Feb 2018 15:50:42 -0500

Given the recent thread on the meaning of "WiFi" I scanned through the document to see if that term is really adding value.

I also noticed that "Wi-Fi" is a registered mark.   Avoiding an argument with the owner of that mark seems desirable if the term is not adding a lot of value in the document.

The term appears six times:
 - The definition in Section 2 that started the thread.
 - The Figure 3 in Section 4.2.1 (two places).
 - The note below Figure 3 in Section 4.2.1.
 - The ChangeLog in Appendix A
 - The discussion in Appendix C.

In most of these places, the sentence or figure is clear without "WiFi."

In Appendix C, I think that the sentence could be easily reworded to avoid the term.  I suggest:

   From the IP perspective, an 802.11-OCB MAC layer
   offers practically the same interface to IP as 802.11a/b/g/n
   and 802.3.

Based on this quick analysis, I suggest that we remove "WiFi" from the document.

Russ

> On Feb 13, 2018, at 8:37 AM, [email-masked] wrote:
> 
> 
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 14 Feb 2018 09:27:38 +0200

13, 2018 at 10:50 PM, Russ Housley <[email-masked]> wrote:

> Given the recent thread on the meaning of "WiFi" I scanned through the
> document to see if that term is really adding value.
>
> I also noticed that "Wi-Fi" is a registered mark.   Avoiding an argument
> with the owner of that mark seems desirable if the term is not adding a lot
> of value in the document.
>

Yes, no problem, I never liked these terms of other SDOs, it is better to
stick with only one term they use IEEE802.11a/b.

>    offers practically the same interface to IP as 802.11a/b/g/n

that  suggest that the IP interface has the similar BSS service, but we are
doing Outside that Context which is OCB, in other words OCB mode is not the
operation of BSS and even the frame is different, our physical network
infrastructure is not the same and services also, no more LAN services.

We may define a special interface for IPWAVE in the draft. Does WG think we
will have same LLC for all the MAC protocols you defined above including
Ieee802.1obc?

We don't forget that many SDOs are working on this WAVE network
architecture, so hopefully we adapt our IPv6 to such OCB,

Thanks,
AB

> >        Title           : Transmission of IPv6 Packets over IEEE 802.11
> Networks operating in mode Outside the Context of a Basic Service Set
> (IPv6-over-80211-OCB)

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 14 Feb 2018 08:59:31 +0100

Abdussalam,

Let me clarify.

Le 14/02/2018 à 08:27, Abdussalam Baryun a écrit :
> 
> 
> 13, 2018 at 10:50 PM, Russ Housley <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> Given the recent thread on the meaning of "WiFi" I scanned through 
> the document to see if that term is really adding value.
> 
> I also noticed that "Wi-Fi" is a registered mark.   Avoiding an 
> argument with the owner of that mark seems desirable if the term is 
> not adding a lot of value in the document.
> 
> The term appears six times: - The definition in Section 2 that
> started the thread. - The Figure 3 in Section 4.2.1 (two places). -
> The note below Figure 3 in Section 4.2.1. - The ChangeLog in Appendix
> A - The discussion in Appendix C.
> 
> Yes, no problem, I never liked these terms of other SDOs, it is
> better to stick with only one term they use IEEE802.11a/b.
> 
> 
> From the IP perspective, an 802.11-OCB MAC layer offers practically
> the same interface to IP as 802.11a/b/g/n and 802.3.
> 
> 
> that  suggest that the IP interface has the similar BSS service,

But no, because the IP interface does not use anything from a BSS
service anyways.  For example, the ESSID name (the 'network name') is
not used by IP headers.

Or maybe I dont know what do yo u mean by BSS service.

> but we are doing Outside that Context which is OCB,

YEs.

> in other words
> OCB mode is not the operation of BSS 

Right.

> and even the frame is different,

No.  The 802.11 OCB frame is the same as 802.11.

But I agree that the 802.11 frame is different than 802.3.

Alex

> our physical network infrastructure is not the same and services
> also, no more LAN services.
> 
> We may define a special interface for IPWAVE in the draft. Does WG
> think we will have same LLC for all the MAC protocols you defined
> above including Ieee802.1obc?
> 
> Thanks, AB
>> On Feb 13, 2018, at 8:37 AM, [email-masked]
> <mailto:[email-masked]> wrote:
>> 
>> 
>> Title           : Transmission of IPv6 Packets over IEEE
> 802.11 Networks operating in mode Outside the Context of a Basic 
> Service Set (IPv6-over-80211-OCB)
>> Authors         : Alexandre Petrescu Nabil Benamar Jerome Haerri 
>> Jong-Hyouk Lee Thierry Ernst Filename        :
>> draft-ietf-ipwave-ipv6-over-80211ocb-15.txt Pages           : 39 
>> Date            : 2018-02-13
>> 
>> Abstract: In order to transmit IPv6 packets on IEEE 802.11 networks
>> running outside the context of a basic service set (OCB, earlier
>> "802.11p") there is a need to define a few parameters such as the
>> supported Maximum Transmission Unit size on the 802.11-OCB link,
>> the header format preceding the IPv6 header, the Type value within
>> it, and others.  This document describes these parameters for IPv6
>> and IEEE 802.11-OCB networks; it portrays the layering of IPv6 on
>> 802.11-OCB similarly to other known 802.11 and Ethernet layers - by
>> using an Ethernet Adaptation Layer.
>> 
>> 
<https://datatracker.ietf.org/doc/draft-ietf-ipwave-ipv6-over-80211ocb/>
> <https://tools.ietf.org/html/draft-ietf-ipwave-ipv6-over-80211ocb-15>
>
> 
> 
<https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-ipv6-over-80211ocb-15>
> https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-ipv6-over-80211ocb-15
<https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-ipv6-over-80211ocb-15>
>> until the htmlized version and diff are available at
> tools.ietf.org <http://tools.ietf.org>.
>> 
> <ftp://ftp.ietf.org/internet-drafts/>
>> 
>> _______________________________________________ its mailing list 
>> [email-masked] <mailto:[email-masked]> 
> <https://www.ietf.org/mailman/listinfo/its>
> 
> _______________________________________________ its mailing list 
> [email-masked] <mailto:[email-masked]> 
> <https://www.ietf.org/mailman/listinfo/its>
> 
> 
> 
> 
> _______________________________________________ its mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/its
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 14 Feb 2018 10:46:01 +0100

> Based on this quick analysis, I suggest that we remove "WiFi" from the document.

I agree.  These changes will be in -16.

Alex