Subject: [ipwave] Why ieee802.11 ocb Similar to Ethernet layers? do we mean MAC (was Re: WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 14 Feb 2018 09:23:51 +0200

On Wed, Feb 14, 2018 at 7:11 AM, Abdussalam Baryun <
[email-masked]> wrote:

> Hi Alex,
>
> How are you doing, it is always nice to chat with you, as it was a long
> time from our last meeting in London 89.  my comments below,
>
> On Mon, Feb 12, 2018 at 12:49 PM, Alexandre Petrescu <
> [email-masked]> wrote:
>
>> Abdussalam,
>>
>> Let me reply now after a few months.
>>
>> Le 05/10/2017 à 05:55, Abdussalam Baryun a écrit :
>>
>>> Hi Alex,
>>>
>>> I thank the authors for their hard work and hope we can work together
>>> to make the doc best. I don't think it is ready for submission. I am
>>> still reviewing but I give now some comments.
>>>
>>> Ethernet is defined by IEEE as IEEE802.3.
>>>
>>
>> I think yes, in principle; Additionally, I am not sure but it may be that
>> "Ethernet" is a label for 802.3 like "WiFi" is for 802.11.
>>
>> However, I think the document should not mention IEEE802.11 protocol
>>> (some name WiFi) as similar protocol like IEEE802.3 ( Ethernet)
>>> protocol, one is wireless protocol and the other is wired.
>>>
>>
>> I agree.
>>
>> I dont think this ipwave document mentions that 802.11 is similar like
>> 802.3.  Can you point me where you think it does so?
>
>
In the Abstract in draft-12 and maybe in others:

This document describes these parameters for IPv6 and IEEE
   802.11-OCB networks; it portrays the layering of IPv6 on 802.11-OCB
   similarly to other known 802.11 and Ethernet layers - by using an
   Ethernet Adaptation Layer.

So why did WG choose that in the first place? I understand that IEEE802.11
OCB has different frame or activity or diff MAC, which is Outside Context
of BSS. It is not coordinated with other IEEE802.11.

AB

>
> I seen that some where or understood that from the draft, but will check
> it again for you,
>
>>
>>
>> The transmissions are different, I don't see that they are similar
>>> even their frames are not similar. So it is not correct in section
>>> 5.2 mentioned that:
>>>
>>> IP packets are transmitted over 802.11-OCB as standard Ethernet
>>>
>>> packets.
>>>
>>
>> Well, IP packets _are_ transmitted as standard Ethernet packets, with an
>> Adaptation Layer.  The next phrase says so.
>
>
> This draft is doing transmission, so transmission IMHO does not mean only
> packing, what will be the way of adaptation to lower layers, and if there
> is a problem who will take over to adapt. Does this layer see all
> possibilities? So that are my  questions,
>
> However, did the authors find a reference to the adaptation layer
> techniques or not?
>
> Best Regards
>
> AB
>
>>
>>
>> IMO even the document RFC2464, should have been (more technical
>>> focus) referencing the protocol IEEE802.3, instead of naming that may
>>> change by time.
>>>
>>
>> I agree.
>>
>> There is an ongoing work on RFC2464bis (draft-hinden something), that
>> could be improved with this comment.
>>
>> Alex
>> [...]
>>
>
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 14 Feb 2018 09:15:25 +0100

Le 14/02/2018 à 08:23, Abdussalam Baryun a écrit :
> 
> 
> On Wed, Feb 14, 2018 at 7:11 AM, Abdussalam Baryun 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Hi Alex,
> 
>     How are you doing, it is always nice to chat with you, as it was a
>     long time from our last meeting in London 89.  my comments below,
> 
>     On Mon, Feb 12, 2018 at 12:49 PM, Alexandre Petrescu
>     <[email-masked] <mailto:[email-masked]>>
>     wrote:
> 
>         Abdussalam,
> 
>         I think yes, in principle; Additionally, I am not sure but it
>         may be that "Ethernet" is a label for 802.3 like "WiFi" is for
>         802.11.
> 
>         I dont think this ipwave document mentions that 802.11 is
>         similar like 802.3.  Can you point me where you think it does so?
> 
> 
> So why did WG choose that in the first place?

Choose what?

> I understand that 
> IEEE802.11 OCB has different frame

802.11 OCB has different frame format than 802.3 (Ethernet), but same 
format as 802.11.

NEW:
> This document describes these parameters for IPv6 and IEEE 802.11-OCB
> networks; it portrays the layering of IPv6 on 802.11-OCB similarly to
> IPv6 over other known 802.11 layers - by using an Ethernet Adaptation
> Layer.

What do you think about this NEW formulation?

> or activity or diff MAC, which is 
> Outside Context of BSS. It is not coordinated with other IEEE802.11.

What do you mean by not coordinated with other IEEE802.11?

Alex
> 
> AB
> 
> 
>     I seen that some where or understood that from the draft, but will
>     check it again for you,
> 
> 
> 
>         Well, IP packets _are_ transmitted as standard Ethernet packets,
>         with an Adaptation Layer.  The next phrase says so.
> 
> 
>     This draft is doing transmission, so transmission IMHO does not mean
>     only packing, what will be the way of adaptation to lower layers,
>     and if there is a problem who will take over to adapt. Does this
>     layer see all possibilities? So that are my  questions,
> 
>         There is an ongoing work on RFC2464bis (draft-hinden something),
>         that could be improved with this comment.
> 
>         Alex
>         [...]
> 
> 
>

---

From: Tony Li <[email-masked]>
Date: Wed, 14 Feb 2018 00:20:02 -0800

>> So why did WG choose that in the first place?

Choose to use an adaptation layer?

Because it’s what is done to make it more obvious for the rest of the world to make use of the media. When the rest of the world can only deal with Ethernet encapsulation, everything else is simpler.

Folks writing the device driver deal with the adaptation and everyone else can ignore it and just use Ethernet.

Tony