Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 12 Feb 2018 11:49:36 +0100

Abdussalam,

Let me reply now after a few months.

Le 05/10/2017 à 05:55, Abdussalam Baryun a écrit :
> Hi Alex,
> 
> I thank the authors for their hard work and hope we can work together
> to make the doc best. I don't think it is ready for submission. I am
> still reviewing but I give now some comments.
> 
> Ethernet is defined by IEEE as IEEE802.3.

I think yes, in principle; Additionally, I am not sure but it may be 
that "Ethernet" is a label for 802.3 like "WiFi" is for 802.11.

> However, I think the document should not mention IEEE802.11 protocol
> (some name WiFi) as similar protocol like IEEE802.3 ( Ethernet)
> protocol, one is wireless protocol and the other is wired.

I agree.

I dont think this ipwave document mentions that 802.11 is similar like 
802.3.  Can you point me where you think it does so?

> The transmissions are different, I don't see that they are similar
> even their frames are not similar. So it is not correct in section
> 5.2 mentioned that:
> 
> IP packets are transmitted over 802.11-OCB as standard Ethernet
> 
> packets.

Well, IP packets _are_ transmitted as standard Ethernet packets, with an 
Adaptation Layer.  The next phrase says so.

> IMO even the document RFC2464, should have been (more technical
> focus) referencing the protocol IEEE802.3, instead of naming that may
> change by time.

I agree.

There is an ongoing work on RFC2464bis (draft-hinden something), that 
could be improved with this comment.

Alex
[...]

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 13 Feb 2018 11:16:54 +0100

Le 13/02/2018 à 02:20, Dick Roy a écrit :
> FYI ... TPDUs are called segment, NPDUs are packets, MPDUs are frames, and
> PPDUs are streams if you care.

YEs noted.

Alex
[...]

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 13 Feb 2018 13:14:52 +0100

SDUs are called Service Data Units, and FL-SDUs are Facility-layer SDUs.

Alex

Le 13/02/2018 à 11:16, Alexandre Petrescu a écrit :
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 14 Feb 2018 07:11:47 +0200

Hi Alex,

How are you doing, it is always nice to chat with you, as it was a long
time from our last meeting in London 89.  my comments below,

On Mon, Feb 12, 2018 at 12:49 PM, Alexandre Petrescu <
[email-masked]> wrote:

> I think yes, in principle; Additionally, I am not sure but it may be that
> "Ethernet" is a label for 802.3 like "WiFi" is for 802.11.
>

I seen that some where or understood that from the draft, but will check it
again for you,

> Adaptation Layer.  The next phrase says so.

This draft is doing transmission, so transmission IMHO does not mean only
packing, what will be the way of adaptation to lower layers, and if there
is a problem who will take over to adapt. Does this layer see all
possibilities? So that are my  questions,

However, did the authors find a reference to the adaptation layer
techniques or not?

Best Regards

AB

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 14 Feb 2018 08:53:55 +0100

It is worth writing a terminology draft about *DUs, maybe it will get 
the terms to be more used.

Alex

Le 13/02/2018 à 18:51, Dick Roy a écrit :
> 
> 
> -----Original Message-----
> From: its [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
> Sent: Tuesday, February 13, 2018 4:15 AM
> To: [email-masked]; 'Abdussalam Baryun'
> Cc: [email-masked]; 'its'
> Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08 -
> *DUs
> 
> [RR] Yes, and TPDUs are NSDUs, NPDUs are MSDUs, etc..
> 
> Alex
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 14 Feb 2018 09:17:54 +0100

Le 14/02/2018 à 06:11, Abdussalam Baryun a écrit :
> On Mon, Feb 12, 2018 at 12:49 PM, Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Abdussalam,
> 
>     I dont think this ipwave document mentions that 802.11 is similar
>     like 802.3.  Can you point me where you think it does so?
> 
> 
> I seen that some where or understood that from the draft, but will check 
> it again for you,
> 
> 
> 
>     Well, IP packets _are_ transmitted as standard Ethernet packets,
>     with an Adaptation Layer.  The next phrase says so.
> 
> 
> This draft is doing transmission, so transmission IMHO does not mean 
> only packing, what will be the way of adaptation to lower layers, and if 
> there is a problem who will take over to adapt. Does this layer see all 

By 'transmission' I understand the entire set of operations of sending 
and receiving.  Here I understand it in a very generic manner (not just 
sending), because all IP-over-foo documents are titled 'Transmission'.

> However, did the authors find a reference to the adaptation layer 

Not that I am aware of.  Do you want to ask them one by one?

Did you find a reference to the adaptation layers techniques?

Alex

>     There is an ongoing work on RFC2464bis (draft-hinden something),
>     that could be improved with this comment.
> 
>     Alex
>     [...]
> 
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 14 Feb 2018 14:43:31 +0200

> Not that I am aware of.  Do you want to ask them one by one?

No just one is enough. So there is no reference, then please delete this
issue of Ethernet adaptation, while it has no reference,

> Did you find a reference to the adaptation layers techniques?

I was against this so why should I find something I did not put in the
draft. The WG should find or they should delete,

AB

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 14 Feb 2018 13:55:54 +0100

Le 14/02/2018 à 13:43, Abdussalam Baryun a écrit :
> 
> 
> On Wed, Feb 14, 2018 at 10:17 AM, Alexandre Petrescu 
>         However, did the authors find a reference to the adaptation
>         layer techniques or not?
> 
> 

The Ethernet Adaptation Layer reference is this draft.

> draft. The WG should find or they should delete,

See above.

Alex

>                  focus) referencing the protocol IEEE802.3, instead of
>         naming
>                  that may
>                  change by time.
> 
> 
>              I agree.
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 14 Feb 2018 14:58:58 +0200

On Wed, Feb 14, 2018 at 2:55 PM, Alexandre Petrescu <
[email-masked]> wrote:

>> [email-masked] <mailto:[email-masked]>>
>> wrote:
>>
>>
>>
>>

before the answer was no reference and now this is, ok, If so then the
draft  may need to define it,

AB

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 15 Feb 2018 13:08:47 +0100

I doubt ISO has the FL-SDU term, as Facility Layer is an ETSI term.

Alex

Le 14/02/2018 à 18:31, Dick Roy a écrit :
> Just refer to ISO OSI model and the relevant ISO standards ... they have all
> that in there already!
> 
> Sent: Tuesday, February 13, 2018 11:54 PM

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 15 Feb 2018 19:54:00 +0100

Sorry, it may be I went too fast with my statement.

I googled "FS-SDU" and first entry was ETSI.

But I agree that as with wikipedia, must double check before relying on 
google searches.

Alex

Le 15/02/2018 à 19:50, Dick Roy a écrit :
> Wow, interesting how history keeps changing!  I along with two others
> created the name "Facility layer", and there most assuredly is an "FSDU"
> throughout the ISO standards.  ETSI TC ITS, which a few of us also
> "created", simply adopted ISO 21217 as they were required to do by the
> agreement between ISO TC204 and ETSI when TC ITS was created.  It's a long
> story ... perhaps over a beer or three sometime:^)))
> 
> Sent: Thursday, February 15, 2018 4:09 AM

---

From: Knut Evensen <[email-masked]>
Date: Thu, 15 Feb 2018 19:30:36 +0000

Yes, this is one of the disadvantages with CEN and ISO keeping their standards under strict IPR, whilst ETSI offer them freely downloadable so Google can crawl and index them every half hour...

Best regards,

  -knut

-----Original Message-----
From: Alexandre Petrescu [mailto:[email-masked]] 
Sent: Thursday, 15 February, 2018 19:54
To: [email-masked]; 'Abdussalam Baryun' <[email-masked]>
Cc: [email-masked]; 'its' <[email-masked]>; Knut Evensen <[email-masked]>; [email-masked]
Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08 - *DUs

But I agree that as with wikipedia, must double check before relying on google searches.

Alex

Le 15/02/2018 à 19:50, Dick Roy a écrit :
> agreement between ISO TC204 and ETSI when TC ITS was created.  It's a 
> long story ... perhaps over a beer or three sometime:^)))
> 
> Subject: Re: [ipwave] WGLC for draft-ietf-ipwave-ipv6-over-80211ocb-08 
> - *DUs
> 
>> Just refer to ISO OSI model and the relevant ISO standards ... they 
>> have
> all
>> that in there already!
>>
>> Subject: Re: [ipwave] WGLC for 
>> draft-ietf-ipwave-ipv6-over-80211ocb-08 - *DUs
>>
>>> Subject: Re: [ipwave] WGLC for 
>>> draft-ietf-ipwave-ipv6-over-80211ocb-08 - *DUs
>>>
>>>>> FYI ... TPDUs are called segment, NPDUs are packets, MPDUs are 
>>>>> frames, and PPDUs are streams if you care.
>>>>
>>>> YEs noted.
>>>>
>>>> Alex
>>>> [...]
>>>>

---

From: "Dr. Hans-Joachim Fischer" <[email-masked]>
Date: Thu, 15 Feb 2018 21:16:02 +0100

Right. But not just CEN and ISO.

Also IEEE takes money for standards. Not for all, but this is the same 
at ISO - some standards can be downloaded from the web free of charge.

At ETSI you have to pay for making standards.

Sincerely
Hans-Joachim

-- 
Dr. Hans-Joachim Fischer
Managing Director

--------------------------------------------------------------------------------

                ESF News edition 2018/1
https://fischer-tech.eu/Feeds/News/ESF-News-2018-01.pdf

--------------------------------------------------------------------------------
       Towards deployment of C-ITS based on proven technology
Avoid risks and delay by looking on potential future technologies.

                The real advocate on ITS is ISO TC204!
--------------------------------------------------------------------------------
+ + + Instaurare omnia in Christo + + +
--------------------------------------------------------------------------------
The information contained in this message is confidential and may be legally
privileged. This email is intended for the addressee(s). Addressees may be
individual persons or members of mailing list.
If you are not an addressee, you are hereby notified that any use,
dissemination, or reproduction of this email and its optional attachements is
strictly prohibited and may be unlawful. If you are not an addressee, please
contact the sender by return e-mail and destroy all copies of the original
message.
--------------------------------------------------------------------------------
ESF GmbH
Fichtenweg 9
89143 Blaubeuren
+49 (7344) 175340 (Direct line Dr. Fischer)
+49 (7344) 919188 (Central office)
+49 (7344) 919123 (Fax)
https://fischer-tech.eu :  Main web of ESF GmbH
http://its-standards.eu : News on cooperative ITS standardization
http://its-testing.org :  International consultancy for cooperative ITS
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
ESF online-news:        http://fischer-tech.eu/Feeds/esf.rss
C-ITS online news:      http://its-standards.info/Feeds/cits.rss
ESF Online Nachrichten: http://fischer-tech.de/Feeds/esfD.rss
-------------------------------------------------------------------------------

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 16 Feb 2018 11:39:49 +0100

Thanks for the message.

Le 15/02/2018 à 20:30, Knut Evensen a écrit :
> Yes, this is one of the disadvantages with CEN and ISO keeping their 
> standards under strict IPR, whilst ETSI offer them freely 
> downloadable so Google can crawl and index them every half hour...

I agree CEN and ISO have most (not all) of their documents 'hidden',
i.e. have to pay money to access them.

But it is worth noting that ETSI ITS standards, while publicly and
freely available, are also covered by a number of IPR and licensing
aspects.  For example, ETSI ITS CAM message and GeoNetworking are IPRed
by several enterprises and the licensing scheme is mentioned in the
publicly available ETSI IPR Policy.

Also worth mentioning that ETSI ITS standards under development are not
publicly available (e.g. currently platooning).  They can be accessed
only if paying member of ETSI.

Another problem is when a publicly and freely available ETSI ITS
standard refers to an ISO document that is not freely available.
Without it, the first is hard if not impossible to implement.

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 16 Feb 2018 16:21:58 +0100

The info of IPR on CAM (EN 302 637-2, among others), is publicly 
available on ipr.etsi.org, excerpts attached.

I make sure I am telling: I am not a lawyer.

Alex

Le 16/02/2018 à 14:56, Dick Roy a écrit :
> Alex,
> 
> I am well-aware, and painfully so, of the GeoNotworking IPR.  To date, I am
> not aware of any IPR related to the CAM application specifications.  Can you
> provide a reference to such IP and the assignees thereof?
> 
> RR
> 
> Sent: Friday, February 16, 2018 2:40 AM
> To: Knut Evensen; [email-masked]; 'Abdussalam Baryun'
> Cc: [email-masked]; [email-masked]; 'its'
> other SDOs IPR and licensing
> 
> Thanks for the message.
>