Subject: [ipwave] IP and L2 aspects

From: Jérôme Härri <[email-masked]>
Date: Mon, 26 Feb 2018 11:23:00 +0100

Dear All,

Not wanting to blame anybody, but from a higher level perspective, I would like to suggest stop these endless discussions between what IPv6 requires and what OCB does. I mean, there is a clear specification of what OCB does (in IEEE 802.11-2016). And IETF should not specify aspects from L2, unless the L2 spec leaves it open (which is seldom not the case for the OCB case). 

I mean, there is a standard that has been optimized over 10 years to operate (and be now deployed in various US state DOT), which does not use IP. Now, it is fully legitimate to make use of IPv6 and without using WSM or Geonet. I support this effort, as I am even co-author of the draft and I also need this standard…and I wish that we could have a RFC by now (or even by yesterday…).

But as IPv6 has some requirements that is not provided by OCB (not open, rather not possible), there are some attempts to use OCB with wrong configurations. Also there is a recurring invalid claim that IPv6-over-OCB would be isolated (and as such independent) from other WAVE/ETSI traffic.  This is wrong, as at least that at the current form (and similarly to attempts of C-V2X to use ITS-G5 spectra), there is a complex debate on spectrum neutrality…but the current direction is that WAVE/ETSI have been specified first and are there (and deployed now), so whatever comes not should not break anything.

I mean, people at IETF are expert in IP, and people who designed the OCB are expect in L2 (with 10 years of experience in making OCB work - regardless of what is on top/L3). Now, over the endless (and recurring) discussions over this thread, I have seen many hypothesis from IETF on what OCB could/would do, which has been corrected by some OCB experts (whom some of them even have been involved in the writing of the very OCB specs). Of course, debate are always possible, what about trusting the OCB people of what OCB does and build IPv6 over it ? 

If you think it could make sense, maybe can gather a team of OCB experts, have them on a telco for a one-time clear-all-issues discussion, and end all debate after this.

I mean, it is a fully valid to need to tweak OCB for IPv6 requirements,  but we should take OCB as it is now, make a spec on top of it as good as possible, and enhance it later if necessary.

As such, I strongly push to complete the debate on the current OCB draft and move it to RFC, yet with leaving any L2 discussions/parameters outside the RFC.

Then, if IPv6 requires something that OCB does not provide, then let’s go to IEEE and ask for change. But at least we have a spec…as if we keep exchanging long e-mails and keep having misunderstanding from what the IP community thinks of OCB and what OCB actually is, we will never complete the work.

I see a need to use IPv6 over OCB (and without specifically Geonet), example for IoT-related V2I sensor gathering, and I see there are a few aspects to solve before this happens. Let’s try to solve that at our London meeting, so we can move to other challenges of actually using the draft/RFC for future connected vehicles applications..

My two cents hoping we can move forward,

BR,

Jérôme

From: its [mailto:[email-masked]] On Behalf Of Jérôme Härri
Sent: Monday 26 February 2018 10:41
To: 'Dr. Hans-Joachim Fischer'; 'Abdussalam Baryun'; 'Alexandre Petrescu'
Cc: 'Tony Li'; 'its'
Subject: Re: [ipwave] 802.11 Data vs 802.11 QoS Data in IPv6-over-802.11-OCB

Oh, and forgot to mention that there is a clear mapping in 802.11-2016 between the 7-bits priority field (802.1D) and the 4 queues…nothing to do here.

BR,

Jérôme

From: its [mailto:[email-masked]] On Behalf Of Jérôme Härri
Sent: Monday 26 February 2018 10:34
To: 'Dr. Hans-Joachim Fischer'; 'Abdussalam Baryun'; 'Alexandre Petrescu'
Cc: 'Tony Li'; 'its'
Subject: Re: [ipwave] 802.11 Data vs 802.11 QoS Data in IPv6-over-802.11-OCB

>From: its [mailto:[email-masked]] On Behalf Of Dr. Hans-Joachim Fischer
>

>Be careful with voice and audio transmission in ITS using 5,9 GHz. That seems to be prohibited by regulation in Europe; well, not explicitly, but this is a possible >interpretation of the technical requirements presented in regulatory documents. In Germany, it is prohibited.

>Hans-Joachim

Sorry to come again on this…this is a big misunderstanding…there is NO audio and NO video transmitted…

It is just that the WiFi uses AC with old names…which ETSI and WAVE uses for something else…let’s describe it so:

At L2, there is 4 access categories, with proven properties in channel access (I do not want to go in that direction, but there is plethora of publications showing the impact of using EDCA and unfair access if different WLAN uses DCF and others uses EDCA). 

At L2, 

-          AC_1 (VO) provides the highest channel access priority

-          AC_2 (VI) provides the second highest channel access priority

-          AC_3 (BE) provides a neutral access priority

-          AC_4 (BK) provides the lowest access priority

A L3 packet must be mapped to one of these 4 access categories (whatever their names). 

It is a high(er) layer decision to do the mapping, as WLAN will only look at the priority field and map (no question asked). 

Thus, a higher layer is forbidden to transmit VI traffic, but not to use AC_VI if another type of traffic needs this level of priority. 

Hoping it is clearer now,

BR,

Jérôme

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Mon, 26 Feb 2018 13:50:19 +0100

Hi Jérôme,

Am 26.02.2018 um 11:23 schrieb Jérôme Härri:
> Not wanting to blame anybody, but from a higher level perspective, I
> would like to suggest stop these endless discussions between what IPv6
> requires and what OCB does. I mean, there is a clear specification of
> what OCB does (in IEEE 802.11-2016). And IETF should not specify aspects
> from L2, unless the L2 spec leaves it open (which is seldom not the case
> for the OCB case).

I disagree a bit with "IETF should not specify aspects from L2"
if the link layer designers can imagine that IP is run some day
over their protocol. In this case, the link layers should probably
consider RFC3814 'Advice for Internet Subnetwork Designers'from 2004:
https://tools.ietf.org/html/rfc3819
Thus, the IETF provides _recommendations_ for link layer designers.

> I mean, there is a standard that has been optimized over 10 years to
> operate (and be now deployed in various US state DOT), which does not
> use IP. Now, it is fully legitimate to make use of IPv6 and without
> using WSM or Geonet. I support this effort, as I am even co-author of
> the draft and I also need this standard…and I wish that we could have a
> RFC by now (or even by yesterday…).

So in case the link layer doesn't fulfill the requirements an adaptation
layer can be used as in 6lowpan or the proposed
draft-ietf-ipwave-ipv6-over-80211ocb
This is obviously an extra effort, but allows to have better performance
and less overhead for non-IP communications.

Regards
 Roland

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 26 Feb 2018 23:18:40 +0200

On Mon, Feb 26, 2018 at 12:23 PM, Jérôme Härri <[email-masked]>
wrote:

> Dear All,
>
>
>
> *Not wanting to blame anybody, but from a higher level perspective, I
> requires and what OCB does.*
>

*Why you see it is endless, I see we are ending many issues, and our WG
chair is listening the discussion, if the chair tells us stop we can, but I
don't think we are discussing in endless, because we solved many things so
far and we are updating draft to better versions.*

> * I mean, there is a clear specification of what OCB does (in IEEE
> 802.11-2016). And IETF should not specify aspects from L2, unless the L2
> spec leaves it open (which is seldom not the case for the OCB case). *
>

*this WG is not specifying L2, but using L2 technologies, *

>
> *I mean, there is a standard that has been optimized over 10 years to
> operate (and be now deployed in various US state DOT), which does not use
> IP. *
>

*Any standard protocol uses what is under only, so I don't think IEEE802.11
can use IP. We are focusing this work that IP uses IEEE802.11p for best
transmissions *

> *Now, it is fully legitimate to make use of IPv6 and without using WSM or
> Geonet. I support this effort, as I am even co-author of the draft and I
> also need this standard…and I wish that we could have a RFC by now (or even
> by yesterday…). *
>

*We let this by the AD and WG chair, they can guide us what to do and when,*

>
>
> *But as IPv6 has some requirements that is not provided by OCB (not open,
> rather not possible), there are some attempts to use OCB with wrong
> configurations. *
>

*Not agreeing, but please specify? *

> *Also there is a recurring invalid claim that IPv6-over-OCB would be
> isolated (and as such independent) from other WAVE/ETSI traffic. *
>

*I think isolated is better. WAVE/ETSI have different users from Internet
users. *

> * This is wrong, as at least that at the current form (and similarly to
> attempts of C-V2X to use ITS-G5 spectra), there is a complex debate on
> spectrum neutrality…but the current direction is that WAVE/ETSI have been
> specified first and are there (and deployed now), so whatever comes not
> should not break anything.*
>
> *I mean, people at IETF are expert in IP, and people who designed the OCB
> are expect in L2 (with 10 years of experience in making OCB work -
> regardless of what is on top/L3). Now, over the endless (and recurring)
> discussions over this thread, I have seen many hypothesis from IETF on what
> OCB could/would do, which has been corrected by some OCB experts (whom some
> of them even have been involved in the writing of the very OCB specs). Of
> course, debate are always possible, what about trusting the OCB people of
> what OCB does and build IPv6 over it ? *
>

*I trust all, but I would like to discuss until the WG chair advices. *

>
>
> *If you think it could make sense, maybe can gather a team of OCB experts,
> have them on a telco for a one-time clear-all-issues discussion, and end
> all debate after this.*
>

*It is not debate but discussions. IETF use discussion to get to consensus,
and then editor update draft as we are doing,*

>
>
> *I mean, it is a fully valid to need to tweak OCB for IPv6 requirements,
>  but we should take OCB as it is now, make a spec on top of it as good as
> possible, and enhance it later if necessary.*
>
> *As such, I strongly push to complete the debate on the current OCB draft
> and move it to RFC, yet with leaving any L2 discussions/parameters outside
> the RFC.*
>
>
>
> *Then, if IPv6 requires something that OCB does not provide, then let’s go
> to IEEE and ask for change. But at least we have a spec…as if we keep
> exchanging long e-mails and keep having misunderstanding from what the IP
> community thinks of OCB and what OCB actually is, we will never complete
> the work.*
>

*IEEE and IETF has an agreement.  some in IETF   are in connection with
IEEE, and we have an officer that his/her job is for coordination between
IEEE and IETF. We always can use that through our AD. *

*AB*