Subject: Re: [ipwave] 802.11 Data vs 802.11 QoS Data in IPv6-over-802.11-OCB-implementations

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 17 May 2018 11:08:27 +0200

Hi William,

Recently I performed a visit in the city of Vesailles in France, Europe; 
there are deployed about 5 Road-Side Units for experimentations, since a 
few years now.

Some of them send CAMs and SPATs.  The ones I could test use "Data", not 
"QoS Data".

The packet dump is available upon request.

Here is a wireshark image showing the Data field:

Le 02/03/2018 à 18:02, William Whyte a écrit :
> US implementations use QoSData with everything -- although it's not 
> required by 802.11-OCB, as we discussed earlier, it *is* required for 
> a "WAVE device", which all US devices are.
>
> Here's a Wireshark image from a contact showing the QoSData field:
>
> Inline image 1
>
> Cheers,
>
> William
>
> On Fri, Mar 2, 2018 at 11:28 AM, Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>
>
>     Le 02/03/2018 à 17:16, William Whyte a écrit :
>
>         I've confirmed that the US implementations use QoSData, just
>         to close that loop.
>
>
>     Thanks.  It's QoSData with IP, right?
>
>     Alex
>
>
>         Cheers,
>
>         William
>
>
>         On Thu, Mar 1, 2018 at 11:05 AM, Alexandre Petrescu
>         <[email-masked]
>         <mailto:[email-masked]>
>         <mailto:[email-masked]
>         <mailto:[email-masked]>>> wrote:
>
>             William,
>
>             Le 01/03/2018 à 16:59, William Whyte a écrit :
>
>                   > I propose we rename 'OCB' into 'IP-OCB' in the draft.
>
>                   > 'IP-OCB' is an OCB mode that can be transport IP
>         packets
>                 with .11 Data
>
>                   > headers or with .11 QoS Data headers.
>
>                 If it’s over OCB, then it needs to use QoSData. If
>         you’re doing
>                 Data, you’re not conformant to OCB. There can’t be an
>         OCB mode
>                 that transports packets with .11 Data, because OCB by
>         definition
>                 uses QoSData. If the draft implies that you can do
>                 non-conformant OCB, that’s a serious defect in the draft.
>
>                 Some implementations may not yet have implemented
>         this, but
>                 that’s on those developers.
>
>
>             For one second, allow me the benefit of the doubt about
>             specifications that may not be implemented.
>
>             I would like to know whether there is an implementation of
>         IP over
>             OCB with QoSData headers?  Packet dump is sufficient, or
>         any other
>             kind of statement.
>
>             I agree with you that many times it is good to write
>         specification
>             first and implementation after.
>
>             Alex
>
>
>                 Cheers,
>
>                 William
>
>                 Sent from Mail
>         <https://go.microsoft.com/fwlink/?LinkId=550986
>         <https://go.microsoft.com/fwlink/?LinkId=550986>
>                 <https://go.microsoft.com/fwlink/?LinkId=550986
>         <https://go.microsoft.com/fwlink/?LinkId=550986>>> for Windows 10
>
>                 *From: *Alexandre Petrescu
>         <mailto:[email-masked]
>         <mailto:[email-masked]>
>                 <mailto:[email-masked]
>         <mailto:[email-masked]>>>
>                 *Sent: *Thursday, March 1, 2018 10:54 AM
>                 *To: *William Whyte <mailto:[email-masked]
>         <mailto:[email-masked]>
>                 <mailto:[email-masked]
>         <mailto:[email-masked]>>>; [email-masked]
>         <mailto:[email-masked]>
>                 <mailto:[email-masked] <mailto:[email-masked]>>
>         <mailto:[email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>>
>                 *Subject: *Re: [ipwave] 802.11 Data vs 802.11 QoS Data in
>                 IPv6-over-802.11-OCB-implementations
>
>
>                 Le 01/03/2018 à 16:50, William Whyte a écrit :
>
>                   >  >> (there are some packet dumps with IP packets
>         transported
>                 with .11 Data
>
>                   >
>
>                   > headers in OCB mode at 5.9GHz, e.g. attached).
>
>                   >
>
>                   > My understanding is OCB mode requires QoSData, so
>         those
>                 packets aren’t
>
>                   > conformant to the standard.
>
>                 I propose we rename 'OCB' into 'IP-OCB' in the draft.
>
>                 'IP-OCB' is an OCB mode that can be transport IP
>         packets with
>                 .11 Data
>
>                 headers or with .11 QoS Data headers.
>
>                 Alex
>
>                   >
>
>                   > Cheers,
>
>                   >
>
>                   > William
>
>                   >
>
>                   > Sent from Mail
>                 <https://go.microsoft.com/fwlink/?LinkId=550986
>         <https://go.microsoft.com/fwlink/?LinkId=550986>
>                 <https://go.microsoft.com/fwlink/?LinkId=550986
>         <https://go.microsoft.com/fwlink/?LinkId=550986>>> for
>
>                   > Windows 10
>
>                   >
>
>                   > *From: *Alexandre Petrescu
>                 <mailto:[email-masked]
>         <mailto:[email-masked]>
>                 <mailto:[email-masked]
>         <mailto:[email-masked]>>>
>
>                   > *Sent: *Thursday, March 1, 2018 10:48 AM
>
>                   > *To: [email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>
>                 <mailto:[email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>>
>
>                   > *Subject: *Re: [ipwave] 802.11 Data vs 802.11 QoS
>         Data in
>
>                   > IPv6-over-802.11-OCB -implementations
>
>                   >
>
>                   > In a private discussion, this question came up:
>
>                   >
>
>                   > Is there a packet dump showing an IP packet
>         transported with
>                 .11 QoSData
>
>                   >
>
>                   > headers in OCB mode at 5.9GHz.
>
>                   >
>
>                   > (there are some packet dumps with IP packets
>         transported
>                 with .11 Data
>
>                   >
>
>                   > headers in OCB mode at 5.9GHz, e.g. attached).
>
>                   >
>
>                   > Alex
>
>                   >
>
>                   > Le 01/03/2018 à 15:32, Alexandre Petrescu a écrit :
>
>                   >
>
>                   >  > I received some feedback from programmer.
>
>                   >
>
>                   >  >
>
>                   >
>
>                   >  > Le 28/02/2018 à 23:48, Abdussalam Baryun a écrit :
>
>                   >
>
>                   >  > [...]
>
>                   >
>
>                   >  >> ieee802.11ocb protocol is already
>         implemented/tested and
>                 it is
>
>                   >
>
>                   >  >> interoperable, but what is the problem, sorry
>         maybe I
>                 did not follow
>
>                   >
>
>                   >  >> the discussion well,
>
>                   >
>
>                   >  >
>
>                   >
>
>                   >  > Here is the QoS problem for IP over 802.11 OCB in
>                 implementations.
>
>                   >
>
>                   >  >
>
>                   >
>
>                   >  > In short, in open source on linux, we dont know
>         how to
>                 send IP packets
>
>                   >
>
>                   >  > transported as 802.11 QoSData, all IP packets are
>                 transported as 802.11
>
>                   >
>
>                   >  > Data instead.
>
>                   >
>
>                   >  >
>
>                   >
>
>                   >  > - if you ping -Q at 5.9GHz in OCB mode, the
>         DSCP fields
>                 do get
>
>                   >
>
>                   >  >    set properly in IP headers of Echorequest,
>         but there
>                 is no .11 QoSData
>
>                   >
>
>                   >  >    headers in packets.  Normally, one expects
>         the QoSData
>                 headers to be
>
>                   >
>
>                   >  >    present there when the DSCP (an IP field) is
>         set.
>
>                   >
>
>                   >  >
>
>                   >
>
>                   >  > - if you want to modify kernel, and force
>         always to use
>                 QoSData headers
>
>                   >
>
>                   >  >    on WiFi, including OCB at 5.9GHz, there is a
>                 net/mac80211/tx.c file
>
>                   >
>
>                   >  >    with a flag called wme_sta that you could set to
>                 true.  But take care
>
>                   >
>
>                   >  >    that the C comments there say that it's not
>         normal to
>                 use QoSData
>
>                   >
>
>                   >  >    headers in OCB mode, because a terminal sending
>                 QoSData has no
>
>                   >
>
>                   >  >    guarantee that receivers also use QoSData (the
>                 negotiation of QoS
>
>                   >
>
>                   >  >    capabilities are absent in OCB).
>
>                   >
>
>                   >  >
>
>                   >
>
>                   >  > As you can see, this can be long to try and fix.
>
>                   >
>
>                   >  >
>
>                   >
>
>                   >  > Until then I will propose to set QoS aside from
>                 IP-over-OCB at this time.
>
>                   >
>
>                   >  >
>
>                   >
>
>                   >  > Alex
>
>                   >
>
>                   >  >
>
>                   >
>
>                   >  > _______________________________________________
>
>                   >
>
>                   >  > its mailing list
>
>                   >
>
>                   >  > [email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>
>
>                   >
>
>                   >  > https://www.ietf.org/mailman/listinfo/its
>         <https://www.ietf.org/mailman/listinfo/its>
>                 <https://www.ietf.org/mailman/listinfo/its
>         <https://www.ietf.org/mailman/listinfo/its>>
>
>                   >
>
>
>
>
>         -- 
>
>
>         PLEASE UPDATE YOUR ADDRESS BOOKS WITH MY NEW ADDRESS:
>         [email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked]
>         <mailto:[email-masked]>>
>
>
>
>
> -- 
>
>
> PLEASE UPDATE YOUR ADDRESS BOOKS WITH MY NEW ADDRESS: 
> [email-masked] <mailto:[email-masked]>

---

From: Lawrence M <[email-masked]>
Date: Thu, 17 May 2018 14:31:28 +0300

Alexandre,
Could you share the Radio Header information of the screenshot?
I am a student trying to learn the draft and hopefully contribute to it.

Regards,
Muchilwal Lawrence,
Systems Solutions Architect

On Thu, May 17, 2018, 12:08 PM Alexandre Petrescu <
[email-masked]> wrote:

> required by 802.11-OCB, as we discussed earlier, it *is* required for a
> "WAVE device", which all US devices are.
>
> On Fri, Mar 2, 2018 at 11:28 AM, Alexandre Petrescu <
> [email-masked]> wrote:
>
>>
>>
>>> I've confirmed that the US implementations use QoSData, just to close
>>> that loop.
>>>
>>
>>> On Thu, Mar 1, 2018 at 11:05 AM, Alexandre Petrescu <
>>> [email-masked] <mailto:[email-masked]>>
>>> wrote:
>>>
>>>     William,
>>>
>>>           > 'IP-OCB' is an OCB mode that can be transport IP packets
>>>         with .11 Data
>>>
>>>         If it’s over OCB, then it needs to use QoSData. If you’re doing
>>>         Data, you’re not conformant to OCB. There can’t be an OCB mode
>>>         that transports packets with .11 Data, because OCB by definition
>>>         Some implementations may not yet have implemented this, but
>>>     I would like to know whether there is an implementation of IP over
>>>     OCB with QoSData headers?  Packet dump is sufficient, or any other
>>>     kind of statement.
>>>
>>>     I agree with you that many times it is good to write specification
>>>         Sent from Mail <https://go.microsoft.com/fwlink/?LinkId=550986
>>>         <https://go.microsoft.com/fwlink/?LinkId=550986>> for Windows 10
>>>
>>>         *From: *Alexandre Petrescu <mailto:[email-masked]
>>>         <mailto:[email-masked]>>
>>>         <mailto:[email-masked]>>; [email-masked]
>>>         <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]
>>> >>
>>>           >  >> (there are some packet dumps with IP packets transported
>>>         with .11 Data
>>>
>>>           >
>>>
>>>           > headers in OCB mode at 5.9GHz, e.g. attached).
>>>
>>>           >
>>>
>>>           > My understanding is OCB mode requires QoSData, so those
>>>         packets aren’t
>>>
>>>           > conformant to the standard.
>>>
>>>         'IP-OCB' is an OCB mode that can be transport IP packets with
>>>         .11 Data
>>>
>>>         <https://go.microsoft.com/fwlink/?LinkId=550986>> for
>>>
>>>           > Windows 10
>>>
>>>           >
>>>
>>>         <mailto:[email-masked]>>
>>>
>>>           > *Sent: *Thursday, March 1, 2018 10:48 AM
>>>
>>>           > *To: [email-masked] <mailto:[email-masked]>
>>>           > IPv6-over-802.11-OCB -implementations
>>>
>>>           >
>>>
>>>           > In a private discussion, this question came up:
>>>
>>>           >
>>>
>>>           > Is there a packet dump showing an IP packet transported with
>>>         .11 QoSData
>>>
>>>           >
>>>
>>>           > headers in OCB mode at 5.9GHz.
>>>
>>>           >
>>>
>>>           > (there are some packet dumps with IP packets transported
>>>         with .11 Data
>>>
>>>           >
>>>
>>>           > headers in OCB mode at 5.9GHz, e.g. attached).
>>>
>>>           >
>>>
>>>           > Alex
>>>
>>>           >
>>>
>>>           > Le 01/03/2018 à 15:32, Alexandre Petrescu a écrit :
>>>
>>>           >
>>>
>>>           >  > I received some feedback from programmer.
>>>
>>>           >
>>>
>>>           >  >
>>>
>>>           >
>>>
>>>           >  > Le 28/02/2018 à 23:48, Abdussalam Baryun a écrit :
>>>
>>>           >
>>>
>>>           >  > [...]
>>>
>>>           >
>>>
>>>           >  >> ieee802.11ocb protocol is already implemented/tested and
>>>         it is
>>>
>>>           >
>>>
>>>           >  >> interoperable, but what is the problem, sorry maybe I
>>>         did not follow
>>>
>>>           >
>>>
>>>           >  >> the discussion well,
>>>
>>>           >
>>>
>>>           >  >
>>>
>>>           >
>>>
>>>           >  > Here is the QoS problem for IP over 802.11 OCB in
>>>         implementations.
>>>
>>>           >
>>>
>>>           >  >
>>>
>>>           >
>>>
>>>           >  > In short, in open source on linux, we dont know how to
>>>         send IP packets
>>>
>>>           >
>>>
>>>           >  > transported as 802.11 QoSData, all IP packets are
>>>         transported as 802.11
>>>
>>>           >
>>>
>>>           >  > Data instead.
>>>
>>>           >
>>>
>>>           >  >
>>>
>>>           >
>>>
>>>           >  > - if you ping -Q at 5.9GHz in OCB mode, the DSCP fields
>>>         do get
>>>
>>>           >
>>>
>>>           >  >    set properly in IP headers of Echorequest, but there
>>>         is no .11 QoSData
>>>
>>>           >
>>>
>>>           >  >    headers in packets.  Normally, one expects the QoSData
>>>         headers to be
>>>
>>>           >
>>>
>>>           >  >    present there when the DSCP (an IP field) is set.
>>>
>>>           >
>>>
>>>           >  >
>>>
>>>           >
>>>
>>>           >  > - if you want to modify kernel, and force always to use
>>>         QoSData headers
>>>
>>>           >
>>>
>>>           >  >    on WiFi, including OCB at 5.9GHz, there is a
>>>         net/mac80211/tx.c file
>>>
>>>           >
>>>
>>>           >  >    with a flag called wme_sta that you could set to
>>>         true.  But take care
>>>
>>>           >
>>>
>>>           >  >    that the C comments there say that it's not normal to
>>>         use QoSData
>>>
>>>           >
>>>
>>>           >  >    headers in OCB mode, because a terminal sending
>>>         QoSData has no
>>>
>>>           >
>>>
>>>           >  >    guarantee that receivers also use QoSData (the
>>>         negotiation of QoS
>>>
>>>           >
>>>
>>>           >  >    capabilities are absent in OCB).
>>>
>>>           >
>>>
>>>           >  >
>>>
>>>           >
>>>
>>>           >  > As you can see, this can be long to try and fix.
>>>
>>>           >
>>>
>>>           >  >
>>>
>>>           >
>>>
>>>           >  > Until then I will propose to set QoS aside from
>>>           >  > _______________________________________________
>>>
>>>           >
>>>
>>>           >  > its mailing list
>>>
>>>           >
>>>
>>>           >  > [email-masked] <mailto:[email-masked]>
>>>
>>>           >
>>>
>>>           >  > https://www.ietf.org/mailman/listinfo/its
> [email-masked]
>
>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 17 May 2018 14:00:03 +0200

Sure see image below.  I sent you privately the pcap file of this packet 
so you can expand arbitrary fields.

Alex

Le 17/05/2018 à 13:31, Lawrence M a écrit :
> On Thu, May 17, 2018, 12:08 PM Alexandre Petrescu 
>     Recently I performed a visit in the city of Vesailles in France,
>     Europe; there are deployed about 5 Road-Side Units for
>     experimentations, since a few years now.
>
>     Some of them send CAMs and SPATs.  The ones I could test use
>     "Data", not "QoS Data".
>
>>     US implementations use QoSData with everything -- although it's
>>     not required by 802.11-OCB, as we discussed earlier, it *is*
>>     required for a "WAVE device", which all US devices are.
>>
>>     <mailto:[email-masked]>> wrote:
>>
>>
>>
>>             I've confirmed that the US implementations use QoSData,
>>             just to close that loop.
>>
>>
>>                       > 'IP-OCB' is an OCB mode that can be transport
>>             IP packets
>>                     with .11 Data
>>
>>                       >  >> (there are some packet dumps with IP
>>             packets transported
>>                     with .11 Data
>>
>>                       >
>>
>>                       > My understanding is OCB mode requires
>>             QoSData, so those
>>                     packets aren’t
>>
>>                       > *Subject: *Re: [ipwave] 802.11 Data vs 802.11
>>             QoS Data in
>>
>>                       >  >> interoperable, but what is the problem,
>>             sorry maybe I
>>                     did not follow
>>
>>                       >
>>
>>                       >  > In short, in open source on linux, we dont
>>             know how to
>>                     send IP packets
>>
>>                       >
>>
>>                       >  > - if you ping -Q at 5.9GHz in OCB mode,
>>             the DSCP fields
>>                     do get
>>
>>                       >
>>
>>                       >  >    set properly in IP headers of
>>             Echorequest, but there
>>                     is no .11 QoSData
>>
>>                       >
>>
>>                       >  >    headers in packets.  Normally, one
>>             expects the QoSData
>>                     headers to be
>>
>>                       >
>>
>>                       >  >    present there when the DSCP (an IP
>>             field) is set.
>>
>>                       >
>>
>>                       >  >
>>
>>                       >
>>
>>                       >  >    that the C comments there say that it's
>>             not normal to
>>                     use QoSData
>>
>>                       >
>>