Subject: [ipwave] Argument about 'LTE-V2X' term

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 25 Jun 2018 13:33:06 +0200

We had an internal discussion about what means 'LTE-V2X'.

I may be very wrong about this, but this is where I am:

The term 'LTE-V2X' is not defined.

I pretend that 'LTE-V2X' is when a car sends CAM messages over UDP over 
IPv6 to an IoT platform in the cloud, or to another car via LTE.

Is this wrong?

Alex

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Mon, 25 Jun 2018 13:25:16 +0000

I would read this term as, V2X communication based on 3GPP LTE infrastructure. Its not only about CAM messages, but any safety related V2V/V2I/V2P communications over LTE infra, as opposed to DSRC.

On Jun 25, 2018, at 4:33 AM, Alexandre Petrescu <[email-masked]<mailto:[email-masked]>> wrote:

I pretend that 'LTE-V2X' is when a car sends CAM messages over UDP over IPv6 to an IoT platform in the cloud, or to another car via LTE.

Is this wrong?

Alex

_______________________________________________
its mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/its

---

From: Jérôme Härri <[email-masked]>
Date: Mon, 25 Jun 2018 16:17:24 +0200

HI Alex,  Sri,

The ‘V2X’ is a ‘function’ part of the 3GPP specification. And LTE means ‘not 5G’…(just to avoid confusion with future 5G-V2X)…so, LTE-V2X actually means: 3GPP rel.14 V2X communication. 

The 3GPP rel.14 V2X specification does not say anything about what type of message and under which ‘pipe’ (IP or non-IP), not even the frequency band (yes, LTE-V2X PC5 is restricted to 5.9Ghz, but not LTE-V2X Uu). 

The only thing that the 3GPP rel.14 V2X provides is the availability of a non-IP packet format for the negotiation of the radio bearers (unlike LTE D2D, which only allows IPv4 and IPv6), as well as semi-persistent scheduling opportunities (which LTE-D2D does not offer)..and additionally, the fact that you bypass the Discovery phase of the LTE-D2D (another limitation of the rel.14 version..). 

What LTE-V2X also does not say is the type of V2X. You would need to add mode 3 (D2D infrastructure) or mode 4 (D2D ad-hoc) to be complete. And you would also have the LTE-V2X Uu, which is actually the V2I…and indeed, in that case, I assume (but did not formally check) that it is IP (I would even guess IPv4 and IPv6). 

And we also need to specify the level of the 3GPP LTE-V2X. so far, I only mentioned the Access Stratum, but you also have LTE-V2X functions at the NAS (non-access stratum)…

In both cases, nothing is said about the type of message, for a simple reason that a message is only seen by the LTE-V2X ‘stack’ as a Logical Channels (and Radio Bearers)...

So, the term ‘LTE-V2X’ is actually specified by 3GPP as one ProSe (Proximity Service) function (a bit like Public Safety or Device-to-Device)…maybe to make an analogy, it could be seem similarly to the OCB in IEEE…OCB is a tag to modify the behavior of a standard to reflex a type of communication…

So, LTE-V2X by itself, it does not mean much. We need to add further details:

-          V2V: LTE-V2X mode 3 (or mode 4) under IPv6 (or under geonet/WSM) transmitting CAM (with this, we have no doubt on what and under which frequency)

-          V2V: LTE-V2X mode 4 (or mode 3) under WSM transmitting CAM

-          V2I: LTE-V2X Uu under IPv6 transmitting HD-Maps

So, summarizing, LTE-V2X means (by shortcutting the 3GPP rel.14 in front) the V2X functions, but if we want to be absolutely clear (and usually we need J), just saying: we use LTE-V2X is indeed not sufficiently defined !!

@Alex: now for your statement, it is a bit confusing…you should differentiate the communication type: CAM being sent over UDP / IP to an IoT platform would then be a *LTE-V2X Uu sent on the 3.4GHz frequency band* (as I do not think it is allowed to transmit V2X messages over the Uu interface at 5.9Ghz). And CAM being sent over UDP/IP to another car is the *LTE-V2X PC5 sent over the 5.9Ghz*. As you can see, both means fully different things…

And as I am sure you will mention this…yes, you can transmit CAM over IPv6 in both PC5 or Uu J …at least from 3GPP perspective…, but I am sure that either IEEE WAVE or ETSI ITS might but the same restrictions at ITS-G5 J 

BR,

Jérôme

From: its [mailto:[email-masked]] On Behalf Of Sri Gundavelli (sgundave)
Sent: Monday 25 June 2018 15:25
To: Alexandre Petrescu
Cc: [email-masked]
Subject: Re: [ipwave] Argument about 'LTE-V2X' term

On Jun 25, 2018, at 4:33 AM, Alexandre Petrescu <[email-masked]> wrote:

Is this wrong?

Alex

[email-masked]

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 25 Jun 2018 17:00:57 +0200

Le 25/06/2018 à 16:17, Jérôme Härri a écrit :
[...]> So, summarizing, LTE-V2X means (by shortcutting the 3GPP rel.14 in
> front) the V2X functions, but if we want to be absolutely clear (and 
> usually we need J), just saying: we use LTE-V2X is indeed not 
> sufficiently defined !!

In private we tried to find a 3GPP document that defines the term 
'LTE-V2X' but we couldnt.  We did find a 5GAA document that uses 
'LTE-V2X' throughout.  Yet 5GAA is not 3GPP.

If one has a 3GPP document that defines the term 'LTE-V2X' then I would 
be grateful.

> @Alex: now for your statement, it is a bit confusing…you should 
> differentiate the communication type: CAM being sent over UDP / IP to an 
> IoT platform would then be a **LTE-V2X Uu sent on the 3.4GHz frequency 
> band** (as I do not think it is allowed to transmit V2X messages over 
> the Uu interface at 5.9Ghz). And CAM being sent over UDP/IP to another 
> car is the **LTE-V2X PC5 sent over the 5.9Ghz**. As you can see, both 
> means fully different things…

I agree with the clarification.

I would first need to understand whether or not 3GPP defines the term 
'LTE-V2X'.

For the other distinction (Uu to cloud, PC5 to car) - it is indeed a 
right distinction.  But you could also have a car that sends a CAM/IP up 
an Uu and down another Uu to reach a car: V-Uu-Uu-V.  No?

Alex
> 
> And as I am sure you will mention this…yes, you can transmit CAM over 
> IPv6 in both PC5 or Uu J…at least from 3GPP perspective…, but I am sure 
> that either IEEE WAVE or ETSI ITS might but the same restrictions at 
> ITS-G5 J
> 
> BR,
> 
> Jérôme
> 
> *From:*its [mailto:[email-masked]] *On Behalf Of *Sri Gundavelli 
> (sgundave)
> *Sent:* Monday 25 June 2018 15:25
> *To:* Alexandre Petrescu
> *Cc:* [email-masked]
> *Subject:* Re: [ipwave] Argument about 'LTE-V2X' term
> 
>   I would read this term as, V2X communication based on 3GPP LTE 
> infrastructure. Its not only about CAM messages, but any safety related 
> V2V/V2I/V2P communications over LTE infra, as opposed to DSRC.
> 
> 
> On Jun 25, 2018, at 4:33 AM, Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     I pretend that 'LTE-V2X' is when a car sends CAM messages over UDP
>     over IPv6 to an IoT platform in the cloud, or to another car via LTE.
> 
>     Is this wrong?
> 
>     Alex
> 
>     [email-masked] <mailto:[email-masked]>