Subject: [ipwave] Fwd: Re: Request for 6man review of draft-ietf-ipwave-ipv6-over-80211ocb-22

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 15 Jun 2018 14:04:38 +0200

Hi IPWAVErs,

An important comment was made on our draft, in the 6man WG.

The comment is the following: ND on OCB can not be 'different' than ND
on normal links, while being at the same time 'not specified'
And this is what this current text suggests:

>> The operation of the Neighbor Discovery protocol (ND) over
>> 802.11-OCB links is different than over 802.11 links.  In OCB, the
>> link layer
                ^^^^^^^^^
>> does not ensure that all associated members receive all messages, 
>> because there is no association operation.  The operation of ND
>> over 802.11-OCB is not specified in this document.
[...]
>> The operation of ND over 802.11-OCB is not specified in this
>> document.

To solve this issue, I propose that we remove the latter phrase.

Do you disagree?

Alex

-------- Message transféré --------
Sujet : Re: Request for 6man review of
draft-ietf-ipwave-ipv6-over-80211ocb-22
Date : Thu, 14 Jun 2018 08:50:17 +1200
De : Brian E Carpenter <[email-masked]>
Pour : Suresh Krishnan <[email-masked]>, Lorenzo Colitti
<[email-masked]>
Copie à : Alexandre Petrescu <[email-masked]>, 6man
<[email-masked]>, [email-masked]

I see that there has been no significant change in the -23 version.
The two contradictory statements are still present:
  >    The operation of the Neighbor Discovery protocol (ND) over 802.11-OCB
> links is different than over 802.11 links.  In OCB, the link layer 
> does not ensure that all associated members receive all messages, 
> because there is no association operation.  The operation of ND over 
> 802.11-OCB is not specified in this document.

ND can't be both "different" and "not specified".

Also, an IPv6 spec without neighbour discovery is incomplete and seems
likely to be unusable.

Regards
    Brian Carpenter

On 17/05/2018 04:37, Suresh Krishnan wrote:
> Hi Lorenzo,
> 
> On May 14, 2018, at 9:41 PM, Lorenzo Colitti
> <[email-masked]<mailto:[email-masked]>> wrote:
> 
> On Tue, May 15, 2018 at 9:08 AM Brian E Carpenter
> <[email-masked]<mailto:[email-masked]>>
> wrote: What I understand is that multicast is highly unreliable on
> OCB (as opposed to reasonably reliable on classical 802.11).
> 
> Because you not specify how neighbours are discovered, I don't see
> how an actual IPv6 service could be provided.
> 
> If that's true then that means this document does not actually
> specify a feasible scheme to implement IPv6 over this network type.
> As such, perhaps the 6man WG should recommend that this document
> should not be published until it either documents a working
> specification or at least clearly and unambiguously documents what
> works and what doesn’t.
> 
> Yep. That would be the right thing to do,
> 
> 
> Suresh, chairs - what's the best way forward here? Would it be a good
> idea to present this document at the 6man slot in Montreal to solicit
> input from other participants and see if together we can come up with
> better text?
> 
> I’d rather not wait till the Montreal meeting if we can make progress
> on this document before then. I will have a discussion with the
> ipwave/6man chairs and the document editor to work out a way forward
> 
> Regards Suresh
>

---

From: Nabil Benamar <[email-masked]>
Date: Fri, 15 Jun 2018 12:41:10 +0000

Hi Alex,

I agree on removing this sentence: "The operation of ND over 802.11-OCB is
not specified in this document."

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

On Fri, Jun 15, 2018 at 12:04 PM Alexandre Petrescu <
[email-masked]> wrote:

> 802.11-OCB
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Tony Li <[email-masked]>
Date: Fri, 15 Jun 2018 08:11:11 -0700

Yes, please remove that sentence.

Further, I suggest replacing the entire paragraph with: “Neighbor Discovery (ND) is used over 802.11-OCB.”

Tony

> On Jun 15, 2018, at 5:41 AM, Nabil Benamar <[email-masked]> wrote:
> 
> Hi Alex,
> 
> I agree on removing this sentence: "The operation of ND over 802.11-OCB is not specified in this document." 
> 
> 
> Best regards
> Nabil Benamar
> -------------------
> نبيل بنعمرو
> 
> 
> 
> 
> 
> 
> 
> On Fri, Jun 15, 2018 at 12:04 PM Alexandre Petrescu <[email-masked] <mailto:[email-masked]>> wrote:
> Hi IPWAVErs,
> 
> De : Brian E Carpenter <[email-masked] <mailto:[email-masked]>>
> Pour : Suresh Krishnan <[email-masked] <mailto:[email-masked]>>, Lorenzo Colitti
> <[email-masked] <mailto:[email-masked]>>
> Copie à : Alexandre Petrescu <[email-masked] <mailto:[email-masked]>>, 6man
> <[email-masked] <mailto:[email-masked]>>, [email-masked] <mailto:[email-masked]>
> 
> > <[email-masked] <mailto:[email-masked]><mailto:[email-masked] <mailto:[email-masked]>>> wrote:
> > 
> > <[email-masked] <mailto:[email-masked]><mailto:[email-masked] <mailto:[email-masked]>>>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/its <https://www.ietf.org/mailman/listinfo/its>