Subject: [ipwave] Fwd: New Version Notification for draft-ietf-ipwave-ipv6-over-80211ocb-23.txt

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 13 Jun 2018 14:04:29 +0200

Hi IPWAVErs,

I submitted the version -23 of the IPv6-over-OCB draft.

There is no content modification.  (I will do the ND modifs requested  
by AD later).

You should ignore this version -23.

The goal of this -23 version is to verify the following: check our car 
network is connected to the Internet, and check the process.

The results of this check are the following:

- the car is able to offer both IPv4 and IPv6 to its computers.
- the github.com is only on IPv4; it can not be accessed on IPv6.
- the ietf.org process is ok on IPv6.  The following work ok if accessed 
from a Client that does only IPv6: xml2rfc.ietf.org, and submission on 
datatracker.ietf.org.
- during submission, the confirmation email is sent to the author's 
organisation.  In my case that email is on IPv4 only.
- sidenote: submission does not accept if submit just the .xml, it needs 
.txt as well, otherwise it complains about title and filename.
- I send this email on google smtp with a client on IPv6, and IPv4 
unchecked box.  If it reaches the list it means that gmail works on IPv6 
only, and that the mailing lists at IETF also work ok if
   accessed from a Client that does only IPv6.

You are free to ignore this -23 version, it's not very important to the 
contents of our draft.

Yours,

Alex

-------- Message transféré --------
Sujet : 	New Version Notification for 
draft-ietf-ipwave-ipv6-over-80211ocb-23.txt
Date : 	Wed, 13 Jun 2018 04:44:43 -0700
De : 	[email-masked]
Pour : 	Jerome Haerri <[email-masked]>, 
[email-masked], Jerome Haerri <[email-masked]>, 
Alexandre Petrescu <[email-masked]>, Alexandre Petrescu 
<[email-masked]>, Nabil Benamar <[email-masked]>, 
Thierry Ernst <[email-masked]>, Jong-Hyouk Lee 
<[email-masked]>

A new version of I-D, draft-ietf-ipwave-ipv6-over-80211ocb-23.txt
has been successfully submitted by Alexandre Petrescu and posted to the
IETF repository.

Name:		draft-ietf-ipwave-ipv6-over-80211ocb
Revision:	23
Title:		Transmission of IPv6 Packets over IEEE 802.11 Networks operating in mode Outside the Context of a Basic Service Set (IPv6-over-80211-OCB)
Document date:	2018-06-13
Group:		ipwave
Pages:		39
URL:            https://www.ietf.org/internet-drafts/draft-ietf-ipwave-ipv6-over-80211ocb-23.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-ipwave-ipv6-over-80211ocb/
Htmlized:       https://tools.ietf.org/html/draft-ietf-ipwave-ipv6-over-80211ocb-23
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-ipv6-over-80211ocb
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-ipv6-over-80211ocb-23

Abstract:
    In order to transmit IPv6 packets on IEEE 802.11 networks running
    outside the context of a basic service set (OCB, earlier "802.11p")
    there is a need to define a few parameters such as the supported
    Maximum Transmission Unit size on the 802.11-OCB link, the header
    format preceding the IPv6 header, the Type value within it, and
    others.  This document describes these parameters for IPv6 and IEEE
    802.11-OCB networks; it portrays the layering of IPv6 on 802.11-OCB
    similarly to other known 802.11 and Ethernet layers - by using an
    Ethernet Adaptation Layer.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 13 Jun 2018 14:05:56 +0200

[only this email was sent on IPv6 only: IPv4 was unchecked in the 
sending Windows]

Hi IPWAVErs,

Yours,

Alex

-------- Message transféré --------

Name:		draft-ietf-ipwave-ipv6-over-80211ocb
Revision:	23
Title:		Transmission of IPv6 Packets over IEEE 802.11 Networks operating in mode Outside the Context of a Basic Service Set (IPv6-over-80211-OCB)
Document date:	2018-06-13
Group:		ipwave
Pages:		39
URL:https://www.ietf.org/internet-drafts/draft-ietf-ipwave-ipv6-over-80211ocb-23.txt
Status:https://datatracker.ietf.org/doc/draft-ietf-ipwave-ipv6-over-80211ocb/
Htmlized:https://tools.ietf.org/html/draft-ietf-ipwave-ipv6-over-80211ocb-23
Htmlized:https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-ipv6-over-80211ocb
Diff:https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-ipv6-over-80211ocb-23

Abstract:

The IETF Secretariat

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 13 Jun 2018 14:10:24 +0200

The email was sent ok on IPv6, from the car network, up to the server, 
and to the email list and in the archive ietf.org/mailman/listinfo/its

IPv4 was disabled during this entire chain - I am happy!

Alex

Le 13/06/2018 à 14:05, Alexandre Petrescu a écrit :
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: François Simon <[email-masked]>
Date: Wed, 13 Jun 2018 10:02:38 -0400

Thank you for let me know.   Here again….Whoaaaa! about the testing.   I am sure that there are serious test suites already written that can be modified for the purpose.  Fygs

From: its <[email-masked]> On Behalf Of Alexandre Petrescu
Sent: Wednesday, June 13, 2018 8:06 AM
To: [email-masked]
Subject: [ipwave] Fwd: New Version Notification for draft-ietf-ipwave-ipv6-over-80211ocb-23.txt

[only this email was sent on IPv6 only: IPv4 was unchecked in the sending Windows]

Hi IPWAVErs,

There is no content modification.  (I will do the ND modifs requested  by AD later).

The goal of this -23 version is to verify the following: check our car network is connected to the Internet, and check the process.

- the car is able to offer both IPv4 and IPv6 to its computers.
- the github.com is only on IPv4; it can not be accessed on IPv6.
- the ietf.org process is ok on IPv6.  The following work ok if accessed from a Client that does only IPv6: xml2rfc.ietf.org, and submission on datatracker.ietf.org.
- during submission, the confirmation email is sent to the author's organisation.  In my case that email is on IPv4 only.
- sidenote: submission does not accept if submit just the .xml, it needs .txt as well, otherwise it complains about title and filename.
- I send this email on google smtp with a client on IPv6, and IPv4 unchecked box.  If it reaches the list it means that gmail works on IPv6 only, and that the mailing lists at IETF also work ok if 
  accessed from a Client that does only IPv6.

You are free to ignore this -23 version, it's not very important to the contents of our draft. 

Yours,

Alex

-------- Message transféré -------- 

Sujet : 

New Version Notification for draft-ietf-ipwave-ipv6-over-80211ocb-23.txt

Date : 

Wed, 13 Jun 2018 04:44:43 -0700

De : 

[email-masked] <mailto:[email-masked]> 

Pour : 

Jerome Haerri  <mailto:[email-masked]> <[email-masked]>, [email-masked] <mailto:[email-masked]> , Jerome Haerri  <mailto:[email-masked]> <[email-masked]>, Alexandre Petrescu  <mailto:[email-masked]> <[email-masked]>, Alexandre Petrescu  <mailto:[email-masked]> <[email-masked]>, Nabil Benamar  <mailto:[email-masked]> <[email-masked]>, Thierry Ernst  <mailto:[email-masked]> <[email-masked]>, Jong-Hyouk Lee  <mailto:[email-masked]> <[email-masked]>

 
Abstract:

 
 
The IETF Secretariat

---

From: François Simon <[email-masked]>
Date: Wed, 13 Jun 2018 10:02:38 -0400

Just curious.  Is the way you are testing functions which eventually going to part of a standard?   Fygs

-----Original Message-----
From: its <[email-masked]> On Behalf Of Alexandre Petrescu
Sent: Wednesday, June 13, 2018 8:10 AM
To: [email-masked]
Subject: Re: [ipwave] Fwd: New Version Notification for draft-ietf-ipwave-ipv6-over-80211ocb-23.txt

The email was sent ok on IPv6, from the car network, up to the server, and to the email list and in the archive ietf.org/mailman/listinfo/its

Alex

Le 13/06/2018 à 14:05, Alexandre Petrescu a écrit :
> - the ietf.org process is ok on IPv6.  The following work ok if 
> accessed from a Client that does only IPv6: xml2rfc.ietf.org, and 
> submission on datatracker.ietf.org.
> - sidenote: submission does not accept if submit just the .xml, it 
> needs .txt as well, otherwise it complains about title and filename.
> unchecked box.  If it reaches the list it means that gmail works on 
> IPv6 only, and that the mailing lists at IETF also work ok if
> has been successfully submitted by Alexandre Petrescu and posted to 
> the IETF repository.
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 13 Jun 2018 16:18:44 +0200

Yes,
for example, when we write standards-to-be we would like to be sure they 
are used, and not just write for writing.

For example, IPv6 is a technology that could be used in a car, and also 
used to standardise.  This is not the case with CAM: one can standardise 
CAMs, but can not use CAM to standardise CAMs.

In this sense, this exercise is a proof of implementability.  It is very 
positive for any draft.

On a more mundane matter, this test allowed me to realise that both .xml 
_and_ .txt files are still mandatory during the submmission process. 
This is not related to IPv6, but it is a mundane issue that people who 
write documents at IETF are confronted with.  The basic question is: why 
should I submit _both_ an xml _and_ a txt when the latter is 
automatically deduced from the first (e.g. the tool at 
xml2rfc.ietf.org).  It sounds redundant.  It's as if I had to submit 
both a pdf and a doc, of the same document, to some organisation.  The 
temptation to complain is itching.

At some point, this redundancy was acknowledged on the submission site: 
it said you _must_ submit both (an asterisk was present, as mandatory 
fields).  Then the asterisks disappeared, yet the mechanics have the 
same effect: one _must_ submit both formats.

But again, this is about the process, which is dear overall.

This is not about the draft contents.

In the long term, if the process is easier, the contents may become 
smoother too :-)

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 13 Jun 2018 16:41:39 +0200

Is there a test suite to test IPv6 in a car?

Alex

Le 13/06/2018 à 16:02, François Simon a écrit :
> Thank you for let me know.   Here again….Whoaaaa! about the testing.   I 
> am sure that there are serious test suites already written that can be 
> modified for the purpose.  Fygs
> 
> *From:*its <[email-masked]> *On Behalf Of *Alexandre Petrescu
> *Sent:* Wednesday, June 13, 2018 8:06 AM
> *To:* [email-masked]
> *Subject:* [ipwave] Fwd: New Version Notification for 
> *Sujet : *
> *Date : *
> *De : *
> *Pour : *
> Jerome Haerri <[email-masked]> 
> <mailto:[email-masked]>, [email-masked] 
> <mailto:[email-masked]>, Jerome Haerri 
> <[email-masked]> <mailto:[email-masked]>, Alexandre 
> Petrescu <[email-masked]> <mailto:[email-masked]>, 
> Alexandre Petrescu <[email-masked]> 
> <mailto:[email-masked]>, Nabil Benamar 
> <[email-masked]> <mailto:[email-masked]>, Thierry 
> Ernst <[email-masked]> <mailto:[email-masked]>, 
> Jong-Hyouk Lee <[email-masked]> <mailto:[email-masked]>
>

---

From: François Simon <[email-masked]>
Date: Wed, 13 Jun 2018 11:33:02 -0400

Since the Certification Service Providers (in the US) are suppose to test IEEE 1609.3 (see below) then it should be test cases for IPv6 in WAVE.  Fygs

USDOT Connected Vehicle PlugFest 
Date: May 8-12, 2017
Registration: Click Here   

The U.S. Department of Transportation (USDOT) will hold its next Connected Vehicle PlugFest in San Antonio, TX, from May 8 through 12, 2017. These events provide a venue for vendor-to-vendor connected vehicle device testing as needed to develop certification services for multi-vendor connected vehicle networks.

Three certification service providers (Danlaw, OmniAir, and 7Layers) will be on site to demonstrate certification testing products developed through the USDOT Certification Testing Program. Testing will focus on verifying conformance to current baseline standards for vehicle-to-infrastructure communications (i.e., IEEE 802.11, IEEE 1609.2, IEEE 1609.3, IEEE 1609.4, RSU 4.1). Provisions will be available to support continued testing of vehicle-to-vehicle communications as time permits.

-----Original Message-----
From: François Simon <[email-masked]> 
Sent: Wednesday, June 13, 2018 11:25 AM
To: [email-masked]
Subject: FW: [ipwave] Fwd: New Version Notification for draft-ietf-ipwave-ipv6-over-80211ocb-23.txt

-----Original Message-----
From: Alexandru Petrescu <[email-masked]>
Sent: Wednesday, June 13, 2018 10:42 AM
To: François Simon <[email-masked]>; [email-masked]
Subject: Re: [ipwave] Fwd: New Version Notification for draft-ietf-ipwave-ipv6-over-80211ocb-23.txt

Alex

Le 13/06/2018 à 16:02, François Simon a écrit :
> Thank you for let me know.   Here again….Whoaaaa! about the testing.   
> I am sure that there are serious test suites already written that can 
> be modified for the purpose.  Fygs
> 
> New Version Notification for
> <[email-masked]> <mailto:[email-masked]>,
> Alexandre Petrescu <[email-masked]> 
> <mailto:[email-masked]>,
> the
> Title:         Transmission of IPv6 Packets over IEEE 802.11 Networks 
> operating in mode Outside the Context of a Basic Service Set
> (IPv6-over-80211-OCB)
> 
> submission

---

From: Russ Housley <[email-masked]>
Date: Wed, 13 Jun 2018 12:22:22 -0400

> - sidenote: submission does not accept if submit just the .xml, it needs .txt as well, otherwise it complains about title and filename.

Others have had success submitting just the .xml file.

Looking at your .xml file, you need to remove the ".txt" from the docName as follows:

OLD:

<rfc category="std"
     docName="draft-ietf-ipwave-ipv6-over-80211ocb-23.txt"
     ipr="trust200902">

NEW:

<rfc category="std"
     docName="draft-ietf-ipwave-ipv6-over-80211ocb-23"
     ipr="trust200902">

Russ