Subject: Re: [ipwave] 回复：Re: Argument about 'LTE-V2X' term

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 26 Jun 2018 11:06:24 +0200

Hello Minpeng,

Thank you for the references.

Le 26/06/2018 à 03:32, [email-masked] a écrit :
> You can find V2X abbreviation definition in 3GPP TS 22.185. That 
> specification is used to define requirement of LTE V2X: "... provides 
> 3GPP support for V2X service requirements to be supported by LTE transport."

I downloaded the document.  It does not seem to define the term 
'LTE-V2X'.  It does however define formally, in its Definitions and 
Abbreviations sections, other terms like 'Road Side Unit','Pseudonimity' 
and 'V2X'.

For 'V2X', it says 'Vehicle-to-Everything'.  This definition in 
particular could be further discussed.  Because some people use 'V2X' to 
mean _one_ of 'V2V' or 'V2P' (like in classical computing: 'X' is a 
variable and could have a single value which could be 'V' or 'P', but 
not the two at the same time like in quantum computing).  And 
'Everything' means everything at the same time, like  when sending a 
datagram to everyone else in multicast mode.

But back to my need of 'LTE-V2X'.

At this point, I strongly believe that whenever we hear 'LTE-V2X' it is 
a colloquial term common in conversation.  It is not a formally defined 
term. It is a little bit like the term 'core network'.

The advantage of such term defined in a colloquial manner is that it can 
mean whatever the speaker wants it to mean.

If I designate 'LTE-V2X' to mean CAM-as-XER-over-UDP-over-IP from a car 
to another car, now I dont think I am incorrect.  Unless, of course, 
some people oppose it, or prefer a more refined definition to cover 
also, e.g., BSM or DENM or SPAT; and maybe not just XER but also JSON. 
And so on.

But really, at this time, there is no formal definition of 'LTE-V2X'.

This does not mean 'LTE-V2X' does not exist: there are multiple 
demonstrated prototypes that send CAMs over LTE, but just the term 
definition does not exist.

> There are series technical reports and specifications related to LTE 
> V2X. TS22.185, TS23.185, TS 33.185 are specifications for system 
> requirements, architecture and security part. For radio specification, 
> V2X will be a feature and be defined in several TSs, such as TS 
> 36.21x(x=1,2,3,4,6), TS 36.321, TS 36.331, etc.

Thank you for references.

> @alex, for your last question, yes there are two ways for V2V/V2I/V2P 
> communication. One way is directly communication, i.e. through PC5 
> interface. And the other is through LTE-Uu interface, which is usually 
> be called (unofficially) as V2N2V, V2N2I, V2N2P. Related definition can 
> be found in TS22.185 "Such 3GPP transport includes the transport between 
> UEs directly and/or, due to the limited direct communication range, the 
> transport between UEs via infrastructure supporting V2X communication, 
> e.g., RSU, application server, etc."

Thank you, I looked.  It is as you say; but just not defining 'V2N2V'. 
It is a term that you may use in a colloquial manner with other people. 
And you may understand each other correctly.  But it is not formally 
defined.  In particular, I dont understand you :-)

Alex

> 
> BRs,
> Minpeng
> 
> ----- 原始邮件 -----
> 发件人：Alexandre Petrescu <[email-masked]>
> 收件人：Jérôme Härri <[email-masked]>, "'Sri Gundavelli 
> (sgundave)'" <sgundave=[email-masked]>
> 抄送人：[email-masked]
> 主题：Re: [ipwave] Argument about 'LTE-V2X' term
> 日期：2018年06月25日 23点01分
> 
> 
> Le 25/06/2018 à 16:17, Jérôme Härri a écrit :
> [...]> So, summarizing, LTE-V2X means (by shortcutting the 3GPP rel.14 in
>  > front) the V2X functions, but if we want to be absolutely clear (and
>  > usually we need J), just saying: we use LTE-V2X is indeed not
>  > sufficiently defined !!
> In private we tried to find a 3GPP document that defines the term
> 'LTE-V2X' but we couldnt. We did find a 5GAA document that uses
> 'LTE-V2X' throughout. Yet 5GAA is not 3GPP.
> If one has a 3GPP document that defines the term 'LTE-V2X' then I would
> be grateful.
>  > @Alex: now for your statement, it is a bit confusing…you should
>  > differentiate the communication type: CAM being sent over UDP / IP to an
>  > IoT platform would then be a **LTE-V2X Uu sent on the 3.4GHz frequency
>  > band** (as I do not think it is allowed to transmit V2X messages over
>  > the Uu interface at 5.9Ghz). And CAM being sent over UDP/IP to another
>  > car is the **LTE-V2X PC5 sent over the 5.9Ghz**. As you can see, both
>  > means fully different things…
> I agree with the clarification.
> I would first need to understand whether or not 3GPP defines the term
> 'LTE-V2X'.
> For the other distinction (Uu to cloud, PC5 to car) - it is indeed a
> right distinction. But you could also have a car that sends a CAM/IP up
> an Uu and down another Uu to reach a car: V-Uu-Uu-V. No?
> Alex
>  >
>  > And as I am sure you will mention this…yes, you can transmit CAM over
>  > IPv6 in both PC5 or Uu J…at least from 3GPP perspective…, but I am sure
>  > that either IEEE WAVE or ETSI ITS might but the same restrictions at
>  > ITS-G5 J
>  >
>  > BR,
>  >
>  > Jérôme
>  >
>  > *From:*its [mailto:[email-masked]] *On Behalf Of *Sri Gundavelli
>  > (sgundave)
>  > *Sent:* Monday 25 June 2018 15:25
>  > *To:* Alexandre Petrescu
>  > *Cc:* [email-masked]
>  > *Subject:* Re: [ipwave] Argument about 'LTE-V2X' term
>  >
>  >  I would read this term as, V2X communication based on 3GPP LTE
>  > infrastructure. Its not only about CAM messages, but any safety related
>  > V2V/V2I/V2P communications over LTE infra, as opposed to DSRC.
>  >
>  >
>  > On Jun 25, 2018, at 4:33 AM, Alexandre Petrescu
>  > <[email-masked] <mailto:[email-masked]>> 
> wrote:
>  >
>  > We had an internal discussion about what means 'LTE-V2X'.
>  >
>  > I may be very wrong about this, but this is where I am:
>  >
>  > The term 'LTE-V2X' is not defined.
>  >
>  > I pretend that 'LTE-V2X' is when a car sends CAM messages over UDP
>  > over IPv6 to an IoT platform in the cloud, or to another car via LTE.
>  >
>  > Is this wrong?
>  >
>  > Alex
>  >
>  > _______________________________________________
>  > its mailing list
>  > [email-masked] <mailto:[email-masked]>
>  > https://www.ietf.org/mailman/listinfo/its
>  >
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its

---

From: Jérôme Härri <[email-masked]>
Date: Tue, 26 Jun 2018 14:10:18 +0200

Hello Alex,

For once, I think we should not seek too complex answers. From a 3GPP perspective, LTE-V2X does not need to be defined because it kind of is...by default (in the 3GPP community). 

So, in one line answer: LTE means '4G' and V2X means 'Vehicle-to-Everything'. So, LTE-V2X is 4G technology for Vehicle-to-Everything...period. And as what is above PDCP is IP, then whatever is higher than PDCP (kind of L2++) does not need to be specified...then you no specification on what/how to use it...(for once a nice Layer Separation :-) )

Now, for more details...As you mentioned, the 'V2X' term means what 3GPP defined as Vehicle-to-Everything and this, from a 'service perspective' (Proximity Service, which is the heard of the V2X/Sidelink/PC5 enhancements). So, it truly does not matter if it goes direct, over eNB, over a MEC, if you use a CAM, smoke signals or even morse code...etc..

Yet, 3GPP uses V2X as a mean of a specific operation of the traditional cellular system...as I said, it is very similar to saying OCB (and you have all variations of OCB)..So, you will see 'V2X functions', 'V2X Services', etc.. everywhere in 3GPP, as it simply means that as V2X requires the cellular system to operate differently, we need specific functions or 'code' to let people know we deal with a different operation (another example is Public Safety (PS)..similar meaning). 

So, you are right...LTE-V2X means various things, and you are correct, you can use it for your various use cases...all are correct...but it might make your life a bit harder, as now, you will need to define it yourself (explaining on which pipe, which frequency, which interface (PC5, Uu), which mode, ...

But let's take a different approach...what does it 'not' mean:

- it DOES NOT mean anything related to 3GPP 5G rel.15 and up on 'ANYTHING' in these specs...(this is particularly important when considering the V2X 'scheduler', which is limited LTE-V2X but will be improved in 5G-V2X). As I said, although never written in 3GPP, the LTE actually refers to the 4G system..it is kind of a naming type, nothing else.

- it DOES NOT apply for autonomous driving, platooning or safety of vulnerable road users. As the definitions of the phases, LTE-V2X applies to DAY ONE applications (safety) and 5G-V2X will apply to DAY 2 (you can see that on the various 5G documents, like  TS 22.186 (rel. 15)). Actually, you may use LTE-V2X for Day2, but the chip manufacturers acknowledged a limited capacity and delay that can only be solved by 5G-V2X.

- it DOES NOT allow D2D Service Discovery (but 5G-V2X might)...the V2X function is assumed to be 'the' service. So, the whole Sidelink processes only rely on SL-control, SL-data (and SL-broadcast for synchronization)

- it DOES NOT allow D2D Unicast communication (but 5G-V2X might)

- it DOES NOT assume anything above PDCP...(you basically get an IP or a WSM/Geonet interface on your linux system)....so, as IP is 'de facto standard', anything that can go on IP is good for LTE-V2X...So, you can use JSON, XML, XER...and also CAM or anything else...it does not matter, as long as the PDCP (and RRC) can get a LC and a RB. Even if in theory, you could do IPv6-over-PC5 (so LTE-V2V using IP), the process to configure the IP address considering only broadcast communication is...'complicated'...that is why 3GPP allowed a non-IP stack to configure the PC5 link (btw, if this an IPv6 ‘link’ configuration only relying on broadcast communication…so a broadcast IP link…) specification would need to be defined, and it would certainly NOT be done by 3GPP but by IETF…).

- it DOES NOT only apply to 5.9GHz and WILL NOT  be free for everything. The LTE-V2X Uu is rather expected to rely on 3.4Ghz, and this will be a commercial band...so, any LTE-V2X-Uu will most likely need to be 'paid' for by one way or another. This comes from the 5.9Ghz V2V restrictions provided in both EU and US regulations (the spectrum is provided for direct V2V communication). But maybe 5GAA has a better marketing way of describing this...

Maybe another aspect. The LTE-V2X has the V2X communication profile defined: LTE-V2X PC5 is on 5.9Ghz and LTE-V2X Uu is on 3.4-3.7Ghz. Considering your target application, you seems to be using Uu, then you might not have to bother (and even need to discuss) with the ITS guys, as Uu is not meant for 5.9Ghz...so, no issue about what to do or what to transmit (IP or not IP...)..that is the nice aspect...now, the less nice aspect is it is really not clear when, who and how the 3.4-3.7Ghz will be made available by the operators...But if you want to transmit CAM with IP over the PC5 interface, it is ‘very’ highly likely that this will be restricted in one wat or another again by US or EU regulations…(exactly as ITS-G5).

But one question that you might want to get answered, is what Cellular V2X (C-V2X) actually mean...as for mode 4, there is no cellular, no SIM card, no concept of eNB and even the scheduler is standardized and collision-prone...far from a typical cellular technology. Considering this is the deployed V2X for critical V2V communication, I think this US naming is awkward...

Alternatively, LTE-V is also weird to me as it looks like a 'vehicular LTE', which might not always be the case...(you can have LTE-V for pedestrian...or even for trains).

BR,

Jérôme

-----Original Message-----
From: Alexandre Petrescu [mailto:[email-masked]] 
Sent: Tuesday 26 June 2018 11:06
To: [email-masked]; Jérôme Härri; 'Sri Gundavelli (sgundave)'
Cc: its
Subject: Re: 回复：Re: [ipwave] Argument about 'LTE-V2X' term

Hello Minpeng,

> 3GPP support for V2X service requirements to be supported by LTE transport."

I downloaded the document.  It does not seem to define the term 'LTE-V2X'.  It does however define formally, in its Definitions and Abbreviations sections, other terms like 'Road Side Unit','Pseudonimity' 

and 'V2X'.

For 'V2X', it says 'Vehicle-to-Everything'.  This definition in particular could be further discussed.  Because some people use 'V2X' to mean _one_ of 'V2V' or 'V2P' (like in classical computing: 'X' is a variable and could have a single value which could be 'V' or 'P', but not the two at the same time like in quantum computing).  And 'Everything' means everything at the same time, like  when sending a datagram to everyone else in multicast mode.

At this point, I strongly believe that whenever we hear 'LTE-V2X' it is a colloquial term common in conversation.  It is not a formally defined term. It is a little bit like the term 'core network'.

The advantage of such term defined in a colloquial manner is that it can mean whatever the speaker wants it to mean.

If I designate 'LTE-V2X' to mean CAM-as-XER-over-UDP-over-IP from a car to another car, now I dont think I am incorrect.  Unless, of course, some people oppose it, or prefer a more refined definition to cover also, e.g., BSM or DENM or SPAT; and maybe not just XER but also JSON. 

And so on.

This does not mean 'LTE-V2X' does not exist: there are multiple demonstrated prototypes that send CAMs over LTE, but just the term definition does not exist.

> be called (unofficially) as V2N2V, V2N2I, V2N2P. Related definition 

> can be found in TS22.185 "Such 3GPP transport includes the transport 

> between UEs directly and/or, due to the limited direct communication 

> range, the transport between UEs via infrastructure supporting V2X 

> communication, e.g., RSU, application server, etc."

And you may understand each other correctly.  But it is not formally defined.  In particular, I dont understand you :-)

Alex

> 发件人：Alexandre Petrescu < <mailto:[email-masked]> [email-masked]>

> 收件人：Jérôme Härri < <mailto:[email-masked]> [email-masked]>, "'Sri Gundavelli 

> (sgundave)'" < <mailto:sgundave=[email-masked]> sgundave=[email-masked]>

> 抄送人： <mailto:[email-masked]> [email-masked]

> [...]> So, summarizing, LTE-V2X means (by shortcutting the 3GPP rel.14 

> in  > front) the V2X functions, but if we want to be absolutely clear 

> (and  > usually we need J), just saying: we use LTE-V2X is indeed not  

> If one has a 3GPP document that defines the term 'LTE-V2X' then I 

> would be grateful.

>  > @Alex: now for your statement, it is a bit confusing…you should  > 

> differentiate the communication type: CAM being sent over UDP / IP to 

> an  > IoT platform would then be a **LTE-V2X Uu sent on the 3.4GHz 

> frequency  > band** (as I do not think it is allowed to transmit V2X 

> messages over  > the Uu interface at 5.9Ghz). And CAM being sent over 

> UDP/IP to another  > car is the **LTE-V2X PC5 sent over the 5.9Ghz**. 

> As you can see, both  > means fully different things… I agree with the 

> clarification.

> right distinction. But you could also have a car that sends a CAM/IP 

> up an Uu and down another Uu to reach a car: V-Uu-Uu-V. No?

>  > And as I am sure you will mention this…yes, you can transmit CAM 

> over  > IPv6 in both PC5 or Uu J…at least from 3GPP perspective…, but 

> I am sure  > that either IEEE WAVE or ETSI ITS might but the same 

> restrictions at  > ITS-G5 J  >  > BR,  >  > Jérôme  >  > *From:*its 

> [ <mailto:[email-masked]> mailto:[email-masked]] *On Behalf Of *Sri Gundavelli  > 

> (sgundave)  > *Sent:* Monday 25 June 2018 15:25  > *To:* Alexandre 

> Petrescu  > *Cc:*  <mailto:[email-masked]> [email-masked]  > *Subject:* Re: [ipwave] Argument 

> about 'LTE-V2X' term  >  >  I would read this term as, V2X 

> communication based on 3GPP LTE  > infrastructure. Its not only about 

> CAM messages, but any safety related  > V2V/V2I/V2P communications 

> over LTE infra, as opposed to DSRC.

>  > On Jun 25, 2018, at 4:33 AM, Alexandre Petrescu  > 

> < <mailto:[email-masked]%20%3cmailto:[email-masked]> [email-masked] <mailto:[email-masked]>>

>  >  <mailto:[email-masked]> [email-masked] < <mailto:[email-masked]> mailto:[email-masked]>

>  >  <https://www.ietf.org/mailman/listinfo/its> https://www.ietf.org/mailman/listinfo/its

>  <mailto:[email-masked]> [email-masked]

>  <https://www.ietf.org/mailman/listinfo/its> https://www.ietf.org/mailman/listinfo/its