Subject: Re: [ipwave] 802.11 Data vs 802.11 QoS Data in IPv6-over-802.11-OCB-implementations

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 3 Jul 2018 15:35:54 +0200

Hi William,

Today we performed a visit in a nearby area to test other things.

QoSData-vs-Data on road N118 Bièvre to Les Ulis was not the goal of 
testing, but since we were there we listened to the recently deployed 
RSUs out of curiosity.

We received CAMs with 802.11 QoS Data headers (not Data).

The ones deployed in City of Versailles send 802.11 Data headers (not 
QoS Data).

It may be that the manufacturers are different.

Alex

Le 17/05/2018 à 11:08, Alexandre Petrescu a écrit :
> Hi William,
> 
> Recently I performed a visit in the city of Vesailles in France, Europe; 
> there are deployed about 5 Road-Side Units for experimentations, since a 
> few years now.
> 
> Some of them send CAMs and SPATs.  The ones I could test use "Data", not 
> "QoS Data".
> 
> The packet dump is available upon request.
> 
> Here is a wireshark image showing the Data field:
> 
> 
> Le 02/03/2018 à 18:02, William Whyte a écrit :
>> US implementations use QoSData with everything -- although it's not 
>> required by 802.11-OCB, as we discussed earlier, it *is* required for 
>> a "WAVE device", which all US devices are.
>>
>> Here's a Wireshark image from a contact showing the QoSData field:
>>
>> Inline image 1
>>
>> Cheers,
>>
>> William
>>
>> On Fri, Mar 2, 2018 at 11:28 AM, Alexandre Petrescu 
>> <[email-masked] <mailto:[email-masked]>> 
>> wrote:
>>
>>
>>
>>     Le 02/03/2018 à 17:16, William Whyte a écrit :
>>
>>         I've confirmed that the US implementations use QoSData, just
>>         to close that loop.
>>
>>
>>     Thanks.  It's QoSData with IP, right?
>>
>>     Alex
>>
>>
>>         Cheers,
>>
>>         William
>>
>>
>>         On Thu, Mar 1, 2018 at 11:05 AM, Alexandre Petrescu
>>         <[email-masked]
>>         <mailto:[email-masked]>
>>         <mailto:[email-masked]
>>         <mailto:[email-masked]>>> wrote:
>>
>>             William,
>>
>>             Le 01/03/2018 à 16:59, William Whyte a écrit :
>>
>>                   > I propose we rename 'OCB' into 'IP-OCB' in the draft.
>>
>>                   > 'IP-OCB' is an OCB mode that can be transport IP
>>         packets
>>                 with .11 Data
>>
>>                   > headers or with .11 QoS Data headers.
>>
>>                 If it’s over OCB, then it needs to use QoSData. If
>>         you’re doing
>>                 Data, you’re not conformant to OCB. There can’t be an
>>         OCB mode
>>                 that transports packets with .11 Data, because OCB by
>>         definition
>>                 uses QoSData. If the draft implies that you can do
>>                 non-conformant OCB, that’s a serious defect in the draft.
>>
>>                 Some implementations may not yet have implemented
>>         this, but
>>                 that’s on those developers.
>>
>>
>>             For one second, allow me the benefit of the doubt about
>>             specifications that may not be implemented.
>>
>>             I would like to know whether there is an implementation of
>>         IP over
>>             OCB with QoSData headers?  Packet dump is sufficient, or
>>         any other
>>             kind of statement.
>>
>>             I agree with you that many times it is good to write
>>         specification
>>             first and implementation after.
>>
>>             Alex
>>
>>
>>                 Cheers,
>>
>>                 William
>>
>>                 Sent from Mail
>>         <https://go.microsoft.com/fwlink/?LinkId=550986
>>         <https://go.microsoft.com/fwlink/?LinkId=550986>
>>                 <https://go.microsoft.com/fwlink/?LinkId=550986
>>         <https://go.microsoft.com/fwlink/?LinkId=550986>>> for Windows 10
>>
>>                 *From: *Alexandre Petrescu
>>         <mailto:[email-masked]
>>         <mailto:[email-masked]>
>>                 <mailto:[email-masked]
>>         <mailto:[email-masked]>>>
>>                 *Sent: *Thursday, March 1, 2018 10:54 AM
>>                 *To: *William Whyte <mailto:[email-masked]
>>         <mailto:[email-masked]>
>>                 <mailto:[email-masked]
>>         <mailto:[email-masked]>>>; [email-masked]
>>         <mailto:[email-masked]>
>>                 <mailto:[email-masked] <mailto:[email-masked]>>
>>         <mailto:[email-masked] <mailto:[email-masked]>
>>         <mailto:[email-masked] <mailto:[email-masked]>>>
>>                 *Subject: *Re: [ipwave] 802.11 Data vs 802.11 QoS Data in
>>                 IPv6-over-802.11-OCB-implementations
>>
>>
>>                 Le 01/03/2018 à 16:50, William Whyte a écrit :
>>
>>                   >  >> (there are some packet dumps with IP packets
>>         transported
>>                 with .11 Data
>>
>>                   >
>>
>>                   > headers in OCB mode at 5.9GHz, e.g. attached).
>>
>>                   >
>>
>>                   > My understanding is OCB mode requires QoSData, so
>>         those
>>                 packets aren’t
>>
>>                   > conformant to the standard.
>>
>>                 I propose we rename 'OCB' into 'IP-OCB' in the draft.
>>
>>                 'IP-OCB' is an OCB mode that can be transport IP
>>         packets with
>>                 .11 Data
>>
>>                 headers or with .11 QoS Data headers.
>>
>>                 Alex
>>
>>                   >
>>
>>                   > Cheers,
>>
>>                   >
>>
>>                   > William
>>
>>                   >
>>
>>                   > Sent from Mail
>>                 <https://go.microsoft.com/fwlink/?LinkId=550986
>>         <https://go.microsoft.com/fwlink/?LinkId=550986>
>>                 <https://go.microsoft.com/fwlink/?LinkId=550986
>>         <https://go.microsoft.com/fwlink/?LinkId=550986>>> for
>>
>>                   > Windows 10
>>
>>                   >
>>
>>                   > *From: *Alexandre Petrescu
>>                 <mailto:[email-masked]
>>         <mailto:[email-masked]>
>>                 <mailto:[email-masked]
>>         <mailto:[email-masked]>>>
>>
>>                   > *Sent: *Thursday, March 1, 2018 10:48 AM
>>
>>                   > *To: [email-masked] <mailto:[email-masked]>
>>         <mailto:[email-masked] <mailto:[email-masked]>>
>>                 <mailto:[email-masked] <mailto:[email-masked]>
>>         <mailto:[email-masked] <mailto:[email-masked]>>>
>>
>>                   > *Subject: *Re: [ipwave] 802.11 Data vs 802.11 QoS
>>         Data in
>>
>>                   > IPv6-over-802.11-OCB -implementations
>>
>>                   >
>>
>>                   > In a private discussion, this question came up:
>>
>>                   >
>>
>>                   > Is there a packet dump showing an IP packet
>>         transported with
>>                 .11 QoSData
>>
>>                   >
>>
>>                   > headers in OCB mode at 5.9GHz.
>>
>>                   >
>>
>>                   > (there are some packet dumps with IP packets
>>         transported
>>                 with .11 Data
>>
>>                   >
>>
>>                   > headers in OCB mode at 5.9GHz, e.g. attached).
>>
>>                   >
>>
>>                   > Alex
>>
>>                   >
>>
>>                   > Le 01/03/2018 à 15:32, Alexandre Petrescu a écrit :
>>
>>                   >
>>
>>                   >  > I received some feedback from programmer.
>>
>>                   >
>>
>>                   >  >
>>
>>                   >
>>
>>                   >  > Le 28/02/2018 à 23:48, Abdussalam Baryun a écrit :
>>
>>                   >
>>
>>                   >  > [...]
>>
>>                   >
>>
>>                   >  >> ieee802.11ocb protocol is already
>>         implemented/tested and
>>                 it is
>>
>>                   >
>>
>>                   >  >> interoperable, but what is the problem, sorry
>>         maybe I
>>                 did not follow
>>
>>                   >
>>
>>                   >  >> the discussion well,
>>
>>                   >
>>
>>                   >  >
>>
>>                   >
>>
>>                   >  > Here is the QoS problem for IP over 802.11 OCB in
>>                 implementations.
>>
>>                   >
>>
>>                   >  >
>>
>>                   >
>>
>>                   >  > In short, in open source on linux, we dont know
>>         how to
>>                 send IP packets
>>
>>                   >
>>
>>                   >  > transported as 802.11 QoSData, all IP packets are
>>                 transported as 802.11
>>
>>                   >
>>
>>                   >  > Data instead.
>>
>>                   >
>>
>>                   >  >
>>
>>                   >
>>
>>                   >  > - if you ping -Q at 5.9GHz in OCB mode, the
>>         DSCP fields
>>                 do get
>>
>>                   >
>>
>>                   >  >    set properly in IP headers of Echorequest,
>>         but there
>>                 is no .11 QoSData
>>
>>                   >
>>
>>                   >  >    headers in packets.  Normally, one expects
>>         the QoSData
>>                 headers to be
>>
>>                   >
>>
>>                   >  >    present there when the DSCP (an IP field) is
>>         set.
>>
>>                   >
>>
>>                   >  >
>>
>>                   >
>>
>>                   >  > - if you want to modify kernel, and force
>>         always to use
>>                 QoSData headers
>>
>>                   >
>>
>>                   >  >    on WiFi, including OCB at 5.9GHz, there is a
>>                 net/mac80211/tx.c file
>>
>>                   >
>>
>>                   >  >    with a flag called wme_sta that you could set to
>>                 true.  But take care
>>
>>                   >
>>
>>                   >  >    that the C comments there say that it's not
>>         normal to
>>                 use QoSData
>>
>>                   >
>>
>>                   >  >    headers in OCB mode, because a terminal sending
>>                 QoSData has no
>>
>>                   >
>>
>>                   >  >    guarantee that receivers also use QoSData (the
>>                 negotiation of QoS
>>
>>                   >
>>
>>                   >  >    capabilities are absent in OCB).
>>
>>                   >
>>
>>                   >  >
>>
>>                   >
>>
>>                   >  > As you can see, this can be long to try and fix.
>>
>>                   >
>>
>>                   >  >
>>
>>                   >
>>
>>                   >  > Until then I will propose to set QoS aside from
>>                 IP-over-OCB at this time.
>>
>>                   >
>>
>>                   >  >
>>
>>                   >
>>
>>                   >  > Alex
>>
>>                   >
>>
>>                   >  >
>>
>>                   >
>>
>>                   >  > _______________________________________________
>>
>>                   >
>>
>>                   >  > its mailing list
>>
>>                   >
>>
>>                   >  > [email-masked] <mailto:[email-masked]>
>>         <mailto:[email-masked] <mailto:[email-masked]>>
>>
>>                   >
>>
>>                   >  > https://www.ietf.org/mailman/listinfo/its
>>         <https://www.ietf.org/mailman/listinfo/its>
>>                 <https://www.ietf.org/mailman/listinfo/its
>>         <https://www.ietf.org/mailman/listinfo/its>>
>>
>>                   >
>>
>>
>>
>>
>>         -- 
>>
>>
>>         PLEASE UPDATE YOUR ADDRESS BOOKS WITH MY NEW ADDRESS:
>>         [email-masked] <mailto:[email-masked]>
>>         <mailto:[email-masked]
>>         <mailto:[email-masked]>>
>>
>>
>>
>>
>> -- 
>>
>>
>> PLEASE UPDATE YOUR ADDRESS BOOKS WITH MY NEW ADDRESS: 
>> [email-masked] <mailto:[email-masked]>
> 
> 
> 
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 6 Jul 2018 17:44:45 +0200

Hi,

I am still divided about whether QoS Data headers or Data headers are 
best appropriate for IPv6-over-OCB.

Further listening in the 5.9GHz bands while driving car on public road 
reveals a particular RSU [*] sending CAMs and IPv6 RAs (no WSA) with 
802.11 QoS Data headers and 802.11 Data headers respectively (no 
geonet).  Packet dumps available upon request.

I am not affiliated to these RSUs in any way.

Alex

[*]: road N118 at position WGS84 48.7281016 N 2.1652933 E

Le 03/07/2018 à 15:35, Alexandre Petrescu a écrit :
>> Recently I performed a visit in the city of Vesailles in France, 
>> Europe; there are deployed about 5 Road-Side Units for 
>> experimentations, since a few years now.
>>
>> Some of them send CAMs and SPATs.  The ones I could test use "Data", 
>> not "QoS Data".
>>
>>> Windows 10

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 13 Jul 2018 10:32:55 +0200

>
>
> On Fri, Jul 6, 2018 at 5:44 PM, Alexandre Petrescu <
[email-masked]> wrote:

> Hi,
>
> I am still divided about whether QoS Data headers or Data headers are best
> appropriate for IPv6-over-OCB.
>

it just depends on the application used, so both can be used per car.

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 13 Jul 2018 14:36:06 +0200

Le 13/07/2018 à 10:32, Abdussalam Baryun a écrit :
> 
> On Fri, Jul 6, 2018 at 5:44 PM, Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Hi,
> 
>     I am still divided about whether QoS Data headers or Data headers
>     are best appropriate for IPv6-over-OCB.
> 
> 

I will not make a fuss about this, and please excuse me if I am too  blunt.

Currently the draft says only "QoS Data" is a MUST, not "both".

For my part, I am very much divided about this, because I have hands on 
experience with several production Road-Side Units on roads (highway and 
city area) that use "Data" instead.  Worse, some use IPv6 as "Data" in 
addition to useing CAM as "Data".

I dont want these RSUs, especially the ones that send IPv6, to become 
non-standard all of a sudden.

Alex

---

From: Tony Li <[email-masked]>
Date: Fri, 13 Jul 2018 08:59:38 -0700

> On Jul 13, 2018, at 5:36 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> I dont want these RSUs, especially the ones that send IPv6, to become non-standard all of a sudden.

How do you accommodate that when there are multiple existing implementations that have chosen different directions?

The point of making standards is to make an agreement about how to proceed. That requires making decisions. Sometimes it means making hard decisions.

We need one and only one way of transmitting v6.

Tony

---

From: Alexandre Petrescu <[email-masked]>
Date: Sun, 15 Jul 2018 16:14:39 +0200

Le 13/07/2018 à 17:59, Tony Li a écrit :
> 
> 
>> On Jul 13, 2018, at 5:36 AM, Alexandre Petrescu 
>> <mailto:[email-masked]>> wrote:
>> 
> How do you accommodate that when there are multiple existing 
> implementations that have chosen different directions?

If you ask me, then I would go check which implementation choosing the
direction of IPv6 with "QoS Data" headers.  But I dont know of any,
despite active research.

I already checked and found many implementations that use IPv6 with
"Data" headers.  They work ok.

I am worried that we go a wrong direction with the "QoS Data".

In return, as a side point, I would ask whether or not a car with IPv6
with "Data" headers talks to an RSU which implements IPv6 "QoS Data"
headers?  The answer to this would be a good information point in deciding.

The only thing that we know is that, theoretically, if at least one car
in a set of cars is _not_ using "QoS Data" then the QoS guarantees are
not ensured.  But that's in theory.

> The point of making standards is to make an agreement about how to 
> proceed. That requires making decisions. Sometimes it means making
> hard decisions.

> We need one and only one way of transmitting v6.

I agree.

Alex

---

From: [email-masked]
Date: Sun, 15 Jul 2018 09:03:59 -0700

> On Jul 15, 2018, at 7:14 AM, Alexandre Petrescu <[email-masked]> wrote:
> 

Some device drivers may choose to parse both.  Some may choose to parse only one.

I don’t see how this helps in deciding.

Tony