Subject: [ipwave] Unmanned Air System (UAS) applications in ipwave

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 9 Jan 2019 15:29:40 +0000

Hello,

Under FAA program DTFAWA-15-D-00030 and NASA program NNA16BD84C, we
have developed communications architectures for both manned and unmanned
aviation. Unmanned Air Systems (UAS) in particular present an interesting challenge,
as there will be vast numbers operating in worldwide controlled and uncontrolled
air spaces in the coming years. With the advent of applications such as air taxis and
personal air vehicles, UAS will soon “share the road” with the legacy terrestrial
vehicle deployment. As such, technologies such as 4G/5G, C-V2X and DSRC will
be used by these systems in the same fashion as has been discussed in ipwave.

Under the FAA and NASA programs, two IETF works have been developed and
tailored to the mobile networking use case. ‘draft-ietf-rtgwg-atn-bgp’ provides
a scalable routing system based on BGP for tracking IPv6 prefixes associated with
mobile nodes such as terrestrial and air vehicles. ‘draft-templin-intarea-6706bis’
presents the AERO mobile routing service for localized mobility and route
optimization at the vehicular level. Together, these technologies provide a
comprehensive solution for both aeronautical and terrestrial mobile networking.

https://datatracker.ietf.org/doc/draft-ietf-rtgwg-atn-bgp/
https://datatracker.ietf.org/doc/draft-templin-intarea-6706bis/

We would like to explore synergies with the work in progress in ipwave. We
believe the coming UAS applications will need to function in harmony with
terrestrial vehicles, so we perceive a fit with this working group’s activities.
In addition to the two IETF drafts, see below for a list of papers which have
been published in various IEEE forums. Please post comments to the list.

Thanks – Fred

Integrated Communications, Navigation and Surveillance (ICNS) 2017:
*****************************************************
“Considerations for an integrated UAS CNS architecture”
“Requirements for an integrated UAS CNS architecture”
https://ieeexplore.ieee.org/xpl/mostRecentIssue.jsp?filter=issueId EQ "8011878"&refinements=Author:Fred L. Templin&pageNumber=1&resultAction=REFINE

IEEE Aerospace 2018:
****************
“Reliable and secure surveillance, communications and navigation (RSCAN) for Unmanned Air Systems (UAS)
in controlled airspace”
https://ieeexplore.ieee.org/xpl/mostRecentIssue.jsp?filter=issueId EQ "8396361"&refinements=Author:Denise S. Ponchak&pageNumber=1&resultAction=REFINE

Integrated Communications, Navigation and Surveillance (ICNS) 2018:
*****************************************************
“UAS CNS architectures for uncontrolled airspace”
https://ieeexplore.ieee.org/xpl/mostRecentIssue.jsp?filter=issueId EQ "8384823"&refinements=Author:Denise Ponchak&pageNumber=1&resultAction=REFINE

Digital Avionics Systems Conference (DASC) 2018:
*************************************
“An Implementation Analysis of Communications, Navigation, and Surveillance (CNS)
Technologies for Unmanned Air Systems (UAS)”
https://ieeexplore.ieee.org/xpl/mostRecentIssue.jsp?filter=issueId EQ "8569218"&refinements=Author:Denise S. Ponchak&pageNumber=1&resultAction=REFINE

IEEE Aerospace 2019:
****************
" Advancing the Standards for Unmanned Air System Communications, Navigation and Surveillance"
To be presented 3/3/2019

---

From: Nalini J Elkins <[email-masked]>
Date: Wed, 9 Jan 2019 15:47:56 +0000 (UTC)

Fred,

> With the advent of applications such as air taxis and personal air vehicles, UAS will soon “share the road” with the legacy terrestrial vehicle deployment. 

This is a very interesting area.  I wanted to share information about two AirTaxi implementations.

In India, there is active work on AirTaxi at IIT Kanpur.  You may be interested in the following article: "IIT-Kanpur, VTOL Aviation Sign $2.2 Mn MoU To Develop Flying Taxi Prototype"

https://inc42.com/buzz/iit-kanpur-vtol-aviation-sign-mou-to-develop-flying-taxi-prototype/

For any of you who know the incredible traffic problems in India, any solution would be a blessing!

In the Monterey Bay area in California (my local community), there is a startup working on AirTaxi.  You may be interested in the article: An ambitious flying taxi startup is setting up shop at the Marina Municipal Airport"

http://www.montereycountyweekly.com/news/local_news/an-ambitious-flying-taxi-startup-is-setting-up-shop-at/article_9f1a6616-abe8-11e8-b572-db5fa095cca5.html

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

________________________________
From: "Templin (US), Fred L" <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Wednesday, January 9, 2019 7:29 AM
Subject: [ipwave] Unmanned Air System (UAS) applications in ipwave

Hello,

Thanks – Fred

IEEE Aerospace 2018:

****************

in controlled airspace”

IEEE Aerospace 2019:

****************

To be presented 3/3/2019

_______________________________________________

its mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/its

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 9 Jan 2019 16:09:06 +0000

Hi Nalini,

These are great examples. They reminded me that NASA is starting a program
called "Urban Air Mobility" (https://www.nasa.gov/uamgc) that will get started
this year and extend into the early 2020s. I recommend folks take a look at some
of the artists pictures there and the program FAQ. They show that air and ground
vehicles will operate in the same RF airspace and therefore will need to actively
coordinate with one another using compatible OCB comms gear.

Thanks - Fred

> -----Original Message-----
> From: Nalini J Elkins [mailto:[email-masked]]
> Sent: Wednesday, January 09, 2019 7:48 AM
> To: Templin (US), Fred L <[email-masked]>; [email-masked]
> Subject: Re: [ipwave] Unmanned Air System (UAS) applications in ipwave
> 
> Fred,
> 
> 
> In India, there is active work on AirTaxi at IIT Kanpur.  You may be interested in the following article: "IIT-Kanpur, VTOL Aviation Sign
> $2.2 Mn MoU To Develop Flying Taxi Prototype"
> 
> In the Monterey Bay area in California (my local community), there is a startup working on AirTaxi.  You may be interested in the
> article: An ambitious flying taxi startup is setting up shop at the Marina Municipal Airport"
>

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 9 Jan 2019 17:20:11 +0000

Even more near-term are programs like Uber Elevate and Amazon Prime Air:

https://www.uber.com/us/en/elevate/
https://www.amazon.com/Amazon-Prime-Air/b?ie=UTF8&node=8037720011

Fred

> From: its [mailto:[email-masked]] On Behalf Of Templin (US), Fred L
> Sent: Wednesday, January 09, 2019 8:09 AM
> To: Nalini J Elkins <[email-masked]>; [email-masked]
> > http://www.montereycountyweekly.com/news/local_news/an-ambitious-flying-taxi-startup-is-setting-up-shop-
> at/article_9f1a6616-
> > abe8-11e8-b572-db5fa095cca5.html
> >
> >
> > Thanks,
> >
> > Nalini Elkins
> > CEO and Founder
> > Inside Products, Inc.
> > www.insidethestack.com
> > (831) 659-8360
> >
> >
> >

---

From: Nalini J Elkins <[email-masked]>
Date: Wed, 9 Jan 2019 17:47:06 +0000 (UTC)

Fred,
It would be very interesting to see if everyone is creating their own protocols or if any standards are being used.
I assume there is no concern about interoperability.  But, I would think at least in terms of communicating with some type of controlling entity, one might wish there to be standardization. Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

      From: "Templin (US), Fred L" <[email-masked]>
 To: Nalini J Elkins <[email-masked]>; "[email-masked]" <[email-masked]> 
 Sent: Wednesday, January 9, 2019 9:20 AM
 Subject: Re: [ipwave] Unmanned Air System (UAS) applications in ipwave

Fred

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 9 Jan 2019 18:20:39 +0000

Hi Nalini,

I don’t know why we haven’t seen these groups coming to the IETF yet.
I think they are thinking 5G in terms of their infrastructure-mode connectivity,
but I do not think they have been thinking about IPv6, OCB operations or even
Internetworking in general as of yet. That needs to change.

Thanks - Fred

From: Nalini J Elkins [mailto:[email-masked]]
Sent: Wednesday, January 09, 2019 9:47 AM
To: Templin (US), Fred L <[email-masked]>; [email-masked]
Subject: Re: [ipwave] Unmanned Air System (UAS) applications in ipwave

Fred,

I assume there is no concern about interoperability.  But, I would think at least in terms of communicating with some type of controlling entity, one might wish there to be standardization.

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com<http://www.insidethestack.com>
(831) 659-8360

________________________________
From: "Templin (US), Fred L" <[email-masked]<mailto:[email-masked]>>
To: Nalini J Elkins <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, January 9, 2019 9:20 AM
Subject: Re: [ipwave] Unmanned Air System (UAS) applications in ipwave

Fred

> From: its [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Templin (US), Fred L
> To: Nalini J Elkins <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> > From: Nalini J Elkins [mailto:[email-masked]<mailto:[email-masked]>]
> > To: Templin (US), Fred L <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> > www.insidethestack.com<http://www.insidethestack.com>
> > (831) 659-8360
> >
> >
> >
> > From: "Templin (US), Fred L" <[email-masked]<mailto:[email-masked]>>
> > To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
> > [email-masked]<mailto:[email-masked]>
> >
> [email-masked]<mailto:[email-masked]>

_______________________________________________
its mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/its

---

From: Nalini J Elkins <[email-masked]>
Date: Wed, 9 Jan 2019 18:32:46 +0000 (UTC)

Fred,
> That needs to change.
I completely agree.  I am reaching out to IIT Kanpur who has an AirTaxi program.  
The startup in my area is operating in stealth mode so unlikely that I will get any traction there.
 I wonder if people are interested in having an informal discussion on this topic in Prague? Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

      From: "Templin (US), Fred L" <[email-masked]>
 To: Nalini J Elkins <[email-masked]>; "[email-masked]" <[email-masked]> 
 Sent: Wednesday, January 9, 2019 10:20 AM
 Subject: RE: [ipwave] Unmanned Air System (UAS) applications in ipwave
   
#yiv5556230441 #yiv5556230441 -- _filtered #yiv5556230441 {font-family:Helvetica;panose-1:2 11 6 4 2 2 2 2 2 4;} _filtered #yiv5556230441 {panose-1:2 4 5 3 5 4 6 3 2 4;} _filtered #yiv5556230441 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;}#yiv5556230441 #yiv5556230441 p.yiv5556230441MsoNormal, #yiv5556230441 li.yiv5556230441MsoNormal, #yiv5556230441 div.yiv5556230441MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:12.0pt;font-family:New serif;}#yiv5556230441 a:link, #yiv5556230441 span.yiv5556230441MsoHyperlink {color:blue;text-decoration:underline;}#yiv5556230441 a:visited, #yiv5556230441 span.yiv5556230441MsoHyperlinkFollowed {color:purple;text-decoration:underline;}#yiv5556230441 span.yiv5556230441EmailStyle17 {font-family:sans-serif;color:#1F497D;}#yiv5556230441 .yiv5556230441MsoChpDefault {font-size:10.0pt;} _filtered #yiv5556230441 {margin:1.0in 1.0in 1.0in 1.0in;}#yiv5556230441 div.yiv5556230441WordSection1 {}#yiv5556230441 Hi Nalini,    I don’t know why we haven’t seen these groups coming to the IETF yet. I think they are thinking 5G in terms of their infrastructure-mode connectivity, but I do not think they have been thinking about IPv6, OCB operations or even Internetworking in general as of yet. That needs to change.    Thanks - Fred    From: Nalini J Elkins [mailto:[email-masked]]
Sent: Wednesday, January 09, 2019 9:47 AM
To: Templin (US), Fred L <[email-masked]>; [email-masked]
Subject: Re: [ipwave] Unmanned Air System (UAS) applications in ipwave    Fred,    It would be very interesting to see if everyone is creating their own protocols or if any standards are being used.    I assume there is no concern about interoperability.  But, I would think at least in terms of communicating with some type of controlling entity, one might wish there to be standardization.   Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360    From: "Templin (US), Fred L" <[email-masked]>
To: Nalini J Elkins <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Wednesday, January 9, 2019 9:20 AM
Subject: Re: [ipwave] Unmanned Air System (UAS) applications in ipwave    Even more near-term are programs like Uber Elevate and Amazon Prime Air:

Fred

> To: Nalini J Elkins <[email-masked]>;[email-masked]
> > To: Templin (US), Fred L <[email-masked]>;[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Wed, 09 Jan 2019 14:07:54 -0500

Nalini J Elkins <[email-masked]> wrote:
    > It would be very interesting to see if everyone is creating their own
    > protocols or if any standards are being used.

I think that each will have to have standard aviation transponders to
deal with the "is-that-a-drone-I-see" problem we've seen at Gatwick
and Heathrow.  (Not new technology really)

    > I assume there is no concern about interoperability. But, I would think
    > at least in terms of communicating with some type of controlling
    > entity, one might wish there to be standardization.  Thanks,

The first wave will be vertically integrated as you hypothesis, and standards
won't matter, except when there are convenient off-the-shelf-systems that can
be integrated.  A standardization process of communication would probably
evolve if market forces split operators and vendors into different
companies.

Another force might well be LEA requirements.
A third situation would be whether or not the devices need to interoperate
with land-based ITS.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 9 Jan 2019 19:20:44 +0000

Hi Michael,

> From: its [mailto:[email-masked]] On Behalf Of Michael Richardson
> Sent: Wednesday, January 09, 2019 11:08 AM
> To: Nalini J Elkins <[email-masked]>
> Cc: Templin (US), Fred L <[email-masked]>; [email-masked]

In aviation use cases, that would be Automatic Dependent Surveillance
Broadcast (ADS-B), but it is notoriously insecure and the radio channels
are already over-subscribed. That is why our NASA program developed
"ADS/IP", which is transponder data over IP data links. This is discussed
in our documents.

Thanks - Fred

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 9 Jan 2019 19:25:26 +0000

Hi Michael,

> A third situation would be whether or not the devices need to interoperate

Yes, that is why we are proposing the UAS employ DSRC, C-V2X, etc.
the same as if they were a terrestrial vehicle.

Thanks - Fred

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 9 Jan 2019 20:37:42 +0000

Hi Nalini,

It would be good to hear from them, yes.

From: Nalini J Elkins [mailto:[email-masked]]
Sent: Wednesday, January 09, 2019 10:33 AM
To: Templin (US), Fred L <[email-masked]>; [email-masked]
Subject: Re: [ipwave] Unmanned Air System (UAS) applications in ipwave

Fred,

 I wonder if people are interested in having an informal discussion on this topic in Prague?

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

Hi Nalini,

Thanks - Fred

Fred,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com<http://www.insidethestack.com/>
(831) 659-8360

Fred

> > www.insidethestack.com<http://www.insidethestack.com/>
> > (831) 659-8360
> >
> >
> >

---

From: Alexandre Petrescu <[email-masked]>
Date: Sat, 12 Jan 2019 00:20:20 +0100

Le 09/01/2019 à 16:29, Templin (US), Fred L a écrit :
> air spaces in the coming years. With the advent of applications such as air taxis

I wanted to ask whether these air taxies see any necessity in platooning.

Trucks on road do see such necessity, in that they may save fuel and 
driver time.

Grounded automated taxis may see need in platooning in that the 
re-balancing of taxis from station to station may be helped when platooning.

For both of these (trucks and grounded taxis) there are alternatives 
proposed against platooning: truck carrying by another track, and 
independent (non platoon) rebalancing.

But for air taxis, I have no idea whether or not they consider 
platooning of air taxis.

Alex

  and

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 12 Jan 2019 11:28:16 +0200

Hi Fred,

UAS application is not included in ITS, it is different system or different
with purposes, please note that the ITS is not a general purpose system, it
is better that it is a special purpose that can be extended in future as
the internet system done. We need to focus on the Car Land communication
system only while integrated with internet systems.

UAS is mostly ad hoc systems, that is done in IETF MANET WG,

AB

On Wed, Jan 9, 2019 at 5:29 PM Templin (US), Fred L <
[email-masked]> wrote:

> https://ieeexplore.ieee.org/xpl/mostRecentIssue.jsp?filter=issueId EQ
> "8011878"&refinements=Author:Fred L.
> Templin&pageNumber=1&resultAction=REFINE
>
> IEEE Aerospace 2018:
> ****************
> https://ieeexplore.ieee.org/xpl/mostRecentIssue.jsp?filter=issueId EQ
> "8396361"&refinements=Author:Denise S.
> Ponchak&pageNumber=1&resultAction=REFINE
>
> https://ieeexplore.ieee.org/xpl/mostRecentIssue.jsp?filter=issueId EQ
> "8384823"&refinements=Author:Denise Ponchak&pageNumber=1&resultAction=REFINE
>
> https://ieeexplore.ieee.org/xpl/mostRecentIssue.jsp?filter=issueId EQ
> "8569218"&refinements=Author:Denise S.
> Ponchak&pageNumber=1&resultAction=REFINE
>
> IEEE Aerospace 2019:
> ****************

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 12 Jan 2019 11:50:26 +0200

> Internetworking in general as of yet. That needs to change.

Yes you are right we all are thinking of the efficient 5G system which is
the best on the table in market for wireless coverage, each government
needs to secure their city with a secure Land communication system the ITS
is integrated with 5G and also 5G is perfectly integrated with Internet
systems. The UAS is not a secure system if integrated, it is mostly an
emergency or military system if 5G shutdown.

AB

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 14 Jan 2019 15:45:08 +0000

The concept of flying cars platooning has been around for many decades
really. Watch an episode of The Jetsons.

Fred

> From: its [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
> Sent: Friday, January 11, 2019 3:20 PM
> To: [email-masked]