Subject: [ipwave] about ETSI group about IPv6 and V2X

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 29 Mar 2019 22:48:26 +0100

We had a discussion about an ETSI group doing IPv6 and V2X.

I wrongly called it a 'new group'.

The details are:

It is within ETSI IP6 ISG.  ISG stands for 'Industry Specification 
Group'.  IP6 is short for IPv6 I believe; I also saw it expanded as 
"IPv6 Best Practices", probably unrelated to the BCP IETF term.

At ETSI, a group is also called a Committee.

Within this group, there was a recent WI proposal (Work Item) that has 
been adopted in earlier this year.

That WI has a tight schedule with many intermediate steps and a 'TB 
Approval' December 2019.  I dont know what means 'TB'.

The document ETSI name is 'ETSI GR IP6 0030 V1.0.0'.  'GR' stands for 
'Group Report'.  I believe it means there are several authors (a group 
of authors).  I dont think it represents a report of the whole group of 
people members of IP6.

The current title is 'IPv6-Based Vehicular Networking (V2X)
Deployment of IPv6-Based Vehicular Networking (V2X)'

I was invited to contribute to it.  The ToC is already made, and I was 
thinking to propose the following topics.

I am not sure I should describe IPv6-over-OCB into it, unless, of 
course, it gets more approval at IETF.

In the following, "we" means me and one or two colleague programmer(s).

"We are also interested to add a text about V2V communications with 
IPv6.  This includes IPv6 RIO (Route Information Option) announcements, 
prefix propagation, addressing architecture for V2V and potentially more.

We are also interested in describing the use of CAM over UDP over IPv6.  
Traditionnally CAMs are sent over BTP and over GeoNetworking but these 
are incompatible with the Internet, so we propose UDP and IPv6.  
Implemented at a few sites.

We are also interested in describing CAM messages sent over LTE (with IPv6).

We are interested in proposing the new term 'LTE-V2X'.  Remark the dash 
'-' instead of undesxoew '_'.  To the best of my knowledge, the 3GPP SDO 
only talks about 'LTE_V2X' and not about 'LTE-V2X'.  The term 'LTE-V2X' 
would designate sending ETSI CAM messages over IPv6 links of LTE (not 
IPv4)."

I hope this clarifies the ETSI discussion during today IPWAVE WG.

Alex

---

From: Jerome Haerri <[email-masked]>
Date: Sat, 30 Mar 2019 11:42:41 +0100

Dear Alex,

thanks for the initiative..EURECOM supports it.

I would have some comments: 

1) there are currently strong position by French car manufacturers (maybe more but I am only aware of them) for not sending CAMs over the internet...they claimed it is for privacy issues (so we might need to lobby them.  We are implemrnting this in a 5GPPP project, so it makes sense to us to allow it through a well defined mechanism.
2) I would not limit to CAM: nowadays people are ‘much more’ interested in the new message called Cooperative Perception Message, CPM, which transmit sensor data..having them over the Internet is important to futurs Geoservers located in MEC or Cloud. I would also add DENM. 

3) including LTE is also important now, I would also suggest to keep LTE-V2X as it is coherent with 3GPP (where did you find LTE_V2X), but again would not restrict to LTE, rather also include 5G-V2X, as I think mechanisms will be similar. And this does not differentiate between PC5 or Uu interfaces (horizontal and vertical) , which is good as well. Maybe another work would be needed...(e.g.  Cellular V2X (in two words) in that context, so it could also remain valid even in beyond 5G as long as the 3GPP interfaces do mot change much).

4) a big WI would be security and privacy I guess...as currently LTE V2X refers to ETSI ITS sec and so does ITS-G5..

BR,

Jérôme

Envoyé de mon iPhone

> Le 29 mars 2019 à 22:48, Alexandre Petrescu <[email-masked]> a écrit :
> 
> It is within ETSI IP6 ISG.  ISG stands for 'Industry Specification Group'.  IP6 is short for IPv6 I believe; I also saw it expanded as "IPv6 Best Practices", probably unrelated to the BCP IETF term.
> 
> Within this group, there was a recent WI proposal (Work Item) that has been adopted in earlier this year. 
> 
> That WI has a tight schedule with many intermediate steps and a 'TB Approval' December 2019.  I dont know what means 'TB'.
> 
> The document ETSI name is 'ETSI GR IP6 0030 V1.0.0'.  'GR' stands for 'Group Report'.  I believe it means there are several authors (a group of authors).  I dont think it represents a report of the whole group of people members of IP6.
> 
> I was invited to contribute to it.  The ToC is already made, and I was thinking to propose the following topics.
> 
> I am not sure I should describe IPv6-over-OCB into it, unless, of course, it gets more approval at IETF.
> 
> "We are also interested to add a text about V2V communications with IPv6.  This includes IPv6 RIO (Route Information Option) announcements, prefix propagation, addressing architecture for V2V and potentially more.
> 
> We are also interested in describing the use of CAM over UDP over IPv6.  Traditionnally CAMs are sent over BTP and over GeoNetworking but these are incompatible with the Internet, so we propose UDP and IPv6.  Implemented at a few sites.
> 
> We are interested in proposing the new term 'LTE-V2X'.  Remark the dash '-' instead of undesxoew '_'.  To the best of my knowledge, the 3GPP SDO only talks about 'LTE_V2X' and not about 'LTE-V2X'.  The term 'LTE-V2X' would designate sending ETSI CAM messages over IPv6 links of LTE (not IPv4)."
> 
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its