Subject: [ipwave] Patching Linux Kernel with OCB

From: John Seur <[email-masked]>
Date: Thu, 20 Jun 2019 16:25:01 +0300

Hello IPWavers,

During the Hackathon@AIS2019 (https://hackathon.internetsummitafrica.org/),
the team in IPWave track (led by Nabil Benamar) was patching the Linux
kernel 4.9.61 with OCB mode and discovered the following bugs in the patch
file (https://drive.google.com/file/d/0BxK6WTQZ97QVWF9tRURjOGhBU2c/view).
  drivers/net/wireless/ath/ath9k/main.c:961:2: error: duplicate case value
  case NL80211_IFTYPE_OCB:
  drivers/net/wireless/ath/ath9k/hw.c:1241:2: error: duplicate case value
  case NL80211_IFTYPE_OCB:

The duplicated lines of code were commented out and the patch file works!

---

From: Sara el hamdani <[email-masked]>
Date: Thu, 20 Jun 2019 17:22:23 +0200

Hi IPWAVERs,

I am in the same team in IPWave track with mister John on  Hackathon@AIS2019
(https://hackathon.internetsummitafrica.org/). I would like to refer that
we have tested the patch proposed by Alex in the mailing list, but it just
did not work for us. Instead, we have used the old patch in the link (
https://drive.google.com/file/d/0BxK6WTQZ97QVWF9tRURjOGhBU2c/view
<http://on:https//drive.google.com/file/d/0BxK6WTQZ97QVWF9tRURjOGhBU2c/view>),
so we have discovered the bugs described above.
I recommand anybody who needs to pach the kernel 4.9.61 with OCB mode to use
the old pach after fixing the bugs.

___
Sara El Hamdani

<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
Garanti
sans virus. www.avast.com
<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
<#m_1966153803618386632_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>

Le jeu. 20 juin 2019 à 15:25, John Seur <[email-masked]> a écrit :

> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

-- 
*Best regards*

*Sara EL HAMDANI*
*Phd student -Umi University.*

<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
Garanti
sans virus. www.avast.com
<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
<#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 21 Jun 2019 12:59:11 +0200

Le 20/06/2019 à 17:22, Sara el hamdani a écrit :
> Hi IPWAVERs,
> 
> I am in the same team in IPWave track with mister John on  
> Hackathon@AIS2019 (https://hackathon.internetsummitafrica.org/). I would 
> like to refer that we have tested the patch proposed by Alex in the 
> mailing list, but it just did not work for us. Instead, we have used the 
> old patch in the link 
> (https://drive.google.com/file/d/0BxK6WTQZ97QVWF9tRURjOGhBU2c/view 
> I recommand anybody who needs to pach the kernel 4.9.61 with OCB mode 
> to use the old pach after fixing the bugs.

Hi Sara,

I thank you very much for the report.  It is good that you patch OCB for 
kernel 4.9.61.  It is a very recent kernel, although the most recent 
seems to be 5.1.12.

For information, I have been patching around the kernels since kernel 
version 3.x.  Before that, some people did it for kernels 2.x if I 
remember correctly.  A few patches existed in public and in private.  At 
my organisation we currently work with a private patch for kernel 
version 4.something.  It relies on the OCB options in the mainline 
kernel  There are other organisations on this email list that work with 
some other patches for 4.something.  There are also a few patches on 
github.com.  Some of them were originated by a Grand Challenge contest 
in Europe.

You now  mention the patch at 
https://drive.google.com/file/d/0BxK6WTQZ97QVWF9tRURjOGhBU2c/view
I would like to ask you who created it?  (organisation, or group, or 
person name).

I would also like to ask you whether, in addition of the OCB patch, you 
also used the OCB options in the normal kernel configuration?  (did you 
do make menuconfig and checked 'OCB' in some option, or not at all?)

This OCB patch is worth setting aside somewhere on a fixed web page, so 
that everybody can use it.

There are many people who created OCB patches.  They seem to have a 
temporary interest in the matter: most of them no longer maintain their 
patches.  Each person starts from an earlier version, upgrade to most 
recent linux and then move on work on other topic.

Alex

> 	Garanti sans virus. www.avast.com 
> Le jeu. 20 juin 2019 à 15:25, John Seur <[email-masked] 
> <mailto:[email-masked]>> a écrit :
> 
>     Hello IPWavers,
> 
>     During the Hackathon@AIS2019
>     (https://hackathon.internetsummitafrica.org/), the team in IPWave
>     track (led by Nabil Benamar) was patching the Linux kernel 4.9.61
>     with OCB mode and discovered the following bugs in the patch file
>     (https://drive.google.com/file/d/0BxK6WTQZ97QVWF9tRURjOGhBU2c/view).
>     [email-masked] <mailto:[email-masked]>
> *
> *
> /Sara EL HAMDANI
> /
> /Phd student -Umi University./
> 
> 	Garanti sans virus. www.avast.com

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 21 Jun 2019 13:00:51 +0200

Hello Mr. Seur,

I would like to ask you whether you can apply that patch to ath10k also? 
(instead of ath9k).

If you do, you risk being the first to achieve 1Gbps on OCB, hopefully 
with IPv6.

Alex

Le 20/06/2019 à 15:25, John Seur a écrit :
> (https://hackathon.internetsummitafrica.org/), the team in IPWave track 
> (led by Nabil Benamar) was patching the Linux kernel 4.9.61 with OCB 
> mode and discovered the following bugs in the patch file

---

From: Nabil Benamar <[email-masked]>
Date: Fri, 21 Jun 2019 14:41:35 +0300

Hi Alex,

Thank you for your comments.
This is exactly what the hackathon participants put in future work!

2 days were not enough to build the testbed and test different drivers and
parameters...

---

From: Sara el hamdani <[email-masked]>
Date: Mon, 24 Jun 2019 00:32:28 +0100

Hello Alex,

Many thanks for sharing your insights.

Indeed, we knew during the hackathon that we should better patch the
kernel in its newest version 5.1.12. However, we couldn't create a new
patch because of the lack of time as mentioned Mr, Nabil. In fact, we
didn't have the right adapter for the physical OCBcard we had. So, we whole
first day spent the the first day trying to install the card on the desktop
including creating manually the adequate antenas.  Then, we had  only six
hours in the next day to capture IPv6 packets patching and recompiling the
kernel ect.

We have recommended to the organizers the reserve more time to this truck
in future hackathons. We think also that creating a new patch for the
current linux of the kernel is worth to be the object of an independent
truck in the hackathon.

Concerning the parameters, we have tested the connectivity using ath9k
driver successfully, and we were about to do the same for ath10k but it was
the already presentation time (as we aforementioned a lack of time).

For the patch creator, we don't know honestly who he is, but we have found
the link mentioned on a previous email of you in the link:
https://drive.google.com/file/d/0BxK6WTQZ97QVWF9tRURjOGhBU2c/view. Thus, we
decided to fix it and to make it work.

Besides, even if we arrived to patch the kernel with ath9k, the report in
the terminal showed that it was not completely successful (not 100%) and it
seems that this is what happens usually. So based on your big in you
experience, Mr. Alex, on creating and patching the kernel, we would know if
it is common for you to patch the kernel successfully 100%?

Sara

Le ven. 21 juin 2019 à 12:41, Nabil Benamar <[email-masked]> a écrit :

> On Fri, Jun 21, 2019, 14:01 Alexandre Petrescu <
> [email-masked]> wrote:
>
>> Hello Mr. Seur,
>>
>> track

-- 
*Best regards*

*Sara EL HAMDANI*

---

From: Sara el hamdani <[email-masked]>
Date: Mon, 24 Jun 2019 01:06:01 +0100

Hello Alex,

Indeed, we knew during the hackathon that we should better patch the
kernel in its newest version 5.1.12. However, we couldn't create a new
patch because of the lack of time as mentioned Mr, Nabil. In fact, we did
not have the right adapter for the physical OCB Card we had. So, we spent
the whole first day trying to install the card on the desktop including
creating the adequate antenas manually . Then, we had  in the next day only
six hours to capture IPv6 packets, patch and recompile the kernel ...

We have recommended to the organizers to reserve more time to this truck in
future hackathons. We think also that creating a new patch for the current
linux of the kernel is worth to be the object of an independent truck in
the hackathon.

Concerning the parameters, we have tested the connectivity using ath9k
driver successfully, and we were about to do the same for ath10k but it was
already the presentation time (as we aforementioned, a lack of time).

Besides, even if we arrived to patch the kernel with ath9k, the report in
the terminal showed that it was not completely successful (not 100%) and it
seems that this is what happens usually. So based on your big experience,
Mr. Alex, in creating and patching the kernel, we would like to know if it
is common for you to patch the kernel successfully 100%?

Le lun. 24 juin 2019 à 00:32, Sara el hamdani <[email-masked]> a
écrit :

> https://drive.google.com/file/d/0BxK6WTQZ97QVWF9tRURjOGhBU2c/view. Thus,
> we decided to fix it and to make it work.
>

>> 2 days were not enough to build the testbed and test different drivers
>> and parameters...
>>

-- 
*Best regards*

*Sara EL HAMDANI*

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 25 Jun 2019 18:15:47 +0200

Sara,

You are asking me about how to patch the kernel successfully 100%.

Frankly speaking I dont remember.  The last time I did was several years 
ago.  Since then I tell others how to.  It is them who know, the 
programmers.  But each time they do then they move to something else and 
forget, or no longer care, or their new employer forbids them from 
telling it to others.  I can remember: Pierre Pfister, Giorgio Campo, 
Mariama Sarr, Artiol Kalca.  But there were more, including those that I 
can not talk about.

This is the thing I remember most recently: in kernel series 4.x (x is 
unknown) the OCB is no longer a patch - it is included.  What is needed 
is to do 'make menuconfig' and check a few options.  There is a 2nd need 
in the 'iw' command: one needs recent iw commands (v4.9 at the time) 
because only they have this 'ocb' parameter which turns it on.

The only little patch that is needed is about the Regulatory Domain.  
The Regulatory Domain tells on which frequencies to work.

I hope in kernel 5.y (y is another unknown) there is no longer a need 
even for that little patch in Regulatory Domain.  I do not know.  You 
could tell me: is kernel 5.y still in need for a patch for Regulatory 
Domain for OCB to work?

You and John Seur also provided a patch to correct a duplicate 
definition of 'NL80211_IFTYPE_OCB'.  I never saw that error myself.

Maybe all this should be put into one single document, easy to ready for 
others.

Below you can find the OCB howto me and programmers wrote more than a 
year ago:

---------------------------------------------------------------------------------------------------------

- download the linux kernel linux-4.9.61.
- copy the patch file inside the linux folder
- cd into the linux folder
- make menuconfig and check:
          > Networking support > Wireless ->  cfg80211 - wireless 
configuration API
          > Networking support > Wireless ->  use statically compiled 
regulatory rules database
          > Networking support > Wireless -> support CRDA
          > Networking support > Wireless -> Generic IEEE 802.11 
Networking Stack (mac80211)
          > Device Drivers > Network device support -> Wireless LAN -> 
Atheros 802.11n wireless cards support
          > Device Drivers > Network device support -> Wireless LAN -> 
Atheros ath9k PCI/PCIe bus support
- Patch the kernel using the command "patch -p1 < patch.file"
- and make the kernel

- install iw 4.9
- iw dev wlan0 set type ocb
- ifconfig wlan0 up
- iw dev wlan0 ocb join 5900 10MHz

When we boot the board our country code is US. If for you it is 
different you can change the country with the "iw reg set" command.
This is important in order to define which channels are available.

This patch file was created with inspiration from somebody else from the 
Internet who used python to achieve the same, but which is hard to do on 
small platforms.

Date: 27 February 2018
Based 
on:https://drive.google.com/file/d/0BxK6WTQZ97QVWF9tRURjOGhBU2c/view; 
and other online resources
diff -ur linux-4.9.61/drivers/net/wireless/ath/ath9k/common-init.c 
linux-4.9.61-pat/drivers/net/wireless/ath/ath9k/common-init.c
--- linux-4.9.61/drivers/net/wireless/ath/ath9k/common-init.c 2017-11-08 
03:08:37.000000000 -0600
+++ linux-4.9.61-pat/drivers/net/wireless/ath/ath9k/common-init.c 
2017-11-17 04:33:50.168704602 -0600
@@ -86,6 +86,27 @@
       CHAN5G(5785, 35), /* Channel 157 */
       CHAN5G(5805, 36), /* Channel 161 */
       CHAN5G(5825, 37), /* Channel 165 */
+
+    CHAN5G(5850, 38), /* Channel 170 */
+        /* ITA-G5B */
+        CHAN5G(5855, 39), /* Channel 171 */
+        CHAN5G(5860, 40), /* Channel 172 */
+        CHAN5G(5865, 41), /* Channel 173 */
+        CHAN5G(5870, 42), /* Channel 174 */
+        /* ITS-G5A */
+        CHAN5G(5875, 43), /* Channel 175 */
+        CHAN5G(5880, 44), /* Channel 176 */
+        CHAN5G(5885, 45), /* Channel 177 */
+        CHAN5G(5890, 46), /* Channel 178 */
+        CHAN5G(5895, 47), /* Channel 179 */
+        CHAN5G(5900, 48), /* Channel 180 */
+        CHAN5G(5905, 49), /* Channel 181 */
+        /* ITS-G5D */
+        CHAN5G(5910, 50), /* Channel 182 */
+        CHAN5G(5915, 51), /* Channel 183 */
+        CHAN5G(5920, 52), /* Channel 184 */
+        CHAN5G(5925, 53), /* Channel 185 */
+
   };
     /* Atheros hardware rate code addition for short premble */
diff -ur linux-4.9.61/drivers/net/wireless/ath/ath9k/hw.h 
linux-4.9.61-pat/drivers/net/wireless/ath/ath9k/hw.h
--- linux-4.9.61/drivers/net/wireless/ath/ath9k/hw.h    2017-11-08 
03:08:37.000000000 -0600
+++ linux-4.9.61-pat/drivers/net/wireless/ath/ath9k/hw.h 2017-11-17 
04:34:18.781260652 -0600
@@ -73,7 +73,7 @@
     #define ATH9K_RSSI_BAD            -128
   -#define ATH9K_NUM_CHANNELS    38
+#define ATH9K_NUM_CHANNELS    54
     /* Register read/write primitives */
   #define REG_WRITE(_ah, _reg, _val) \
diff -ur linux-4.9.61/drivers/net/wireless/ath/regd.c 
linux-4.9.61-pat/drivers/net/wireless/ath/regd.c
--- linux-4.9.61/drivers/net/wireless/ath/regd.c    2017-11-08 
03:08:37.000000000 -0600
+++ linux-4.9.61-pat/drivers/net/wireless/ath/regd.c    2017-11-17 
04:37:11.684613511 -0600
@@ -45,9 +45,9 @@
   /* We allow IBSS on these on a case by case basis by regulatory 
domain */
   #define ATH9K_5GHZ_5150_5350    REG_RULE(5150-10, 5350+10, 80, 0, 30,\
                        NL80211_RRF_NO_IR)
-#define ATH9K_5GHZ_5470_5850    REG_RULE(5470-10, 5850+10, 80, 0, 30,\
+#define ATH9K_5GHZ_5470_5925    REG_RULE(5470-10, 5925+10, 80, 0, 30,\
                        NL80211_RRF_NO_IR)
-#define ATH9K_5GHZ_5725_5850    REG_RULE(5725-10, 5850+10, 80, 0, 30,\
+#define ATH9K_5GHZ_5725_5925    REG_RULE(5725-10, 5925+10, 80, 0, 30,\
                        NL80211_RRF_NO_IR)
     #define ATH9K_2GHZ_ALL        ATH9K_2GHZ_CH01_11, \
@@ -55,11 +55,11 @@
                   ATH9K_2GHZ_CH14
     #define ATH9K_5GHZ_ALL        ATH9K_5GHZ_5150_5350, \
-                ATH9K_5GHZ_5470_5850
+                ATH9K_5GHZ_5470_5925
     /* This one skips what we call "mid band" */
   #define ATH9K_5GHZ_NO_MIDBAND    ATH9K_5GHZ_5150_5350, \
-                ATH9K_5GHZ_5725_5850
+                ATH9K_5GHZ_5725_5925
     /* Can be used for:
    * 0x60, 0x61, 0x62 */
Only in linux-4.9.61-pat/include: config
Only in linux-4.9.61-pat/include: generated
diff -ur linux-4.9.61/net/wireless/db.txt 
linux-4.9.61-pat/net/wireless/db.txt
--- linux-4.9.61/net/wireless/db.txt    2017-11-08 03:08:37.000000000 -0600
+++ linux-4.9.61-pat/net/wireless/db.txt    2017-11-17 
04:38:44.958417939 -0600
@@ -1,17 +1,1220 @@
+# This is the world regulatory domain
+country 00:
+    (2402 - 2472 @ 40), (20)
+    # Channel 12 - 13.
+    (2457 - 2482 @ 40), (20), NO-IR
+    # Channel 14. Only JP enables this and for 802.11b only
+    (2474 - 2494 @ 20), (20), NO-IR, NO-OFDM
+    # Channel 36 - 48
+    (5170 - 5250 @ 80), (20), NO-IR, AUTO-BW
+    # Channel 52 - 64
+    (5250 - 5330 @ 80), (20), NO-IR, DFS, AUTO-BW
+    # Channel 100 - 144
+    (5490 - 5730 @ 160), (20), NO-IR, DFS
+    # Channel 149 - 165
+    (5735 - 5835 @ 80), (20), NO-IR
+    # IEEE 802.11ad (60GHz), channels 1..3
+    (57240 - 63720 @ 2160), (0)
+
+    #channel 172 184
+    (5860 - 5920 @ 80), (10), NO-IR
+
+country AD:
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20)
+    (5250 - 5330 @ 80), (20), DFS
+    (5490 - 5710 @ 80), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country AE: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country AF: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+# Source:
+#http://pucanguilla.org/Downloads/January2005-Anguilla%20Table%20of%20Allocations.pdf 

+country AI: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country AL: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20.00), AUTO-BW
+    (5250 - 5330 @ 80), (20.00), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27.00), DFS
+
+country AM: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (18)
+    (5250 - 5330 @ 80), (18), DFS
+
+country AN: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country AR: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country AS: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country AT: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country AU:
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country AW: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country AZ: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (18), AUTO-BW
+    (5250 - 5330 @ 80), (18), DFS, AUTO-BW
+
+country BA: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country BB: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (23), AUTO-BW
+    (5250 - 5330 @ 80), (23), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (30)
+
+country BD: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5735 - 5835 @ 80), (30)
+
+country BE: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country BF: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country BG: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country BH: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20)
+    (5250 - 5330 @ 80), (20), DFS
+    (5735 - 5835 @ 80), (20)
+
+country BL: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country BM: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country BN: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (20)
+
+country BO: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5250 - 5330 @ 80), (30), DFS
+    (5735 - 5835 @ 80), (30)
+
+country BR: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country BS: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+# Source:
+#http://www.bicma.gov.bt/paper/publication/nrrpart4.pdf
+country BT: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country BY: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country BZ: DFS-JP
+    (2402 - 2482 @ 40), (30)
+    (5735 - 5835 @ 80), (30)
+
+country CA: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+# Source:
+#http://www.art-rca.org
+country CF: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 40), (17)
+    (5250 - 5330 @ 40), (24), DFS
+    (5490 - 5730 @ 40), (24), DFS
+    (5735 - 5835 @ 40), (30)
+
+country CH: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country CI: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country CL: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (20)
+
+country CN: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (23), AUTO-BW
+    (5250 - 5330 @ 80), (23), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (30)
+    # 60 gHz band channels 1,4: 28dBm, channels 2,3: 44dBm
+    # 
ref:http://www.miit.gov.cn/n11293472/n11505629/n11506593/n11960250/n11960606/n11960700/n12330791.files/n12330790.pdf 

+    (57240 - 59400 @ 2160), (28)
+    (59400 - 63720 @ 2160), (44)
+    (63720 - 65880 @ 2160), (28)
+
+country CO: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country CR: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17)
+    (5250 - 5330 @ 80), (24), DFS
+    (5490 - 5730 @ 80), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country CX: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country CY: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+# Data fromhttp://www.ctu.eu/164/download/VOR/VOR-12-08-2005-34.pdf
+# andhttp://www.ctu.eu/164/download/VOR/VOR-12-05-2007-6-AN.pdf
+# Power at 5250 - 5350 MHz and 5470 - 5725 MHz can be doubled if TPC is
+# implemented.
+country CZ: DFS-ETSI
+    (2400 - 2483.5 @ 40), (100 mW)
+    (5150 - 5250 @ 80), (200 mW), NO-OUTDOOR, AUTO-BW
+    (5250 - 5350 @ 80), (100 mW), NO-OUTDOOR, DFS, AUTO-BW
+    (5470 - 5725 @ 160), (500 mW), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+# Data from "Frequenznutzungsplan" (as published in April 2008), 
downloaded from
+#http://www.bundesnetzagentur.de/cae/servlet/contentblob/38448/publicationFile/2659/Frequenznutzungsplan2008_Id17448pdf.pdf 

+# For the 5GHz range also see
+#http://www.bundesnetzagentur.de/cae/servlet/contentblob/38216/publicationFile/6579/WLAN5GHzVfg7_2010_28042010pdf.pdf 

+# The values have been reduced by a factor of 2 (3db) for non TPC devices
+# (in other words: devices with TPC can use twice the tx power of this 
table).
+# Note that the docs do not require TPC for 5150--5250; the reduction to
+# 100mW thus is not strictly required -- however the conservative 100mW
+# limit is used here as the non-interference with radar and satellite
+# apps relies on the attenuation by the building walls only in the
+# absence of DFS; the neighbour countries have 100mW limit here as well.
+
+country DE: DFS-ETSI
+    # entries 279004 and 280006
+    (2400 - 2483.5 @ 40), (100 mW)
+    # entry 303005
+    (5150 - 5250 @ 80), (100 mW), NO-OUTDOOR, AUTO-BW
+    # entries 304002 and 305002
+    (5250 - 5350 @ 80), (100 mW), NO-OUTDOOR, DFS, AUTO-BW
+    # entries 308002, 309001 and 310003
+    (5470 - 5725 @ 160), (500 mW), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country DK: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+# Source:
+#http://www.ntrcdom.org/index.php?option=com_content&view=category&layout=blog&id=10&Itemid=55 

+country DM: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (23), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (30)
+
+country DO: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (23), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (30)
+
+country DZ: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5170.000 - 5250.000 @ 80.000), (23.00), AUTO-BW
+    (5250.000 - 5330.000 @ 80.000), (23.00), DFS, AUTO-BW
+    (5490.000 - 5670.000 @ 160.000), (23.00), DFS
+
+country EC: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17)
+    (5250 - 5330 @ 80), (24), DFS
+    (5490 - 5730 @ 80), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country EE: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country EG: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20)
+    (5250 - 5330 @ 80), (20), DFS
+
+# Orden IET/787/2013, de 25 de abril, por la que se aprueba
+# el cuadro nacional de atribuciÃ³n de frecuencias.
+#http://www.boe.es/diario_boe/txt.php?id=BOE-A-2013-4845
   #
-# This file is a placeholder to prevent accidental build breakage if 
someone
-# enables CONFIG_CFG80211_INTERNAL_REGDB.  Almost no one actually needs to
-# enable that build option.
-#
-# You should be using CRDA instead.  It is even better if you use the CRDA
-# package provided by your distribution, since they will probably keep it
-# up-to-date on your behalf.
-#
-# If you_really_  intend to use CONFIG_CFG80211_INTERNAL_REGDB then you 
will
-# need to replace this file with one containing appropriately formatted
-# regulatory rules that cover the regulatory domains you will be using. 
  Your
-# best option is to extract the db.txt file from the wireless-regdb git
-# repository:
-#
-# git://git.kernel.org/pub/scm/linux/kernel/git/linville/wireless-regdb.git
-#
+# more info at "Cuadro nacional de atribuciÃ³n de frecuencias (CNAF)":
+#http://www.minetur.gob.es/telecomunicaciones/espectro/paginas/cnaf.aspx
+
+country ES: DFS-ETSI
+    (2400 - 2483.5 @ 40), (100 mW)
+    (5150 - 5250 @ 80), (200 mW), NO-OUTDOOR, AUTO-BW
+    (5250 - 5350 @ 80), (100 mW), NO-OUTDOOR, DFS, AUTO-BW
+    (5470 - 5725 @ 160), (500 mW), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country ET: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country FI: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country FM: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country FR: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country GB: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country GD: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country GE: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (18), AUTO-BW
+    (5250 - 5330 @ 80), (18), DFS, AUTO-BW
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country GF: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country GH: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country GL: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20)
+    (5250 - 5330 @ 80), (20), DFS
+    (5490 - 5710 @ 80), (27), DFS
+
+country GP: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country GR: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country GT: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (23), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (30)
+
+country GU: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (17)
+    (5250 - 5330 @ 80), (24), DFS
+    (5490 - 5730 @ 80), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country GY:
+    (2402 - 2482 @ 40), (30)
+    (5735 - 5835 @ 80), (30)
+
+country HK:
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country HN: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country HR: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country HT: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country HU: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country ID: DFS-JP
+    # 
ref:http://www.postel.go.id/content/ID/regulasi/standardisasi/kepdir/bwa%205,8%20ghz.pdf 

+    (2402 - 2482 @ 40), (20)
+    (5735 - 5815 @ 80), (23)
+
+country IE: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country IL: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5150 - 5250 @ 80), (200 mW), NO-OUTDOOR, AUTO-BW
+    (5250 - 5350 @ 80), (200 mW), NO-OUTDOOR, DFS, AUTO-BW
+
+country IN: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (20)
+
+country IR: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5735 - 5835 @ 80), (30)
+
+country IS: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country IT: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country JM: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country JO: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (23)
+    (5735 - 5835 @ 80), (23)
+
+country JP: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (2474 - 2494 @ 20), (20), NO-OFDM
+    (4910 - 4990 @ 40), (23)
+    (5030 - 5090 @ 40), (23)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (23), DFS
+
+country KE: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (23)
+    (5490 - 5570 @ 80), (30), DFS
+    (5735 - 5775 @ 40), (23)
+
+country KH: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+# Source
+#http://ntrc.kn/?page_id=7
+country KN: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (30), DFS
+    (5735 - 5815 @ 80), (30)
+
+country KP: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5630 @ 80), (30), DFS
+    (5735 - 5815 @ 80), (30)
+
+country KR: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (30), DFS
+    (5735 - 5835 @ 80), (30)
+
+country KW: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+
+country KY: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country KZ:
+    (2402 - 2482 @ 40), (20)
+
+country LB: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+# Source:
+#http://www.ntrc.org.lc/operational_structures.htm
+country LC: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (30), DFS
+    (5735 - 5815 @ 80), (30)
+
+country LI: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country LK: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17)
+    (5250 - 5330 @ 80), (24), DFS
+    (5490 - 5730 @ 80), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+# Source:
+#http://lca.org.ls/images/documents/lesotho_national_frequency_allocation_plan.pdf 

+country LS: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country LT: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country LU: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country LV: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country MA: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+
+country MC: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+# Source:
+#http://www.cnfr.md/index.php?pag=sec&id=117&l=en
+country MD: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+# Source:
+#http://www.cept.org/files/1050/Tools%20and%20Services/EFIS%20-%20ECO%20Frequency%20Information%20System/National%20frequency%20tables/Montenegro%20NAFT%20-%202010.pdf 

+country ME: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country MF: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country MH: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country MK: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country MN: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country MO:
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 40), (23)
+    (5250 - 5330 @ 40), (23), DFS
+    (5735 - 5835 @ 40), (30)
+
+country MP: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country MQ: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+# Source:
+#http://www.are.mr/pdfs/telec_freq_TNAbf_2010.pdf
+country MR: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country MT: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country MU: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country MW: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country MX: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country MY: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (23), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (30)
+
+country NI: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country NL: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), NO-OUTDOOR, AUTO-BW
+    (5250 - 5330 @ 80), (20), NO-OUTDOOR, DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+# Data fromhttp://www.lovdata.no/dokument/SF/forskrift/2012-01-19-77
+# Power at 5250 - 5350 MHz, 5470 - 5725 MHz and 5815 â€“ 5850 MHz can
+# be doubled if TPC is implemented.
+# Up to 2W (or 4W with TPC) is allowed in the 5725 â€“ 5795 MHz band
+# which has been merged with 5470 - 5725 MHz to allow wide channels
+country NO: DFS-ETSI
+    (2400 - 2483.5 @ 40), (100 mW)
+    (5150 - 5250 @ 80), (200 mW), AUTO-BW
+    (5250 - 5350 @ 80), (100 mW), DFS, AUTO-BW
+    (5470 - 5795 @ 160), (500 mW), DFS
+    (5815 - 5850 @ 35), (2000 mW), DFS
+    (17100 - 17300 @ 200), (100 mW)
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country NP: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (20)
+
+country NZ: DFS-FCC
+    (2402 - 2482 @ 40), (30)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country OM: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country PA: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (23), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (30)
+
+country PE: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country PF: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country PG: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country PH: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country PK: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5735 - 5835 @ 80), (30)
+
+country PL: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country PM: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country PR: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country PT: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country PW: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country PY: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country QA: DFS-JP
+    (2402 - 2482 @ 40), (20)
+    (5735 - 5835 @ 80), (30)
+
+country RE: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country RO: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+
+# Source:
+#http://www.ratel.rs/upload/documents/Plan_namene/Plan_namene-sl_glasnik.pdf 

+country RS: DFS-ETSI
+    (2400 - 2483.5 @ 40), (100 mW)
+    (5150 - 5350 @ 40), (200 mW), NO-OUTDOOR
+    (5470 - 5725 @ 20), (1000 mW), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country RU: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20)
+    (5250 - 5330 @ 80), (20), DFS
+    (5650 - 5730 @ 80), (30), DFS
+    (5735 - 5835 @ 80), (30)
+
+country RW: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country SA: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country SE: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country SG: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country SI: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country SK: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+# Source:
+# Regulation NÂ° 2004-005 ART/DG/DRC/D.RÃ©g
+country SN: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country SR: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country SV: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17)
+    (5250 - 5330 @ 80), (23), DFS
+    (5735 - 5835 @ 80), (30)
+
+country SY:
+    (2402 - 2482 @ 40), (20)
+
+# Source:
+#http://www.telecommission.tc/Spectrum-plan20110324-101210.html
+country TC: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country TD: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country TG: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 40), (20)
+    (5250 - 5330 @ 40), (20), DFS
+    (5490 - 5710 @ 40), (27), DFS
+
+country TH: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country TN: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+
+country TR: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country TT: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country TW: DFS-JP
+    (2402 - 2472 @ 40), (30)
+    (5270 - 5330 @ 40), (17), DFS
+    (5490 - 5590 @ 80), (30), DFS
+    (5650 - 5710 @ 40), (30), DFS
+    (5735 - 5835 @ 80), (30)
+
+# Source:
+# #914 / 06 Sep 2007:http://www.ucrf.gov.ua/uk/doc/nkrz/1196068874
+# #1174 / 23 Oct 
2008:http://www.nkrz.gov.ua/uk/activities/ruling/1225269361
+# (appendix 8)
+# Listed 5GHz range is a lowest common denominator for all related
+# rules in the referenced laws. Such a range is used because of
+# disputable definitions there.
+country UA: DFS-ETSI
+    (2400 - 2483.5 @ 40), (20), NO-OUTDOOR
+    (5150 - 5350 @ 40), (20), NO-OUTDOOR
+    (5490 - 5670 @ 80), (20), DFS
+    (5735 - 5835 @ 80), (20)
+    # 60 gHz band channels 1-4, ref: Etsi En 302 567
+    (57000 - 66000 @ 2160), (40)
+
+country UG: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country US: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (23), DFS, AUTO-BW
+    (5490 - 5710 @ 20), (30)
+    (5735 - 5835 @ 80), (30)
+    (5850 - 5935 @ 10), (30)
+    # 60g band
+    # reference:http://cfr.regstoday.com/47cfr15.aspx#47_CFR_15p255
+    # channels 1,2,3, EIRP=40dBm(43dBm peak)
+    (57240 - 63720 @ 2160), (40)
+
+country UY: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+# Source:
+#http://cemc.uz/article/1976/
+country UZ: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+
+# Source:
+#http://www.ntrc.vc/regulations/Jun_2006_Spectrum_Managment_Regulations.pdf 

+country VC: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+# Source:
+# Official Gazette (Gaceta Oficial) concerning Unlicensed transmitter use
+# (10 June 2013)
+#http://www.conatel.gob.ve/
+country VE: DFS-FCC
+    (2402 - 2482 @ 40), (30)
+    (5170 - 5250 @ 80), (23), AUTO-BW
+    (5250 - 5330 @ 80), (23), DFS, AUTO-BW
+    (5735 - 5835 @ 80), (30)
+
+country VI: DFS-FCC
+    (2402 - 2472 @ 40), (30)
+    (5170 - 5250 @ 80), (24), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country VN: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17)
+    (5250 - 5330 @ 80), (24), DFS
+    (5490 - 5730 @ 80), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+# Source:
+#http://www.trr.vu/attachments/category/130/GURL_for_Short-range_Radiocommunication_Devices2.pdf 

+country VU: DFS-FCC
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (17), AUTO-BW
+    (5250 - 5330 @ 80), (24), DFS, AUTO-BW
+    (5490 - 5730 @ 160), (24), DFS
+    (5735 - 5835 @ 80), (30)
+
+country WF: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country YE:
+    (2402 - 2482 @ 40), (20)
+
+country YT: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country ZA: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+country ZW: DFS-ETSI
+    (2402 - 2482 @ 40), (20)
+    (5170 - 5250 @ 80), (20), AUTO-BW
+    (5250 - 5330 @ 80), (20), DFS, AUTO-BW
+    (5490 - 5710 @ 160), (27), DFS
+
+
Only in linux-4.9.61-pat/scripts/basic: .fixdep.cmd
Only in linux-4.9.61-pat/scripts/basic: fixdep
Only in linux-4.9.61-pat/scripts/kconfig: .conf.cmd
Only in linux-4.9.61-pat/scripts/kconfig: .conf.o.cmd
Only in linux-4.9.61-pat/scripts/kconfig: .mconf.cmd
Only in linux-4.9.61-pat/scripts/kconfig: .mconf.o.cmd
Only in linux-4.9.61-pat/scripts/kconfig: .zconf.tab.o.cmd
Only in linux-4.9.61-pat/scripts/kconfig: conf
Only in linux-4.9.61-pat/scripts/kconfig: conf.o
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: .checklist.o.cmd
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: .inputbox.o.cmd
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: .menubox.o.cmd
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: .textbox.o.cmd
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: .util.o.cmd
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: .yesno.o.cmd
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: checklist.o
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: inputbox.o
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: menubox.o
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: textbox.o
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: util.o
Only in linux-4.9.61-pat/scripts/kconfig/lxdialog: yesno.o
Only in linux-4.9.61-pat/scripts/kconfig: mconf
Only in linux-4.9.61-pat/scripts/kconfig: mconf.o
Only in linux-4.9.61-pat/scripts/kconfig: zconf.hash.c
Only in linux-4.9.61-pat/scripts/kconfig: zconf.lex.c
Only in linux-4.9.61-pat/scripts/kconfig: zconf.tab.c
Only in linux-4.9.61-pat/scripts/kconfig: zconf.tab.o

Le 24/06/2019 à 01:32, Sara el hamdani a écrit :
> didn't have the right adapter for the physical OCBcard we had. So, we 
> whole first day spent the the first day trying to install the card on 
> the desktop including creating manually the adequate antenas.  Then, 
> we had  only six hours in the next day to capture IPv6 packets 
> patching and recompiling the kernel ect.
>
> We have recommended to the organizers the reserve more time to this 
> truck in future hackathons. We think also that creating a new patch 
> for the current linux of the kernel is worth to be the object of an 
> independent truck in the hackathon.
>
> driver successfully, and we were about to do the same for ath10k but 
> it was the already presentation time (as we aforementioned a lack of 
> time).
>
> For the patch creator, we don't know honestly who he is, but we have 
> found the link mentioned on a previous email of you in the link: 
> https://drive.google.com/file/d/0BxK6WTQZ97QVWF9tRURjOGhBU2c/view. 
> Thus, we decided to fix it and to make it work.
>
> Besides, even if we arrived to patch the kernel with ath9k, the report 
> in the terminal showed that it was not completely successful (not 
> 100%) and it seems that this is what happens usually. So based on your 
> big in you experience, Mr. Alex, on creating and patching the kernel, 
> we would know if it is common for you to patch the kernel successfully 
> 100%?
>
>
> Sara
>
> Le ven. 21 juin 2019 à 12:41, Nabil Benamar <[email-masked] 
> <mailto:[email-masked]>> a écrit :
>
>     Hi Alex,
>
>     2 days were not enough to build the testbed and test different
>     drivers and parameters...
>
>     On Fri, Jun 21, 2019, 14:01 Alexandre Petrescu
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         Hello Mr. Seur,
>

---

From: Sara el hamdani <[email-masked]>
Date: Wed, 26 Jun 2019 15:12:14 +0100

Dear Alex,

Thank you very much for giving us all this information including the name
of programmers.

It is more clear to me now, since I know the little parameters that need
modification.

For the newest version of the kernel (5.Y), I have not yet tested it myself
to know if it is still in need for a patch in Regulatory Domain or not.
But, when I will do I will surely give you my feedback.

Regards

Le mar. 25 juin 2019 à 17:15, Alexandre Petrescu <
[email-masked]> a écrit :

> forget, or no longer care, or their new employer forbids them from telling
> it to others.  I can remember: Pierre Pfister, Giorgio Campo, Mariama Sarr,
> Artiol Kalca.  But there were more, including those that I can not talk
> about.
>
> unknown) the OCB is no longer a patch - it is included.  What is needed is
> to do 'make menuconfig' and check a few options.  There is a 2nd need in
> the 'iw' command: one needs recent iw commands (v4.9 at the time) because
> only they have this 'ocb' parameter which turns it on.
>
> The only little patch that is needed is about the Regulatory Domain.  The
> Regulatory Domain tells on which frequencies to work.
>
> I hope in kernel 5.y (y is another unknown) there is no longer a need even
> for that little patch in Regulatory Domain.  I do not know.  You could tell
> me: is kernel 5.y still in need for a patch for Regulatory Domain for OCB
> to work?
>
> You and John Seur also  provided a patch to correct a duplicate definition
> of 'NL80211_IFTYPE_OCB'.  I never saw that error myself.
>
> Below you can find the OCB howto me and programmers wrote more than a year
> ago:
>
>
>          > Networking support > Wireless ->  cfg80211 - wireless
> configuration API
>          > Networking support > Wireless ->  use statically compiled
>          > Networking support > Wireless -> support CRDA
>          > Networking support > Wireless -> Generic IEEE 802.11 Networking
> Stack (mac80211)
>          > Device Drivers > Network device support -> Wireless LAN ->
>          > Device Drivers > Network device support -> Wireless LAN ->
> When we boot the board our country code is US. If for you it is different
> you can change the country with the "iw reg set" command.
> Based on:https://drive.google.com/file/d/0BxK6WTQZ97QVWF9tRURjOGhBU2c/view;
> --- linux-4.9.61/drivers/net/wireless/ath/ath9k/common-init.c
> 2017-11-08 03:08:37.000000000 -0600
>   /* We allow IBSS on these on a case by case basis by regulatory domain
> */
> +++ linux-4.9.61-pat/net/wireless/db.txt    2017-11-17 04:38:44.958417939
> -0600
> @@ -1,17 +1,1220 @@
> +#
> http://pucanguilla.org/Downloads/January2005-Anguilla%20Table%20of%20Allocations.pdf
> +country AI: DFS-ETSI
> +    # ref:
> http://www.miit.gov.cn/n11293472/n11505629/n11506593/n11960250/n11960606/n11960700/n12330791.files/n12330790.pdf
> +#
> http://www.bundesnetzagentur.de/cae/servlet/contentblob/38448/publicationFile/2659/Frequenznutzungsplan2008_Id17448pdf.pdf
> +#
> http://www.bundesnetzagentur.de/cae/servlet/contentblob/38216/publicationFile/6579/WLAN5GHzVfg7_2010_28042010pdf.pdf
> +#
> http://www.ntrcdom.org/index.php?option=com_content&view=category&layout=blog&id=10&Itemid=55
> +country DM: DFS-FCC
> -# git://
> git.kernel.org/pub/scm/linux/kernel/git/linville/wireless-regdb.git
> -#
> +    # ref:
> http://www.postel.go.id/content/ID/regulasi/standardisasi/kepdir/bwa%205,8%20ghz.pdf
> +#
> http://lca.org.ls/images/documents/lesotho_national_frequency_allocation_plan.pdf
> +country LS: DFS-ETSI
> +#
> http://www.cept.org/files/1050/Tools%20and%20Services/EFIS%20-%20ECO%20Frequency%20Information%20System/National%20frequency%20tables/Montenegro%20NAFT%20-%202010.pdf
> +country ME: DFS-ETSI
> +#
> http://www.ratel.rs/upload/documents/Plan_namene/Plan_namene-sl_glasnik.pdf
> +country RS: DFS-ETSI
> +# #1174 / 23 Oct 2008:
> http://www.nkrz.gov.ua/uk/activities/ruling/1225269361
> +# (appendix 8)
> +#
> http://www.ntrc.vc/regulations/Jun_2006_Spectrum_Managment_Regulations.pdf
> +country VC: DFS-ETSI
> +#
> http://www.trr.vu/attachments/category/130/GURL_for_Short-range_Radiocommunication_Devices2.pdf
> +country VU: DFS-FCC
> *Sara EL HAMDANI *

-- 
*Best regards*

*Sara EL HAMDANI*