Subject: [ipwave] IPWAVE Side Meeting

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 21 Nov 2019 11:11:39 +0800

Hi IPWAVE WG,

There will be a side meeting for I2NSF WG's next steps from 3:30PM to
4:30PM today
at Bras Basah.
https://datatracker.ietf.org/meeting/106/floor-plan?room=bras-basah#raffles-city-convention-center

The agenda for IPWAVE side meeting is as follows:

- IPWAVE Hackathon Project (Yiwen Chris Shen, 5 min)
- IPWAVE Problem Statement Draft (Jaehoon Paul Jeong, 5 min)
- Vehicular Neighbor Discovery Draft (Yiwen Chris Shen, 5 min)
- Vehicular Mobility Management Draft (Yiwen Chris Shen, 5 min)
- Security and Privacy Draft (Jaehoon Paul Jeong, 5 min)
- Context-Aware Navigator Draft (Yiwen Chris Shen, 5 min)
- Open Discussion for IPWAVE WG Progress (30 min)

The main purpose of this side meeting is to share the progress of
IPWAVE PS draft and the IPWAVE hackathon project using the video
delivery in the Linux system for IPv6 over IEEE 802.11-OCB.

I would like to explain the status of our WG and the importance of
the IPWAVE PS draft for the next step of our WG.

Welcome your engagement and feedback.

Thanks.

Best Regards,
Paul

---

From: Chris Shen <[email-masked]>
Date: Thu, 21 Nov 2019 15:13:08 +0800

Hi its,

Here I share side meeting slides for IPWAVE WG.

Please join us to give your opinions and suggestions about the work in
IPWAVE WG.

We really need your input! ^_^

Thanks!
Chris.

On Thu, Nov 21, 2019 at 11:12 AM Mr. Jaehoon Paul Jeong <
[email-masked]> wrote:

> --
> You received this message because you are subscribed to the Google Groups
> "skku-iotlab-members" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email-masked].
> To post to this group, send email to [email-masked].
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/skku-iotlab-members/CAPK2DeyAWKbA0jZmpSdvJVwG3RsqVd5c15r-wxTjEsH3uGbk0w%40mail.gmail.com
> <https://groups.google.com/d/msgid/skku-iotlab-members/CAPK2DeyAWKbA0jZmpSdvJVwG3RsqVd5c15r-wxTjEsH3uGbk0w%40mail.gmail.com?utm_medium=email&utm_source=footer>
> .
> For more options, visit https://groups.google.com/d/optout.
>

-- 
Yiwen (Chris) Shen, Ph.D. Candidate

Homepage: https://chrisshen.github.io
IoT Lab: *http://iotlab.skku.edu <http://iotlab.skku.edu/>*
Sungkyunkwan University, Suwon, South Korea
Mobile:+82-(0)10-6871-8103
Email: [email-masked]

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 26 Nov 2019 13:56:25 +0100

Hi Chris,

With respect to the Hackathon slides, my colleague and I would like to 
ask you:

- is the manual available? ("Made a new manual for running OCB mode")
- have you made a patch file?
- did you use a notion of QoS?  For example, can you send us a wireshark
   packet dump made in monitor mode, of the IPv6 packets used for video
   streaming between the two laptops?  These packets have 802.11 QoS Data
   headers or just 802.11 Data headers?
- the wifi card wilocity is on USB or is it internal to the laptop?

Yours,

Alex

Le 21/11/2019 à 08:13, Chris Shen a écrit :
> On Thu, Nov 21, 2019 at 11:12 AM Mr. Jaehoon Paul Jeong 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Hi IPWAVE WG,
> 
>     There will be a side meeting for I2NSF WG's next steps from 3:30PM
>     to 4:30PM today
>     at Bras Basah.
>     https://datatracker.ietf..org/meeting/106/floor-plan?room=bras-basah#raffles-city-convention-center
>     <https://datatracker.ietf.org/meeting/106/floor-plan?room=bras-basah#raffles-city-convention-center>
> 
> 
>     You received this message because you are subscribed to the Google
>     Groups "skku-iotlab-members" group.
>     To unsubscribe from this group and stop receiving emails from it,
>     send an email to [email-masked]
>     <mailto:[email-masked]>.
>     To post to this group, send email to
>     [email-masked]
>     <mailto:[email-masked]>.
>     <https://groups.google.com/d/msgid/skku-iotlab-members/CAPK2DeyAWKbA0jZmpSdvJVwG3RsqVd5c15r-wxTjEsH3uGbk0w%40mail.gmail.com?utm_medium=email&utm_source=footer>.
> IoT Lab: _http://iotlab.skku.edu <http://iotlab.skku.edu/>_
> <mailto:[email-masked]>
> 
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Chris Shen <[email-masked]>
Date: Wed, 27 Nov 2019 18:41:53 +0900

Hi Alex,

I answer your questions as follows:

Yes, it is in the following github link:
https://github.com/ipwave-hackathon-ietf/ipwave-hackathon-ietf-106/blob/master/IPWAVE-Manual-Hackathon-IETF106-v0.2.pdf

> - have you made a patch file?
I didn't make patch file for this implementation.
Based on existing resources, there are some patch work to enable
OCB mode in the Linux kernel.
One of them is much concrete, which was made by Czech Technical University
in Prague and Volkswagen.
The resource link is as follows:
https://ctu-iig.github.io/802.11p-linux/
But when I follow their instructions to configure OCB mode, there
are some unclear steps and some compiling errors coming out,
so I have modified the Makefile and explored other ways to configure
OCB mode, which is shown in the manual.

>    headers or just 802.11 Data headers?
I didn't use QoS. For the current webcam streaming, I use gst-launch
from Gstreamer. This gst-launch uses UDP and RTP to stream webcam.

I checked packet dump, there is no QoS information, so I believe the
packets
just use 802.11 Data headers.
I will send you the packet dump later, since I didn't save them.

> - the wifi card wilocity is on USB or is it internal to the laptop?

For the current test, we replaced the original wifi card inside a laptop
with an Athero wifi card using ath9k driver. This wifi card uses PCIe-mini
interface to connect with the laptop.
We also use the laptop internal antennas for 5.9GHz band. Initially,
we are not sure if the antennas of the testing laptop can support 5.9GHz
band, so we connect the wifi card with external antennas that support
5.9GHz.
After testing, we found that the laptop internal antennas can also support
5.9GHz band, so we just use them.
If you have a USB dongle that has PCIe-mini interface, I believe an Atheros
wifi
card can work as well, but you need to have external antennas to connect
with
the wifi card on the USB dongle.

Thanks!
Chris.

On Tue, Nov 26, 2019 at 9:56 PM Alexandre Petrescu <
[email-masked]> wrote:

> >     https://datatracker.ietf.
> .org/meeting/106/floor-plan?room=bras-basah#raffles-city-convention-center
> >     <
> >     <
> https://groups.google.com/d/msgid/skku-iotlab-members/CAPK2DeyAWKbA0jZmpSdvJVwG3RsqVd5c15r-wxTjEsH3uGbk0w%40mail.gmail.com?utm_medium=email&utm_source=footer
> >.