Subject: Re: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-14.txt

From: Jung-Soo Park <[email-masked]>
Date: Wed, 1 Apr 2020 20:26:21 +0900

Hi, all.

I reviewed IPWAVE draft and wrote down the humble comments.

---

#Clause 1.

At the third paragraph, my proposal is adding new reference,
[ISO-ITS-IPv6-Amd1].

“Along with these WAVE standards, IPv6 …

For Land Mobile (CALM) [ISO-ITS-IPv6], [ISO-ITS-IPv6-Amd1].

#Clause 2.

-New term, V2X should be added.

Generally speaking, vehicle-to-everything (V2X)  term is including V2I and
V2V.

So, new term should be define in Clause 2 (Terminology) with a sentence
excluding V2I and V2V use cases like a description of the first paragraph
of Clause 3. And this term should also include the V2P and V2D use cases.

-About Edge Network (EN),  “In” is changed to “It”.

-About IP-OBU,

This term is currently focused on a vehicle.

In case of a Device or Pedestrian, I want to know whether the IP-OBU
functionality is supported in them or not. I think this issue is solved in
this term.

-About Vehicle Detection Loop (i.e., Loop Detector),

This term is only used to define TCC in this document.

So, I think this term is useless.

#Clause 3,

-In Clause 3.1 V2V

In the first paragraph of Clause 3.1, these are four use cases of V2V
networking.

The second “cruise control” use case is described for urban environment.

The third “platooning” is also described for the highway.

So, I suggest that “in an urban roadway” and “in a highway” is redundant at
the second and third bullet  points.

-In Clause 3.1

In “Cooperative-environment-sensing” use case, describing the reward
system  is better. For more active cooperation, the supporter of
information should have   the benefit.

-In Clause 3.3 V2X

V2I2X is not described in upper part.

#Clause 4,

-In the fourth paragraph on page 12

We suggest like this;

“In the host-based mobility scheme, an IP-RSU plays a role of a home

  agent.”  We propose just deleting the “in a visited network”.

-In Clause 4.2 V2I-based Internetworking

In Figure 2, the internal network of Vehicle1 is constructed using wired
and wireless. So, the internal network of Vehicle1 should be changed
including two types of arrows (wired and wireless link) unlike EN1.

-In Figure 4,

It just comments. I think the Figure 4 can be used in Platooning
environment.

In that case, a Host has a role of leading vehicle with driver’s operation.
Others will be a driverless vehicles. So, star topology will be also used.

#Clause 6

-In the second paragraph of Clause 6,

“Also, in-vehicle devices (e.g., ECU) and mobile devices (e.g., smartphone)
in a vehicle need to …in another vehicle,”

I think that “mobile devices” can be existed out of the vehicle, just near
the vehicle. And the pedestrian also has them. So, this sentence should be
extended to include others such as pedestrian.

#Clause 7

[ISO-ITS-IPv6-Amd1]

ISO/TC 204, Intelligent transport systems - Communications access for

Land mobiles (CALM) - IPv6 Networking Amendment 1, September 2017.

Thanks.

Jungsoo, PARK

On Thu, Mar 19, 2020 at 12:42 AM Russ Housley <[email-masked]> wrote:

> We look forward to your review.  Please post it to the mail list.
>
> Russ
>
>
> On Mar 18, 2020, at 7:20 AM, Jung-Soo Park <[email-masked]> wrote:
>
> Hi All,
>
> I'm volunteer for reviewing.
> I hope giving a good response in the IPv6 networking and security aspects.
>
> Best Regards,
> JungSoo
>
> On Tue, Mar 10, 2020 at 4:46 AM Russ Housley <[email-masked]> wrote:
>
>> Paul believes that he has addressed all comments in revision:
>> https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-14
>>
>> I think we need to let at least five reviewers.  Could you do a review of
>> this revision?  Please respond to the WG mail list.
>>
>> Thanks,
>>   Russ
>>
>>
>> On Mar 9, 2020, at 2:17 PM, [email-masked] wrote:
>>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>> This draft is a work item of the IP Wireless Access in Vehicular
>> Environments WG of the IETF.
>>
>>        Title           : IPv6 Wireless Access in Vehicular Environments
>> (IPWAVE): Problem Statement and Use Cases
>>        Author          : Jaehoon Paul Jeong (editor)
>> Filename        : draft-ietf-ipwave-vehicular-networking-14.txt
>> Pages           : 32
>> Date            : 2020-03-09
>>
>> Abstract:
>>   This document discusses the problem statement and use cases of
>>   IPv6-based vehicular networking for Intelligent Transportation
>>   Systems (ITS).  The main scenarios of vehicular communications are
>>   vehicle-to-vehicle (V2V), vehicle-to-infrastructure (V2I), and
>>   vehicle-to-everything (V2X) communications.  First, this document
>>   explains use cases using V2V, V2I, and V2X networking.  Next, it
>>   makes a problem statement about key aspects in IPv6-based vehicular
>>   networking, such as IPv6 Neighbor Discovery, Mobility Management, and
>>   Security & Privacy.  For each key aspect, this document specifies
>>   requirements for IPv6-based vehicular networking.
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-ipwave-vehicular-networking/
>>
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-14
>> <https://tools.ietf..org/html/draft-ietf-ipwave-vehicular-networking-14>
>>
>> https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-vehicular-networking-14
>>
>> A diff from the previous version is available at:
>>
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-vehicular-networking-14
>>
>>
>> Please note that it may take a couple of minutes from the time of
>> submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>>
>> _______________________________________________
>> its mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/its
>>
>>
>> _______________________________________________
>> its mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/its
>>
>
>
> --
> Dr. JungSoo PARK
> -----------------
> Smart Infra Standardization Team
> Electronics and Telecommunications Research Institute (ETRI), Korea
> Tel:+82-42-860-6514, Fax:861-5404
> MSN: [email-masked], E-mail : [email-masked] <pjs@etri..re.kr>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>
>
>

-- 
Dr. JungSoo PARK
-----------------
Smart Infra Standardization Team
Electronics and Telecommunications Research Institute (ETRI), Korea
Tel:+82-42-860-6514, Fax:861-5404
MSN: [email-masked], E-mail : [email-masked]

---

From: 김증일 글로벌R&D마스터 <[email-masked]>
Date: Thu, 2 Apr 2020 02:27:14 +0000

Hello Jungsoo Park

I totally agree with your comment for cooperative environments sensing.

Reward system can help to deploy IP-based wireless vehicular network on the market.

In heavy traffic situation, if a vehicle allows the approaching adjacent one to cut-in, he and  ones in that lane should be rewarded with any method.

On the contrary, the cut-in vehicle should pay some cost for causing the traffic jam.

Coin in vehicular network using blockchain could be one of good alternatives.

Best wishes

Zeungil (Ben) Kim

김증일       글로벌R&D마스터 / 전력제어시험팀   

ZEUNG IL (Ben) KIM        Global R&D Master / Electric Power Control Test Team

Automotive Research & Development Division, www.hyundai.com<http://www.hyundai.com>

18280 경기도 화성시 남양읍 현대연구소로 150 Tel: +82-31-5172-3134, Mobile: +82-10 -8805-3810
150, Hyundaiyeonguso-ro, Namyang-eup, Hwaseong-si, Gyeonggi-do, 18280, Korea

________________________________
보낸 사람: Jung-Soo Park <[email-masked]>
보낸 날짜: 2020년 4월 1일 수요일 오후 8:26:21
받는 사람: [email-masked]
참조: Carlos Jesús Bernardos Cano
제목: Re: [ipwave] I-D Action: draft-ietf-ipwave-vehicular-networking-14.txt

Hi, all.

---
#Clause 1.
At the third paragraph, my proposal is adding new reference, [ISO-ITS-IPv6-Amd1].
“Along with these WAVE standards, IPv6 …
For Land Mobile (CALM) [ISO-ITS-IPv6], [ISO-ITS-IPv6-Amd1].

#Clause 2.
-New term, V2X should be added.
Generally speaking, vehicle-to-everything (V2X)  term is including V2I and V2V.
So, new term should be define in Clause 2 (Terminology) with a sentence excluding V2I and V2V use cases like a description of the first paragraph of Clause 3. And this term should also include the V2P and V2D use cases.

-About IP-OBU,
This term is currently focused on a vehicle..
In case of a Device or Pedestrian, I want to know whether the IP-OBU functionality is supported in them or not. I think this issue is solved in this term.

#Clause 3,
-In Clause 3.1 V2V
In the first paragraph of Clause 3.1, these are four use cases of V2V networking.
The second “cruise control” use case is described for urban environment.
The third “platooning” is also described for the highway.
So, I suggest that “in an urban roadway” and “in a highway” is redundant at the second and third bullet  points.

-In Clause 3.1
In “Cooperative-environment-sensing” use case, describing the reward system  is better. For more active cooperation, the supporter of information should have   the benefit.

-In Clause 3.3 V2X

#Clause 4,

-In Clause 4.2 V2I-based Internetworking
In Figure 2, the internal network of Vehicle1 is constructed using wired and wireless. So, the internal network of Vehicle1 should be changed including two types of arrows (wired and wireless link) unlike EN1.

-In Figure 4,
It just comments. I think the Figure 4 can be used in Platooning environment.
In that case, a Host has a role of leading vehicle with driver’s operation. Others will be a driverless vehicles. So, star topology will be also used.

#Clause 6
-In the second paragraph of Clause 6,
“Also, in-vehicle devices (e.g., ECU) and mobile devices (e.g., smartphone) in a vehicle need to …in another vehicle,”
I think that “mobile devices” can be existed out of the vehicle, just near the vehicle. And the pedestrian also has them. So, this sentence should be extended to include others such as pedestrian.

#Clause 7

[ISO-ITS-IPv6-Amd1]

Thanks.
Jungsoo, PARK

On Thu, Mar 19, 2020 at 12:42 AM Russ Housley <[email-masked]<mailto:[email-masked]>> wrote:
We look forward to your review.  Please post it to the mail list.

Russ

On Mar 18, 2020, at 7:20 AM, Jung-Soo Park <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,

Best Regards,
JungSoo

On Tue, Mar 10, 2020 at 4:46 AM Russ Housley <[email-masked]<mailto:[email-masked]>> wrote:
Paul believes that he has addressed all comments in revision:
https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-14

I think we need to let at least five reviewers.  Could you do a review of this revision?  Please respond to the WG mail list.

Thanks,
  Russ

On Mar 9, 2020, at 2:17 PM, [email-masked]<mailto:[email-masked]> wrote:

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Wireless Access in Vehicular Environments WG of the IETF.

       Title           : IPv6 Wireless Access in Vehicular Environments (IPWAVE): Problem Statement and Use Cases
       Author          : Jaehoon Paul Jeong (editor)
Filename        : draft-ietf-ipwave-vehicular-networking-14.txt
Pages           : 32
Date            : 2020-03-09

Abstract:

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-14<https://tools.ietf..org/html/draft-ietf-ipwave-vehicular-networking-14>
https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-vehicular-networking-14

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

_______________________________________________
its mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/its

_______________________________________________
its mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/its

--
Dr. JungSoo PARK
-----------------
Smart Infra Standardization Team
Electronics and Telecommunications Research Institute (ETRI), Korea
Tel:+82-42-860-6514, Fax:861-5404
MSN: [email-masked]<mailto:[email-masked]>, E-mail : [email-masked]<mailto:pjs@etri...re.kr>
_______________________________________________
its mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/its

--
Dr. JungSoo PARK
-----------------
Smart Infra Standardization Team
Electronics and Telecommunications Research Institute (ETRI), Korea
Tel:+82-42-860-6514, Fax:861-5404
MSN: [email-masked]<mailto:[email-masked]>, E-mail : [email-masked]<mailto:[email-masked]>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 9 Apr 2020 19:19:36 +0900

Hi Russ and Carlos,
As you see, the following five people reviewed the IPWAVE PS draft
according to the advice of our AD, Suresh:

Zeungil (Ben) Kim (Hyundai Motors)
Zhiwei Yan (CNNIC)
Yong-Joon Joe (LSware)
Jung-Soo Park (ETRI)
Kyoungjae Sun (Soongsil University)

I will revise our IPWAVE PS draft with their comments by the end of this
April.
With the revised draft, I believe you can do WGLC for it.

Thanks.

Best Regards,
Paul

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Fri, 1 May 2020 03:02:47 +0900

Hi Russ, Carlos and IPWAVE WG,
I need more time to address the reviewers' comments.
I will be able to post the revised draft early next week.

Thanks for your support and patience.

Best Regards,
Paul

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Russ Housley <[email-masked]>
Date: Thu, 30 Apr 2020 15:32:58 -0400

I look forward to the new I-D and the WG discussion of the changes.

Russ

> On Apr 30, 2020, at 2:02 PM, Mr. Jaehoon Paul Jeong <[email-masked]> wrote:
> 
> On Thu, Apr 9, 2020 at 7:19 PM Mr. Jaehoon Paul Jeong <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Russ and Carlos,
> As you see, the following five people reviewed the IPWAVE PS draft according to the advice of our AD, Suresh:
> 
> I will revise our IPWAVE PS draft with their comments by the end of this April.
> 2020년 3월 10일 (화) 오전 4:46, Russ Housley <[email-masked] <mailto:[email-masked]>>님이 작성:
> https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-14 <https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-14> 
> 
>> On Mar 9, 2020, at 2:17 PM, [email-masked] <mailto:[email-masked]> wrote:
>> 
>> 
>> https://datatracker.ietf.org/doc/draft-ietf-ipwave-vehicular-networking/ <https://datatracker.ietf.org/doc/draft-ietf-ipwave-vehicular-networking/>
>> 
>> https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-14 <https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-14>
>> https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-vehicular-networking-14 <https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-vehicular-networking-14>
>> 
>> https://www..ietf.org/rfcdiff?url2=draft-ietf-ipwave-vehicular-networking-14 <https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-vehicular-networking-14>
>> 
>> 
>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>> 
>> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/its <https://www.ietf.org/mailman/listinfo/its>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/its <https://www.ietf.org/mailman/listinfo/its>
> 
> 
> -- 
> Email: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php <http://cpslab.skku.edu/people-jaehoon-jeong.php>