Subject: [ipwave] IPWAVE Hackathon Project at IETF-108 Online Hackathon

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Mon, 13 Jul 2020 08:39:56 +0900

Hi IPWAVE WG,
My SKKU team is preparing for IPWAVE Hackathon Project that
demonstrates a safe-driving navigation service called Context-Aware
Navigator:
This Context-Aware Navigator protocol works on top of IPv6 over IEEE
802.11-OCB (RFC8691):
https://datatracker.ietf.org/doc/draft-jeong-ipwave-context-aware-navigator/

The project description is put into the Hackathon Wiki as follows:
https://trac.ietf.org/trac/ietf/meeting/wiki/108hackathon

----------------------------------------------------------------------------------------------------------------------------

*IP Wireless Access in Vehicular Environments (IPWAVE) Basic Protocols*

   - Champion(s)
      - Jaehoon Paul Jeong <pauljeong at skku.edu>
   - Project(s)
      - IP-Based Context-Aware Navigator Protocol
         - This project proves the effectiveness of IPv6-Based
         Context-Aware Navigator Protocol for safe driving
         - IPv6 neighbor mobility information sharing in IP-based vehicular
         network
         - A coordinated path planning for obstacle and collision avoidance
         in vehicular networks
         - Light-weight driving information exchange in IP-based vehicular
         networks
         - Network-based coordinated driving environment sensing and
         perception
         - Vehicular Simulations of IPWAVE with SUMO, INET, and VEINS
      - Specifications:
      - https://tools.ietf.org/html/rfc8691
      -
      https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-neighbor-discovery-09
      -
      https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-14
      -
      https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-mobility-management-03
      -
      https://tools.ietf.org/html/draft-jeong-ipwave-context-aware-navigator-01
   - Where to get code:
      - https://github.com/ipwave-hackathon-ietf
   - Video clip demo:
      - https://www.youtube.com/watch?v=sKYfa0MC6Jg&t=64s

 ----------------------------------------------------------------------------------------------------------------------------
The github code and video clip demo will be updated in the above links
before the Hackathon week (from 7/20/2020 to 7/24/2020).

I invite you as remote participants to our hackathon project.
If you have interest in the participation, please let me know.
We can collaborate with a WebEx meeting.

Thanks.

Paul
-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 15 Jul 2020 16:05:54 +0200

Le 13/07/2020 à 01:39, Mr. Jaehoon Paul Jeong a écrit :
> https://trac.ietf..org/trac/ietf/meeting/wiki/108hackathon 
> <https://trac.ietf.org/trac/ietf/meeting/wiki/108hackathon>
> 
>   * Champion(s)
>       o Jaehoon Paul Jeong <pauljeong at skku.edu <http://skku.edu>>
>   * Project(s)
>       o IP-Based Context-Aware Navigator Protocol
>           + This project proves the effectiveness of IPv6-Based
>           + IPv6 neighbor mobility information sharing in IP-based
>             vehicular network
>           + A coordinated path planning for obstacle and collision
>             avoidance in vehicular networks
>           + Light-weight driving information exchange in IP-based
>             vehicular networks
>           + Network-based coordinated driving environment sensing and
>             perception
>           + Vehicular Simulations of IPWAVE with SUMO, INET, and VEINS
>   * Specifications:
>       o https://tools.ietf.org/html/rfc8691
>       o https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-neighbor-discovery-09
>       o https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-14
>         <https://tools.ietf..org/html/draft-ietf-ipwave-vehicular-networking-14>
>       o https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-mobility-management-03
>       o https://tools.ietf.org/html/draft-jeong-ipwave-context-aware-navigator-01
>   * Where to get code:
>       o https://github.com/ipwave-hackathon-ietf

I would like to learn whether IPv6 works fine over 802.11ac driver in 
OCB mode with source code from
https://gitlab.com/hpi-potsdam/osm/g5-on-linux/11p-on-linux/-/tree/ath10k

If it works, then maybe I will use it too.

Alex

>   * Video clip demo:
>       o https://www.youtube.com/watch?v=sKYfa0MC6Jg&t=64s
> 
> Email: [email-masked] <mailto:[email-masked]>, 
> [email-masked] <mailto:[email-masked]>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>