Subject: [ipwave] IETF-108 IPWAVE Hackathon Project

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Mon, 20 Jul 2020 18:36:13 +0900

Hi IPWAVE WG,
My SKKU team is working for IETF-108 IPWAVE Hackathon Project.

This is the IETF-108 Hackathon Wiki:
https://trac.ietf.org/trac/ietf/meeting/wiki/108hackathon

There will be a kickoff session for the IETF-108 Hackathon at 10am on
7/20/2020 in EDT.
This is the Meetecho link:
https://meetings.conf.meetecho.com/ietf108/?group=hackathon

The following is the information of the IPWAVE Hackathon Project:
---------------------------------------------------------------------------------------------------

*IP Wireless Access in Vehicular Environments (IPWAVE) Basic Protocols*

   - Champion(s)
      - Jaehoon Paul Jeong <pauljeong at skku.edu>
   - Project(s)
      - IP-Based Context-Aware Navigator Protocol
         - This project proves the effectiveness of IPv6-Based
         Context-Aware Navigator Protocol (CNP) for safe driving.
         - The CNP is a light-weight driving information exchange protocol
         in IP-based vehicular networks.
         - IPv6 neighbor mobility information sharing can be performed by
         the CNP
         - A coordinated path planning is used for obstacle detection and
         collision avoidance in vehicular networks.
         - Vehicular simulation for IPWAVE is performed with SUMO, OMNeT++,
         and VEINS.
      - Specifications:
      - https://tools.ietf.org/html/rfc8691
      -
      https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-16
      -
      https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-neighbor-discovery-09
      -
      https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-mobility-management-03
      -
      https://tools.ietf.org/html/draft-jeong-ipwave-context-aware-navigator-01
   - Where to get code:
      - https://github.com/ipwave-hackathon-ietf/ipwave-hackathon-ietf-108
   - Video clip demo:
      - https://www.youtube.com/watch?v=27jlV4q9vZw

--------------------------------------------------------------------------------------------------

There is a manual for installation of our IPWAVE hackathon project on top
of the above simulation environments in the following Github link:
https://github.com/ipwave-hackathon-ietf/ipwave-hackathon-ietf-108/tree/master/IETF%202020

As the primary goal in this Hackathon, we want to show the effectiveness of
IPWAVE for
a navigation service for safe driving (called Context-Aware Navigator) as a
use case in our IPWAVE PS draft:
https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-16

We are also planning to implement the IPWAVE Basic Protocols and CNP in
robot vehicles for the IETF-109 Hackathon Project.

If you have an interest in this project, please let me know.
We can discuss and work together by email or WebEx online meeting.

Thanks.

Best Regards,
Paul
-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 20 Jul 2020 12:11:02 +0200

Thank you for the announcements.

I will try to join today at 16h Paris time, to listen.

Until then, I make some remarks below.

As you might know, I am trying to access various IETF URLs from a 
computer on "IPv6 only".  It means the IPv4 box is unchecked in Ethernet 
interface Properties in Windows 10.  Now it is my first opportunity to 
try it with IETF URLs, thank you.

All the remarks below are from a computer that is on IPv6 only.

> https://trac.ietf.org/trac/ietf/meeting/wiki/108hackathon

Works ok.

> https://meetings.conf.meetecho.com/ietf108/?group=hackathon

This link worked ok.

It then re-directed to a longer process of registration.  The 
'Hackathon' option of registering worked fine.  There is no payment for 
this option.  This worked fine.

It then said it sent me an email of registration; I will have to read 
that email on company VPN IPv4-only account, later.

Then I tried the option that I am already registered on Datatracker. 
That worked ok.  It says the "Room is still closed", and displays a 
counter of 4 hours left before starting.

>   * Champion(s)
>       o Jaehoon Paul Jeong <pauljeong at skku.edu <http://skku.edu>>
>   * Project(s)
>       o IP-Based Context-Aware Navigator Protocol
>           + This project proves the effectiveness of IPv6-Based
>           + The CNP is a light-weight driving information exchange
>             protocol in IP-based vehicular networks.
>           + IPv6 neighbor mobility information sharing can be performed
>             by the CNP
>           + A coordinated path planning is used for obstacle detection
>             and collision avoidance in vehicular networks.
>           + Vehicular simulation for IPWAVE is performed with SUMO,
>             OMNeT++, and VEINS.
>   * Specifications:
>       o https://tools.ietf.org/html/rfc8691
The above URL of RFC8691 is well accessible, it is ok.

>       o https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-16
>       o https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-neighbor-discovery-09
>       o https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-mobility-management-03
>       o https://tools.ietf.org/html/draft-jeong-ipwave-context-aware-navigator-01
>   * Where to get code:
>       o https://github.com/ipwave-hackathon-ietf/ipwave-hackathon-ietf-108

This URL does not work when I access it from a computer in IPv6-only.

>   * Video clip demo:
>       o https://www.youtube.com/watch?v=27jlV4q9vZw

This works ok when I access it from a computer in IPv6-only.  It 
displays a 5minute clip of a sophisticated road and simulator.

> There is a manual for installation of our IPWAVE hackathon project on 
> top of the above simulation environments in the following Github link:

Does not work when accessed from an "IPv6 only" computer.

> 
> 
> As the primary goal in this Hackathon, we want to show the effectiveness 
> of IPWAVE for
> a navigation service for safe driving (called Context-Aware Navigator) 
> as a use case in our IPWAVE PS draft:

Access on IPv6 only works ok for the above URL.

Alex

> We can discuss and work together by email or WebEx online meeting >
> Thanks.
> 
> Best Regards,
> Paul
> -- 
> Email: [email-masked] <mailto:[email-masked]>, 
> [email-masked] <mailto:[email-masked]>
> Personal Homepage: http://iotlab..skku.edu/people-jaehoon-jeong.php 
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 20 Jul 2020 15:58:23 +0200

> https://meetings.conf.meetecho.com/ietf108/?group=hackathon

Now there were some glitches to connect.

I am on IPv6 only, again.

It briefly says "setting the getter" or something like that.

But then it redirects to https://ietf108.conf.meetecho.com/
and there it does not work.

I tried several times.

Now it works.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 20 Jul 2020 16:09:46 +0200

So, no, it does not work.

Setting "getter-only" message property, and then it blocks.

I could vaguely see there were about 15 people in the room, and new 
attractive buttons.

But it does not work on IPv6 only.

The page that it can not dpwnload is this: 
https://ietf108.conf.meetecho.com/

I remark, many other things like google and youtube work ok on IPv6 only.

Maybe it works on IPv4 only.  Let me try IPv4.

Alex

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Mon, 20 Jul 2020 23:12:35 +0900

Hi IPWAVE WG,
There is a technical issue on IETF-108 Hackathon Meetecho.
Here is the message from the Hackathon Chair, Charles Eckel.

Thanks.

Paul
-----------------------------------------------------------

[hackathon] Meetecho session for hackathon kickoff
Inbox
x
Charles Eckel (eckelcu) <eckelcu=[email-masked]>
11:05 PM (4 minutes ago)
to [email-masked]
Hi Folks,

There are some technical issues with the session. The link is correct. Hope
to have it sorted and start soon.

Cheers,
Charles

On Mon, Jul 20, 2020 at 11:10 PM Alexandru Petrescu <
[email-masked]> wrote:

> >       o
> >       o
> >       o
> >       o
> >       o
> https://github.com/ipwave-hackathon-ietf/ipwave-hackathon-ietf-108
> >   * Video clip demo:

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 20 Jul 2020 16:26:32 +0200

Thank you Paul for the notification!

For info, I found a page for 'Self Test', but it does not work either

https://selftest.conf.meetecho.com/

https://ietf108.conf.meetecho.com/index.php/Self_Test

The idea of a Self Test in order to prepare for a meeting is excellent, 
I should have tried it earlier.

Alex

Le 20/07/2020 à 16:12, Mr. Jaehoon Paul Jeong a écrit :
>       Charles Eckel (eckelcu) <eckelcu=[email-masked]
>       <mailto:[email-masked]>>
> 
> 	
> 11:05 PM (4 minutes ago)
> 		
> to [email-masked] <mailto:[email-masked]>
> 
> Hi Folks,
> 
> There are some technical issues with the session. The link is correct. 
> Hope to have it sorted and start soon.
> 
> Cheers,
> Charles
> 
> On Mon, Jul 20, 2020 at 11:10 PM Alexandru Petrescu 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>      >       o Jaehoon Paul Jeong <pauljeong at skku.edu
>     <http://skku.edu> <http://skku.edu>>
>      >   * Project(s)
>      > Email: [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>,
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      > Personal Homepage:
>     http://iotlab..skku.edu/people-jaehoon-jeong.php
>     <http://skku.edu/people-jaehoon-jeong.php>
>      > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: wangyali <[email-masked]>
Date: Wed, 22 Jul 2020 13:10:22 +0000

Hi folks,

I found the following Hackathon meeting link did not work. Is there any new meeting link?

Thanks,
Yali

From: its [mailto:[email-masked]] On Behalf Of Mr. Jaehoon Paul Jeong
Sent: Monday, July 20, 2020 5:36 PM
To: [email-masked]
Cc: skku-iotlab-members <[email-masked]>; Mr. Jaehoon Paul Jeong <[email-masked]>
Subject: [ipwave] IETF-108 IPWAVE Hackathon Project

Hi IPWAVE WG,

There will be a kickoff session for the IETF-108 Hackathon at 10am on 7/20/2020 in EDT.
This is the Meetecho link:
https://meetings.conf.meetecho.com/ietf108/?group=hackathon

IP Wireless Access in Vehicular Environments (IPWAVE) Basic Protocols

  *   Champion(s)

     *   Jaehoon Paul Jeong <pauljeong at skku.edu<http://skku.edu>>

  *   Project(s)

     *   IP-Based Context-Aware Navigator Protocol

        *   This project proves the effectiveness of IPv6-Based Context-Aware Navigator Protocol (CNP) for safe driving.
        *   The CNP is a light-weight driving information exchange protocol in IP-based vehicular networks.
        *   IPv6 neighbor mobility information sharing can be performed by the CNP
        *   A coordinated path planning is used for obstacle detection and collision avoidance in vehicular networks.
        *   Vehicular simulation for IPWAVE is performed with SUMO, OMNeT++, and VEINS.

  *   Specifications:

     *   https://tools.ietf.org/html/rfc8691
     *   https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-16
     *   https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-neighbor-discovery-09
     *   https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-mobility-management-03
     *   https://tools.ietf.org/html/draft-jeong-ipwave-context-aware-navigator-01

  *   Where to get code:

     *   https://github.com/ipwave-hackathon-ietf/ipwave-hackathon-ietf-108

  *   Video clip demo:

     *   https://www.youtube.com/watch?v=27jlV4q9vZw
--------------------------------------------------------------------------------------------------

There is a manual for installation of our IPWAVE hackathon project on top of the above simulation environments in the following Github link:
https://github.com/ipwave-hackathon-ietf/ipwave-hackathon-ietf-108/tree/master/IETF%202020

As the primary goal in this Hackathon, we want to show the effectiveness of IPWAVE for
a navigation service for safe driving (called Context-Aware Navigator) as a use case in our IPWAVE PS draft:
https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-16

We are also planning to implement the IPWAVE Basic Protocols and CNP in robot vehicles for the IETF-109 Hackathon Project.

Thanks.

Best Regards,
Paul
--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Computer Science and Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab..skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 22 Jul 2020 15:38:36 +0200

We can try to meet virtually at the round table 'E' of color yellow-ish.

https://gather.town/z6N2SDxHebMdDAfo/IETF-108

Le 22/07/2020 à 15:10, wangyali a écrit :
> *From:*its [mailto:[email-masked]] *On Behalf Of *Mr. Jaehoon 
> Paul Jeong
> *Sent:* Monday, July 20, 2020 5:36 PM
> *To:* [email-masked]
> *Cc:* skku-iotlab-members <[email-masked]>; Mr. 
> Jaehoon Paul Jeong <[email-masked]>
> *Subject:* [ipwave] IETF-108 IPWAVE Hackathon Project
>
> Hi IPWAVE WG,
>
>           + IPv6 neighbor mobility information sharing can be
>             performed by the CNP
> We are also planning to implement the IPWAVE Basic Protocols and CNP 
> in robot vehicles for the IETF-109 Hackathon Project.
>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 23 Jul 2020 13:41:59 +0900

Hi Yali and Alex,
There will be our IPWAVE Hackathon Project Meeting with the following WebEx
information.
We will discuss the progress on CNP (Context-Aware Navigator Protocol) over
IPv6-over-802.11-OCB
and the presentation slides for IETF-108 Hackathon Closing Meeting.

-----------------------------------------------------------------------------------------------------------------
IETF-108 IPWAVE Hackathon Project

- Meeting Time:
>From 6AM to 7AM on July 23, 20202 in EST
(11AM to 12PM on July 23, 20202 in UTC )

- Meeting Link:
https://skku-ict.webex.com/skku-ict/j.php?MTID=mbf91a2ce4b81f41f33f91ea9105ba76f

- Meeting Number:
166 037 0364

- Password:
GSpQwXEd684
-----------------------------------------------------------------------------------------------------------------

Anyone in IPWAVE WG is welcomed to this session.

Thanks.

Paul

On Wed, Jul 22, 2020 at 10:10 PM wangyali <[email-masked]> wrote:

> *From:* its [mailto:[email-masked]] *On Behalf Of *Mr. Jaehoon Paul
> Jeong
>    - This project proves the effectiveness of IPv6-Based Context-Aware
>          Navigator Protocol (CNP) for safe driving.
>          - The CNP is a light-weight driving information exchange
>          - Vehicular simulation for IPWAVE is performed with SUMO,
>          OMNeT++, and VEINS.
>
>
>    - Specifications:
>
>

---

From: wangyali <[email-masked]>
Date: Thu, 23 Jul 2020 06:19:30 +0000

Hi Paul and Alex,

Many thanks for your reply. See you there.

Best regards,
Yali

From: Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
Sent: Thursday, July 23, 2020 12:42 PM
To: wangyali <[email-masked]>; Alexandru Petrescu <[email-masked]>
Cc: [email-masked]; skku-iotlab-members <[email-masked]>; Mr. Jaehoon Paul Jeong <[email-masked]>
Subject: Re: [ipwave] IETF-108 IPWAVE Hackathon Project

Hi Yali and Alex,
There will be our IPWAVE Hackathon Project Meeting with the following WebEx information.
We will discuss the progress on CNP (Context-Aware Navigator Protocol) over IPv6-over-802.11-OCB
and the presentation slides for IETF-108 Hackathon Closing Meeting.

- Meeting Time:

- Meeting Link:

- Meeting Number:
166 037 0364

- Password:
GSpQwXEd684

Thanks.

Paul

On Wed, Jul 22, 2020 at 10:10 PM wangyali <[email-masked]<mailto:[email-masked]>> wrote:
Hi folks,

Thanks,
Yali

From: its [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mr. Jaehoon Paul Jeong
Sent: Monday, July 20, 2020 5:36 PM
To: [email-masked]<mailto:[email-masked]>
Cc: skku-iotlab-members <[email-masked]<mailto:[email-masked]>>; Mr. Jaehoon Paul Jeong <[email-masked]<mailto:[email-masked]>>
Subject: [ipwave] IETF-108 IPWAVE Hackathon Project

Hi IPWAVE WG,

  *   Champion(s)

  *   Project(s)

  *   Specifications:

  *   Where to get code:

  *   Video clip demo:

Thanks.

Best Regards,
Paul

Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: wangyali <[email-masked]>
Date: Thu, 23 Jul 2020 06:24:35 +0000

Hi Paul and Alex,

Best regards,
Yali

Hi Yali and Alex,

- Meeting Time:

- Meeting Link:

- Meeting Number:
166 037 0364

- Password:
GSpQwXEd684

Thanks.

Paul

Thanks,
Yali

Hi IPWAVE WG,

  *   Champion(s)

  *   Project(s)

  *   Specifications:

  *   Where to get code:

  *   Video clip demo:

Thanks.

Best Regards,
Paul

---

From: Danilo Moreira <[email-masked]>
Date: Fri, 24 Jul 2020 10:49:01 +0000

Greetings everyone.

I'm having trouble with running the project on the IDE. I'm trying to run the examples of the CNDveins project but at the moment of building it, i have the following error:
make MODE=release all

make: *** No rule to make target 'src/scripts/run.in.py', needed by 'run'. Stop.
I'm running the project with the specifications of the manual: Ubuntu 16.04, Omnetpp 5.4.1. I've also imported the inet project that was on the repository.

Regards,
DM

Sent with [ProtonMail](https://protonmail.com) Secure Email.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Monday, July 20, 2020 5:36 AM, Mr. Jaehoon Paul Jeong <[email-masked]> wrote:

> - This project proves the effectiveness of IPv6-Based Context-Aware Navigator Protocol (CNP) for safe driving.
> - The CNP is a light-weight driving information exchange protocol in IP-based vehicular networks.
> - IPv6 neighbor mobility information sharing can be performed by the CNP
> - A coordinated path planning is used for obstacle detection and collision avoidance in vehicular networks.
> - Vehicular simulation for IPWAVE is performed with SUMO, OMNeT++, and VEINS.
>
> - Specifications:
>
> - https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-16
>
> - https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-neighbor-discovery-09
>
> - https://tools.ietf.org/html/draft-jeong-ipwave-vehicular-mobility-management-03
>
> - https://tools.ietf.org/html/draft-jeong-ipwave-context-aware-navigator-01
>
> - Where to get code:
>
> Personal Homepage: [http://iotlab..skku.edu/people-jaehoon-jeong.php](http://cpslab.skku.edu/people-jaehoon-jeong.php)