Subject: [Jmap] Fwd: New Version Notification for draft-murchison-jmap-websocket-01.txt

From: Ken Murchison <[email-masked]>
Date: Thu, 9 Aug 2018 11:52:29 -0400

I moved wsURL into a urn:ietf:params:jmap:websocket capability. My 
question is does this have to be a full wss: URL (e.g. 
wss://server.example.com/jmap/ws/) or can it just be a path (e.g. 
/jmap/ws/) ?

-------- Forwarded Message --------
Subject: 	New Version Notification for 
draft-murchison-jmap-websocket-01.txt
Date: 	Fri, 03 Aug 2018 20:34:48 -0700
From: 	[email-masked]
To: 	Ken Murchison <[email-masked]>, Kenneth Murchison 
<[email-masked]>

A new version of I-D, draft-murchison-jmap-websocket-01.txt
has been successfully submitted by Kenneth Murchison and posted to the
IETF repository.

Name:		draft-murchison-jmap-websocket
Revision:	01
Title:		A JSON Meta Application Protocol (JMAP) Subprotocol for WebSocket
Document date:	2018-08-03
Group:		Individual Submission
Pages:		8
URL:            https://www.ietf.org/internet-drafts/draft-murchison-jmap-websocket-01.txt
Status:         https://datatracker.ietf.org/doc/draft-murchison-jmap-websocket/
Htmlized:       https://tools.ietf.org/html/draft-murchison-jmap-websocket-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-murchison-jmap-websocket
Diff:           https://www.ietf.org/rfcdiff?url2=draft-murchison-jmap-websocket-01

Abstract:
    This document defines a binding for the JSON Meta Application
    Protocol (JMAP) over a WebSocket transport layer.  A WebSocket
    binding for JMAP provides higher performance than the current HTTP
    binding for JMAP.

Open Issues

    o  Should we allow push notifications over the WS connection?

    o  Should we allow out of order processing od requests?

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Neil Jenkins <[email-masked]>
Date: Thu, 09 Aug 2018 21:19:46 -0400

On Fri, 10 Aug 2018, at 1:52 AM, Ken Murchison wrote:
> I moved wsURL into a urn:ietf:params:jmap:websocket capability. 
      My question is does this have to be a full wss: URL (e.g. wss://server.example.com/jmap/ws/) or can it just be a path (e.g.
      /jmap/ws/) ?

If it's just a path, what's it relative to? The JMAP session resource URL I guess? This is probably OK if the spec explicitly states it.

I think yes, this should be the only "permanent" connection you need"

Again, I would say yes (methods within a request must be processed in order as usual of course). Otherwise you need to establish concurrent websocket connections to make concurrent requests, which seems like unnecessary overhead.

Neil.