Subject: [Jmap] Publication has been requested for draft-ietf-jmap-mail-12

From: Bron Gondwana <[email-masked]>
Date: Sun, 02 Dec 2018 22:59:47 -0800

Bron Gondwana has requested publication of draft-ietf-jmap-mail-12 as Proposed Standard on behalf of the JMAP working group.

Please verify the document's state at https://datatracker.ietf.org/doc/draft-ietf-jmap-mail/

---

From: "Matthew Horsfall (alh)" <[email-masked]>
Date: Wed, 5 Dec 2018 11:10:21 -0500

> Please verify the document's state at https://datatracker.ietf.org/doc/draft-ietf-jmap-mail/

Sometimes examples appear only 4 spaces over (section 7.5.1), other times
they appear very far over (section 5.2 in the request) or not indented
at all (section 5.2 in the response).

> 7. Email Submission
>
>
>   o  *undoStatus*: "String" (server-set) This represents whether the
>      submission may be canceled.  This is server set and MUST be one of
>      the following values:

So this is server-set. Later we say:

>      If in pending
>      state, a client can attempt to cancel the submission by setting
>      this property to "canceled"

The core spec makes it sound like server-set attributes *cannot* be
altered by a client:

      Any server-set properties MAY be included in the patch if their
      value is identical to the current server value (before applying
      the patches to the object).  Otherwise, the update MUST be
      rejected with an _invalidProperties_ SetError.

So is this allowed? Should the core spec say "there may be exceptions"?

> 8. Vacation Response
>
>
>   o  *textBody*: "String|null" The plain text body to send in response
>      to emails when the vacation response is enabled.  If this is
>      "null", when the vacation message is sent a plain-text body part
>      SHOULD be generated from the _htmlBody_ but the server MAY choose
>      to send the response as HTML only.
>
>   o  *htmlBody*: "String|null" The HTML body to send in response to
>      emails when the vacation response is enabled.  If this is "null",
>      when the vacation message is sent an HTML body part MAY be
>      generated from the _textBody_, or the server MAY choose to send
>      the response as plain-text only.

What if both are null?

I've also opened a number of merge requests with other minor issues:

  https://github.com/jmapio/jmap/pull/269
  https://github.com/jmapio/jmap/pull/270
  https://github.com/jmapio/jmap/pull/271

Cheers,

-- Matthew Horsfall (alh)

---

From: "Neil Jenkins" <[email-masked]>
Date: Wed, 05 Dec 2018 22:02:46 -0500

Hi Matt,
 
> at all (section 5.2 in the response). 
 
I'm not sure why this is happening; something weird with the converter I'm using from the markdown source files. I'm hoping this can be fixed up manually as a final edit pass. 
 
> So is this allowed? Should the core spec say "there may be exceptions"? 
 Yeh, this shouldn't be marked as server-set. That label is explicitly for properties the client may never change. Good catch.
 
> > the response as plain-text only. 
 
It's probably reasonable to say the server should use a default body in this case like it does with subject etc. 
 
Neil.