Subject: [Jmap] Call for adoption of JMAP calendars - reply by April 15

From: "Bron Gondwana" <[email-masked]>
Date: Tue, 26 Mar 2019 07:22:41 -0400

Hi All,

As discussed at Prague, we believe we're ready to start work on Calendars. A recharter to bring calendars into scope is planned, and along with that I propose that we adopt as an initial starting point the work here:

https://jmap.io/spec-calendars.html

Using the JSCalendar data format:

https://datatracker.ietf.org/doc/draft-ietf-calext-jscalendar/

Neil Jenkins has volunteered to remain as one of the authors for this document. Is anyone else (ideally from outside FastMail) keen to co-author? Let me know.

If you have any objections, please reply by April 15th with your objections.

Regards,

Bron.

--
 Bron Gondwana, CEO, FastMail Pty Ltd
 [email-masked]

---

From: "Neil Jenkins" <[email-masked]>
Date: Tue, 26 Mar 2019 11:45:33 -0400

I have posted an IETF-format draft of the initial spec: https://tools.ietf.org/html/draft-jenkins-jmapcalendars-01.

Work still required includes:
 * Deciding if the client should be able to ask the server to expand recurrences (probably yes), and what this looks like.
 * Defining scheduling (when to send iMIP messages) in more detail, and probably making this an explicit API method rather than implicit reaction to event changes.
 * Deciding whether to allow events to exist in multiple calendars at the same time (like labels vs folders in mail).
 * Moving calendar permissions into a `myRights` property to match JMAP Mail.
Neil.