Subject: Re: [Jmap] [Technical Errata Reported] RFC8620 (5791)

From: "Neil Jenkins" <[email-masked]>
Date: Tue, 23 Jul 2019 12:33:43 -0400

I can verify this errata report is correct. What is the process to approve?

Neil.

On Tue, 23 Jul 2019, at 11:56, RFC Errata System wrote:
> The following errata report has been submitted for RFC8620,
> "The JSON Meta Application Protocol (JMAP)".
> 
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid5791
> 
> --------------------------------------
> Type: Technical
> Reported by: Neil Jhaveri <[email-masked]>
> 
> Section: 2.1
> 
> Original Text
> -------------
> "capabilities": {
>  "urn:ietf:params:jmap:core": {
>  "maxSizeUpload": 50000000,
>  "maxConcurrentUpload": 8,
>  "maxSizeRequest": 10000000,
>  "maxConcurrentRequest": 8,
>  "maxCallsInRequest": 32,
>  "maxObjectsInGet": 256,
>  "maxObjectsInSet": 128,
>  "collationAlgorithms": [
>  "i;ascii-numeric",
>  "i;ascii-casemap",
>  "i;unicode-casemap"
>  ]
>  },
>  "urn:ietf:params:jmap:mail": {}
>  "urn:ietf:params:jmap:contacts": {},
>  "https://example.com/apis/foobar": {
>  "maxFoosFinangled": 42
>  }
> }
> 
> Corrected Text
> --------------
> "capabilities": {
>  "urn:ietf:params:jmap:core": {
>  "maxSizeUpload": 50000000,
>  "maxConcurrentUpload": 8,
>  "maxSizeRequest": 10000000,
>  "maxConcurrentRequests": 8,
>  "maxCallsInRequest": 32,
>  "maxObjectsInGet": 256,
>  "maxObjectsInSet": 128,
>  "collationAlgorithms": [
>  "i;ascii-numeric",
>  "i;ascii-casemap",
>  "i;unicode-casemap"
>  ]
>  },
>  "urn:ietf:params:jmap:mail": {},
>  "urn:ietf:params:jmap:contacts": {},
>  "https://example.com/apis/foobar": {
>  "maxFoosFinangled": 42
>  }
> }
> 
> Notes
> -----
> In the capabilities section of the example Session Resource response, "maxConcurrentRequest" should be "maxConcurrentRequests". 
> 
> In addition, the following line is missing a trailing comma:
>  "urn:ietf:params:jmap:mail": {}

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 23 Jul 2019 12:35:36 -0400

> On 23 Jul 2019, at 12:33, Neil Jenkins <[email-masked]> wrote:
> 

I need to login and approve.

---

From: RFC Errata System <[email-masked]>
Date: Tue, 23 Jul 2019 08:56:16 -0700 (PDT)

Section: 2.1

Original Text
-------------
"capabilities": {

Corrected Text
--------------
"capabilities": {

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8620 (draft-ietf-jmap-core-17)
--------------------------------------
Title               : The JSON Meta Application Protocol (JMAP)
Publication Date    : July 2019
Author(s)           : N. Jenkins, C. Newman
Category            : PROPOSED STANDARD
Source              : JSON Mail Access Protocol
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG