Subject: Re: [Jmap] Working group last call: draft-ietf-jmap-mdn-03

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 17 Jan 2020 15:57:10 +1100

Sorry that I haven't gone ahead with this! It's on my list to write up the Shepherding document and submit it.

Just to confirm, can you let me know if you have any IPR to disclose for this document.

Thanks,

Bron.

On Tue, Dec 17, 2019, at 03:58, Raphael OUAZANA wrote:
> Thank you all for your remarks.

> I uploaded a new version of the draft. I have taken care of all the comments that were made, thank you very much for the suggestions, it was really helpful.

> Regards,

> Raphaël.

> Le 22 novembre 2019 06:19, de [email-masked]
>> Raphael,
>> 
>> With my chair hat on - I'm happy for you to either issue drafts with updates during the last call period, or wait until the end and issue another draft containing all the feedback at the end of the last call period.
>> 
>> Either way, I'm happy to submit to publication after this last call without doing another last call - so long as those who have given feedback during this time agree that it's been addressed in the final draft!
>> 
>> Cheers,
>> 
>> Bron.
>> 
>> On Fri, Nov 22, 2019, at 15:51, Neil Jenkins wrote:
>>> Overall I think this doc is good. A few nits:
>>> 
>>>> o  forEmailId: "String" Email Id of the received email this MDN is
   relative to.
>>> 
>>> This needs to be nullable, as described in MDN/parse.
>>> 
>>>> o  originalMessageID: "String|null" (server-set)
>>> 
>>> I think this should be *originalMessageId* (lowercase d on the end) for consistency.
>>> 
>>>> 2.1 <https://tools.ietf.org/html/draft-ietf-jmap-mdn-03#section-2.1>.  MDN/set

   Standard "/set" method as described in [RFC8620 <https://tools.ietf..org/html/rfc8620>] where only the
   _create_ parameter is supported.
>>> 
>>> This is not quite right: the "accountId" and "ifInState" arguments are fine. I think this text should say something like:
>>> 
>>>> Only create is supported; any attempt to update/destroy MUST be rejected with a "forbidden" SetError.
>>> 
>>> And as a general comment, in the final versions of RFC8620/8621 we cleaned up the formatting so it worked better in the plain text version of the RFCs; I suggest adopting the same. So we use "quote" for a property name reference (not _underscore_) and remove the *asterisks* around the property names in the definitions.
>>> 
>>> Cheers,
>>> Neil.
>>> _______________________________________________
>>> Jmap mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/jmap
>>> 
>> 
>> --
>>  Bron Gondwana, CEO, Fastmail Pty Ltd
>>  [email-masked]
>> 
>> 
> _______________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap
> 

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]

---

From: Raphael OUAZANA <[email-masked]>
Date: Fri, 17 Jan 2020 08:13:19 +0000

Hi Bron,

What do you mean? Do you need any IPR notice from my company?

Regards,

Raphaël.

Le 17 janvier 2020 05:57, de [email-masked]

Thanks,

Bron.

Regards,

Raphaël.

Raphael,

Cheers,

Bron.

I think this should be originalMessageId (lowercase d on the end) for consistency.

2.1. MDN/set

Standard "/set" method as described in [RFC8620] where only the
_create_ parameter is supported.

Cheers,

Neil.

Jmap mailing list

[email-masked]

--

[email-masked]

Jmap mailing list

[email-masked]

--

[email-masked]

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 17 Jan 2020 19:18:22 +1100

If there was IPR, I would hope you'd already filed an IPR notice by now! If there's no IPR covering the material in this document, all I need is your statement to that effect.

Cheers,

Bron.

   relative to.

---

From: Raphael OUAZANA <[email-masked]>
Date: Fri, 17 Jan 2020 08:58:17 +0000

No, there is no IPR covering the material in this document.

Raphaël.

Le 17 janvier 2020 09:18, de [email-masked]

Cheers,

Bron.

Hi Bron,

Regards,

Raphaël.

Thanks,

Bron.

Regards,

Raphaël.

Raphael,

Cheers,

Bron.

2.1. MDN/set

Cheers,

Neil.

Jmap mailing list

[email-masked]

--

[email-masked]

Jmap mailing list

[email-masked]

https://www..ietf.org/mailman/listinfo/jmap

--

[email-masked]

Jmap mailing list

[email-masked]

--

[email-masked]

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 29 Jan 2020 16:53:03 +1100

Hi Raphael,

Sorry for the delay. I've finally actually read the -04 and I have more comments that I'd like to resolve before submitting. I'll write a separate email with that.

Bron.

   relative to.

   Standard "/set" method as described in [RFC8620 <https://tools.ietf...org/html/rfc8620>] where only the
   _create_ parameter is supported.