Subject: [kitten] OAUTH/SASL and the format debate

From: William Mills <[email-masked]>
Date: Mon, 14 May 2012 14:59:03 -0700 (PDT)

Having inquired of a number of folks that have implemented the XOAUTH mechanism and getting no reply, I'm planning to go with "silence == consent" and presume there's no big objection to moving away form the HTTP format style for the SASL messages.  I' planning on a key/value pair format, which is easily extensible.  My plan was something like:

    NONZERO ::=  %x31-39
    key ::= NONZERO *DIGIT 
    value ::= *(SP HTAB VCHAR)

    msg_line ::= key SP value CRLF
    sasl_msg ::= +msg_line CRLF

We would need an IANA registry for keys.  Objections?  Other preferred formats?

-bill

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 14 May 2012 16:09:17 -0600

On 5/14/12 3:59 PM, William Mills wrote:
> Having inquired of a number of folks that have implemented the XOAUTH
> mechanism and getting no reply, I'm planning to go with "silence ==
> consent" and presume there's no big objection to moving away form the
> HTTP format style for the SASL messages.  I' planning on a key/value
> pair format, which is easily extensible.  My plan was something like:
> 
>     NONZERO ::= %x31-39
>     key ::= NONZERO *DIGIT 

+1. This approach seems more easily parseable than HTTPish headers
(especially given questions about how complete one's HTTP parser needs
to be). However, if we're going to have a simple key-value format, why
not use JSON instead of defining something new? (And yes, I'm an XML guy
myself...)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: William Mills <[email-masked]>
Date: Mon, 14 May 2012 15:37:20 -0700 (PDT)

I don't have a preference.  The key value format is easier to parse.  JSON has libraries.

Folks please weigh in with JSON vs. KV votes please.

Thanks,

-bill

>________________________________
> From: Peter Saint-Andre <[email-masked]>
>To: William Mills <[email-masked]> 
>Cc: "[email-masked]" <[email-masked]> 
>Sent: Monday, May 14, 2012 3:09 PM
>Subject: Re: [kitten] OAUTH/SASL and the format debate
>

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 16 May 2012 16:12:50 +0100

> Folks please weigh in with JSON vs. KV votes please.
I slightly prefer KV, but I can live with either.
> Thanks,
>
> -bill
>
>     ------------------------------------------------------------------------
>     *From:* Peter Saint-Andre <[email-masked]>
>     *To:* William Mills <[email-masked]>
>     *Cc:* "[email-masked]" <[email-masked]>
>     *Sent:* Monday, May 14, 2012 3:09 PM
>     *Subject:* Re: [kitten] OAUTH/SASL and the format debate
>
>     > We would need an IANA registry for keys.  Objections?  Other
>     preferred
>     > formats?
>