Subject: Re: [kitten] RFC 5742 review of draft-hotz-kx509

From: "Henry B. Hotz" <[email-masked]>
Date: Wed, 6 Jun 2012 10:11:24 -0700

I'm cc'ing kitten, since the IANA registry in question is nominally a gssapi, not a kerberos one.

Your comment about the underscore is interesting.  Since we're documenting an existing protocol, the underscore is what it is.  Should we resolve the issue by requesting an exception, or by deleting the request for an addition to the registry?

I'd prefer an exception, but I'm OK either way.

On Jun 6, 2012, at 4:30 AM, Stephen Farrell wrote:

> 
> Hi,
> 
> I've done my 5742 review of this and reckon that its doesn't
> conflict with the planned work on the topic in the kerberos
> WG, so I've put this on the June 21st IESG telechat agenda
> for the other ADs to see if they agree or not.
> 
> Note that I also had some comments on the text itself. [1]
> The authors/ISE might want to take a look at those in the
> meantime, in particular the IANA registration comment.
> (Authors - I think the right thing here is to do what the
> ISE wants in terms of any possible revisions, but from
> the IESG point of view, I'd guess changes you might want
> to make to address those comments if made in the next week
> wouldn't be a problem.)
> 
> Cheers,
> Stephen.
> 
> [1] https://datatracker.ietf.org/doc/draft-hotz-kx509/writeup/
> 
> On 05/31/2012 12:35 AM, Stephen Farrell wrote:
>> 
>> Hi,
>> 
>> The independent submissions editor (ISE) has asked the
>> IESG to do an RFC 5742 review of this [1] document.
>> 
>> That review is to check that the publication of this
>> independent stream submission would not conflict with
>> IETF work.
>> 
>> In this case, the work is clearly related to the pkix
>> and kerberos working groups, hence this mail.
>> 
>> Note: this mail is not a request for a technical review
>> of the content, but rather asking if publication would
>> somehow be damaging to the work of these wgs. (If you
>> do have technical comments, send them to the author
>> or ISE). If you're not sure about any of that, then
>> read RFC 5742. [2]
>> 
>> I'll take silence as meaning that nobody thinks that
>> there's a conflict. If someone thinks there is a
>> conflict let me, the list, or the wg chairs know. In
>> due course, I'll be doing my own evaluation as well
>> of course, as will other IESG members.
>> 
>> Thanks,
>> Stephen.
>> 
>> [1] http://tools.ietf.org/html/draft-hotz-kx509-04
>> [2] http://tools.ietf.org/html/rfc5742
>> 
>> _______________________________________________
>> pkix mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/pkix
>> 
>> 

------------------------------------------------------
The opinions expressed in this message are mine,
not those of Caltech, JPL, NASA, or the US Government.
[email-masked], or [email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 06 Jun 2012 18:18:53 +0100

Hi,

> I'm cc'ing kitten, since the IANA registry in question is nominally a gssapi, not a kerberos one.

Thanks, I missed that.

> Your comment about the underscore is interesting.  Since we're documenting an existing protocol, the underscore is what it is.  Should we resolve the issue by requesting an exception, or by deletin…

I don't even know what requesting an exception might mean for
an IANA registry to be honest. It sounds like a bunch of work
for someone in any case;-)

If you're ok with leaving it out, I suspect that might be the
easier option all right.

I suppose you could register without the illegal character
and note in the text that current deployments use "_" and
not "-" in the name but I'm not sure that'd be useful.

S

---

From: Nico Williams <[email-masked]>
Date: Wed, 6 Jun 2012 12:43:16 -0500

> I'm cc'ing kitten, since the IANA registry in question is nominally a gssapi, not a kerberos one.

The registry being the service name registry, which IIRC includes the
IANA port service names by implication.  Anyways, no objection.

> I'd prefer an exception, but I'm OK either way.

I agree, it is what it is.  We should make the exception.

Nico
--

---

From: "Henry B. Hotz" <[email-masked]>
Date: Wed, 6 Jun 2012 11:00:29 -0700

> not "-" in the name but I'm not sure that'd be useful.

I'd rather not register than register the wrong thing.  I'd just say in the IANA section what the name is, and that the name isn't registered because it doesn't meet the IANA requirements for the registry.

In words we keep using more often than I like, we could fix this issue in an incompatible upgrade to the protocol.

---

From: Nico Williams <[email-masked]>
Date: Wed, 6 Jun 2012 12:45:30 -0500

> for someone in any case;-)

My guess is that when the IANA looks at this I-D on the RFC-Editor
queue they'll point this out, at which point the author(s) will point
out the need for an exception, which IANA should probably take to
require comment/consensus from KITTEN WG, which surely will be easy to
obtain.

> not "-" in the name but I'm not sure that'd be useful.

I'd rather the registry reflect reality :/  Let's try that first.

Nico
--

---

From: Nico Williams <[email-masked]>
Date: Wed, 6 Jun 2012 15:11:38 -0500

Agreed, there's no need to register this service name, so if it's too
muc trouble, then don't.