Subject: Re: [kitten] WGLC on draft-ietf-kitten-sasl-oauth-08.txt

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 03 Oct 2012 21:48:15 +0300

I did a quick review of the document. It can be found here:
http://www.tschofenig.priv.at/draft-ietf-kitten-sasl-oauth-08.pdf
http://www.tschofenig.priv.at/draft-ietf-kitten-sasl-oauth-08.doc

There is one issue that I am not entirely sure about.

OAUTH10A refers to "Authorization using OAuth 1.0a tokens."

OAuth 1.0a, however, has three mechanisms

  a) HMAC-SHA1
  b) RSA-SHA1
  c) PLAINTEXT (over TLS)

(The PLAINTEXT version without TLS was part of the community edition of 
OAuth 1.0. I ignore it here.)

To which of these three mechanisms does OAUTH10A refer to?

Ciao
Hannes

On 09/23/2012 09:22 AM, Alexey Melnikov wrote:
> On behalf of Kitten WG chairs I would like to initiate 2 weeks Working
> Group Last Call on draft-ietf-kitten-sasl-oauth-08.txt. Please reply
> with your comments (positive and/or negative) directly to the mailing
> list or to WG chairs [email-masked]. Statement of support
> such as "I reviewed the document and it looks ready for publication"
> will also be appreciated.
>
> Alexey,
> as [outgoing] Kitten co-chair.
>
> _______________________________________________
> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten

---

From: William Mills <[email-masked]>
Date: Wed, 3 Oct 2012 12:25:10 -0700 (PDT)

In 1.0a the signature method is part of the transaction, i.e. 

    oauth_signature_method="HMAC-SHA1"

The server actually has to support all 3 methods I believe.  There is no choice to make here for the mechanism. 

>________________________________
> From: Hannes Tschofenig <[email-masked]>
>To: Alexey Melnikov <[email-masked]> 
>Cc: "[email-masked]" <[email-masked]> 
>Sent: Wednesday, October 3, 2012 11:48 AM
>Subject: Re: [kitten] WGLC on draft-ietf-kitten-sasl-oauth-08.txt
> 
>(The PLAINTEXT version without TLS was part of the community edition of OAuth 1.0. I ignore it here.)
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 04 Oct 2012 10:18:20 +0300

There are two problems:

1) OAUTH10A-PLUS says that it adds channel binding capability to 
OAUTH10A for additional security guarantees.

Since OAUTH10A includes the PLAINTEXT mechanism the channel binding 
procedure does not work as described. The PLAINTEXT mechanism (which is 
a misleading name given that it runs on top of TLS) corresponds to the 
OAuth 2.0 Bearer Token-based mechanism but is just less well specified 
(which may lead to interoperability problems).

2) RSA-SHA1 is not sufficiently specified in OAuth 1.0a that it would 
actually work. In particular, there is no protocol mechanism to obtain 
the temporary RSA key pair.

Ciao
Hannes

On 10/03/2012 10:25 PM, William Mills wrote:
>     ------------------------------------------------------------------------
>     *From:* Hannes Tschofenig <[email-masked]>
>     *To:* Alexey Melnikov <[email-masked]>
>     *Cc:* "[email-masked]" <[email-masked]>
>     *Sent:* Wednesday, October 3, 2012 11:48 AM
>     *Subject:* Re: [kitten] WGLC on draft-ietf-kitten-sasl-oauth-08.txt
>
>      > list or to WG chairs [email-masked]
>     <mailto:[email-masked]>. Statement of support
>      > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: William Mills <[email-masked]>
Date: Thu, 4 Oct 2012 07:49:41 -0700 (PDT)

For #1 below can we solve this with text stating that in -PLUS that "PLAINTEXT" MUST NOT be used?

For #2, I see the problem, but do we need to fix it?

>To: William Mills <[email-masked]> 
>Cc: Hannes Tschofenig <[email-masked]>; Alexey Melnikov <[email-masked]>; "[email-masked]" <[email-masked]> 
>Sent: Thursday, October 4, 2012 12:18 AM
>>      > On behalf of Kitten WG chairs I would like to initiate 2 weeks
>>     Working
>>      > Group Last Call on draft-ietf-kitten-sasl-oauth-08.txt. Please reply
>>      > with your comments (positive and/or negative) directly to the mailing
>>      > list or to WG chairs [email-masked]
>>      > such as "I reviewed the document and it looks ready for publication"
>>      > will also be appreciated.
>>      >
>>      > Alexey,
>>      > as [outgoing] Kitten co-chair.
>>      >
>>      > _______________________________________________
>>      > Kitten mailing list
>>      > [email-masked] <mailto:[email-masked]>
>>      > https://www.ietf.org/mailman/listinfo/kitten
>>

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 4 Oct 2012 18:12:09 +0300

Hey, 

> For #1 below can we solve this with text stating that in -PLUS that "PLAINTEXT" MUST NOT be used?
Sure. 

> For #2, I see the problem, but do we need to fix it?

No, we can say that we are talking about HMAC-SHA1 only and ignore the RSA stuff. 

Ciao
hannes

---

From: William Mills <[email-masked]>
Date: Thu, 4 Oct 2012 09:11:47 -0700 (PDT)

Hannes, 

Since you have the "token" at the moment on the draft, I'd like to propose the following change in Section 3.4, last sentence of the first paragraph.  It currently reads:

    It should be noted that while the Bearer token scheme specifies SSL for normal usage 
    it offers no integrity protection and is not suitable for use with channel binding.

And I think it should change to:

    The OAuth 1.0a PLAINTEXT "signature method" MUST NOT be used in OAUTH10A-PLUS, similarly 
    the Bearer token scheme specifies SSL for normal usage but offers no integrity protection 

    and is not suitable for use with channel binding.

-bill

>Sent: Thursday, October 4, 2012 8:12 AM

---

From: William Mills <[email-masked]>
Date: Thu, 4 Oct 2012 09:20:34 -0700 (PDT)

I think we can just ignore the RSA key exchange issue since it's possible for 2 endpoints to have specified RSA keys out of band.  No point in writing it out of the spec.

----- Original Message -----
>>  Cc: Hannes Tschofenig <[email-masked]>; Alexey Melnikov 
> <[email-masked]>; "[email-masked]" 
> <[email-masked]> 
>>  > The server actually has to support all 3 methods I believe.  There is 
> no choice to make here for the mechanism.
>>  >
>>  >
>>  >
>>  >    
>>  >    (The PLAINTEXT version without TLS was part of the community 
> edition
>>  >    of OAuth 1.0. I ignore it here.)
>>  >