Subject: RE: The status of the approaches to the E-Tree solution?

From: Jiangyuanlong <[email-masked]>
Date: Tue, 17 Apr 2012 17:38:10 +0000

Hi Daniel,

Please see my comments inline.

Regards
Yuanlong

------------------------------

Date: Tue, 17 Apr 2012 00:08:02 +0300
From: "Daniel Cohn" <[email-masked]>
To: "Lucy yong" <[email-masked]>, "Rogers, Josh"
        <[email-masked]>,      "Henderickx, Wim (Wim)"
        <[email-masked]>,    <[email-masked]>,
        <[email-masked]>,       <[email-masked]>
Cc: [email-masked], [email-masked],
        [email-masked],     [email-masked],
        [email-masked],     [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?
Message-ID: <[email-masked]>
Content-Type: text/plain;       charset="utf-8"

Hi lucy,

As we discussed extensively in the list, and as reflected in giles slide, 2 pws are only needed between pes with both root and leaf acs, which will typically be a small minority.
[YL] For a PE with only leaf ACs and a PE with both root and leaf ACs, do you really think only 1 PW is needed? if so, should it be a root PW or a leaf PW? 

Also as per giles slide, dual vlan can have scalability issues due to additional lookup and double use of vlans in internal emulated lan interface. Also there are potential backward compatibility issues with silicon that doesn't support vlan mapping.
[YL] Dual VLAN may have scalability concerns only when the PE can only support a single global VLAN space, not sure a VLAN lookup at the port has any scalability issue. 
[YL] If VLAN mapping can not be supported by the PE, global VLAN may be used instead.

Regards,

Daniel

Thumb typed - please be tolerant

Lucy yong <[email-masked]> wrote:

In my mind, the VLAN approach means dual vlan method.

The main concern for CW approach is hardware support.

Two PW approach can be complex too if the VPLS instance for E-Tree uses P2P PW for unicast traffic and P2MP PW for broadcast and unknown unicast traffic, and some P2MP PWs for multicast traffic. It may double all of them.

E-tree is an Ethernet service and there is already VLAN based solution in IEEE, can we just utilize it without complicating VPLS transport construction? This also makes interworking with Eth only network easier.

Cheers,
Lucy

-----Original Message-----
From: Rogers, Josh [mailto:[email-masked]]
Sent: Monday, April 16, 2012 8:35 AM
To: Lucy yong; Henderickx, Wim (Wim); [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: RE: The status of the approaches to the E-Tree solution?

I believe the initial question was in regard to the CW method.  Are you saying that you no longer are interested in that method in preference of the dual vlan method?

Lucy yong <[email-masked]> wrote:

Agree with Wim. VLAN approach is the best solution for E-Tree.

Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, April 12, 2012 2:03 AM
To: [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: Re: The status of the approaches to the E-Tree solution?

The vlan approach is superior as it also works for eth only networks, etc. On top some vendors indicate hw issues with the cw approach. As such we have dropped more or less the cw approach.

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein <[email-masked]>
Cc: [email-masked] <[email-masked]>; Vladimir Kleiner <[email-masked]>; Andrew Sergeev <[email-masked]>; Idan Kaspit <[email-masked]>; Mishael Wexler <[email-masked]>; Rotem Cohen <[email-masked]>
Subject: Re: The status of the approaches to the E-Tree solution?

Sorry - the "anonymous presentation" was mine.  I should possibly have put
in a third column on the CW approach.  And hopefully the minutes will be
posted soon.

We had various discussions, as Simon stated, and consensus seemed to be
forming around the two alternatives of two PWEs or two VLANs.  I believe
three of the authors of the CW approach are also authors of the two VLAN
approach and one is also an author of the two PWE approach. So perhaps it's
best to let those four individuals say which approach they prefer and why?

Giles

On 10/04/2012 00:45, "Simon Delord" <[email-masked]> wrote:

> Hi Alexander,
>
> You are right, no discussion on the WG mailing list recently, but there
> have been substantial discussions among the authors of various solution
> drafts off the mailing list. As far as I know, no consensus yet before
> ietf83, not sure the progress in the Paris WG meeting. I think the CW
> approach has not been rejected by the WG yet, or the WG has not yet decided
> on which one to adopt.
>
> Simon
>
> 2012/4/8 Alexander Vainshtein <[email-masked]>
>
>>  Hi all,
>>
>> Unfortunately I have not been able to attend the Paris IETF.
>>
>> However, looking up the L2VPN proceedings, I've found a short anonymous
>> presentation called "E-Tree Update"  (
>> http://www.ietf.org/proceedings/83/slides/slides-83-l2vpn-1.pptx). This
>> presentation discusses the differences of the E-Tree approaches based on
>> dedicated VLANs (as in
>> http://datatracker.ietf.org/doc/draft-cao-l2vpn-vpls-etree/?include_text=1)
>> and multiple PWs between the PEs (as in
>> http://datatracker.ietf.org/doc/draft-ram-l2vpn-etree-multiple-pw/?include_te
>> xt=1)
>> and completely ignores the solution based on usage of the CW in the PWs
>> connecting the PEs (as in
>> http://datatracker.ietf.org/doc/draft-key-l2vpn-vpls-etree/?include_text=1
>> ).
>>
>>
>>
>> The Minutes of the Paris L2VPN session are not yet available, but I wonder
>> whether the WG has taken a decision to reject the approach based on the CW
>> usage? I do not remember any recent discussion of this topic on the WG
>> mailing list.
>>
>>
>>
>> Regards, and lots of thanks in advance,
>>
>> Sasha
>>
>>
>>
>>
>>
>> This e-mail message is intended for the recipient only and contains
>> information which is CONFIDENTIAL and which may be proprietary to ECI
>> Telecom. If you have received this transmission in error, please inform us
>> by e-mail, phone or fax, and then delete the original and all copies
>> thereof.
>>

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

------------------------------

Message: 3
Date: Mon, 16 Apr 2012 21:38:51 +0000
From: Lucy yong <[email-masked]>
To: Daniel Cohn <[email-masked]>, "Rogers, Josh"
        <[email-masked]>, "Henderickx, Wim (Wim)"
        <[email-masked]>, "[email-masked]"
        <[email-masked]>,        "[email-masked]"
        <[email-masked]>,       "[email-masked]"
        <[email-masked]>
Cc: "[email-masked]" <[email-masked]>,  "[email-masked]"
        <[email-masked]>, "[email-masked]"
        <[email-masked]>,   "[email-masked]"
        <[email-masked]>,      "[email-masked]"
        <[email-masked]>,   "[email-masked]"
        <[email-masked]>
Subject: RE: The status of the approaches to the E-Tree solution?
Message-ID: <2691CE0099834E4A9C5044EEC662BB9D3264A1C0@dfweml505-mbx>
Content-Type: text/plain; charset="utf-8"

Snipped,

As we discussed extensively in the list, and as reflected in giles slide, 2 pws are only needed between pes with both root and leaf acs, which will typically be a small minority.
[[LY]] Don't know if the assumption is true. Even it is the case, both approaches can benefit from it. I was off for a while and captures some discussions now.

Also as per giles slide, dual vlan can have scalability issues due to additional lookup and double use of vlans in internal emulated lan interface. Also there are potential backward compatibility issues with silicon that doesn't support vlan mapping.
[[LY]] I was not in IETF83 meeting and wait on the meeting minutes. I am not clear on all the issues. Could you be more specific? As I mentioned in below, two PW approach makes VPLS transport construction and packet forwarding more complex, I can see potential backward compatibility issues with 2 PW solution.

Regards,
Lucy

Regards,

Daniel

Thumb typed - please be tolerant

Lucy yong <[email-masked]> wrote:

In my mind, the VLAN approach means dual vlan method.

The main concern for CW approach is hardware support.

Two PW approach can be complex too if the VPLS instance for E-Tree uses P2P PW for unicast traffic and P2MP PW for broadcast and unknown unicast traffic, and some P2MP PWs for multicast traffic. It may double all of them.

E-tree is an Ethernet service and there is already VLAN based solution in IEEE, can we just utilize it without complicating VPLS transport construction? This also makes interworking with Eth only network easier.

Cheers,
Lucy

-----Original Message-----
From: Rogers, Josh [mailto:[email-masked]]
Sent: Monday, April 16, 2012 8:35 AM
To: Lucy yong; Henderickx, Wim (Wim); [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: RE: The status of the approaches to the E-Tree solution?

I believe the initial question was in regard to the CW method.  Are you saying that you no longer are interested in that method in preference of the dual vlan method?

Lucy yong <[email-masked]> wrote:

Agree with Wim. VLAN approach is the best solution for E-Tree.

Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, April 12, 2012 2:03 AM
To: [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: Re: The status of the approaches to the E-Tree solution?

The vlan approach is superior as it also works for eth only networks, etc. On top some vendors indicate hw issues with the cw approach. As such we have dropped more or less the cw approach.

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein <[email-masked]>
Cc: [email-masked] <[email-masked]>; Vladimir Kleiner <[email-masked]>; Andrew Sergeev <[email-masked]>; Idan Kaspit <[email-masked]>; Mishael Wexler <[email-masked]>; Rotem Cohen <[email-masked]>
Subject: Re: The status of the approaches to the E-Tree solution?

Sorry - the "anonymous presentation" was mine.  I should possibly have put
in a third column on the CW approach.  And hopefully the minutes will be
posted soon.

We had various discussions, as Simon stated, and consensus seemed to be
forming around the two alternatives of two PWEs or two VLANs.  I believe
three of the authors of the CW approach are also authors of the two VLAN
approach and one is also an author of the two PWE approach. So perhaps it's
best to let those four individuals say which approach they prefer and why?

Giles

On 10/04/2012 00:45, "Simon Delord" <[email-masked]> wrote:

> Hi Alexander,
>
> You are right, no discussion on the WG mailing list recently, but there
> have been substantial discussions among the authors of various solution
> drafts off the mailing list. As far as I know, no consensus yet before
> ietf83, not sure the progress in the Paris WG meeting. I think the CW
> approach has not been rejected by the WG yet, or the WG has not yet decided
> on which one to adopt.
>
> Simon
>
> 2012/4/8 Alexander Vainshtein <[email-masked]>
>
>>  Hi all,
>>
>> Unfortunately I have not been able to attend the Paris IETF.
>>
>> However, looking up the L2VPN proceedings, I've found a short anonymous
>> presentation called "E-Tree Update"  (
>> http://www.ietf.org/proceedings/83/slides/slides-83-l2vpn-1.pptx). This
>> presentation discusses the differences of the E-Tree approaches based on
>> dedicated VLANs (as in
>> http://datatracker.ietf.org/doc/draft-cao-l2vpn-vpls-etree/?include_text=1)
>> and multiple PWs between the PEs (as in
>> http://datatracker.ietf.org/doc/draft-ram-l2vpn-etree-multiple-pw/?include_te
>> xt=1)
>> and completely ignores the solution based on usage of the CW in the PWs
>> connecting the PEs (as in
>> http://datatracker.ietf.org/doc/draft-key-l2vpn-vpls-etree/?include_text=1
>> ).
>>
>>
>>
>> The Minutes of the Paris L2VPN session are not yet available, but I wonder
>> whether the WG has taken a decision to reject the approach based on the CW
>> usage? I do not remember any recent discussion of this topic on the WG
>> mailing list.
>>
>>
>>
>> Regards, and lots of thanks in advance,
>>
>> Sasha
>>
>>
>>
>>
>>
>> This e-mail message is intended for the recipient only and contains
>> information which is CONFIDENTIAL and which may be proprietary to ECI
>> Telecom. If you have received this transmission in error, please inform us
>> by e-mail, phone or fax, and then delete the original and all copies
>> thereof.
>>

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

------------------------------

Message: 4
Date: Tue, 17 Apr 2012 11:56:29 +0300
From: "Daniel Cohn" <[email-masked]>
To: "Lucy yong" <[email-masked]>, "Rogers, Josh"
        <[email-masked]>,      "Henderickx, Wim (Wim)"
        <[email-masked]>,    <[email-masked]>,
        <[email-masked]>,       <[email-masked]>, "Sam
        Cao" <[email-masked]>
Cc: [email-masked], [email-masked],
        [email-masked],     [email-masked],
        [email-masked],     [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?
Message-ID: <44F4E579A764584EA9BDFD07D0CA081307510E14@tlvmail1>
Content-Type: text/plain;       charset="us-ascii"

Adding Sam (as l2vpn@ is holding messages)

DC

-----Original Message-----
From: Lucy yong [mailto:[email-masked]]
Sent: Tuesday, April 17, 2012 12:39 AM
To: Daniel Cohn; Rogers, Josh; Henderickx, Wim (Wim);
[email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?

Snipped,

As we discussed extensively in the list, and as reflected in giles
slide, 2 pws are only needed between pes with both root and leaf acs,
which will typically be a small minority.
[[LY]] Don't know if the assumption is true. Even it is the case, both
approaches can benefit from it. I was off for a while and captures some
discussions now.

Also as per giles slide, dual vlan can have scalability issues due to
additional lookup and double use of vlans in internal emulated lan
interface. Also there are potential backward compatibility issues with
silicon that doesn't support vlan mapping.
[[LY]] I was not in IETF83 meeting and wait on the meeting minutes. I am
not clear on all the issues. Could you be more specific? As I mentioned
in below, two PW approach makes VPLS transport construction and packet
forwarding more complex, I can see potential backward compatibility
issues with 2 PW solution.

Regards,
Lucy

Regards,

Daniel

Thumb typed - please be tolerant

Lucy yong <[email-masked]> wrote:

In my mind, the VLAN approach means dual vlan method.

The main concern for CW approach is hardware support.

Two PW approach can be complex too if the VPLS instance for E-Tree uses
P2P PW for unicast traffic and P2MP PW for broadcast and unknown unicast
traffic, and some P2MP PWs for multicast traffic. It may double all of
them.

E-tree is an Ethernet service and there is already VLAN based solution
in IEEE, can we just utilize it without complicating VPLS transport
construction? This also makes interworking with Eth only network easier.

Cheers,
Lucy

-----Original Message-----
From: Rogers, Josh [mailto:[email-masked]]
Sent: Monday, April 16, 2012 8:35 AM
To: Lucy yong; Henderickx, Wim (Wim); [email-masked]';
[email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]';
[email-masked]'; [email-masked]';
[email-masked]'; [email-masked]'
Subject: RE: The status of the approaches to the E-Tree solution?

I believe the initial question was in regard to the CW method.  Are you
saying that you no longer are interested in that method in preference of
the dual vlan method?

Lucy yong <[email-masked]> wrote:

Agree with Wim. VLAN approach is the best solution for E-Tree.

Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Henderickx, Wim (Wim)
Sent: Thursday, April 12, 2012 2:03 AM
To: [email-masked]'; [email-masked]';
[email-masked]'
Cc: [email-masked]'; [email-masked]';
[email-masked]'; [email-masked]';
[email-masked]'; [email-masked]'
Subject: Re: The status of the approaches to the E-Tree solution?

The vlan approach is superior as it also works for eth only networks,
etc. On top some vendors indicate hw issues with the cw approach. As
such we have dropped more or less the cw approach.

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein
<[email-masked]>
Cc: [email-masked] <[email-masked]>; Vladimir Kleiner
<[email-masked]>; Andrew Sergeev
<[email-masked]>; Idan Kaspit <[email-masked]>;
Mishael Wexler <[email-masked]>; Rotem Cohen
<[email-masked]>
Subject: Re: The status of the approaches to the E-Tree solution?

Sorry - the "anonymous presentation" was mine.  I should possibly have
put in a third column on the CW approach.  And hopefully the minutes
will be posted soon.

We had various discussions, as Simon stated, and consensus seemed to be
forming around the two alternatives of two PWEs or two VLANs.  I believe
three of the authors of the CW approach are also authors of the two VLAN
approach and one is also an author of the two PWE approach. So perhaps
it's best to let those four individuals say which approach they prefer
and why?

Giles

On 10/04/2012 00:45, "Simon Delord" <[email-masked]> wrote:

> Hi Alexander,
>
> You are right, no discussion on the WG mailing list recently, but
> there have been substantial discussions among the authors of various
> solution drafts off the mailing list. As far as I know, no consensus
> yet before ietf83, not sure the progress in the Paris WG meeting. I
> think the CW approach has not been rejected by the WG yet, or the WG
> has not yet decided on which one to adopt.
>
> Simon
>
> 2012/4/8 Alexander Vainshtein <[email-masked]>
>
>>  Hi all,
>>
>> Unfortunately I have not been able to attend the Paris IETF.
>>
>> However, looking up the L2VPN proceedings, I've found a short
>> anonymous presentation called "E-Tree Update"  (
>> http://www.ietf.org/proceedings/83/slides/slides-83-l2vpn-1.pptx).
>> This presentation discusses the differences of the E-Tree approaches
>> based on dedicated VLANs (as in
>> http://datatracker.ietf.org/doc/draft-cao-l2vpn-vpls-etree/?include_t
>> ext=1) and multiple PWs between the PEs (as in
>> http://datatracker.ietf.org/doc/draft-ram-l2vpn-etree-multiple-pw/?in
>> clude_te
>> xt=1)
>> and completely ignores the solution based on usage of the CW in the
>> PWs connecting the PEs (as in
>> http://datatracker.ietf.org/doc/draft-key-l2vpn-vpls-etree/?include_t
>> ext=1
>> ).
>>
>>
>>
>> The Minutes of the Paris L2VPN session are not yet available, but I
>> wonder whether the WG has taken a decision to reject the approach
>> based on the CW usage? I do not remember any recent discussion of
>> this topic on the WG mailing list.
>>
>>
>>
>> Regards, and lots of thanks in advance,
>>
>> Sasha
>>
>>
>>
>>
>>
>> This e-mail message is intended for the recipient only and contains
>> information which is CONFIDENTIAL and which may be proprietary to ECI

>> Telecom. If you have received this transmission in error, please
>> inform us by e-mail, phone or fax, and then delete the original and
>> all copies thereof.
>>

This E-mail and any of its attachments may contain Time Warner Cable
proprietary information, which is privileged, confidential, or subject
to copyright belonging to Time Warner Cable. This E-mail is intended
solely for the use of the individual or entity to which it is addressed.
If you are not the intended recipient of this E-mail, you are hereby
notified that any dissemination, distribution, copying, or action taken
in relation to the contents of and attachments to this E-mail is
strictly prohibited and may be unlawful. If you have received this
E-mail in error, please notify the sender immediately and permanently
delete the original and any copy of this E-mail and any printout.

------------------------------

_______________________________________________
L2vpn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l2vpn

End of L2vpn Digest, Vol 95, Issue 20
*************************************

---

From: "Daniel Cohn" <[email-masked]>
Date: Thu, 19 Apr 2012 22:24:00 +0300

Hi Sasha, 

Both solutions include the leaf-only information in the bgp extension

Alexander Vainshtein <[email-masked]> wrote:

Josh,
Lots of thanks for a prompt response.

Yes, of course I consider BGP-AD and fully agree that with BGP-AD (extended to distribute PE state - AFAIK, it is not part of the regular VPLS-related NRLI) the situation becomes manageable.

The question is, can the dual-PW solution manageable without BGP-AD?

Regards,
     Sasha 

________________________________________
From: Rogers, Josh [[email-masked]]
Sent: Thursday, April 19, 2012 8:18 PM
To: Alexander Vainshtein; DelRegno, Christopher N (Nick)
Cc: [email-masked]; Daniel Cohn; Henderickx, Wim (Wim); Lucy yong; Sam Cao
Subject: Re: The status of the approaches to the E-Tree solution?

Sasha,

are you considering a vantage of using BGP-AD, or no?  BGP-AD isn't what
I'd call 'an elaborate' auto discovery.  If BGP signaling is enlisted,
then all PE's are aware of the existence of all other PE's (regardless of
type), even if they don't setup PW to them.

So, for your example, current Leaf PE moves to mixed PE.  As soon as it
does, it updates signaling (presumably via a defined route-target), all
other PE's now know this is a Mixed PE, and set up PW's to it, just the
same as they would if a new PE was added to the instance.

If no signaling is involved, these sorts of changes could be laborious,
but no more than any PE add/remove from an instance.

Thanks,
-Josh

On 4/19/12 12:46 PM, "Alexander Vainshtein"
<[email-masked]> wrote:

>Nick,
>I am probably repeating myself, but please consider the case when a
>Leaf-only PE migrates to a Mix one.
>
>Prior to migration all the other Leaf PEs in this VPN did not need any
>PWs to the migrating one so there is a good chance they did not even know
>of its existence. After migration you need PWs between the migrated PE
>and all these Leaf PEs. This means that the configuration action is not
>local to a migrating PE. (PW teardown is easier, since it is enough for
>one side to initiate it, but with setup you need two to tango:-).
>
>My 2c,
>     Sasha
>
>
>> From: DelRegno, Christopher N (Nick) [mailto:[email-masked]]
>> Sent: Thursday, April 19, 2012 7:38 PM
>> To: Daniel Cohn; Henderickx, Wim (Wim); Alexander Vainshtein; Rogers,
>> Josh; Lucy yong; Sam Cao
>> Cc: [email-masked]
>> No, I don't see a problem with setting up/tearing down a PW when there
>>is
>> a move of the root to leaf nodes or vice versa, assuming the move is
>>based
>> on a provisioning action (e.g. an customer order), not some dynamic
>> bouncing between switches.
>>
>> Nick
>>
>> From: Daniel Cohn [mailto:[email-masked]]
>> Sent: Thursday, April 19, 2012 7:53 AM
>> To: DelRegno, Christopher N (Nick); Henderickx, Wim (Wim); Alexander
>> Vainshtein; Rogers, Josh; Lucy yong; Sam Cao
>> Cc: [email-masked]
>> Nick,
>> Thanks for the feedback. Now, do you see a problem setting up/tearing
>> down a PW when this happens?
>>
>> Daniel
>>
>> From: DelRegno, Christopher N (Nick) [mailto:[email-masked]]
>> Sent: Thursday, April 19, 2012 3:40 PM
>> To: Daniel Cohn; Henderickx, Wim (Wim); Alexander Vainshtein; Rogers,
>> Josh; Lucy yong; Sam Cao
>> Cc: [email-masked]
>> Dan:
>> As the transformation of a PE from Root<-->Mix and Mix<-->Leaf will be
>> driven by our customers, we can't say how often this will or won't
>>occur.  It
>> must be accommodated regardless of perceived rarity.
>>
>> If I use one of our current extremely popular L2VPN services as an
>>example,
>> our customers tend to move their ENNI (e.g. Root) locations constantly,
>> quite frequently to switches which heretofore only contained UNIs (e.g.
>> leaves).
>>
>> Nick
>>
>> Of Daniel Cohn
>> Sent: Thursday, April 19, 2012 4:49 AM
>> To: Henderickx, Wim (Wim); Alexander Vainshtein; Rogers, Josh; Lucy
>>yong;
>> Sam Cao
>> Cc: [email-masked]
>> Hi Wim,
>> That seems to me a non-negligible change to bridge forwarding logic, I
>>think
>> setting up/tearing down the PE is cleaner. I don't expect that
>>leaf-only to
>> root/leaf PE transformations will happen all that often.
>> But I think it's important to clarify that the issue is common to both
>>drafts.
>>
>> DC
>>
>> From: Henderickx, Wim (Wim) [mailto:wim.henderickx@alcatel-
>> lucent.com]
>> Sent: Thursday, April 19, 2012 9:34 AM
>> To: Daniel Cohn; Alexander Vainshtein; Rogers, Josh; Lucy yong; Sam Cao
>> Cc: [email-masked]
>> Daniel, we should discuss this as this is not absolutely required to
>>tear down
>> PW. You can also have an indication in the E-TREE fwd to indicate that
>>the
>> endpoint has no leaf and as such avoid sending traffic down but allow
>>the
>> PW to be setup. As such we have some flexibility such that operators can
>> select the proper approach they would like to have/implement.
>>
>> From: Daniel Cohn [mailto:[email-masked]]
>> Sent: donderdag 19 april 2012 8:16
>> To: Alexander Vainshtein; Henderickx, Wim (Wim); Rogers, Josh; Lucy
>>yong;
>> Sam Cao
>> Cc: [email-masked]
>> Hi Sasha and all,
>> You have exactly the same "problem" in the 2-VLAN approach - quoting
>> from the draft:
>>
>> 6. LDP Extensions for E-Tree Support
>> <snip>
>> P is a Leaf-only bit, it is set to 1 to indicate that the PE is
>>attached with only
>> leaves, and set to 0 otherwise.
>> <snip>
>> If the P bit is set, then:
>>
>>       {
>>
>>           If the PE is a leaf-only node itself, then a label release
>>       message with the error code "Leaf to Leaf PW error" is sent to the
>>       peer PE and exit the process;
>>
>>
>> So all that you wrote about a leaf-only PE becoming mixed and viceversa
>> applies to both solutions.
>>
>> Regards,
>>
>> Daniel
>>
>> From: Alexander Vainshtein [mailto:[email-masked]]
>> Sent: Thursday, April 19, 2012 8:31 AM
>> To: Henderickx, Wim (Wim); Rogers, Josh; Lucy yong; Daniel Cohn; Sam Cao
>> Cc: [email-masked]
>> Wim,
>> Lots of thanks for a prompt response.
>>
>> I think that operational aspects of the VLAN approach (e.g., how is the
>> Global VID selected and distributed) should be examined in more detail.
>>
>> At the same time it seems that the double PW approach carries with it
>>too
>> many operational problems.
>> E.g., no PWs are set up between Leaf-only PEs, but once one of these
>> becomes a Mix PE, all the Leaf-only PEs must now recognize it as a valid
>> peer. And if a Mix PE reverts to a Leaf only one, all its Leaf-only
>>peers must
>> drop it and shut down the relevant PWs...
>>
>> My 2c,
>>      Sasha
>>
>> ________________________________________
>> From: Henderickx, Wim (Wim) [[email-masked]]
>> Sent: Thursday, April 19, 2012 7:21 AM
>> To: Alexander Vainshtein; Rogers, Josh; Lucy yong; Daniel Cohn; Sam Cao
>> Cc: [email-masked]
>> Sasha, the VLAN approach allows for a similar operation as the CW does.
>> It is orthogonal to the underlying PW deployment of VPLS.
>>
>> Of Alexander Vainshtein
>> Sent: donderdag 19 april 2012 6:39
>> To: Rogers, Josh; Lucy yong; Daniel Cohn; Sam Cao
>> Cc: [email-masked]
>> I fully understand that that what I am going to say is not very popular,
>> but:
>>
>> IMO one of the advantages of the CW-based solution is that it is
>>orthogonal
>> to usage (or non-usage) of P2MP PWs for effective delivery of BUN
>>traffic.
>>
>> Another advantage is preservation of full mesh of P2P PWs in a VPLS,
>>and, in
>> a more generic way, localization of effects of changes in the PE
>> configuration.
>>
>> In particular, adding a Leaf AC to a PE that previously has been only
>> supporting Root ACs (or vice versa), removal of the last Leaf or last
>>Root AC
>> from a PE that previously has been supporting a mix etc. affect only
>>the PE
>> where this operation happens and not the rest of the PEs.
>>
>> As for the need for HW changes that have been mentioned as a main
>> disadvantage of the CW-based approach - I believe it strongly depends on
>> specific implementations. And some changes in the forwarding process are
>> required in any solution.
>>
>> My 2c,
>>      Sasha
>>
>>
>>
>> ________________________________________
>> From: [email-masked] [[email-masked]] on behalf of
>> Rogers, Josh [[email-masked]]
>> Sent: Wednesday, April 18, 2012 9:57 PM
>> To: Lucy yong; Daniel Cohn; Sam Cao
>> Cc: [email-masked]
>> Again, the P2MP situation throws me.  Is this something that is used
>> commonly?
>>
>> I'm under the impression that adding P2MP to any model results in a more
>> complex model.  Wether outside s-tag is used to differentiate, or
>>dedicated
>> pw's are used for the same purpose, it seems both become more complex.
>>
>> Gile's comparison slide still concisely captures the differences between
>> these methods, in my opinion.  I haven't seen any new ideas or thoughts
>> brought to the group in the past week or two on the subject.  I would
>>hate
>> for both proposed methods to die on the vine because we couldn't decide
>> between two methods that have nothing inherently wrong with either.
>>
>> -Josh
>>
>>
>> On 4/18/12 1:53 PM, "Lucy yong" <[email-masked]> wrote:
>>
>> >Send this again.
>> >
>> >P2P PW for unicast traffic and P2MP PW for broadcast and unknown
>> >unicast traffic, and some P2MP PWs for multicast traffic. It may double
>> >all of them.
>> >
>> >Lucy
>> >
>> >From: Daniel Cohn [mailto:[email-masked]]
>> >Sent: Wednesday, April 18, 2012 1:42 PM
>> >To: Lucy yong; Rogers, Josh; Sam Cao
>> >Cc: [email-masked]
>> >I think the first option its the natural way to go. How is the
>> processing
>> >in this case more complex?
>> >
>> >Snipped..
>> >Multi-PW - On ingress PE, frame is placed onto either a Leaf-only P2MP
>> PW
>> >(for traffic coming from a leaf AC), or onto a Root/Leaf P2MP PW (for
>> >traffic coming from a root AC) [[LY]] Not that simple. You construct
>> >either two P2MP PWs to all other PEs and let egress PE performing
>> >filtering, or construct one P2MP PW to leaf-only PEs and two P2MP PWs
>> >to root and leaf PEs and let ingress PE perform forwarding and
>> >filtering. Both make node process complex.
>> >
>> >[[LY]] VPLS is built with the mechanism utilizing P2P and P2MP PW for
>> >delivering the frames to remote PEs. We should utilize them with the
>> >minimized changes. Dual VLAN solution is simpler than Dual PW.
>> >
>> >Regards,
>> >Lucy
>> >
>> >
>> >I see how 2VLAN is simpler when P2MP PW's are involved, I think.  I
>> >haven't had any first hand experience with P2MP PW's, however, so don't
>> >feel terribly strong about this objection.  Is this a real problem for
>> >others (now or in the future), or is this objection in the weeds?
>> >
>> >I'm not sure the 'additional complexity' is notable, or even relevant.
>> I
>> >encourage others to speak up if they disagree, as P2MP PW is only
>> >conceptual to me, and I am unfamiliar with real-life use cases for it.
>> >
>> >Thanks,
>> >Josh
>> >
>> >
>> >
>> >On 4/18/12 10:30 AM, "Lucy yong" <[email-masked]> wrote:
>> >
>> >>Please see inline.
>> >>
>> >>From: Sam Cao [mailto:[email-masked]]
>> >>Sent: Tuesday, April 17, 2012 7:14 AM
>> >>To: 'Daniel Cohn'; Lucy yong; 'Rogers, Josh'; 'Henderickx, Wim (Wim)';
>> >>Yes, 2 pws are only needed between pes with both root and leaf acs
>> after
>> >>improving Dual-PW approach. If consider P2MP, Dual-PW approach setup
>> 2
>> >>P2MP PWs if need. There is no difference between P2MP or normal PW
>> >>setup.
>> But,
>> >>can Leaf-ACs be bound to Root PE of P2MP PW?
>> >>
>> >>[[LY]] No, it makes complex in setting up P2MP PW. Should a PE with
>> both
>> >>root and leaf ACs set up two or one P2MP PW to other PEs (some PE have
>> >>both root and leaf AC and some only have leaf ACs)?
>> >>Regards,
>> >>Lucy
>> >>
>> >>Regards,
>> >>
>> >>Yuqun (Sam) Cao
>> >>E-mail: [email-masked]
>> >>
>> >>
>> >>From: Daniel Cohn [mailto:[email-masked]]
>> >>Sent: Tuesday, April 17, 2012 4:56 PM
>> >>To: Lucy yong; Rogers, Josh; Henderickx, Wim (Wim);
>> >>[email-masked]; Sam Cao
>> to
>> >copyright belonging to Time Warner Cable. This E-mail is intended
>> solely
>> >for the use of the individual or entity to which it is addressed. If
>> you
>> >are not the intended recipient of this E-mail, you are hereby notified
>> >that any dissemination, distribution, copying, or action taken in
>> >relation to the contents of and attachments to this E-mail is strictly
>> >prohibited and may be unlawful. If you have received this E-mail in
>> >error, please notify the sender immediately and permanently delete the
>> >original and any copy of this E-mail and any printout.
>>
>>
>>to
>> copyright belonging to Time Warner Cable. This E-mail is intended
>>solely for
>> the use of the individual or entity to which it is addressed.
>>notified
>> that any dissemination, distribution, copying, or action taken in
>>relation to
>> the contents of and attachments to this E-mail is strictly prohibited
>>and may
>> be unlawful. If you have received this E-mail in error, please notify
>>the
>> sender immediately and permanently delete the original and any copy of
>> this E-mail and any printout.
>> Telecom. If you have received this transmission in error, please inform
>>us by
>> e-mail, phone or fax, and then delete the original and all copies
>>thereof.
>> Telecom. If you have received this transmission in error, please inform
>>us by
>> e-mail, phone or fax, and then delete the original and all copies
>>thereof.
>
>
>Telecom. If you have received this transmission in error, please inform
>us by e-mail, phone or fax, and then delete the original and all copies
>thereof.
>

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.
This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.