Subject: RE: The status of the approaches to the E-Tree solution?

From: "Daniel Cohn" <[email-masked]>
Date: Tue, 17 Apr 2012 00:08:02 +0300

Hi lucy,

As we discussed extensively in the list, and as reflected in giles slide, 2 pws are only needed between pes with both root and leaf acs, which will typically be a small minority.
Also as per giles slide, dual vlan can have scalability issues due to additional lookup and double use of vlans in internal emulated lan interface. Also there are potential backward compatibility issues with silicon that doesn't support vlan mapping.

Regards,

Daniel

Thumb typed - please be tolerant

Lucy yong <[email-masked]> wrote:

In my mind, the VLAN approach means dual vlan method.

The main concern for CW approach is hardware support.

Two PW approach can be complex too if the VPLS instance for E-Tree uses P2P PW for unicast traffic and P2MP PW for broadcast and unknown unicast traffic, and some P2MP PWs for multicast traffic. It may double all of them.

E-tree is an Ethernet service and there is already VLAN based solution in IEEE, can we just utilize it without complicating VPLS transport construction? This also makes interworking with Eth only network easier.

Cheers,
Lucy

-----Original Message-----
From: Rogers, Josh [mailto:[email-masked]] 
Sent: Monday, April 16, 2012 8:35 AM
To: Lucy yong; Henderickx, Wim (Wim); [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: RE: The status of the approaches to the E-Tree solution?

I believe the initial question was in regard to the CW method.  Are you saying that you no longer are interested in that method in preference of the dual vlan method?

Lucy yong <[email-masked]> wrote:

Agree with Wim. VLAN approach is the best solution for E-Tree.

Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, April 12, 2012 2:03 AM
To: [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: Re: The status of the approaches to the E-Tree solution?

The vlan approach is superior as it also works for eth only networks, etc. On top some vendors indicate hw issues with the cw approach. As such we have dropped more or less the cw approach.

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein <[email-masked]>
Cc: [email-masked] <[email-masked]>; Vladimir Kleiner <[email-masked]>; Andrew Sergeev <[email-masked]>; Idan Kaspit <[email-masked]>; Mishael Wexler <[email-masked]>; Rotem Cohen <[email-masked]>
Subject: Re: The status of the approaches to the E-Tree solution?

Sorry - the "anonymous presentation" was mine.  I should possibly have put
in a third column on the CW approach.  And hopefully the minutes will be
posted soon.

We had various discussions, as Simon stated, and consensus seemed to be
forming around the two alternatives of two PWEs or two VLANs.  I believe
three of the authors of the CW approach are also authors of the two VLAN
approach and one is also an author of the two PWE approach. So perhaps it's
best to let those four individuals say which approach they prefer and why?

Giles

On 10/04/2012 00:45, "Simon Delord" <[email-masked]> wrote:

> Hi Alexander,
>
> You are right, no discussion on the WG mailing list recently, but there
> have been substantial discussions among the authors of various solution
> drafts off the mailing list. As far as I know, no consensus yet before
> ietf83, not sure the progress in the Paris WG meeting. I think the CW
> approach has not been rejected by the WG yet, or the WG has not yet decided
> on which one to adopt.
>
> Simon
>
> 2012/4/8 Alexander Vainshtein <[email-masked]>
>
>>  Hi all,
>>
>> Unfortunately I have not been able to attend the Paris IETF.
>>
>> However, looking up the L2VPN proceedings, I've found a short anonymous
>> presentation called "E-Tree Update"  (
>> http://www.ietf.org/proceedings/83/slides/slides-83-l2vpn-1.pptx). This
>> presentation discusses the differences of the E-Tree approaches based on
>> dedicated VLANs (as in
>> http://datatracker.ietf.org/doc/draft-cao-l2vpn-vpls-etree/?include_text=1)
>> and multiple PWs between the PEs (as in
>> http://datatracker.ietf.org/doc/draft-ram-l2vpn-etree-multiple-pw/?include_te
>> xt=1)
>> and completely ignores the solution based on usage of the CW in the PWs
>> connecting the PEs (as in
>> http://datatracker.ietf.org/doc/draft-key-l2vpn-vpls-etree/?include_text=1
>> ).
>>
>>
>>
>> The Minutes of the Paris L2VPN session are not yet available, but I wonder
>> whether the WG has taken a decision to reject the approach based on the CW
>> usage? I do not remember any recent discussion of this topic on the WG
>> mailing list.
>>
>>
>>
>> Regards, and lots of thanks in advance,
>>
>> Sasha
>>
>>
>>
>>
>>
>> This e-mail message is intended for the recipient only and contains
>> information which is CONFIDENTIAL and which may be proprietary to ECI
>> Telecom. If you have received this transmission in error, please inform us
>> by e-mail, phone or fax, and then delete the original and all copies
>> thereof.
>>

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Lucy yong <[email-masked]>
Date: Mon, 16 Apr 2012 21:38:51 +0000

Snipped,

As we discussed extensively in the list, and as reflected in giles slide, 2 pws are only needed between pes with both root and leaf acs, which will typically be a small minority.
[[LY]] Don't know if the assumption is true. Even it is the case, both approaches can benefit from it. I was off for a while and captures some discussions now. 

Also as per giles slide, dual vlan can have scalability issues due to additional lookup and double use of vlans in internal emulated lan interface. Also there are potential backward compatibility issues with silicon that doesn't support vlan mapping.
[[LY]] I was not in IETF83 meeting and wait on the meeting minutes. I am not clear on all the issues. Could you be more specific? As I mentioned in below, two PW approach makes VPLS transport construction and packet forwarding more complex, I can see potential backward compatibility issues with 2 PW solution. 

Regards,
Lucy

Regards,

Daniel

Cheers,
Lucy

-----Original Message-----
From: Rogers, Josh [mailto:[email-masked]] 
Sent: Monday, April 16, 2012 8:35 AM
To: Lucy yong; Henderickx, Wim (Wim); [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: RE: The status of the approaches to the E-Tree solution?

Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, April 12, 2012 2:03 AM
To: [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: Re: The status of the approaches to the E-Tree solution?

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein <[email-masked]>
Cc: [email-masked] <[email-masked]>; Vladimir Kleiner <[email-masked]>; Andrew Sergeev <[email-masked]>; Idan Kaspit <[email-masked]>; Mishael Wexler <[email-masked]>; Rotem Cohen <[email-masked]>
Subject: Re: The status of the approaches to the E-Tree solution?

Giles

---

From: "Daniel Cohn" <[email-masked]>
Date: Tue, 17 Apr 2012 11:56:29 +0300

Adding Sam (as l2vpn@ is holding messages)

DC 

-----Original Message-----
From: Lucy yong [mailto:[email-masked]] 
Sent: Tuesday, April 17, 2012 12:39 AM
To: Daniel Cohn; Rogers, Josh; Henderickx, Wim (Wim);
[email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?

Snipped,

As we discussed extensively in the list, and as reflected in giles
slide, 2 pws are only needed between pes with both root and leaf acs,
which will typically be a small minority.
[[LY]] Don't know if the assumption is true. Even it is the case, both
approaches can benefit from it. I was off for a while and captures some
discussions now. 

Also as per giles slide, dual vlan can have scalability issues due to
additional lookup and double use of vlans in internal emulated lan
interface. Also there are potential backward compatibility issues with
silicon that doesn't support vlan mapping.
[[LY]] I was not in IETF83 meeting and wait on the meeting minutes. I am
not clear on all the issues. Could you be more specific? As I mentioned
in below, two PW approach makes VPLS transport construction and packet
forwarding more complex, I can see potential backward compatibility
issues with 2 PW solution. 

Regards,
Lucy

Regards,

Daniel

Two PW approach can be complex too if the VPLS instance for E-Tree uses
P2P PW for unicast traffic and P2MP PW for broadcast and unknown unicast
traffic, and some P2MP PWs for multicast traffic. It may double all of
them.

E-tree is an Ethernet service and there is already VLAN based solution
in IEEE, can we just utilize it without complicating VPLS transport
construction? This also makes interworking with Eth only network easier.

Cheers,
Lucy

-----Original Message-----
From: Rogers, Josh [mailto:[email-masked]]
Sent: Monday, April 16, 2012 8:35 AM
To: Lucy yong; Henderickx, Wim (Wim); [email-masked]';
[email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]';
[email-masked]'; [email-masked]';
[email-masked]'; [email-masked]'
Subject: RE: The status of the approaches to the E-Tree solution?

I believe the initial question was in regard to the CW method.  Are you
saying that you no longer are interested in that method in preference of
the dual vlan method?

Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Henderickx, Wim (Wim)
Sent: Thursday, April 12, 2012 2:03 AM
To: [email-masked]'; [email-masked]';
[email-masked]'
Cc: [email-masked]'; [email-masked]';
[email-masked]'; [email-masked]';
[email-masked]'; [email-masked]'
Subject: Re: The status of the approaches to the E-Tree solution?

The vlan approach is superior as it also works for eth only networks,
etc. On top some vendors indicate hw issues with the cw approach. As
such we have dropped more or less the cw approach.

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein
<[email-masked]>
Cc: [email-masked] <[email-masked]>; Vladimir Kleiner
<[email-masked]>; Andrew Sergeev
<[email-masked]>; Idan Kaspit <[email-masked]>;
Mishael Wexler <[email-masked]>; Rotem Cohen
<[email-masked]>
Subject: Re: The status of the approaches to the E-Tree solution?

Sorry - the "anonymous presentation" was mine.  I should possibly have
put in a third column on the CW approach.  And hopefully the minutes
will be posted soon.

We had various discussions, as Simon stated, and consensus seemed to be
forming around the two alternatives of two PWEs or two VLANs.  I believe
three of the authors of the CW approach are also authors of the two VLAN
approach and one is also an author of the two PWE approach. So perhaps
it's best to let those four individuals say which approach they prefer
and why?

Giles

On 10/04/2012 00:45, "Simon Delord" <[email-masked]> wrote:

> Hi Alexander,
>
> You are right, no discussion on the WG mailing list recently, but 
> there have been substantial discussions among the authors of various 
> solution drafts off the mailing list. As far as I know, no consensus 
> yet before ietf83, not sure the progress in the Paris WG meeting. I 
> think the CW approach has not been rejected by the WG yet, or the WG 
> has not yet decided on which one to adopt.
>
> Simon
>
>> However, looking up the L2VPN proceedings, I've found a short 
>> anonymous presentation called "E-Tree Update"  ( 
>> http://www.ietf.org/proceedings/83/slides/slides-83-l2vpn-1.pptx). 
>> This presentation discusses the differences of the E-Tree approaches 
>> based on dedicated VLANs (as in
>> http://datatracker.ietf.org/doc/draft-cao-l2vpn-vpls-etree/?include_t
>> ext=1) and multiple PWs between the PEs (as in 
>> and completely ignores the solution based on usage of the CW in the 
>> PWs connecting the PEs (as in
>> The Minutes of the Paris L2VPN session are not yet available, but I 
>> wonder whether the WG has taken a decision to reject the approach 
>> based on the CW usage? I do not remember any recent discussion of 
>> this topic on the WG mailing list.
>>
>>
>>

>> Telecom. If you have received this transmission in error, please 
>> inform us by e-mail, phone or fax, and then delete the original and 
>> all copies thereof.
>>

This E-mail and any of its attachments may contain Time Warner Cable
proprietary information, which is privileged, confidential, or subject
to copyright belonging to Time Warner Cable. This E-mail is intended
solely for the use of the individual or entity to which it is addressed.
If you are not the intended recipient of this E-mail, you are hereby
notified that any dissemination, distribution, copying, or action taken
in relation to the contents of and attachments to this E-mail is
strictly prohibited and may be unlawful. If you have received this
E-mail in error, please notify the sender immediately and permanently
delete the original and any copy of this E-mail and any printout.

---

From: "Sam Cao" <[email-masked]>
Date: Tue, 17 Apr 2012 19:59:42 +0800

[YL] two PW approach makes VPLS transport construction and packet forwarding
more complex, I can see potential backward compatibility issues with 2 PW
solution.
[Sam] Dual-PW approach uses 2 PW labels to identify frames if need. After
decapsulation (stripe PW label out), bridge will forward the frame to
corresponding ACs with frame type [input, identified by PW label]; Dual-VLAN
approach uses VLAN-ID to identify frames, so after decapsulation, bridge
will stripe S-VLAN ID out then forward the frame to corresponding ACs (We
should integrate S-VLAN ID pop operation into bridge, I think). Considering
forwarding process, both work in similar way. The difference is, Dual-VLAN
approach needs one more POP operation. So, I think Dual-VLAN is a little
complex, maybe not much.

In addition, Dual-PW approach has considered backward compatibility. Please
let us know if we miss something.

BTW, Dual-PW or Dual-VLAN is good solution if there is one or more
Root-Leaf-Mixed PE in E-Tree domain. Mostly there are Root-only and
Leaf-Only in an E-Tree domain, current solutions have supported, but
configuration is complex. Dual-VLAN still uses traditional configuration,
but Dual-PW approach does NOT setup PW between Leaf-only PEs, so Dual-PW
approach breaks communication between Leaf-Only PEs natively, but Dual-VLAN
can not.

Regards,
 
Yuqun (Sam) Cao
E-mail: [email-masked] 
 
-----Original Message-----
From: Daniel Cohn [mailto:[email-masked]] 
Sent: Tuesday, April 17, 2012 4:56 PM
To: Lucy yong; Rogers, Josh; Henderickx, Wim (Wim); [email-masked];
[email-masked]; [email-masked]; Sam Cao

DC 

-----Original Message-----
From: Lucy yong [mailto:[email-masked]] 
Sent: Tuesday, April 17, 2012 12:39 AM
To: Daniel Cohn; Rogers, Josh; Henderickx, Wim (Wim);

Snipped,

Regards,
Lucy

Regards,

Daniel

Cheers,
Lucy

-----Original Message-----
From: Rogers, Josh [mailto:[email-masked]]
Sent: Monday, April 16, 2012 8:35 AM
To: Lucy yong; Henderickx, Wim (Wim); [email-masked]';

Lucy

-----Original Message-----

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein

Giles

---

From: "Sam Cao" <[email-masked]>
Date: Tue, 17 Apr 2012 20:13:50 +0800

Yes, 2 pws are only needed between pes with both root and leaf acs after
improving Dual-PW approach. If consider P2MP, Dual-PW approach setup 2 P2MP
PWs if need. There is no difference between P2MP or normal PW setup. But,
can Leaf-ACs be bound to Root PE of P2MP PW? 

Regards,
 
Yuqun (Sam) Cao

-----Original Message-----
From: Daniel Cohn [mailto:[email-masked]] 
Sent: Tuesday, April 17, 2012 4:56 PM
To: Lucy yong; Rogers, Josh; Henderickx, Wim (Wim); [email-masked];

DC 

-----Original Message-----
From: Lucy yong [mailto:[email-masked]] 
Sent: Tuesday, April 17, 2012 12:39 AM
To: Daniel Cohn; Rogers, Josh; Henderickx, Wim (Wim);

Snipped,

Regards,
Lucy

Regards,

Daniel

Cheers,
Lucy

-----Original Message-----
From: Rogers, Josh [mailto:[email-masked]]
Sent: Monday, April 16, 2012 8:35 AM
To: Lucy yong; Henderickx, Wim (Wim); [email-masked]';

Lucy

-----Original Message-----

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein

Giles

---

From: Lucy yong <[email-masked]>
Date: Wed, 18 Apr 2012 15:30:43 +0000

Please see inline.

-----Original Message-----
From: Sam Cao [mailto:[email-masked]] 
Sent: Tuesday, April 17, 2012 7:14 AM
To: 'Daniel Cohn'; Lucy yong; 'Rogers, Josh'; 'Henderickx, Wim (Wim)'; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?

[[LY]] No, it makes complex in setting up P2MP PW. Should a PE with both root and leaf ACs set up two or one P2MP PW to other PEs (some PE have both root and leaf AC and some only have leaf ACs)? 
Regards,
Lucy

Regards,
 
Yuqun (Sam) Cao

-----Original Message-----
From: Daniel Cohn [mailto:[email-masked]] 
Sent: Tuesday, April 17, 2012 4:56 PM
To: Lucy yong; Rogers, Josh; Henderickx, Wim (Wim); [email-masked];

DC 

-----Original Message-----
From: Lucy yong [mailto:[email-masked]] 
Sent: Tuesday, April 17, 2012 12:39 AM
To: Daniel Cohn; Rogers, Josh; Henderickx, Wim (Wim);

Snipped,

Regards,
Lucy

Regards,

Daniel

Cheers,
Lucy

-----Original Message-----
From: Rogers, Josh [mailto:[email-masked]]
Sent: Monday, April 16, 2012 8:35 AM
To: Lucy yong; Henderickx, Wim (Wim); [email-masked]';

Lucy

-----Original Message-----

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein

Giles

---

From: "Rogers, Josh" <[email-masked]>
Date: Wed, 18 Apr 2012 12:08:08 -0400

Lucy,

Allow me to think out loud here, as the interchange thus far as been
overly terse, and has not helped me understand the issue better.

I believe the answer is two.  To me, this seems like a moot point, as both
methods require the ingress traffic to be encapsulated uniquely based on
the AC type (one applies a root or leaf S-Tag, and the other places the
traffic into a PW purposed for root or leaf traffic).  The defining
difference when considering P2MP PW's, is the decision to forward is being
made at the ingress PE, or the egress PE.

2VLAN - On ingress PE, all frames are forwarded onto P2MP PW on ingress
PE, and at the egress PE a decision to forward out the receiving AC is
made.

Multi-PW - On ingress PE, frame is placed onto either a Leaf-only P2MP PW
(for traffic coming from a leaf AC), or onto a Root/Leaf P2MP PW (for
traffic coming from a root AC)

I see how 2VLAN is simpler when P2MP PW's are involved, I think.  I
haven't had any first hand experience with P2MP PW's, however, so don't
feel terribly strong about this objection.  Is this a real problem for
others (now or in the future), or is this objection in the weeds?

I'm not sure the 'additional complexity' is notable, or even relevant.  I
encourage others to speak up if they disagree, as P2MP PW is only
conceptual to me, and I am unfamiliar with real-life use cases for it.

Thanks,
Josh

On 4/18/12 10:30 AM, "Lucy yong" <[email-masked]> wrote:

>To: 'Daniel Cohn'; Lucy yong; 'Rogers, Josh'; 'Henderickx, Wim (Wim)';
>[[LY]] No, it makes complex in setting up P2MP PW. Should a PE with both
>root and leaf ACs set up two or one P2MP PW to other PEs (some PE have
>both root and leaf AC and some only have leaf ACs)?
>Regards,
>Lucy
>
>Regards,
>
>Yuqun (Sam) Cao

---

From: Lucy yong <[email-masked]>
Date: Wed, 18 Apr 2012 16:29:56 +0000

Snipped..

Multi-PW - On ingress PE, frame is placed onto either a Leaf-only P2MP PW
(for traffic coming from a leaf AC), or onto a Root/Leaf P2MP PW (for
traffic coming from a root AC)
[[LY]] Not that simple. You construct either two P2MP PWs to all other PEs and let egress PE performing filtering, or construct one P2MP PW to leaf-only PEs and two P2MP PWs to root and leaf PEs and let ingress PE perform forwarding and filtering. Both make node process complex.

[[LY]] VPLS is built with the mechanism utilizing P2P and P2MP PW for delivering the frames to remote PEs. We should utilize them with the minimized changes. Dual VLAN solution is simpler than Dual PW.

Regards,
Lucy

Thanks,
Josh