Subject: RE: The status of the approaches to the E-Tree solution?

From: Jiangyuanlong <[email-masked]>
Date: Thu, 26 Apr 2012 01:57:12 +0000

A good analysis of the implication for S-VLAN access. This reminds me of an old email in the mailing list proposing E-Tree over E-Tree. It seems both E-LAN over E-Tree and E-Tree over E-Tree scenarios can be supported with Dual VLAN as you analyzed.

However I am not sure any SP has such requirements yet.

Best Regards,
Yuanlong
----------------------------------------------------------------------

Date: Wed, 25 Apr 2012 17:04:57 -0400
From: David Allan I <[email-masked]>
To: Daniel Cohn <[email-masked]>, "[email-masked]"
	<[email-masked]>
Subject: RE: The status of the approaches to the E-Tree solution?
Message-ID:
	<[email-masked]>
	
Content-Type: text/plain; charset="us-ascii"

OK I feel like I am digressing a fair distance from the actual problem.... But here goes:

So the scenarios center around "how ETREE do you want to be?"....

If the ACs are root/leaf, then if they are P2P (single ethernet end station attached to each AC) this is moot. ETREE semantics are enforced by the 2VID domain in the center of the example. If you assumed nodes A&B in the example were L2VPN PEs, the tagging and the PW tag imposition all happened at the same point in the network.

If they are not simple P2P all the way to end systems and the objective is to avoid bridging between leaf "sites" but allowing intra-leaf-site connectivity then the leaves can be LANs but the root is not, such that I cannot bridge through the root. But all hosts at a given leaf site can see each other. So root Ethernet end systems are directly attached or two VIDs are used in the root site.

If the objective is that there are multiple ethernet attached end stations at both the leaf and root sites, and the objective is to enforce L2 isolation everywhere then I need two VIDs extended to the end system attachement point in the local LANs by whatever means....

And I do not see adding VLANs in any particular spot, simply selection of the VID and associated semantics where VIDs are translated. The actual point of S-tag imposition could be a PE, or cloud be a NID/CLE on the customer prem (more likely scenario here to extend OAM demarc to the prem), or some switch in a RAN downstream of the MPLS PE... blah blah blah. And if ETREE is extended into a customer site LAN and outside of the provider domain, then two C-tags would have to be used that mapped to S-tags at the PBN boundary...

Make sense?
Dave

-----Original Message-----
From: Daniel Cohn [mailto:[email-masked]]
Sent: Wednesday, April 25, 2012 4:39 PM
To: David Allan I; [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?

Dave, but the ACs are root/leaf (that's what the whole vpls etree is about - see the reqt draft), so per the 2vlan draft the root/leaf vlan must be added.

Thumb typed - please be tolerant

David Allan I <[email-masked]> wrote:

HI Daniel:

In the example provided,

"ingress VLAN ID <-> Etree Root/Leaf VID <-> Egress VID"
                  A                       B

the service is not ETREE in the domains of the ingress and egress VID. It is ELAN. SO there is no root/leaf attribute to shovel around. It would require two VIDs in each domain if the ETREE semantics were to be telescoped E2E.

Otherwise it is a provisioning of the VID translation tables at the intermediate nodes (A&B that I've added to the picture) that would determine the VID values used in each domain. Or in the example above, what the ingress, Etree and egress VID values were.

Cheers
Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniel Cohn
Sent: Wednesday, April 25, 2012 3:46 PM
To: Lucy yong; Rogers, Josh; Shahram Davari; Lizhong Jin; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?

And to this I asked how this mapping works - how does the egress pe recover the ingress vid when it gets the frame tagged with only the root/leaf vid? How can you convey the ingress vid plus the root/leaf attribute in the same number of bits?
What am I missing?

Daniel

Thumb typed - please be tolerant

Lucy yong <[email-masked]> wrote:

Daniel,

David Allen already explained the solution.

---

From: Jiangyuanlong <[email-masked]>
Date: Thu, 26 Apr 2012 02:04:21 +0000

Don,

Exactly, that is the intention of the Dual VLAN draft.

Thanks,
Yuanlong

------------------------------
Date: Wed, 25 Apr 2012 16:22:38 -0500
From: "Fedyk, Donald (Don)" <[email-masked]>
To: David Allan I <[email-masked]>, Daniel Cohn
	<[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: The status of the approaches to the E-Tree solution?
Message-ID:
	<[email-masked]>

Hi Dave

Yes the only point I would add is Dual VLAN means One VID for Root and one VID for Leaf. Not two TAGs at a time on the frame but two allocated for the service.

The confusing part is no doubt that Dual PWE/Dual VLAN comparison talks about Encapsulation Overhead as a VLAN Tag. While that is true in a PWE sense it is still a single VLAN Tag at a time in a Ethernet E-tree sense.  The compelling driver for Dual VLAN is having a Etree service that works in many environments and the DUAL VLAN (really dual VLAN interface on a VSI) uses the same mechanism (one VID for root and one VID for Leaf at a time) as specified in the IEEE. In a pure Ethernet bridging world the VLAN TAGs for Etree are not typically an overhead since translation is used.

Don

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David Allan I
Sent: Wednesday, April 25, 2012 5:05 PM
To: Daniel Cohn; [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?

Make sense?
Dave

-----Original Message-----
From: Daniel Cohn [mailto:[email-masked]]
Sent: Wednesday, April 25, 2012 4:39 PM
To: David Allan I; [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?

HI Daniel:

In the example provided,

Cheers
Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniel Cohn
Sent: Wednesday, April 25, 2012 3:46 PM
To: Lucy yong; Rogers, Josh; Shahram Davari; Lizhong Jin; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?

Daniel

Daniel,

--- stipped -----------------