Subject: Re: The status of the approaches to the E-Tree solution?

From: Giles Heron <[email-masked]>
Date: Thu, 12 Apr 2012 07:22:08 +0100

Sorry - the "anonymous presentation" was mine.  I should possibly have put
in a third column on the CW approach.  And hopefully the minutes will be
posted soon.

We had various discussions, as Simon stated, and consensus seemed to be
forming around the two alternatives of two PWEs or two VLANs.  I believe
three of the authors of the CW approach are also authors of the two VLAN
approach and one is also an author of the two PWE approach. So perhaps it's
best to let those four individuals say which approach they prefer and why?

Giles

On 10/04/2012 00:45, "Simon Delord" <[email-masked]> wrote:

> Hi Alexander,
> 
> You are right, no discussion on the WG mailing list recently, but there
> have been substantial discussions among the authors of various solution
> drafts off the mailing list. As far as I know, no consensus yet before
> ietf83, not sure the progress in the Paris WG meeting. I think the CW
> approach has not been rejected by the WG yet, or the WG has not yet decided
> on which one to adopt.
> 
> Simon
> 
> 2012/4/8 Alexander Vainshtein <[email-masked]>
> 
>>  Hi all,
>> 
>> Unfortunately I have not been able to attend the Paris IETF.
>> 
>> However, looking up the L2VPN proceedings, I've found a short anonymous
>> presentation called "E-Tree Update"  (
>> http://www.ietf.org/proceedings/83/slides/slides-83-l2vpn-1.pptx). This
>> presentation discusses the differences of the E-Tree approaches based on
>> dedicated VLANs (as in
>> http://datatracker.ietf.org/doc/draft-cao-l2vpn-vpls-etree/?include_text=1)
>> and multiple PWs between the PEs (as in
>> http://datatracker.ietf.org/doc/draft-ram-l2vpn-etree-multiple-pw/?include_te
>> xt=1)
>> and completely ignores the solution based on usage of the CW in the PWs
>> connecting the PEs (as in
>> http://datatracker.ietf.org/doc/draft-key-l2vpn-vpls-etree/?include_text=1
>> ).
>> 
>> 
>> 
>> The Minutes of the Paris L2VPN session are not yet available, but I wonder
>> whether the WG has taken a decision to reject the approach based on the CW
>> usage? I do not remember any recent discussion of this topic on the WG
>> mailing list.
>> 
>> 
>> 
>> Regards, and lots of thanks in advance,
>> 
>> Sasha
>> 
>> 
>> 
>> 
>> 
>> This e-mail message is intended for the recipient only and contains
>> information which is CONFIDENTIAL and which may be proprietary to ECI
>> Telecom. If you have received this transmission in error, please inform us
>> by e-mail, phone or fax, and then delete the original and all copies
>> thereof.
>>

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 12 Apr 2012 09:02:49 +0200

The vlan approach is superior as it also works for eth only networks, etc. On top some vendors indicate hw issues with the cw approach. As such we have dropped more or less the cw approach.

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein <[email-masked]>
Cc: [email-masked] <[email-masked]>; Vladimir Kleiner <[email-masked]>; Andrew Sergeev <[email-masked]>; Idan Kaspit <[email-masked]>; Mishael Wexler <[email-masked]>; Rotem Cohen <[email-masked]>
Subject: Re: The status of the approaches to the E-Tree solution?

Giles

---

From: "Shahram Davari" <[email-masked]>
Date: Thu, 12 Apr 2012 10:16:20 -0700

Hi,

Wim is correct. CW flag requires extensive hardware change. Many implementation don't even support CW.

Thx
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, April 12, 2012 12:03 AM
To: [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: Re: The status of the approaches to the E-Tree solution?

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein <[email-masked]>
Cc: [email-masked] <[email-masked]>; Vladimir Kleiner <[email-masked]>; Andrew Sergeev <[email-masked]>; Idan Kaspit <[email-masked]>; Mishael Wexler <[email-masked]>; Rotem Cohen <[email-masked]>
Subject: Re: The status of the approaches to the E-Tree solution?

Giles

---

From: Lucy yong <[email-masked]>
Date: Fri, 13 Apr 2012 22:48:48 +0000

Agree with Wim. VLAN approach is the best solution for E-Tree. 

Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, April 12, 2012 2:03 AM
To: [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: Re: The status of the approaches to the E-Tree solution?

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein <[email-masked]>
Cc: [email-masked] <[email-masked]>; Vladimir Kleiner <[email-masked]>; Andrew Sergeev <[email-masked]>; Idan Kaspit <[email-masked]>; Mishael Wexler <[email-masked]>; Rotem Cohen <[email-masked]>
Subject: Re: The status of the approaches to the E-Tree solution?

Giles

---

From: David Allan I <[email-masked]>
Date: Mon, 16 Apr 2012 13:19:13 -0400

+1 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Friday, April 13, 2012 3:49 PM
To: Henderickx, Wim (Wim); [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: RE: The status of the approaches to the E-Tree solution?

Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, April 12, 2012 2:03 AM
To: [email-masked]'; [email-masked]'; [email-masked]'
Cc: [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'; [email-masked]'
Subject: Re: The status of the approaches to the E-Tree solution?

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Giles Heron [mailto:[email-masked]]
Sent: Thursday, April 12, 2012 08:22 AM
To: Simon Delord <[email-masked]>; Alexander Vainshtein <[email-masked]>
Cc: [email-masked] <[email-masked]>; Vladimir Kleiner <[email-masked]>; Andrew Sergeev <[email-masked]>; Idan Kaspit <[email-masked]>; Mishael Wexler <[email-masked]>; Rotem Cohen <[email-masked]>
Subject: Re: The status of the approaches to the E-Tree solution?

Sorry - the "anonymous presentation" was mine.  I should possibly have put in a third column on the CW approach.  And hopefully the minutes will be posted soon.

We had various discussions, as Simon stated, and consensus seemed to be forming around the two alternatives of two PWEs or two VLANs.  I believe three of the authors of the CW approach are also authors of the two VLAN approach and one is also an author of the two PWE approach. So perhaps it's best to let those four individuals say which approach they prefer and why?

Giles

On 10/04/2012 00:45, "Simon Delord" <[email-masked]> wrote:

> Hi Alexander,
> 
> You are right, no discussion on the WG mailing list recently, but 
> there have been substantial discussions among the authors of various 
> solution drafts off the mailing list. As far as I know, no consensus 
> yet before ietf83, not sure the progress in the Paris WG meeting. I 
> think the CW approach has not been rejected by the WG yet, or the WG 
> has not yet decided on which one to adopt.
> 
> Simon
> 
>> However, looking up the L2VPN proceedings, I've found a short 
>> anonymous presentation called "E-Tree Update"  ( 
>> http://www.ietf.org/proceedings/83/slides/slides-83-l2vpn-1.pptx). 
>> This presentation discusses the differences of the E-Tree approaches 
>> based on dedicated VLANs (as in
>> http://datatracker.ietf.org/doc/draft-cao-l2vpn-vpls-etree/?include_t
>> ext=1) and multiple PWs between the PEs (as in 
>> and completely ignores the solution based on usage of the CW in the 
>> PWs connecting the PEs (as in
>> The Minutes of the Paris L2VPN session are not yet available, but I 
>> wonder whether the WG has taken a decision to reject the approach 
>> based on the CW usage? I do not remember any recent discussion of 
>> this topic on the WG mailing list.
>> 
>> 
>> 
>> Telecom. If you have received this transmission in error, please 
>> inform us by e-mail, phone or fax, and then delete the original and 
>> all copies thereof.
>>

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 16 Apr 2012 14:54:34 -0400

+1

Regards,
Jeff