Subject: Re: The status of the approaches to the E-Tree solution?

From: Lizhong Jin<[email-masked]>
Date: Thu, 19 Apr 2012 15:21:25 +0800

[snipped...]
> Yes, 2 pws are only needed between pes with both root and leaf acs after
> improving Dual-PW approach. If consider P2MP, Dual-PW approach setup 2 
P2MP
> PWs if need. There is no difference between P2MP or normal PW setup. 
But,
> can Leaf-ACs be bound to Root PE of P2MP PW? 
> 
> [[LY]] No, it makes complex in setting up P2MP PW. Should a PE with 
> both root and leaf ACs set up two or one P2MP PW to other PEs (some 
> PE have both root and leaf AC and some only have leaf ACs)? 
> Regards,
> Lucy
[Lizhong] a bit arbitrary to say "complex" here. Both have PROS and CONS. 
If 2-PW approach uses two P2MP PW, the BUM traffic from leaf would be only 
to root, and BUM traffic from root would be only to leaf. While if 2-VLAN 
approach uses only one P2MP PW, the BUM traffic from leaf would be also to 
other leaf only nodes, and filtered at egress node, which wastes the 
traffic bandwidth in the network. 

Thanks
Lizhong

> 
> Regards,
> 
> Yuqun (Sam) Cao
> E-mail: [email-masked] 
> 
> 
> -----Original Message-----
> From: Daniel Cohn [mailto:[email-masked]] 
> Sent: Tuesday, April 17, 2012 4:56 PM
> To: Lucy yong; Rogers, Josh; Henderickx, Wim (Wim); 
[email-masked];
> [email-masked]; [email-masked]; Sam Cao
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: The status of the approaches to the E-Tree solution?
> 
> Adding Sam (as l2vpn@ is holding messages)
> 
> DC 
> 
> -----Original Message-----
> From: Lucy yong [mailto:[email-masked]] 
> Sent: Tuesday, April 17, 2012 12:39 AM
> To: Daniel Cohn; Rogers, Josh; Henderickx, Wim (Wim);
> [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: The status of the approaches to the E-Tree solution?
> 
> 
> Snipped,
> 
> As we discussed extensively in the list, and as reflected in giles
> slide, 2 pws are only needed between pes with both root and leaf acs,
> which will typically be a small minority.
> [[LY]] Don't know if the assumption is true. Even it is the case, both
> approaches can benefit from it. I was off for a while and captures some
> discussions now. 
> 
> Also as per giles slide, dual vlan can have scalability issues due to
> additional lookup and double use of vlans in internal emulated lan
> interface. Also there are potential backward compatibility issues with
> silicon that doesn't support vlan mapping.
> [[LY]] I was not in IETF83 meeting and wait on the meeting minutes. I am
> not clear on all the issues. Could you be more specific? As I mentioned
> in below, two PW approach makes VPLS transport construction and packet
> forwarding more complex, I can see potential backward compatibility
> issues with 2 PW solution. 
> 
> Regards,
> Lucy
> 
> Regards,
> 
> Daniel
> 
> Thumb typed - please be tolerant
> 
> Lucy yong <[email-masked]> wrote:
> 
> In my mind, the VLAN approach means dual vlan method.
> 
> The main concern for CW approach is hardware support.
> 
> Two PW approach can be complex too if the VPLS instance for E-Tree uses
> P2P PW for unicast traffic and P2MP PW for broadcast and unknown unicast
> traffic, and some P2MP PWs for multicast traffic. It may double all of
> them.
> 
> E-tree is an Ethernet service and there is already VLAN based solution
> in IEEE, can we just utilize it without complicating VPLS transport
> construction? This also makes interworking with Eth only network easier.
> 
> Cheers,
> Lucy
> 
> -----Original Message-----
> From: Rogers, Josh [mailto:[email-masked]]
> Sent: Monday, April 16, 2012 8:35 AM
> To: Lucy yong; Henderickx, Wim (Wim); [email-masked]';
> [email-masked]'; [email-masked]'
> Cc: [email-masked]'; [email-masked]';
> [email-masked]'; [email-masked]';
> [email-masked]'; [email-masked]'
> Subject: RE: The status of the approaches to the E-Tree solution?
> 
> I believe the initial question was in regard to the CW method.  Are you
> saying that you no longer are interested in that method in preference of
> the dual vlan method?
> 
> 
> 
> Lucy yong <[email-masked]> wrote:
> 
> 
> Agree with Wim. VLAN approach is the best solution for E-Tree.
> 
> Lucy
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Henderickx, Wim (Wim)
> Sent: Thursday, April 12, 2012 2:03 AM
> To: [email-masked]'; [email-masked]';
> [email-masked]'
> Cc: [email-masked]'; [email-masked]';
> [email-masked]'; [email-masked]';
> [email-masked]'; [email-masked]'
> Subject: Re: The status of the approaches to the E-Tree solution?
> 
> The vlan approach is superior as it also works for eth only networks,
> etc. On top some vendors indicate hw issues with the cw approach. As
> such we have dropped more or less the cw approach.
> 
> Cheers,
> Wim
> _________________
> sent from blackberry
> 
> ----- Original Message -----
> From: Giles Heron [mailto:[email-masked]]
> Sent: Thursday, April 12, 2012 08:22 AM
> To: Simon Delord <[email-masked]>; Alexander Vainshtein
> <[email-masked]>
> Cc: [email-masked] <[email-masked]>; Vladimir Kleiner
> <[email-masked]>; Andrew Sergeev
> <[email-masked]>; Idan Kaspit <[email-masked]>;
> Mishael Wexler <[email-masked]>; Rotem Cohen
> <[email-masked]>
> Subject: Re: The status of the approaches to the E-Tree solution?
> 
> Sorry - the "anonymous presentation" was mine.  I should possibly have
> put in a third column on the CW approach.  And hopefully the minutes
> will be posted soon.
> 
> We had various discussions, as Simon stated, and consensus seemed to be
> forming around the two alternatives of two PWEs or two VLANs.  I believe
> three of the authors of the CW approach are also authors of the two VLAN
> approach and one is also an author of the two PWE approach. So perhaps
> it's best to let those four individuals say which approach they prefer
> and why?
> 
> Giles
> 
> On 10/04/2012 00:45, "Simon Delord" <[email-masked]> wrote:
> 
> > Hi Alexander,
> >
> > You are right, no discussion on the WG mailing list recently, but 
> > there have been substantial discussions among the authors of various 
> > solution drafts off the mailing list. As far as I know, no consensus 
> > yet before ietf83, not sure the progress in the Paris WG meeting. I 
> > think the CW approach has not been rejected by the WG yet, or the WG 
> > has not yet decided on which one to adopt.
> >
> > Simon
> >
> > 2012/4/8 Alexander Vainshtein <[email-masked]>
> >
> >>  Hi all,
> >>
> >> Unfortunately I have not been able to attend the Paris IETF.
> >>
> >> However, looking up the L2VPN proceedings, I've found a short 
> >> anonymous presentation called "E-Tree Update"  ( 
> >> http://www.ietf.org/proceedings/83/slides/slides-83-l2vpn-1.pptx). 
> >> This presentation discusses the differences of the E-Tree approaches 
> >> based on dedicated VLANs (as in
> >> http://datatracker.ietf.org/doc/draft-cao-l2vpn-vpls-etree/?include_t
> >> ext=1) and multiple PWs between the PEs (as in 
> >> http://datatracker.ietf.org/doc/draft-ram-l2vpn-etree-multiple-pw/?in
> >> clude_te
> >> xt=1)
> >> and completely ignores the solution based on usage of the CW in the 
> >> PWs connecting the PEs (as in
> >> http://datatracker.ietf.org/doc/draft-key-l2vpn-vpls-etree/?include_t
> >> ext=1
> >> ).
> >>
> >>
> >>
> >> The Minutes of the Paris L2VPN session are not yet available, but I 
> >> wonder whether the WG has taken a decision to reject the approach 
> >> based on the CW usage? I do not remember any recent discussion of 
> >> this topic on the WG mailing list.
> >>
> >>
> >>
> >> Regards, and lots of thanks in advance,
> >>
> >> Sasha
> >>
> >>
> >>
> >>
> >>
> >> This e-mail message is intended for the recipient only and contains 
> >> information which is CONFIDENTIAL and which may be proprietary to ECI
> 
> >> Telecom. If you have received this transmission in error, please 
> >> inform us by e-mail, phone or fax, and then delete the original and 
> >> all copies thereof.
> >>
> 
> 
> 
>

---

From: Giles Heron <[email-masked]>
Date: Tue, 24 Apr 2012 08:46:13 +0100

> traffic bandwidth in the network.

As I said in my last email I'm not sure there's a great need for P2MP from
leaves.  And P2MP from roots needs to go to all roots and leaves of course.

But there would be a slight inefficiency if a node with roots and leaves
sent leaf traffic over a P2MP PW to all other nodes - as leaf-only nodes
wouldn't need to see those packets.

---

From: Lucy yong <[email-masked]>
Date: Wed, 25 Apr 2012 14:53:05 +0000

[Snipped..]

[[LY]] what you suggest is to set up a P2MP PW on the PEs that have an root AC while leaf-only PEs only use P2P PWs for multicast traffic. (no P2P PWs between leaf-only PEs) This applies to Dual-VLAN solution well although there is a slight inefficiency. 
Thanks,
Lucy