Subject: Interest in IS-IS VPLS

From: Giles Heron <[email-masked]>
Date: Fri, 27 Apr 2012 13:57:19 +0100

Hi,

At the IETF meeting in Paris I took an action (as noted in the minutes) to
poll the WG to see if there was any interest (other than by the authors of
course) in progressing the IS-IS VPLS draft.

Would you please respond to this email indicating whether or not you have
interest in seeing this draft progress, ideally giving reasoning for your
position.  It'd be especially interesting to see responses from service
providers of course.

If there are no (or very few) responses to this email then Nabil and I will
probably interpret that as meaning there's insufficient interest to
progress.  Of course it may just mean that you all missed this email in the
deluge of debate on E-Tree ;)

Giles

---

From: "Rogers, Josh" <[email-masked]>
Date: Fri, 27 Apr 2012 10:44:16 -0400

I am not interested.  I prefer already available methods of doing Layer 2
VPN (intentionally avoiding the term VPLS here), and don't see or
appreciate any benefits that an ISIS version might offer.

-Josh

>deluge of debate on E-Tree ;)

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "Mallette, Edwin J." <[email-masked]>
Date: Fri, 27 Apr 2012 18:30:44 +0000

I'm also not interested in seeing the ISIS-VPLS draft progress.  My
rationale for this is very similar to the reasons Josh listed below.

Regards,

Ed

On 4/27/12 4:44 PM, "Rogers, Josh" <[email-masked]> wrote:

>This E-mail and any of its attachments may contain Time Warner Cable
>proprietary information, which is privileged, confidential, or subject to
>copyright belonging to Time Warner Cable. This E-mail is intended solely
>for the use of the individual or entity to which it is addressed. If you
>are not the intended recipient of this E-mail, you are hereby notified
>that any dissemination, distribution, copying, or action taken in
>relation to the contents of and attachments to this E-mail is strictly
>prohibited and may be unlawful. If you have received this E-mail in
>error, please notify the sender immediately and permanently delete the
>original and any copy of this E-mail and any printout.

________________________________

CONFIDENTIALITY NOTICE: This e-mail may contain information that is privileged, confidential or otherwise protected from disclosure. If you are not the intended recipient of this e-mail, please notify the sender immediately by return e-mail, purge it and do not disseminate or copy it.

---

From: Lucy yong <[email-masked]>
Date: Fri, 27 Apr 2012 18:43:21 +0000

Hi Giles,

It seems that the IS-IS VPLS provides the solution for a scalable data center network as mentioned in the draft. I am not sure it is proper to weight service providers more on this. I can see if a service provider already deployed existing VPLS, the gain from IS-IS VPLS is less than the cost on upgrading all the edge devices to support the solution. 

However, for data center network, IS-IS VPLS could be a useful solution. It simplifies current VPLS mechanism, provides a good scalability, and requires IP only function on core switches. 

A vendor provides devices for both service provider network and data center network, the solution brings a synergy in leveraging VPLS solution into DC. 

Thus, I like to see this work moving forward.

Regards,
Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Giles Heron
Sent: Friday, April 27, 2012 7:57 AM
To: [email-masked]
Subject: Interest in IS-IS VPLS

Hi,

Giles

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 27 Apr 2012 15:01:44 -0400

Hi Lucy, et.al,
If we think that IS-IS VPLS might be applicable only to data centers then perhaps l2vpn WG is not the proper WG but NVO3 might be the one.

	Regards,
		Greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Friday, April 27, 2012 11:43 AM
To: Giles Heron; [email-masked]
Subject: RE: Interest in IS-IS VPLS

Hi Giles,

Regards,
Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Giles Heron
Sent: Friday, April 27, 2012 7:57 AM
To: [email-masked]
Subject: Interest in IS-IS VPLS

Hi,

At the IETF meeting in Paris I took an action (as noted in the minutes) to poll the WG to see if there was any interest (other than by the authors of
course) in progressing the IS-IS VPLS draft.

Would you please respond to this email indicating whether or not you have interest in seeing this draft progress, ideally giving reasoning for your position.  It'd be especially interesting to see responses from service providers of course.

If there are no (or very few) responses to this email then Nabil and I will probably interpret that as meaning there's insufficient interest to progress.  Of course it may just mean that you all missed this email in the deluge of debate on E-Tree ;)

Giles

---

From: Lucy yong <[email-masked]>
Date: Fri, 27 Apr 2012 19:12:51 +0000

It should inform NV03 for sure. But the solution is for L2VPN, so should belong to this WG.
Lucy

-----Original Message-----
From: Gregory Mirsky [mailto:[email-masked]] 
Sent: Friday, April 27, 2012 2:02 PM
To: Lucy yong; Giles Heron; [email-masked]
Subject: RE: Interest in IS-IS VPLS

Hi Lucy, et.al,

	Regards,
		Greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Friday, April 27, 2012 11:43 AM
To: Giles Heron; [email-masked]
Subject: RE: Interest in IS-IS VPLS

Hi Giles,

Regards,
Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Giles Heron
Sent: Friday, April 27, 2012 7:57 AM
To: [email-masked]
Subject: Interest in IS-IS VPLS

Hi,

Giles

---

From: Jie Dong <[email-masked]>
Date: Sat, 28 Apr 2012 02:35:14 +0000

According to the discussions in NVO3, there is no conclusion yet about which solution would be used for data center VPN. IS-IS VPLS provides one choice for data center VPN. At this stage maybe it would be better to have multiple alternatives and see which one NVO3 will choose. 

Thus I'm interested to see this move on. 

Best regards,
Jie

> Sent: Friday, April 27, 2012 8:57 PM
> To: [email-masked]

---

From: Xuxiaohu <[email-masked]>
Date: Sat, 28 Apr 2012 03:18:21 +0000

As for whether or not the already available L2VPN methods are suitable for all data center networks, it's an endless debate in NVo3 till now and it would be hard to reach a rough consensus until the NVo3 requirement drafts are approved.

Best regards,
Xiaohu  

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Rogers, Josh
发送时间: 2012年4月27日 22:44
收件人: Giles Heron; [email-masked]
主题: Re: Interest in IS-IS VPLS

-Josh

---

From: Mach Chen <[email-masked]>
Date: Sat, 28 Apr 2012 10:04:29 +0000

Fully agree with lucy here.

In addition, since the ISIS VPLS leverages a uniform protocol(ISIS) for signaling and auto discovery, it would greatly simplify the deployment and maintenance, especially for the DC networks that have already deployed ISIS for IP routing. So I'd like to see the draft moving forward.

Best regards,
Mach

> Sent: Saturday, April 28, 2012 2:43 AM
> It seems that the IS-IS VPLS provides the solution for a scalable data center
> network as mentioned in the draft. I am not sure it is proper to weight
> service providers more on this. I can see if a service provider already
> deployed existing VPLS, the gain from IS-IS VPLS is less than the cost on
> upgrading all the edge devices to support the solution.
> 
> However, for data center network, IS-IS VPLS could be a useful solution. It
> simplifies current VPLS mechanism, provides a good scalability, and
> requires IP only function on core switches.
> 
> A vendor provides devices for both service provider network and data
> center network, the solution brings a synergy in leveraging VPLS solution
> into DC.
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 29 Apr 2012 12:24:47 +0000

Dear colleagues,
I would like to remind you that the original message from Giles says:
<quote>
	It'd be especially interesting to see responses from service providers of course.
<end quote>

So far I've seen just two messages for SPs in this thread, and both have stated "I am not interested".

With this in mind, IMHO and FWIW it premature to discuss details, technical or procedural, at this stage.

My 2c,
     Sasha

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Mach Chen
> Sent: Saturday, April 28, 2012 1:04 PM
> In addition, since the ISIS VPLS leverages a uniform protocol(ISIS) for
> signaling and auto discovery, it would greatly simplify the deployment and
> maintenance, especially for the DC networks that have already deployed
> ISIS for IP routing. So I'd like to see the draft moving forward.
> 
> Best regards,
> Mach
> 

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: John E Drake <[email-masked]>
Date: Mon, 30 Apr 2012 06:12:02 -0700

We already have TRILL and SPB.  Why is yet another IS-IS variant necessary, particularly one that is so completely under-specified? 

Sent from my iPhone

> Sent: Saturday, April 28, 2012 3:04 AM
> signaling and auto discovery, it would greatly simplify the deployment
> and maintenance, especially for the DC networks that have already
> deployed ISIS for IP routing. So I'd like to see the draft moving
> forward.
> 
> Best regards,
> Mach
> 
> > Of Lucy yong
> > It seems that the IS-IS VPLS provides the solution for a scalable
> data
> > center network as mentioned in the draft. I am not sure it is proper
> > to weight service providers more on this. I can see if a service
> > provider already deployed existing VPLS, the gain from IS-IS VPLS is
> > less than the cost on upgrading all the edge devices to support the
> solution.
> >
> > However, for data center network, IS-IS VPLS could be a useful
> > solution. It simplifies current VPLS mechanism, provides a good
> > scalability, and requires IP only function on core switches.
> >
> > center network, the solution brings a synergy in leveraging VPLS
> > solution into DC.
> >
> > Of Giles Heron
> > At the IETF meeting in Paris I took an action (as noted in the
> > minutes) to poll the WG to see if there was any interest (other than
> > by the authors of
> > Would you please respond to this email indicating whether or not you
> > have interest in seeing this draft progress, ideally giving reasoning
> > for your position.  It'd be especially interesting to see responses
> > from service providers of course.
> >
> > If there are no (or very few) responses to this email then Nabil and
> I
> > will probably interpret that as meaning there's insufficient interest
> > to progress.  Of course it may just mean that you all missed this
> > email in the deluge of debate on E-Tree ;)
> >
> > Giles
> >

---

From: Lucy yong <[email-masked]>
Date: Mon, 30 Apr 2012 15:38:51 +0000

John,

IS-IS VPLS is completely different from TRILL and SPB although they all use of IS-IS protocol in control plane. IS-IS VPLS data plane uses an IP/GRE tunnel carrying VPN instances differentiated by MPLS labels. TRILL and SPB data planes are Ethernet based, i.e. the frames are Ethernet frames.

Isn't it good that one control plane protocol can apply to different data planes? 

I agree that VPLS has been well defined and used in Service Provider networks. IS-IS VPLS provides the simplified version of VPLS that can apply to data center networks. This may be better than developing something completely new in data center. 

Maybe we need consider another name for this, for example DC-VPN? In data center, an VPN is not necessary to provide a service to an customer, the infrastructure need VPN capability.  

Regards,
Lucy 

-----Original Message-----
From: John E Drake [mailto:[email-masked]] 
Sent: Monday, April 30, 2012 8:12 AM
To: Mach Chen; Lucy yong; Giles Heron; [email-masked]
Subject: RE: Interest in IS-IS VPLS

Sent from my iPhone

---

From: John E Drake <[email-masked]>
Date: Mon, 30 Apr 2012 09:10:52 -0700

Lucy,

Comments inline.

Thanks,

John

Sent from my iPhone

> From: Lucy yong [mailto:[email-masked]]
> Sent: Monday, April 30, 2012 8:39 AM
> To: John E Drake; Mach Chen; Giles Heron; [email-masked]
> IS-IS VPLS is completely different from TRILL and SPB although they all
> use of IS-IS protocol in control plane. IS-IS VPLS data plane uses an
> IP/GRE tunnel carrying VPN instances differentiated by MPLS labels.
> TRILL and SPB data planes are Ethernet based, i.e. the frames are
> Ethernet frames.

JD:  From what I understand, both TRILL and SP can be used to provide the same capabilities as IS-IS VPLS and they both exist today.
 
> Isn't it good that one control plane protocol can apply to different

JD:  This is a rhetorical question, right?

> 
> I agree that VPLS has been well defined and used in Service Provider
> networks. IS-IS VPLS provides the simplified version of VPLS that can
> apply to data center networks. This may be better than developing
> something completely new in data center.

JD:  Just because it has 'VPLS' in its name does not mean it isn't new.  I agree that we don't want to develop anything new for the data center, and that therefore, IS-IS VPLS is a non-starter.

> 
> Maybe we need consider another name for this, for example DC-VPN? In
> data center, an VPN is not necessary to provide a service to an
> customer, the infrastructure need VPN capability.

JD:  This sounds like a tautology.

> We already have TRILL and SPB.  Why is yet another IS-IS variant
> necessary, particularly one that is so completely under-specified?
> 
> Sent from my iPhone
> 
> 
> > In addition, since the ISIS VPLS leverages a uniform protocol(ISIS)
> > for signaling and auto discovery, it would greatly simplify the
> > deployment and maintenance, especially for the DC networks that have
> > already deployed ISIS for IP routing. So I'd like to see the draft
> > moving forward.
> >
> > Best regards,
> > Mach
> >
> > > have interest in seeing this draft progress, ideally giving
> > > reasoning for your position.  It'd be especially interesting to see
> > > responses from service providers of course.
> > >
> > > will probably interpret that as meaning there's insufficient
> > > interest to progress.  Of course it may just mean that you all
> > > missed this email in the deluge of debate on E-Tree ;)
> > >
> > > Giles
> > >

---

From: "LEVRAU, LIEVEN (LIEVEN)" <[email-masked]>
Date: Mon, 30 Apr 2012 18:13:26 +0200

inline

On 30/04/12 17:38, "Lucy yong" <[email-masked]> wrote:

>IP/GRE tunnel carrying VPN instances differentiated by MPLS labels. TRILL
>and SPB data planes are Ethernet based, i.e. the frames are Ethernet
>frames.
>
No I don't think so - as that creates interop issues and gateway functions
when connecting different control planes together.
>Maybe we need consider another name for this, for example DC-VPN? In data
>center, an VPN is not necessary to provide a service to an customer, the
>infrastructure need VPN capability.
Ok lets not - if there are tools out there that can be built upon, why
introduce a new thing which there seems very little interest and retry by
given the same new thing a different name.

---

From: Lucy yong <[email-masked]>
Date: Mon, 30 Apr 2012 16:45:01 +0000

John,

LY: From the architecture perspective, the backbone implementation between IS-IS VPLS and TRILL/SPB is completely different. IS-IS VPLS relies on IP forwarding in core, TRILL/SPB relies on Ethernet forwarding. Why did we develop VPLS when there was provider bridging (PB) technology, they served the same capability?

LY: I guess that you agree it. :) all the work CCAMP does is to extend the control plane protocol to other data planes.

LY: One argument we often to hear is that MPLS is too "complicated" for the data center. We can see that some complexities have the history reasons and hardware limitation then. As the chip technology improving, these constraints no longer exist. We can simplify them for a new area. IS-IS VPLS is the starting point I see.

Thanks,
Lucy

-----Original Message-----
From: John E Drake [mailto:[email-masked]] 
Sent: Monday, April 30, 2012 11:11 AM
To: Lucy yong; Mach Chen; Giles Heron; [email-masked]
Subject: RE: Interest in IS-IS VPLS

Lucy,

Comments inline.

Thanks,

John

Sent from my iPhone

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 30 Apr 2012 12:49:48 -0400

Dear Lucy,
If authors believe that applicability area for the document is, primarily, in DC VPNs, then, IMHO, NVO3 WG might be suitable WG to continue work assuming the proposal satisfies functional and performance, including scaling, requirements that been referenced in NVO3 WG charter and will be detailed in framework and architectural documents.
And I concur with Sasha, who reminded us, developers, that particular interest and value be paid to feedback from service providers.

	Regards,
		Greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Monday, April 30, 2012 8:39 AM
To: John E Drake; Mach Chen; Giles Heron; [email-masked]
Subject: RE: Interest in IS-IS VPLS

John,

Regards,
Lucy 

-----Original Message-----
From: John E Drake [mailto:[email-masked]]
Sent: Monday, April 30, 2012 8:12 AM
To: Mach Chen; Lucy yong; Giles Heron; [email-masked]
Subject: RE: Interest in IS-IS VPLS

Sent from my iPhone

---

From: Lucy yong <[email-masked]>
Date: Mon, 30 Apr 2012 16:50:30 +0000

[LY] Do you deny all the works in CCAMP?

Lucy

-----Original Message-----
From: LEVRAU, LIEVEN (LIEVEN) [mailto:[email-masked]] 
Sent: Monday, April 30, 2012 11:13 AM
To: Lucy yong; John E Drake; Mach Chen; Giles Heron; [email-masked]
Subject: Re: Interest in IS-IS VPLS

inline

---

From: Lucy yong <[email-masked]>
Date: Mon, 30 Apr 2012 16:58:23 +0000

Authors want to bring this work into NV03. However, NV03 just starts the problem statement and requirement. It is not in the stage of any solution yet. IS-IS VPLS is just an evolution of VPLS, it fits L2VPN too.

Lucy

-----Original Message-----
From: Gregory Mirsky [mailto:[email-masked]] 
Sent: Monday, April 30, 2012 11:50 AM
To: Lucy yong; Giles Heron; [email-masked]
Subject: RE: Interest in IS-IS VPLS

Dear Lucy,

	Regards,
		Greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Monday, April 30, 2012 8:39 AM
To: John E Drake; Mach Chen; Giles Heron; [email-masked]
Subject: RE: Interest in IS-IS VPLS

John,

Regards,
Lucy 

-----Original Message-----
From: John E Drake [mailto:[email-masked]]
Sent: Monday, April 30, 2012 8:12 AM
To: Mach Chen; Lucy yong; Giles Heron; [email-masked]
Subject: RE: Interest in IS-IS VPLS

Sent from my iPhone

---

From: "LEVRAU, LIEVEN (LIEVEN)" <[email-masked]>
Date: Mon, 30 Apr 2012 19:03:50 +0200

Hi Lucy - That is not the point

The point is that we would need yet another interconnection modelŠ. And to
what benefit?

./
Lieven

---

From: Lucy yong <[email-masked]>
Date: Mon, 30 Apr 2012 17:09:25 +0000

I guess that the benefit is to make the solution better and better.
Lucy

-----Original Message-----
From: LEVRAU, LIEVEN (LIEVEN) [mailto:[email-masked]] 
Sent: Monday, April 30, 2012 12:04 PM
To: Lucy yong; John E Drake; Mach Chen; Giles Heron; [email-masked]
Subject: Re: Interest in IS-IS VPLS

./
Lieven

---

From: John E Drake <[email-masked]>
Date: Mon, 30 Apr 2012 10:14:09 -0700

What part of 'Bad Idea' do we not understand?

Sent from my iPhone

---

From: sajassi <[email-masked]>
Date: Mon, 30 Apr 2012 10:18:08 +0900

Not interested. I provided my reasons both at the mic and w/ follow-up
emails. 

-Ali

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Mon, 30 Apr 2012 19:19:34 +0200

Not interested. If the problem needs to be solved it should be discussed in NVO3

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Giles Heron
Sent: vrijdag 27 april 2012 14:57
To: [email-masked]
Subject: Interest in IS-IS VPLS

Hi,

Giles

---

From: "LEVRAU, LIEVEN (LIEVEN)" <[email-masked]>
Date: Mon, 30 Apr 2012 19:20:48 +0200

Hmm interesting by adding more protocols to the mix and hope that things
will work out?
Not sure I can follow that trail of thought - how entertaining it might
look.

./
Lieven

On 30/04/12 19:09, "Lucy yong" <[email-masked]> wrote:

>>>TRILL
>>>Isn't it good that one control plane protocol can apply to different
>>>data
>>>planes?
>>>>for
>>>>reasoning
>>>>interest

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 30 Apr 2012 18:01:51 +0000

Agree with Lucy,  DC-VPN might be a better name. 

Linda

> Sent: Monday, April 30, 2012 10:39 AM
> data planes?

---

From: John E Drake <[email-masked]>
Date: Mon, 30 Apr 2012 11:32:51 -0700

How about DOA?  (Dead On Arrival)

Sent from my iPhone

> From: Linda Dunbar [mailto:[email-masked]]
> Sent: Monday, April 30, 2012 11:02 AM
> > IS-IS VPLS is completely different from TRILL and SPB although they
> > all use of IS-IS protocol in control plane. IS-IS VPLS data plane
> uses
> > an IP/GRE tunnel carrying VPN instances differentiated by MPLS
> labels.
> > > > for your position.  It'd be especially interesting to see

---

From: Lucy yong <[email-masked]>
Date: Mon, 30 Apr 2012 19:11:51 +0000

Execute me. This is a bit of assault. We all need be professional.
Lucy

-----Original Message-----
From: John E Drake [mailto:[email-masked]] 
Sent: Monday, April 30, 2012 1:33 PM
To: Linda Dunbar; Lucy yong; Mach Chen; Giles Heron; [email-masked]
Subject: RE: Interest in IS-IS VPLS

Sent from my iPhone

---

From: John E Drake <[email-masked]>
Date: Mon, 30 Apr 2012 12:39:57 -0700

Lucy,

I'm sorry, I was proposing an alternate name for the draft.

John

Sent from my iPhone