Subject: RE: The status of the approaches to the E-Tree solution?

From: Jiangyuanlong <[email-masked]>
Date: Tue, 24 Apr 2012 11:01:20 +0000

This WG has already standardized PBB VPLS, and it has some fair enough advantages, can we just reuse it for s-vlan preservation?
I believe this will not constrain the possible evolution of the ENNI model.

------------------------------
From: "Daniel Cohn" <[email-masked]>
To: "Lucy yong" <[email-masked]>,	"Rogers, Josh"
	<[email-masked]>,	"Shahram Davari" <[email-masked]>,
	"Lizhong Jin" <[email-masked]>, <[email-masked]>,
	<[email-masked]>
Cc: [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?
Message-ID: <[email-masked]>
Content-Type: text/plain;	charset="utf-8"

Lucy,

even if the current MEF framework doesn't require s-vlan preservation, I believe it's to the industry's benefit to adopt a solution that is not constrained to a specific enni model that, like all things networking, is likely to evolve. Especially when such a solution is available.

Daniel

Thumb typed - please be tolerant

Lucy yong <[email-masked]> wrote:

Daniel,

MEF has worked in ENNI interface for a long time with many service providers' inputs. It had a fair reason to assume S-VLAN over ENNI by then. It may open B-VLAN for the future. It is better for us not to discuss  a future framework here, because it will lead us to nowhere. Here, we want to extend VPLS in supporting E-Tree.

Best Regards,
Lucy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniel Cohn
Sent: Sunday, April 22, 2012 7:34 AM
To: Rogers, Josh; Shahram Davari; Lizhong Jin; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: The status of the approaches to the E-Tree solution?

Shahram and all,

This question already came up in our discussions - is it safe to assume that the VLAN tags at the E-NNI will always be according to the current MEF model? Or should we try to be as transparent as possible to user VLAN encapsulation at the E-NNI, to accommodate future frameworks?
I believe that any approach that looks at user payload (in this case VLAN tag) to signal VPLS information (in this case root/leaf origin) is necessarily tied to specific assumptions on user payload encapsulation (in this case, that S-VLAN tag is "available" to encode root/leaf). I don't think this is a future-proof assumption, it's very likely that other network models will come up that require S-VLAN preservation, which in the 2-VLAN approach would necessitate adding a third VLAN-ID.

Daniel

From: Shahram Davari <[email-masked]<mailto:[email-masked]>>
To: Lizhong Jin <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: The status of the approaches to the E-Tree solution?

Hi,

I also have a question regarding 2-VLAN. What if the customer traffic already has an S-VLAN? Do we need a 3rd VLAN to identify the L/R?

Thx
Shahram

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: Friday, April 20, 2012 9:38 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: The status of the approaches to the E-Tree solution?

Hi, all,
The difference between 2-VLAN and CW approach is who will provide the R/L information, customer payload or PW? The customer payload will be always modified to carry R/L information in 2-VLAN approach, while PW with CW will carry R/L information for CW approach.
I have a question with the 2-VLAN approach in H-VPLS where H-VPLS is accessed by VPWS as described in RFC4672 section 10.1.3. If VPWS is used to access H-VPLS, how could the PE on VPWS side adds VLAN to indicate R/L information?

Thanks
Lizhong

> ------------------------------

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 24 Apr 2012 14:40:48 +0200

Agreed

Cheers,
Wim
_________________
sent from blackberry

----- Original Message -----
From: Jiangyuanlong [mailto:[email-masked]]
Sent: Tuesday, April 24, 2012 01:01 PM
To: Daniel Cohn <[email-masked]>; Lucy yong <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: RE: The status of the approaches to the E-Tree solution?

Lucy,

Daniel

Daniel,

Best Regards,
Lucy

Shahram and all,

Daniel

Hi,

Thx
Shahram

Hi, all,

Thanks
Lizhong