Subject: Minor nit with draft-jiang-l2vpn-vpls-pe-etree-05

From: David Allan I <[email-masked]>
Date: Mon, 30 Apr 2012 17:26:59 -0400

HI:

There is a few inaccuracies in the description of ETREE with 802.1aq SPB on page 2 of the document.

1) Asymmetic VLAN was introduced with 802.1ad, long ago.

2) It refers to 802.1ad assymetric VLAN behavior but the description associates it and its artifacts with 802.1aq.  It suggests that the VLANs are used as a filtering mechanism at root and leaf nodes (which would be true for 802.1ad), suggesting frames are delivered to a superset of the intended recipients as an artifact of the ETREE implementation. This is not true for 802.1aq, the forwarding tree construction in SPB ensures frames are only delivered to intended recipients... leaves to roots and roots to all.

I'd suggest changing the paragraph:

IEEE 802.1 originally specified a generic E-Tree solution in 802.1ad(2005). In the solution, VLANs are used to indicate root/leaf source of a packet: one VLAN ID is used to indicate the frames originated from the roots and another VLAN ID is used to indicate the frames originated from the leaves. At a leaf port, the bridge can then filter out all the frames from other leaf ports based on the VLAN ID. 802.1aq(2012) improved upon this by eliminating the filtering requirement and associated discard by properly scoping the forwarding trees for an ETREE from leaf to root and from root to all. It would be desirable that any VPLS solution reflected this improvement.

Cheers Dave

---

From: David Allan I <[email-masked]>
Date: Mon, 30 Apr 2012 17:39:39 -0400

Ignore the comment below, it is not exactly timely...

my bad!
Dave

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of David Allan I
Sent: Monday, April 30, 2012 2:27 PM
To: [email-masked]
Subject: Minor nit with draft-jiang-l2vpn-vpls-pe-etree-05

HI:

Cheers Dave