Subject: Re: PBB E-VPN and TRILL

From: Giles Heron <[email-masked]>
Date: Fri, 15 Jun 2012 18:03:51 +0100

On 10/05/2012 20:57, "Sam Aldrin" <[email-masked]> wrote:

> I do not agree that It is just a name change of the document.
> 
> As far as the content goes, there is lot more to just BGP route.
> All the content w.r.t unicast forwarding, multicast forwarding etc was added
> recently. Atleast it was not present when the document was adopted as WG one.
> 
> So, without taking groups consensus for WG adoption is not right, IMO. As the
> content is more TRILL specific, it should be polled within that WG as well.

I'm not sure we'd poll an L2VPN WG doc in another WG?  But we can certainly
ask other WGs for comments.
 
> -sam
> On May 10, 2012, at 12:41 PM, Ali Sajassi wrote:
> 
>> 
>> When the doc was adopted as WG draft over 14 months ago, BGP route
>> definition and procedures for TRILL DCI were already in place.
>> 
>> It seems like we are having all these email exchanges for a name change of a
>> WG doc !!
>> 
>> -Ali
>> 
>> On 5/10/12 11:12 AM, "Sam Aldrin" <[email-masked]> wrote:
>> 
>>> As I mentioned in my other email, the split document should be asked for WG
>>> adoption. It may not be for pbb content but for the TRILL content it should
>>> be
>>> done. When the doc was adopted as WG doc, trill content was minimal.
>>> 
>>> Sam
>>> 
>>> Sent from my iPhone
>>> 
>>> On May 10, 2012, at 10:59 AM, "Shah, Himanshu" <[email-masked]> wrote:
>>> 
>>>> Followings are the questions...
>>>> 
>>>> 2) is the WG happy for the authors to split the TRILL section of the PBB
>>>> E-VPN draft into a separate draft?
>>>> 
>>>> 3) is the WG happy for the TRILL draft to be a WG doc?
>>>> 
>>>> I think we are discussing splitting the trill section as a separate draft
>>>> and
>>>> making it a WG doc.
>>>> 
>>>> What am I missing?
>>>> 
>>>> /himanshu
>>>> 
>>>> -----Original Message-----
>>>> From: Ali Sajassi [mailto:[email-masked]]
>>>> Sent: Thursday, May 10, 2012 1:53 PM
>>>> To: Shah, Himanshu; Henderickx, Wim (Wim); Santiago Alvarez (saalvare);
>>>> Giles
>>>> Heron; [email-masked]
>>>> Cc: Stewart Bryant (stbryant)
>>>> Subject: Re: PBB E-VPN and TRILL
>>>> 
>>>> 
>>>>> 
>>>>> Based on my understanding, all the proposals are considered BEFORE
>>>>> one is picked (with or without consolidation) for WG doc.
>>>> 
>>>> One proposal is already part of WG draft. Would you please read the draft
>>>> and then comment.
>>>> 
>>>> Cheers,
>>>> Ali
>>>> 
>>>>> 
>>>>> Thanks,
>>>>> himanshu
>>>>> 
>>>>> 
>>>>> -----Original Message-----
>>>>> From: Ali Sajassi [mailto:[email-masked]]
>>>>> Sent: Thursday, May 10, 2012 1:28 PM
>>>>> To: Shah, Himanshu; Henderickx, Wim (Wim); Santiago Alvarez (saalvare);
>>>>> Giles
>>>>> Heron; [email-masked]
>>>>> Cc: Stewart Bryant (stbryant)
>>>>> Subject: Re: PBB E-VPN and TRILL
>>>>> 
>>>>> Hi Himanshu,
>>>>> 
>>>>> I think every draft should be evaluated based on its own merits and if it
>>>>> is
>>>>> warranted there can be several drafts on this space.
>>>>> 
>>>>> Cheers,
>>>>> Ali 
>>>>> 
>>>>> 
>>>>> On 5/10/12 10:03 AM, "Shah, Himanshu" <[email-masked]> wrote:
>>>>> 
>>>>>> Hi Ali -
>>>>>> 
>>>>>> Correct. 
>>>>>> 
>>>>>> But within the context of previous two, which questions whether to
>>>>>> consider interconnecting TRILL islands via L2VPN as part of WG charter, I
>>>>>> think you
>>>>>> would agree that once TRILL portion is split from your base document,
>>>>>> it might be worth to check if other proposals has merits.
>>>>>> 
>>>>>> Saying differently, if your split TRILL doc becomes WG doc at the same
>>>>>> time
>>>>>> we
>>>>>> include this work in the charter, other proposals would have no chance to
>>>>>> be
>>>>>> even considered..:-(
>>>>>> 
>>>>>> IMHO - himanshu
>>>>>> 
>>>>>> 
>>>>>> -----Original Message-----
>>>>>> From: Ali Sajassi [mailto:[email-masked]]
>>>>>> Sent: Thursday, May 10, 2012 12:47 PM
>>>>>> To: Shah, Himanshu; Henderickx, Wim (Wim); Santiago Alvarez (saalvare);
>>>>>> Giles
>>>>>> Heron; [email-masked]
>>>>>> Cc: Stewart Bryant (stbryant)
>>>>>> Subject: Re: PBB E-VPN and TRILL
>>>>>> 
>>>>>> Himanshu,
>>>>>> 
>>>>>> PBB-EVPN is already a WG draft! And the TRILL portion of it has been
>>>>>> presented to L2VPN WG and has been in discussions for quite some time.
>>>>>> All
>>>>>> we are doing is separating SPB/PBB from TRILL - nothing new is getting
>>>>>> added. Whereas, the other drafts are all new and they came about during
>>>>>> last
>>>>>> IETF meeting.
>>>>>> 
>>>>>> -Ali
>>>>>> 
>>>>>> 
>>>>>> On 5/10/12 9:38 AM, "Shah, Himanshu" <[email-masked]> wrote:
>>>>>> 
>>>>>>> Yes to first 2.
>>>>>>> 
>>>>>>> As for 3rd, before we induct the stated draft as WG doc, we should
>>>>>>> consider
>>>>>>> other two proposals
>>>>>>> mentioned in the mailing list, as part of due diligence. This is the
>>>>>>> only
>>>>>>> fair
>>>>>>> way, and in fact,
>>>>>>> consideration to responses to third question be postponed until other
>>>>>>> proposals have been given
>>>>>>> chance to be reviewed at the WG, IMO.
>>>>>>> 
>>>>>>> /himanshu
>>>>>>> 
>>>>>>> -----Original Message-----
>>>>>>> From: [email-masked] [mailto:[email-masked]] On Behalf
>>>>>>> Of
>>>>>>> Henderickx, Wim (Wim)
>>>>>>> Sent: Thursday, May 10, 2012 12:27 PM
>>>>>>> To: Santiago Alvarez (saalvare); Giles Heron; [email-masked]
>>>>>>> Cc: Ali Sajassi (sajassi); Stewart Bryant (stbryant)
>>>>>>> Subject: RE: PBB E-VPN and TRILL
>>>>>>> 
>>>>>>> Same, yes to all 3
>>>>>>> 
>>>>>>> -----Original Message-----
>>>>>>> From: [email-masked] [mailto:[email-masked]] On Behalf
>>>>>>> Of
>>>>>>> Santiago Alvarez (saalvare)
>>>>>>> Sent: donderdag 10 mei 2012 18:26
>>>>>>> To: Giles Heron; [email-masked]
>>>>>>> Cc: Ali Sajassi (sajassi); Stewart Bryant (stbryant)
>>>>>>> Subject: RE: PBB E-VPN and TRILL
>>>>>>> 
>>>>>>> Yes to all three.
>>>>>>> 
>>>>>>> SA
>>>>>>> --
>>>>>>> 
>>>>>>>> -----Original Message-----
>>>>>>>> From: [email-masked] [mailto:[email-masked]] On Behalf
>>>>>>> Of
>>>>>>>> Giles Heron
>>>>>>>> Sent: Wednesday, May 09, 2012 5:34 AM
>>>>>>>> To: [email-masked]
>>>>>>>> Cc: Ali Sajassi (sajassi); Stewart Bryant (stbryant)
>>>>>>>> Subject: PBB E-VPN and TRILL
>>>>>>>> 
>>>>>>>> Ali presented the PBB-EVPN draft at IETF83 in Paris:
>>>>>>>> 
>>>>>>>> http://tools.ietf.org/html/draft-ietf-l2vpn-pbb-evpn-01
>>>>>>>> 
>>>>>>>> This has since been updated:
>>>>>>>> 
>>>>>>>> http://tools.ietf.org/html/draft-ietf-l2vpn-pbb-evpn-02
>>>>>>>> 
>>>>>>>> During our discussions Ali mentioned that the authors would like the
>>>>>>> TRILL
>>>>>>>> section of the draft to be separated out into a separate draft.  In
>>>>>>> response
>>>>>>>> Stewart questioned whether interconnecting TRILL islands is in-scope
>>>>>>> for
>>>>>>>> L2VPN.
>>>>>>>> 
>>>>>>>> Stewart, Nabil and I have just been discussing these issues.  Whilst
>>>>>>> TRILL
>>>>>>>> interconnect is not explicitly in-charter for L2VPN it would appear to
>>>>>>> be
>>>>>>>> implicitly in-charter - our decision to standardise solutions for PBB
>>>>>>> VPLS
>>>>>>>> and PBB E-VPN probably sets a precedent (since PBB is also unmentioned
>>>>>>> by
>>>>>>>> the charter).
>>>>>>>> 
>>>>>>>> On this basis we would like to ask the WG the following three
>>>>>>> questions:
>>>>>>>> 
>>>>>>>> 1) is the WG happy for us to pursue interconnection of TRILL islands
>>>>>>> over
>>>>>>>> L2VPN?
>>>>>>>> 
>>>>>>>> 2) is the WG happy for the authors to split the TRILL section of the
>>>>>>> PBB E-
>>>>>>>> VPN draft into a separate draft?
>>>>>>>> 
>>>>>>>> 3) is the WG happy for the TRILL draft to be a WG doc?
>>>>>>>> 
>>>>>>>> Please respond by May 22nd if you are unhappy with any of these 3
>>>>>>> actions
>>>>>>>> (I'll take no response to mean the WG is in agreement with us
>>>>>>> proceeding...)
>>>>>>>> 
>>>>>>>> Giles
>>>>>>>> 
>>>>>>> 
>>>>>> 
>>>>> 
>>>> 
>> 
>

---

From: Sam Aldrin <[email-masked]>
Date: Fri, 15 Jun 2012 10:06:17 -0700

Hi Giles,

I replied in subsequent email that my understanding is wrong.
I fully support the document and it's adoption.

Cheers
Sam

Sent from my iPad