Subject: Re: Progressing E-Tree - IPR issues

From: Jiangyuanlong <[email-masked]>
Date: Wed, 6 Jun 2012 04:07:19 +0000

Hi Shahram,

Please see my comments in line.
------------------------------
Date: Tue, 5 Jun 2012 13:26:06 +0000
From: "Shahram Davari" <[email-masked]>
To: "Daniel Cohn" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>,	"Stewart Bryant \(stbryant\)"
	<[email-masked]>
Subject: Re: Progressing E-Tree - IPR issues
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=us-ascii

Although IETF rules accept IPRs with licensing fee, but RF 3979 states and I agree that no licensing fee is preferred. 

The current disclosures either have not provided Licensing terms or they are royalty-bearing or they would want cross licensing in case some one uses their technology.
[JY] As I am aware, all E-Tree IPR claims either follow option b) or c) of RFC 3905, just as most IPRs already claimed in this WG. Or did I miss something? 

So as I said before if there is not a huge difference, I prefer those drafts that have no IPR or that have royalty-free IPR.
[JY]  Taken from RFC 3979: "It should also be noted that the absence of IPR disclosures is not the same thing as the knowledge that there will be no IPR claims in the future." and "It should also be noted that the validity and enforceability of any IPR may be challenged for legitimate reasons, and the mere existence of an IPR disclosure should not automatically be taken to mean that the disclosed IPR is valid or enforceable." We've seen many IPRs claimed only after WG adoption, can we guarantee that a new draft will have no IPR claim at all in the end? After all, alternative E-Tree solutions had been explored and discussed for almost 2 years, and now all seem to be encumbered with IPRs, IMHO, a new fancy solution may more likely be patent-encumbered.
Anyway, all these E-Tree I-Ds are only individual drafts, and any people can contribute new I-Ds to this WG, which will further enrich the solution space for the WG's choice. With regard to Evaluating Alternative Technologies in IETF Working Groups, besides the preference of technologies with no IPR or that have royalty-free IPR as you mentioned, RFC 3979 also indicates: "But IETF working groups have the discretion to adopt technology with a commitment of fair and non-discriminatory terms, or even with no licensing commitment, if they feel that this technology is superior enough to alternatives with fewer IPR claims or free licensing to outweigh the potential cost of the licenses."

Thanks,
Yuanlong

Regards,
Shahram

On Jun 5, 2012, at 12:07 AM, "Daniel Cohn" <[email-masked]> wrote:

> Hi,
> 
> The applicant licensing requirements can be verified in the IPR
> disclosure form, then everyone can judge if they conform to the "normal
> licensing requirements".
> 
> Daniel
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Luyuan Fang (lufang)
> Sent: Monday, June 04, 2012 11:05 PM
> To: Paul Unbehagen; Henderickx, Wim (Wim)
> Cc: [email-masked]; Stewart Bryant (stbryant)
> Subject: RE: Progressing E-Tree - IPR issues
> 
> +1
> Now, would it be up to each IPR applicant(s) to tell the WG if they
> agree to the IETF's normal licensing requirements or not?
> 
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf
>> Of Paul Unbehagen
>> Sent: Monday, June 04, 2012 4:02 PM
>> To: Henderickx, Wim (Wim)
>> Cc: [email-masked]; Stewart Bryant (stbryant)
>> Subject: Re: Progressing E-Tree - IPR issues
>> 
>> +1
>> 
>> 
>> 
>> On Jun 4, 2012, at 1:54 PM, "Henderickx, Wim (Wim)"
>> <[email-masked]> wrote:
>> 
>>> +1
>>> 
>>> -----Original Message-----
>>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of Thomas Nadeau
>>> Sent: maandag 4 juni 2012 17:38
>>> To: Giles Heron
>>> Cc: [email-masked]; Stewart Bryant
>>> Subject: Re: Progressing E-Tree - IPR issues
>>> 
>>> 
>>>   Being encumbered by IPR can mean a number of things. I am ok with
>> having IPR claims for any of the solutions, as long as they agree to
>> the IETF's normal licensing requirements. I am not in favor of
> adopting
>> any solutions that do not follow these requirements.
>>> 
>>>   --Tom
>>> 
>>> 
>>> On Jun 1, 2012:5:03 AM, at 5:03 AM, Giles Heron wrote:
>>> 
>>>> Nabil, Stewart and I discussed the issue of IPR and E-Tree
> recently.
>>>> 
>>>> It appears that some or all of the current E-Tree drafts may be
>> encumbered
>>>> by IPR.
>>>> 
>>>> We'd like to ask the WG whether we should continue to progress
> these
>> drafts,
>>>> or whether we should attempt to pursue alternatives that aren't
>> encumbered.
>>>> 
>>>> Would those with opinions please respond to this question within
> the
>> next 2
>>>> weeks (i.e. by Friday 15th of June).
>>>> 
>>>> Thanks in advance.
>>>> 
>>>> Giles
>>>> 
>>>> 
>>>> 
>>> 
> 

------------------------------

_______________________________________________
L2vpn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l2vpn

End of L2vpn Digest, Vol 97, Issue 5
************************************

---

From: "Shahram Davari" <[email-masked]>
Date: Wed, 6 Jun 2012 04:45:24 +0000

Hi,

You hit the nail in the head in your last sentence. Royalty-Bearing IPRs should be considered only if they are technologically superior.

Regards,
Shahram