Subject: EVPN: MAC age

From: Jakob Heitz <[email-masked]>
Date: Tue, 3 Jul 2012 02:44:57 -0400

Is there a way to age out a MAC address in EVPN?
Does the advertising MES just withdraw it when it ages out?
Is there a possibility to add an age to the MAC NLRI?
Or put an age into a BGP extended community?

--
Jakob Heitz.

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 3 Jul 2012 09:11:10 +0200

Aging is done in the same way as VPLS. You have a local age timer and if it expires the MAC address is withdrawn from the EVPN.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jakob Heitz
Sent: dinsdag 3 juli 2012 8:45
To: [email-masked]
Subject: EVPN: MAC age

--
Jakob Heitz.

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 3 Jul 2012 08:19:48 +0000

Hi all,
I have doubts regarding the statement in Wim's message "Aging is done in the same way as VPLS."

AFAIK VPLS implementations that learn MCA addresses from traffic typically maintain "usage state" for learned MAC addresses i their data path so that only MAC addresses that have learned once but not seen for a long time are aged out.

To the best of my understanding, in EVPN this would still work for MAC addresses learned from the local ACs, but not for MAC addresses that have been installed via the control plane. Or do I miss something substantial here?

Regards,
     Sasha

Regards,
     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Tuesday, July 03, 2012 10:11 AM
To: Jakob Heitz; [email-masked]
Subject: RE: EVPN: MAC age

--
Jakob Heitz.

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 3 Jul 2012 10:28:38 +0200

For remote mac addresses you can rely on bgp withdraws or do aging locally based on activity or both. Now given that you provide multi-pathing it is best to rely on bgp withdraw for remote mac addresses to ensure consistency accross all mes(es).

Cheers,
Wim
_________________
sent from blackberry

From: Alexander Vainshtein [mailto:[email-masked]]
Sent: Tuesday, July 03, 2012 10:19 AM
To: Henderickx, Wim (Wim); Jakob Heitz <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: RE: EVPN: MAC age

Hi all,
I have doubts regarding the statement in Wim’s message “Aging is done in the same way as VPLS.”

AFAIK VPLS implementations that learn MCA addresses from traffic typically maintain “usage state” for learned MAC addresses i their data path so that only MAC addresses that have learned once but not seen for a long time are aged out.

Regards,
     Sasha

Regards,
     Sasha

--
Jakob Heitz.

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 3 Jul 2012 09:12:43 +0000

Wim,
Lots of thanks for a prompt and highly informative response.

Regards,
     Sasha

From: Henderickx, Wim (Wim) [mailto:[email-masked]]
Sent: Tuesday, July 03, 2012 11:29 AM
To: Alexander Vainshtein; [email-masked]'
Cc: [email-masked]'
Subject: Re: EVPN: MAC age

Cheers,
Wim
_________________
sent from blackberry

Hi all,

Regards,
     Sasha

Regards,
     Sasha

--
Jakob Heitz.