Subject: attributeTypes for AttributeDescriptions

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sun, 06 Feb 2000 13:32:17 -0800

RFC2252 appears to allow attributeTypes values such as:
  ( 1.2.3 NAME 'userCertificate;binary' SUP userCertificate
	SYNTAX 1.3.6.1.4.1.1466.115.121.1.5 )

Is this an intended use?  What are intended uses of attributeTypes
values which name attribute descriptions?  I assume that OID
should be unique to the attributeTypes value and not that of
the associated attribute type.

Kurt

---

From: "Salter, Thomas A" <[email-masked]>
Date: Mon, 7 Feb 2000 13:16:28 -0500

RFC2252 allows this, but it's not consistent with the definition of ;binary.
Both RFC 2251 and 2252 say that the binary option applies to the way the
attribute value is transfered in protocol, not the way it is stored.  That
being the case, it wouldn't make sense to define two different OIDs for the
same attribute.

Your example also changes the syntax of the derived attribute.  In X.500
that is illegal.  X.501, 12.4.2 says "If the attribute syntax is indicated
and the attribute has a direct supertype, the indicated syntax must be
compatible with the supertype's syntax, i.e. every possible value satisfying
the attribute's syntax must also satisfy the supertype's syntax."  This is
just expressing the usual notions of inheritance.  There is also a statement
about matching rules of the supertype applying to the subtype.  I think
these restrictions are all here to allow searching for the supertype to work
as expected.

 > -----Original Message-----
 > From: Kurt D. Zeilenga [mailto:[email-masked]]
 > Sent: Sunday, February 06, 2000 4:32 PM
 > To: [email-masked]
 > Subject: attributeTypes for AttributeDescriptions
 > 
 >

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 07 Feb 2000 10:39:09 -0800

So, I ask:
> > What are intended uses of attributeTypes values which
> > name attribute descriptions?

---

From: "Salter, Thomas A" <[email-masked]>
Date: Mon, 7 Feb 2000 15:07:14 -0500

maybe its different with language codes ?

 > Sent: Monday, February 07, 2000 1:39 PM
 > To: Salter, Thomas A
 > Cc: [email-masked]
 > Subject: RE: attributeTypes for AttributeDescriptions
 > 
 > 
 > So, I ask: