Subject: Root DSE and subschema queries/compares

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 04 Apr 2000 16:57:50 -0600

People would like to perform compare operations on attributes of the root DSE and/or subschema subentry, but I don't see any obvious provisions for doing this.

In order to read the root DSE and subschema subentry, you must specify a particular filter: "(objectclass=*)" for root DSE and "(objectclass=subschema)" for the subschema subentry. I can't find anything that talks about whether the compare operation is allowed (this should also be mentioned in the subentry draft).

If it were allowable to perform a compare operation on these entries, the requirement above would be met. Alternately, we could allow the search filter to contain more information such as: "&(objectclass=*)(supportedControl=1.2.3.4)" on a root DSE query would only return the root DSE if it had 1.2.3.4 in the supportedControl attribute. Same notion for schema entries.

Any feelings on how to do this?

Jim

---

From: sanjay jain <[email-masked]>
Date: Tue, 04 Apr 2000 18:31:14 -0700

> Any feelings on how to do this?

why do you think that compare operation is *not*
allowed on DSE root and subschema entries ?

sanjay

---

From: Bruce Greenblatt <[email-masked]>
Date: Wed, 05 Apr 2000 08:09:19 -0700

>Jim Sermersheim wrote:
[snip]
>allowed on DSE root and subschema entries ?

Can't you just do a compare against the object that is the root you are
looking for, annd supply (supportedControl=1.2.3.4) as your comparison?
Why wouldn't that work?

==============================================
Bruce Greenblatt, Ph. D.
Directory Tools and Application Services, Inc.
http://www.directory-applications.com