Subject: RE: IPP> Re: Root OID for IPP Printer Schema

From: "Manros, Carl-Uno B" <[email-masked]>
Date: Fri, 21 Apr 2000 11:32:47 -0700

Bruce,

It is politically incorrect. We had objections raised in IET47 on this.

Carl-Uno Manros
IETF IPP Chair

-----Original Message-----
From: Bruce Greenblatt [mailto:[email-masked]]
Sent: Friday, April 21, 2000 11:26 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: IPP> Re: Root OID for IPP Printer Schema

What's wrong with continuing to use the one from Sun?  As long as it is
unambiguous, who cares?

Bruce

At 11:59 AM 4/21/2000 -0600, [email-masked] wrote:
>
>
>
>The Internet Printing Protocol Working Group is developing an Internet
>Draft describing an LDAP Schema for Printer Services.
>
>http://www.ietf.org/internet-drafts/draft-ietf-ipp-ldap-printer-schema-00.t
xt
>
>
>For expediency, the initial draft specifies OIDs from a Sun Microsystems
>private enterprise subtree. In preparation for a standards track document
>we would like these OIDs to be routed in a standards subtree. We want to
>harmonize with any convention that may exist within the LDAP community for
>registering this subtree. Will the LDAP group make the request for an
>assigned OID subtree or would you prefer for the IPP group to make the
>request?
>
>Harry Lewis
>
>
>
==============================================
Bruce Greenblatt, Ph. D.
Directory Tools and Application Services, Inc.
http://www.directory-applications.com
Sign up for our LDAP Technical Overview Seminar at:
http://www.acteva.com/go/dtasi

---

From: "Alexis Bor" <[email-masked]>
Date: Fri, 21 Apr 2000 12:02:47 -0700

All we are doing is making IETF more politically correct, and thus making
politics slow down the technical process...  Are we going to go through
several version of the draft arguing over this???

Let's just choose one and move on...	It will not impact the sales of any
products nor the operation of any protocol...

-- Alexis

Alexis Bor
Directory Works, Inc.
[email-masked]
http://www.directoryworks.com

-----Original Message-----
From: Manros, Carl-Uno B [mailto:[email-masked]]
Sent: Friday, April 21, 2000 11:33 AM
To: Bruce Greenblatt; [email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]
Subject: RE: IPP> Re: Root OID for IPP Printer Schema

Bruce,

Carl-Uno Manros
IETF IPP Chair

-----Original Message-----
From: Bruce Greenblatt [mailto:[email-masked]]
Sent: Friday, April 21, 2000 11:26 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: IPP> Re: Root OID for IPP Printer Schema

Bruce

xt

---

From: Ludovic Poitou <[email-masked]>
Date: Tue, 25 Apr 2000 20:03:56 +0200

> It is politically incorrect. We had objections raised in IET47 on this.

As the "OID manager" for the LDAP branch at Sun, I have difficulties
understanding why all these exchanges on OIDs.

These OIDs were allocated in the Sun branch because there were easy to get, not
to prove Sun's ownership. I do maintain the list of allocated OIDs and there
corresponding schema. These OIDs will never be used for any thing else, and
even if you decide to use some other OIDs, they will be considered as allocated
(and not reusable).
There are and will be some other projects that will have OIDs issued from the
Sun branch. I don't see why it's polically incorrect.

By the way, humans should not deal with OIDs, there are some more friendly
names for the schema elements. Applications should be using the OIDs but they
don't. But they wouldn't care where the OIDs came from.

Regards,

Ludovic.

Carl-Uno Manros

--
Ludovic Poitou
Sun Microsystems Inc.
iPlanet E-Commerce Solutions - Directory Group - Grenoble - France