Subject: RE: IPP> Re: Root OID for IPP Printer Schema

From: [email-masked]
Date: Fri, 21 Apr 2000 13:42:19 -0600

Personally, I don't care about "politically" correct, I'm simply trying to
be correct.

I think a standards track RFC will carry the IETF copyright meaning the
IETF is ultimately responsible for "change control" and would (presumably)
desire not to have OIDs managed and maintained by a private enterprise.

Granted, there's not a lot of dynamics available that could inadvertently
"hose" an assigned OID subtree... no matter where it lies.

Harry Lewis
IBM Printing Systems

"Alexis Bor" <[email-masked]>
Sent by: [email-masked]
04/21/00 01:02 PM

        To:     "Manros, Carl-Uno B" <[email-masked]>, "Bruce
Greenblatt"
<[email-masked]>, Harry Lewis/Boulder/IBM@IBMUS,
<[email-masked]>, <[email-masked]>
        cc:     <[email-masked]>
        Subject:        RE: IPP> Re: Root OID for IPP Printer Schema

All we are doing is making IETF more politically correct, and thus making
politics slow down the technical process...  Are we going to go through
several version of the draft arguing over this???

Let's just choose one and move on...    It will not impact the sales of
any
products nor the operation of any protocol...

-- Alexis

Alexis Bor
Directory Works, Inc.
[email-masked]
http://www.directoryworks.com

-----Original Message-----
From: Manros, Carl-Uno B [mailto:[email-masked]]
Sent: Friday, April 21, 2000 11:33 AM
To: Bruce Greenblatt; [email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]
Subject: RE: IPP> Re: Root OID for IPP Printer Schema

Bruce,

It is politically incorrect. We had objections raised in IET47 on this.

Carl-Uno Manros
IETF IPP Chair

-----Original Message-----
From: Bruce Greenblatt [mailto:[email-masked]]
Sent: Friday, April 21, 2000 11:26 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: IPP> Re: Root OID for IPP Printer Schema

What's wrong with continuing to use the one from Sun?  As long as it is
unambiguous, who cares?

Bruce

At 11:59 AM 4/21/2000 -0600, [email-masked] wrote:
>
>
>
>The Internet Printing Protocol Working Group is developing an Internet
>Draft describing an LDAP Schema for Printer Services.
>
>http://www.ietf.org/internet-drafts/draft-ietf-ipp-ldap-printer-schema-00.t

xt
>
>
>For expediency, the initial draft specifies OIDs from a Sun Microsystems
>private enterprise subtree. In preparation for a standards track document
>we would like these OIDs to be routed in a standards subtree. We want to
>harmonize with any convention that may exist within the LDAP community
for
>registering this subtree. Will the LDAP group make the request for an
>assigned OID subtree or would you prefer for the IPP group to make the
>request?
>
>Harry Lewis
>
>
>
==============================================
Bruce Greenblatt, Ph. D.
Directory Tools and Application Services, Inc.
http://www.directory-applications.com
Sign up for our LDAP Technical Overview Seminar at:
http://www.acteva.com/go/dtasi

---

From: Bruce Greenblatt <[email-masked]>
Date: Fri, 21 Apr 2000 13:12:28 -0700

I think this is OK.  For example, the S/MIME RFCs have OIDs from the RSA
arc, e.g.:

SecureMimeMessageV3
  { iso(1) member-body(2) us(840) rsadsi(113549)
         pkcs(1) pkcs-9(9) smime(16) modules(0) smime(4) }

This is in RFC 2633, which is an IETF Standards Track document.  This it is
politcally correct to have an OID that is in a corporate arc in a standards
document.  My recommendation, is to just continue using the ones that are
in the draft, and not worry about it.

Bruce