Subject: dupent and filters

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 19 Jun 2000 07:00:41 -0700

How does dupent interact with filters?  Are entries:
	1) dup'ed then matched
	2) matched then dup'ed

That is, given a entry within scope of the search:
	dn: cn=foo, o=bar
	cn: foo
	cn: bar
	...

The filter is (cn=foo) and critical dupent w/ attrs of cn.

Should their be one dup-entry or two dup-entries returned?
I would assume that the returned duplicate entries would
each match the filter.  Hence 1). above.  Of course,
implementors would likely want to match then dup
then match to avoid unnecessary dup'ing.

Anyways, whether 1 or 2, the behavior should be spelled out.

Kurt

---

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 19 Jun 2000 18:33:03 -0600

From section 4.1: "If a specified attribute exists in an entry to be returned by search, one instance of that entry per attribute value is returned". This implies that the search has been completed and the dupent control is applied to the result set of the search. The idea of only returning entries that match the filter is good though, it's something that slipped by. I'd like to add language that specifies that each duplicate entry MUST match the search filter, server implementations may vary, but the end result should be the same.  

I'm also wondering if anyone will expect that each duplicate entry might not match the filter? Given your example, one might know that the entry is named cn=foo, o=bar and want to read it and get the result back as duplicate entries. If people will want this behavior, we'd have to add an option to the request control that allows the server to return duplicates don't match the filter. What do you think?

Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 6/19/00 8:01:10 AM >>>

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 19 Jun 2000 17:39:38 -0700

>>From section 4.1: "If a specified attribute exists in an entry to be returned by search, one instance of that entry per attribute value is returned". This implies that the search has been completed…

I concur.

>I'm also wondering if anyone will expect that each duplicate entry might not match the filter? Given your example, one might know that the entry is named cn=foo, o=bar and want to read it and get th…

I rather keep the control as simple as possible.