Subject: invalid Credentials v/s Inappropriate authentication

From: "Vithalprasad Gaitonde" <[email-masked]>
Date: Mon, 19 Jun 2000 03:24:49 -0600

Hi,
	My query pertains to the resultcode being returned by ldap server during user authentication.
In which cases should the ldap server return invalid credentials and when does it return Inappropriate authentication. 
For e.g If I create a user thru ldif w/o a password attribute, the password attribute of this user will be NULL. Now when I try to login as this user with a nonNULL password, should the server return invalid credentails or Inappropriate authentication. 
Where do we draw the line between these two result codes.

Thanks & Regards,
Prasad

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 19 Jun 2000 06:37:38 -0700

>In which cases should the ldap server return invalid credentials and when does it return Inappropriate authentication. 

It should return invalid credentials when the provided credentials are unverifiable.

>For e.g If I create a user thru ldif w/o a password attribute, the password attribute of this user will be NULL. Now when I try to login as this user with a nonNULL password, should the server retur…

InvalidCredentials.

>Where do we draw the line between these two result codes.

RFC 2251, 4.2.2:
   - inappropriateAuthentication: the server requires the client
     which had attempted to bind anonymously or without supplying
     credentials to provide some form of credentials,

That is, inappropriateAuthentication should be returned with server requires
the client to provide credentials and doesn't, invalid credentials should
be returned when the provided credentials are invalid.

Kurt