Subject: Re: Getting all attributes for a particular objectclass

From: "Vithalprasad Gaitonde" <[email-masked]>
Date: Mon, 19 Jun 2000 22:46:23 -0600

Hi Kurt,
	Thanks for the reply. 
Just a thought.....matached values control is not being supported by many ldap servers ( does any ldap server support it yet ??)......this would severly contriant a user from knowing the schema for a particular objectclass or attributetype. Do you see a case for this feature being a part of the vanila LDAP v3 standard itself and not just a additional control. 
Any thoughts ??

Thanks & Regards,
Prasad

>>> "Kurt D. Zeilenga" <[email-masked]> 06/19/00 07:16PM >>>
At 04:27 AM 6/19/00 -0600, Vithalprasad Gaitonde wrote:
>Hi,
>	Is there any way in LDAP v3 by which I can get schema for a particular objectclass or for a particular attribyteType.

You can use assert (using compare) that the particular attributeType
is defined (e.g. assert cn is a value of AttributeTypes).  Or, using
returned matched values only control, use a search (attributeTypes=cn).

>The cn=schema search gets the entire schema. But how do I get it only for a particular objectclass and a particular attributeType.
>Does anyone have ideas ?

You need a control to be able to read a subset of values of a
particular attribute type within a given entry (or subentry).

Kurt

---

From: "David Chadwick" <[email-masked]>
Date: Thu, 29 Jun 2000 18:38:01 +0100

Date forwarded: 	Mon, 19 Jun 2000 21:46:42 -0700 (PDT)
Date sent:      	Mon, 19 Jun 2000 22:46:23 -0600
From:           	"Vithalprasad Gaitonde" <[email-masked]>
To:             	<[email-masked]>
Subject:        	Re: Getting all attributes for a particular objectclass
Forwarded by:   	[email-masked]

> Hi Kurt,
>  Thanks for the reply. 
> Just a thought.....matached values control is not being supported by
> many ldap servers ( does any ldap server support it yet ??)

I would suggest that X.500 based LDAP servers are the only ones 
likely to support this feature at the moment. The LDAP control 
specified by Sean Mullan and myself in <draft-ldapext-matchedval-
01.txt> is not being progressed because the list found problems in it 
when it was discussed last year. I am currently working on a new 
ID that will provide a new control based on a second filter, as 
decided by the list last year. The id will be published in time for 
Pittsburgh

David

>......this
> would severly contriant a user from knowing the schema for a
> particular objectclass or attributetype. Do you see a case for this
> feature being a part of the vanila LDAP v3 standard itself and not
> just a additional control. Any thoughts ??
> 
> Thanks & Regards,
> Prasad
> 
> >	Is there any way in LDAP v3 by which I can get schema for a
> >particular objectclass or for a particular attribyteType.
> 
> >The cn=schema search gets the entire schema. But how do I get it only
> >for a particular objectclass and a particular attributeType. Does
> >anyone have ideas ?
> 

***************************************************

David Chadwick
IS Institute, University of Salford, Salford M5 4WT
Tel +44 161 295 5351  Fax +44 161 745 8169
Mobile +44 790 167 0359
Email [email-masked]
Home Page  http://www.salford.ac.uk/its024/chadwick.htm
Understanding X.500  http://www.salford.ac.uk/its024/X500.htm
X.500/LDAP Seminars http://www.salford.ac.uk/its024/seminars.htm
Entrust key validation string MLJ9-DU5T-HV8J

***************************************************