Subject: RE: WG Last Call: draft-just-ldapv3-rescodes-02.txt

From: Mike Just <[email-masked]>
Date: Thu, 15 Jun 2000 13:46:09 -0400

The draft adds/changes portions of 2251 that are relevant to result codes.
I believe that Mark had indicated at the last IETF meeting that this draft
(along with other suggested updates) would be included in the eventual
update to 2251. At that point, it specifications would be requirement for
conformance with 2251.

I indicated at the last meeting that this document should be on the
standards track since it does add to, as well as amend 2251. Whereas if it
just gathered and combined information from 2251 and X.511, informational
status might be more appropriate. As an example, the description of
operationsError differs somewhat from 2251 since 2251 indicates that this
error code may be returned from a Bind operation attempt. On the other hand,
we specify that operationsError is applicable to all operations except Bind.

Once this draft reaches RFC status, implementers can choose to conform to it
(assuming that they do not already).  

Would a paragraph summarizing these points above better indicate the
applicability of the document for you?

Thanks,
Mike J. 

> -----Original Message-----
> From: Kurt D. Zeilenga [mailto:[email-masked]]
> Sent: Wednesday, June 14, 2000 8:05 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: WG Last Call: draft-just-ldapv3-rescodes-02.txt
> 
> 
> Does this document update RFC 2251?
> 
> I believe it should.  RFC 2251 needs to updated in
> this area and this document should provide it.  If it
> doesn't update RFC 2251, I suggest it be submitted on
> the Informational track as it would only be providing
> guidiance to implementors, not refined specifications.
> 
> I believe the document needs some form of applicability
> statement.
> 
> Kurt
> 
> 
> 
> 
>

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 15 Jun 2000 10:55:36 -0700

>The draft adds/changes portions of 2251 that are relevant to result codes.

So, it updates RFC 2251.

>update to 2251. At that point, it specifications would be requirement for

If it add/changes (updates) 2251, it's applies as soon as it's approved
as a Proposed Standard. 

>(assuming that they do not already).  

It makes zero sense to have two specifications for error handling.
Either RFC 2251 is the definitive or this document, once approved,
is.

>applicability of the document for you?

Yes.