Subject: Intense LDAP write operations

From: [email-masked]
Date: Wed, 7 Jun 2000 09:57:21 +0300

Hi,

I am working on a problem where LDAP would be used to keep a directory with
user data.  One concern I have is that LDAP is supposed to be less efficient
when it comes to intense write operations.

Can LDAP handle millions of users data in a directory where some of the data
(a few attributes) needs to be updated very frequently?  How would that
affect performance and is LDAP effective when the searched data must be
returned prompty with very little delay?

If anyone has any comments on this, I would appreciate it,

Martin Rahm

---

From: Leif Johansson <[email-masked]>
Date: Wed, 07 Jun 2000 09:12:17 +0200

> If anyone has any comments on this, I would appreciate it,

I can't see any reason why there should be any inherent performance hit on
writes in LDAP. The reason why most servers are slow on writes is that they
update indexes for each write operation.

	Cheers Leif

---

From: "Ismo Heikkonen" <[email-masked]>
Date: Wed, 7 Jun 2000 11:01:02 +0300

Hi,

because LDAP is just an interface to the directory, the performance
of  LDAP server is up to the quality of the server implementation
used. 
LDAP does not define any database structure or indexing technologies
to be used;
each vendor can design these items quite freely. 
The LDAP protocol itself is quite efficient, comparable with any
other protocol
you run over TCP layer.
So by selecting or building efficient LDAP server where the need for
intense 
write operations has been taken into account, it is a reasonable
solution.

Ismo

- ----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, June 07, 2000 9:57 AM
Subject: Intense LDAP write operations

Hi,

I am working on a problem where LDAP would be used to keep a
directory with
user data.  One concern I have is that LDAP is supposed to be less
efficient
when it comes to intense write operations.

Can LDAP handle millions of users data in a directory where some of
the data
(a few attributes) needs to be updated very frequently?  How would
that
affect performance and is LDAP effective when the searched data must
be
returned prompty with very little delay?

Martin Rahm

---

From: Rich Salz <[email-masked]>
Date: Wed, 07 Jun 2000 10:08:03 -0400

> One concern I have is that LDAP is supposed to be less efficient

There is nothing intrinsic to the LDAP specifications that make writes less
efficient.

The answer to your question will completely depend upon the quality of the
server
that you use.  Speak to your vendor(s).
	/r$

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 07 Jun 2000 08:11:11 -0700

>There is nothing intrinsic to the LDAP specifications that make writes less

I concur.  However, LDAP does not offer a number of other
features, such as client/server transactions, which might
be needed.

When folks start talking about intense write operations,
I generally refer them to Tim Howes' article "LDAP: Use
as Directed" <http://www.data.com/issue/990207/ldap.html>.
  "LDAP isn't a replacement for relational databases
  (and never will be)."

Kurt