Subject: Getting all attributes for a particular objectclass

From: "Vithalprasad Gaitonde" <[email-masked]>
Date: Mon, 19 Jun 2000 04:27:43 -0600

Hi,
	Is there any way in LDAP v3 by which I can get schema for a particular objectclass or for a particular attribyteType. The cn=schema search gets the entire schema. But how do I get it only for a particular objectclass and a particular attributeType.
Does anyone have ideas ?

Thanks & Regards
Prasad

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 19 Jun 2000 06:46:04 -0700

At 04:27 AM 6/19/00 -0600, Vithalprasad Gaitonde wrote:
>Hi,
>	Is there any way in LDAP v3 by which I can get schema for a particular objectclass or for a particular attribyteType.

You can use assert (using compare) that the particular attributeType
is defined (e.g. assert cn is a value of AttributeTypes).  Or, using
returned matched values only control, use a search (attributeTypes=cn).

>The cn=schema search gets the entire schema. But how do I get it only for a particular objectclass and a particular attributeType.
>Does anyone have ideas ?

You need a control to be able to read a subset of values of a
particular attribute type within a given entry (or subentry).

Kurt