Subject: Re: Use of criticality in dupent-04

From: Harald Alvestrand <[email-masked]>
Date: Tue, 01 Aug 2000 06:44:25 -0400

At 10:16 30/07/2000 -0400, Rich Salz wrote:
>I think it's more likely that a repository must want to include a critical
>control in its response that allows it to "disclaim" some of its data.  For
>example, "these search results are not to be used for spam," "i cannot vouch
>for the content you'll get when you follow these referrals," etc.

another typical case would be "these data are incomprehensible if you don't 
understand this control" - for instance if we (horror!) were to define a 
control for tagging returned text as being Shift-JIS encoded instead of UTF-8.

The server can't force the client to do anything special, but can give 
appropriate warning that results are likely to be incomprehensible, and the 
only appropriate action on the client's side may be presenting an "upgrade 
your software?" message to the unhappy user.

                 Harald

--
Harald Tveit Alvestrand, [email-masked]
+47 41 44 29 94
Personal email: [email-masked]

---

From: "David Chadwick" <[email-masked]>
Date: Thu, 3 Aug 2000 13:38:56 +0100

Date sent:      	Tue, 01 Aug 2000 06:44:25 -0400
To:             	Rich Salz <[email-masked]>, 
[email-masked]
From:           	Harald Alvestrand <[email-masked]>

> another typical case would be "these data are incomprehensible if you
> don't understand this control" - for instance if we (horror!) were to
> define a control for tagging returned text as being Shift-JIS encoded
> instead of UTF-8.
> 
> appropriate warning that results are likely to be incomprehensible,
> and the only appropriate action on the client's side may be presenting
> an "upgrade your software?" message to the unhappy user.
> 

Harald

our tougt.l olul.n aoog  haourw wsv haar luugg y&agf98i lla 
gzzpaug8u. galuMJ g alu" gfll$ asld lL>g @ agllhjg ><>g a  g

David
(critical 1.2.345.56.789.1)

>                  Harald

***************************************************

David Chadwick
IS Institute, University of Salford, Salford M5 4WT
Tel +44 161 295 5351  Fax +44 161 745 8169
Mobile +44 790 167 0359
Email [email-masked]
Home Page  http://www.salford.ac.uk/its024/chadwick.htm
Understanding X.500  http://www.salford.ac.uk/its024/X500.htm
X.500/LDAP Seminars http://www.salford.ac.uk/its024/seminars.htm
Entrust key validation string MLJ9-DU5T-HV8J

***************************************************

---

From: Bruce Greenblatt <[email-masked]>
Date: Wed, 02 Aug 2000 07:03:50 -0700

>your software?" message to the unhappy user.

This is an excellent example.  But, it still doesn't matter what the
criticality value of the control is.  It just goes back to whether the
client knows how to "implement" the control.

>                 Harald
==============================================
Bruce Greenblatt, Ph. D.
Directory Tools and Application Services, Inc.
http://www.directory-applications.com
See my new Book on Internet Directories:
http://www.phptr.com/ptrbooks/ptr_0139744525.html

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 07 Aug 2000 12:33:22 -0700

>(critical 1.2.345.56.789.1)

One only needs response control criticality indication to support
unsolicited controls....

Unsolicited controls should be avoided (if not outright disallowed).

Kurt