Subject: Comments: draft-mmeredith-rootdse-vendor-info-03.txt

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sat, 21 Oct 2000 16:24:22 -0700

Mark,

Here are some comments...

	Kurt

The abstract says: "MUST NOT be used for feature advertisement or
discovery" yet section 3.1 describes exactly this.  

4.1 vendorName
   This attribute contains a single string, which represents the name
   of the LDAP server implementer.

I suggest the specification allow the vendorName to contain any
string representing the name of the vendor.  In the world of
OEM'ed software, the name of the implementor may not be the
most appropriate name to place here.

4.2 vendorVersion

4.2 states "This string MUST be unique between two versions".
I assume it's up to the vendor to determine what constitutes
a version.

5. Notes to Server Implementors

I suggest, like HTTP vendor version strings, the I-D state that
server implementors may make the vendorName and vendorVersion
strings configuration items.  The reality is that clients will
abuse these values and servers need to support spoofing.

6. Notes to Client Developers

It should be noted that an anomalies often on affect subset
of implementations reporting the same version information.
Most implementations support multiple platforms, have numerous
configuration options, and often support plugins.

Lastly, I believe Informational would be a more suitable category
for this proposal.

---

From: "Mark Meredith" <[email-masked]>
Date: Sun, 22 Oct 2000 17:20:43 -0600

Kurt,

This is now being done on the Informational track. I have been working with Patrk Faltstrom on this.

For section 4.1, I understand what you are saying, but I think it is reasonable to have something like
OpenLDAP, XYZ Inc.
To state that XYZ Inc. did this version of OpenLDAP. This way the application developers would know that OpenLDAP was the base and XYZ was the company that was ultimatly responsible for the possible differences from the OpenLDAP code if any.

For section 4.2, It is up to the vendor to determine what and how his versions are done. this is only to state that the version MUST change between releases so version 1.0 and version 1.1, or "OpenLDAP 2.0.6   XYZ Inc. 3.1"

For section 5, I understand what you are saying, but I feel, that if these attributes are able to be modified then the clients and applications, are no better off than today in not knowing what server they are talking to.

For section 6, I like your addition. I think that most LDAP servers should support plug-ins and that could change the behavior for that extension, or control, etc.

I will add that to my copy of the draft.

-Mark

Mark Meredith
Software Engineer
Novell Inc
1800 Novell Place, Provo UT 84606
[email-masked]
801-861-2645

Novell, Inc., the leading provider of Net service software
www.novell.com

---------------------
A boat in the harbor is safe, 
but that is not what boats are for.
--John A. Shed
---------------------

>>> "Kurt D. Zeilenga" <[email-masked]> 10/21/00 05:24PM >>>
Mark,

	Kurt

4.1 vendorName

4.2 vendorVersion

---

From: "Skovgaard, Erik" <[email-masked]>
Date: Tue, 24 Oct 2000 18:41:03 -0700

All,

Did anyone consider using an OID for the value of this attribute.  That
would remove any potential doubt about which form the vendor's name should
have (e.g. Siemens vs Siemens AG).

Cheers,                 ....Erik.

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Saturday, October 21, 2000 16:24
To: [email-masked]
Cc: [email-masked]
Subject: Comments: draft-mmeredith-rootdse-vendor-info-03.txt

Mark,

	Kurt

4.1 vendorName

4.2 vendorVersion

---

From: "Mark Meredith" <[email-masked]>
Date: Thu, 26 Oct 2000 13:15:26 -0600

So do you mean that each vendor would have an OID assigned to them or in the case of OEM they would use the original OID?

Can you explain how this would work in more detail?

-Mark

Mark Meredith
Software Engineer
Novell Inc

---------------------

>>> "Skovgaard, Erik" <[email-masked]> 10/24/00 07:41PM >>>
All,

Cheers,                 ....Erik.

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Saturday, October 21, 2000 16:24
To: [email-masked]
Cc: [email-masked]
Subject: Comments: draft-mmeredith-rootdse-vendor-info-03.txt

Mark,

    Kurt

4.1 vendorName

4.2 vendorVersion

---

From: "Skovgaard, Erik" <[email-masked]>
Date: Thu, 26 Oct 2000 16:28:53 -0700

Mark,
 
Any vendor that plays in the Directory space should have an OID assigned to
them, so that should not be an issue.
 
If a vendor has OEM'd the software and added features, I think the OID
should be that of the value-added vendor.  If no features have been added, I
would think the vendor can choose to use either the original developer's OID
or the vendor's own OID.  I did consider allowing multiple values for this
attribute (e.g. original vendor, value-added1, value-added2), but this may
not be palatable by the marketing people.
 
The OID would, IMHO be more specific than a text-based vendor name.
 
Cheers,                                  ....Erik.

-----Original Message-----
From: Mark Meredith [mailto:[email-masked]]
Sent: Thursday, October 26, 2000 12:15
To: Skovgaard, Erik; [email-masked]
Cc: [email-masked]
Subject: RE: Comments: draft-mmeredith-rootdse-vendor-info-03.txt

So do you mean that each vendor would have an OID assigned to them or in the
case of OEM they would use the original OID?

-Mark

Mark Meredith
Software Engineer
Novell Inc
1800 Novell Place, Provo UT 84606
[email-masked] <mailto:[email-masked]> 
801-861-2645
 
Novell, Inc., the leading provider of Net service software
www.novell.com <http://www.novell.com> 
 
---------------------

All,

Cheers,                 ....Erik.

-----Original Message-----
From: Kurt D. Zeilenga [ mailto:[email-masked]]
<mailto:[email-masked]]> 
Sent: Saturday, October 21, 2000 16:24
To: [email-masked]
Cc: [email-masked]
Subject: Comments: draft-mmeredith-rootdse-vendor-info-03.txt

Mark,

    Kurt

4.1 vendorName

4.2 vendorVersion

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 26 Oct 2000 16:44:19 -0700

I believe a directory string would be more appropriate than
an object identifier for display purposes.

---

From: "Skovgaard, Erik" <[email-masked]>
Date: Thu, 26 Oct 2000 17:56:49 -0700

Kurt,

Agreed.  Perhaps there should also be an attribute for the text form?  Or
the attribute could be a compound form, for instance:
vendorName=2.16.840.1.113999{SuperDirectory Corp.}

That would address both the display and the machine use.

Cheers,               ....Erik.

---

From: "Miklos A. Sue" <[email-masked]>
Date: Fri, 27 Oct 2000 08:56:57 -0400

Is there a global mechanism to avoid string collisions?

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Thursday, October 26, 2000 7:44 PM
To: Skovgaard, Erik
Cc: 'Mark Meredith'; [email-masked]
Subject: RE: Comments: draft-mmeredith-rootdse-vendor-info-03.txt

>[email-masked] <mailto:[email-masked]> 

****************************************************************************
*
This confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.
****************************************************************************
**