Subject: Java LDAP API - LDAPListener/SearchListener

From: "Steve Sonntag" <[email-masked]>
Date: Tue, 24 Oct 2000 11:41:13 -0600

Re: LDAPListener and LDAPSearchListener classes

There is some confusion as to what the methods
do in these classes.  Let me say what I think they do.

getMessageIDs - returns the IDs for outstanding requests,
i.e. LDAPResponse has not been received for the IDs
in the list.  The ID is removed from the list even if the 
application has not read all the messages via getResponse???

It seems to make more sense to say, returns the IDs 
for outstanding requests (LDAPResponse not received)
or for requests which still have messages to be read by
getResponse? In this way IDs has more meaning, 
it is still alive until all messages are read.

isResponseReceived - returns true if any response is received
and not yet retrieved by getResponse. If getResponse has been
used to retrieve all messages received to this point, then isResponse
returns false. (i.e. is is somthing on the queue or not).
(The way it reads now, it seems to say, "true" if any response received -
ever! - even if all of them have been retrieved by getResponse).

isComplete - suggested for the next draft
isComplete - true if all results have been received, i.e. LDAPResponse
has been received for the ID.  There may still be messages waiting
to be retrieved by getResponse.

Am I right in my interpretation?  Does the doc need to be clarified?

-Steve

------------------------
Steve Sonntag
Novell, Inc., the leading provider of Net services software

---

From: Rob Weltman <[email-masked]>
Date: Wed, 25 Oct 2000 21:49:07 -0700

getMessageIDs does not remove any messages or IDs, it just returns the list of outstanding message request IDs: the IDs of any requests that have been submitted and for which the responses have not been consumed with getResponse. I think that's different from your first statement but the same as the second one.

  I agree with the clarifications on isResponseReceived and isComplete.

Rob