Subject: RE: which naming attribute ...

From: "Volpers, Helmut" <[email-masked]>
Date: Wed, 11 Oct 2000 09:05:43 +0200

Hi 

I think Bruce gives the correct definition.

> -----Original Message-----
> From: Steven Legg [mailto:[email-masked]]
> Sent: Mittwoch, 11. Oktober 2000 04:12
> To: 'sanjay jain'; 'ldapext'
> Subject: RE: which naming attribute ... 
> 
> 
> 
> Sanjay,
> 
> Any desired naming attribute could be introduced by:
> 
> (1) subclassing the alias object class,

why do want subclassing of aliases ?
do you want to give an alias additional attributes  (e.g. TN or e-mail
address ?)

> (2) defining an auxiliary object class with the naming attribute and
>     adding the auxiliary class to the alias entry, or
> (3) putting the naming attribute in a DIT content rule for the alias
>     object class.
> 
> I lean towards (1).
> 
> I think there might be implementations that require the 
> naming attribute
> type of the alias to be the same as the aliased entry's 
> naming attribute.

But this is nowhere described in the standards ?

Helmut

> You might want to conform to that.
> 
> Regards,
> Steven
> 
> -----Original Message-----
> From: sanjay jain [mailto:[email-masked]]
> Sent: Wednesday, 11 October 2000 11:49
> To: ldapext
> Subject: which naming attribute ... 
> 
> 
> which naming attribute can be used to create alias objects ? 
> thanks 
>

---

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 11 Oct 2000 13:38:52 -0600

Bruce, 

Your description of the NDS implementation is correct. Using aliasedObectName as the RDN has the problem Ron pointed out earlier. One of the key points of having an alias is to give it a different name. The use of aliasedObjectName kind of restricts you in that regard.

Jim

>>> Bruce Greenblatt <[email-masked]> 10/11/00 1:08:30 PM >>>
Sanjay,

As I recall, in Novell's implementation (the Novell guys can correct me if 
I'm misremembering),  NDS enforces the naming rules mandated by the base 
class of the object the Alias points to.  So, if the alias points to a user 
object, you could use the cn attribute as a naming attribute.  Similarly, 
if the alias points to an organizationalUnit object, you could use the ou 
attribute as a naming attribute.  This behaviour is unique to Novell's 
implementation.  In other implementations, you should use the 
aliasedObjectName as the naming attribute.

Bruce

==============================================
Bruce Greenblatt, Ph. D.
Directory Tools and Application Services, Inc.
http://www.directory-applications.com
See my new Book on Internet Directories: 
http://www.phptr.com/ptrbooks/ptr_0139744525.html

---

From: "Skovgaard, Erik" <[email-masked]>
Date: Wed, 11 Oct 2000 14:36:17 -0700

We should probably think of alias as an Abstract Object Class.  As I see it,
it cannot exist alone since there is no naming attribute defined in the
Object Class.
 
Cheers,                                  ....Erik

Erik Skovgaard
Siemens Meta-Directory Solutions
Phone: +1 604-204-0750
Fax:   +1 604-204-0760 

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Wednesday, October 11, 2000 12:39
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: which naming attribute ...

Bruce, 
 
Your description of the NDS implementation is correct. Using
aliasedObectName as the RDN has the problem Ron pointed out earlier. One of
the key points of having an alias is to give it a different name. The use of
aliasedObjectName kind of restricts you in that regard.
 
Jim

Sanjay,

Bruce

==============================================
Bruce Greenblatt, Ph. D.
Directory Tools and Application Services, Inc.
http://www.directory-applications.com
<http://www.directory-applications.com> 
See my new Book on Internet Directories: 
http://www.phptr.com/ptrbooks/ptr_0139744525.html
<http://www.phptr.com/ptrbooks/ptr_0139744525.html>