Subject: RE: which naming attribute ...

From: "Ramsay, Ron" <[email-masked]>
Date: Wed, 11 Oct 2000 18:15:26 +1100

I believe it is as Steven says. In particular, aliasedObjectName is a DN an
not realy suitable for use as an RDN!

Ron.

-----Original Message-----
From: Volpers, Helmut [mailto:[email-masked]]
Sent: Wednesday, 11 October 2000 18:06
To: [email-masked]'; 'sanjay jain'; 'ldapext'
Subject: RE: which naming attribute ... 

Hi 

I think Bruce gives the correct definition.

> -----Original Message-----
> From: Steven Legg [mailto:[email-masked]]
> Sent: Mittwoch, 11. Oktober 2000 04:12
> To: 'sanjay jain'; 'ldapext'
> Subject: RE: which naming attribute ... 
> 
> 
> 
> Sanjay,
> 
> Any desired naming attribute could be introduced by:
> 
> (1) subclassing the alias object class,

why do want subclassing of aliases ?
do you want to give an alias additional attributes  (e.g. TN or e-mail
address ?)

> (2) defining an auxiliary object class with the naming attribute and
>     adding the auxiliary class to the alias entry, or
> (3) putting the naming attribute in a DIT content rule for the alias
>     object class.
> 
> I lean towards (1).
> 
> I think there might be implementations that require the 
> naming attribute
> type of the alias to be the same as the aliased entry's 
> naming attribute.

But this is nowhere described in the standards ?

Helmut

> You might want to conform to that.
> 
> Regards,
> Steven
> 
> -----Original Message-----
> From: sanjay jain [mailto:[email-masked]]
> Sent: Wednesday, 11 October 2000 11:49
> To: ldapext
> Subject: which naming attribute ... 
> 
> 
> which naming attribute can be used to create alias objects ? 
> thanks 
>

---

From: "Ismo Heikkonen" <[email-masked]>
Date: Wed, 11 Oct 2000 16:19:54 +0300

X.501 definition for alias object class is:

"alias OBJECT-CLASS ::= {
 SUBCLASS OF { top }
 MUST CONTAIN { aliasedEntryName }
 ID id-oc-alias }
NOTE - The object class alias does not specify appropriate attribute
types for the RDN of an alias entry. Administrative Authorities may
specify subclasses of the class alias which specify useful attribute
types for RDNs of alias entries."

So this is aligned with Steven's choice number 1,

Ismo

- ----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Wednesday, October 11, 2000 10:15 AM
Subject: RE: which naming attribute ...

I believe it is as Steven says. In particular, aliasedObjectName is a
DN an
not realy suitable for use as an RDN!

Ron.

- -----Original Message-----

Hi 

why do want subclassing of aliases ?
do you want to give an alias additional attributes  (e.g. TN or
e-mail
address ?)

Helmut