Subject: Java LDAP API - LDAPConnection.getConstraints

From: "Steve Sonntag" <[email-masked]>
Date: Thu, 19 Oct 2000 12:20:36 -0600

I think the getConstraints and getSearchConstraints methods
of LDAPConnection should be specific as to whether the API
returns a reference to an internal object or whether a reference
to a cloned object is returned.

-Steve

---

From: Rob Weltman <[email-masked]>
Date: Thu, 19 Oct 2000 11:26:06 -0700

Yes. They return a cloned object.

Rob

Steve Sonntag wrote:

>  I think the getConstraints and getSearchConstraints methodsof
> LDAPConnection should be specific as to whether the APIreturns a
> reference to an internal object or whether a referenceto a cloned
> object is returned. -Steve