Subject: JavaLDAP Draft - change to Extended Operation

From: "Steve Sonntag" <[email-masked]>
Date: Mon, 30 Oct 2000 13:53:29 -0700

Previously we discussed adding setValue to LDAPControl,
but a similar method is also needed for LDAPExtendedOperation.

protected void setValue(byte[] newVals);

Both LDAPExtendedOperation and LDAPControl also need

protected void setID(String newoid)

Without these methods a child class is required to know the OID and the BER encoded data at the beginning of its constructor.  Most child classes have to do some manupulation before they have build the BER encoded data and the OID

Should the scope be public or protected?

Probably protected is adequate

-Steve

------------------------
Steve Sonntag
Novell, Inc., the leading provider of Net services software

---

From: Rob Weltman <[email-masked]>
Date: Mon, 30 Oct 2000 12:59:26 -0800

I agree with LDAPExtendedOperation.setValue, but I don't see a need for setID, except for on deserialization. The ID is not computed, it is a constant.

  But we might have to add setID to allow deserialization of an LDAPControl. Does LDAPExtendedOperation need to be serializable?

Rob

Steve Sonntag wrote:

>  Previously we discussed adding setValue to LDAPControl,but a similar method is also needed for LDAPExtendedOperation. protected void setValue(byte[] newVals); Both LDAPExtendedOperation and LDAPControl also need protected void setID(String newoid)  Without these methods a child class is required to know the OID and the BER encoded data at the beginning of its constructor.  Most child classes have to do some manupulation before they have build the BER encoded data and the OID Should the scope be public or protected? Probably protected is adequate
>  -Steve ------------------------
> Steve Sonntag

---

From: "Steve Sonntag" <[email-masked]>
Date: Mon, 30 Oct 2000 15:15:10 -0700

Suppose you have a class that based on the input parameters and
must choose from a selection of OIDs to generate an extended
operation or control , i.e., the class is of an OID multiplexor.

In this case the OIDs constants, but must be chosen and then
put into the constuctor of the class.

-Steve

>>> Rob Weltman <[email-masked]> 30-Oct-00 1:59:26 PM >>>

---

From: Rob Weltman <[email-masked]>
Date: Mon, 30 Oct 2000 14:17:53 -0800

Doesn't that confirm that you don't need a set ID method? The OID multiplexor is a factory for controls or extended operations, invoking the right constructor after figuring out what OID to use.

Rob

Steve Sonntag wrote:

>  Suppose you have a class that based on the input parameters andmust choose from a selection of OIDs to generate an extendedoperation or control , i.e., the class is of an OID multiplexor. In this case the OIDs constants, but must be chosen and thenput into the constuctor of the class. -Steve
>
>   I agree with LDAPExtendedOperation.setValue, but I don't see a need for setID, except for on deserialization. The ID is not computed, it is a constant.  But we might have to add setID to allow deserialization of an LDAPControl. Does LDAPExtendedOperation need to be serializable?
>
> Rob
>
> Steve Sonntag wrote:
>

---

From: "Steve Sonntag" <[email-masked]>
Date: Mon, 30 Oct 2000 15:27:51 -0700

You're right,  don't need setID

we ust need setValue

-Steve

>>> Rob Weltman <[email-masked]> 30-Oct-00 3:17:53 PM >>>
  
Steve Sonntag wrote: