Subject: Java API: LDAPMessage accessor for LDAPException

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 12 Dec 2000 17:23:36 -0700

I've heard a couple people ask how to solve this problem with synchronous calls:

Client sends an extended operation to server. Server returns with extended response but an error condition is present. An LDAPException is thrown and caught by the application, but there is no way to read the extended response.

Can we add a new method to LDAPException -- public LDAPMessage getLDAPMessage()? It would return null if no LDAPMessage is associated with the response.

To date I've told people to use the async methods, but I'd rather the problem just be fixed.

Jim

---

From: Rob Weltman <[email-masked]>
Date: Wed, 27 Dec 2000 19:54:52 -0800

> To date I've told people to use the async methods, but I'd rather the problem just be fixed.

Jim,

  In what cases is there a valid response message as well as an error condition? For the other operation types there is either one or the other.

Rob