Subject: Re: Returning Partial Results for an operation

From: "Haripriya S" <[email-masked]>
Date: Wed, 20 Dec 2000 21:44:57 -0700

Yes but it would then mandate that the server MUST send partial results per entry immediately, and cannot bunch results even if a client wishes so, because the state cannot be conveyed once an abandon is received. 

Thanks and Regards,
Haripriya

>>> Jim Sermersheim 12/21/00 12:45AM >>> 
If the multi-entry operation specification allows for partial results, wouldn't the traditional abandon operation work? i.e. 

Client Server 
---------------------------------------- 
Multi-Delete -----> 
<----------- 0-n partial responses 
Abandon ----------> 
<----------- remaining unsent partial responses 

I do however, wish that abandon had a response. 

>>> "Haripriya S" < [email-masked] > 12/18/00 10:15:24 PM >>> 

LDAP clients today, can start an LDAP operation, and consume the results till the end or abort the operation midway by sending a 'abandon' and not receive any results that were not sent by the server before it received the abandon. It seems that at least in multi-entry operations, it would be useful if a client can send an indication to the server to 'stop' the operation, but still send results that have been generated but not yet sent for the operation. This is like an abandon operation but with a reply. Does this sound like a useful feature? I would like to hear comments on this. 

Thanks and Regards, 
Haripriya

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 20 Dec 2000 21:35:28 -0800

>Yes but it would then mandate that the server MUST send partial results per entry immediately, and cannot bunch results even if a client wishes so, because the state cannot be conveyed once an aband…

Abandon semantics also require the server to defer returning
return results of operations issues subsequent to the abandon
operation until the operation being abandoned has been
abandoned or has completed.

For this reason, I have been considering specifying a new
abandon operation which, like the X.500 abandon operation,
has a response.

Kurt