Subject: Returning Partial Results for an operation

From: "Haripriya S" <[email-masked]>
Date: Mon, 18 Dec 2000 22:15:24 -0700

LDAP clients today, can start an LDAP operation, and consume the results till the end or abort the operation midway by sending a 'abandon' and not receive any results that were not sent by the server before it received the abandon. It seems that at least in multi-entry operations, it would be useful if a client can send an indication to the server to 'stop' the operation, but still send results that have been generated but not yet sent for the operation. This is like an abandon operation but with a reply. Does this sound like a useful feature? I would like to hear comments on this.

Thanks and Regards,
Haripriya

---

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 20 Dec 2000 12:15:48 -0700

If the multi-entry operation specification allows for partial results, wouldn't the traditional abandon operation work? i.e.

Client             Server
----------------------------------------
Multi-Delete ----->
      <----------- 0-n partial responses
Abandon ---------->
      <----------- remaining unsent partial responses

I do however, wish that abandon had a response.

>>> "Haripriya S" <[email-masked]> 12/18/00 10:15:24 PM >>>

Thanks and Regards,
Haripriya

---

From: "Timothy Hahn" <[email-masked]>
Date: Wed, 27 Dec 2000 07:10:41 -0500

Hi all,

When I read the two alternatives, the extended operation seemed to be a 
"better fit" than using a control on an abandon.

Having a control signal that an additional protocol element (a response) 
be sent doesn't seem as "clean" as using an extended operation where a 
request and response are both defined protocol elements.  I can't phrase 
my thoughts on this any better than that but hopefully this makes sense to 
most of you.

Regards,
Tim Hahn

Internet: [email-masked]
Internal: Timothy Hahn/Endicott/IBM@IBMUS or IBMUSM00(HAHNT)
phone: 607.752.6388     tie-line: 8/852.6388
fax: 607.752.3681