Subject: vlv without sss

From: "John Liang" <[email-masked]>
Date: Tue, 5 Dec 2000 13:47:36 -0500

HI there,

If there is no Server Side Sorting control with VLV control,
should the server return unsorted result or just send an error
message back to the client?

And Does the criticality value relative at this case?

Thanks,
--
John Liang

---

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 05 Dec 2000 12:10:05 -0700

In this case, the control is not being sent properly. The operation should fail (most likely with a protocol error) and a vlv response control sent with the error sortControlMissing (60) set. The criticality shouldn't matter in this case. RFC 2251 says that the criticality is only evaluated for two cases, 1) whether the control is recognized, 2) whether the control is appropriate for the operation (an innapropriate case would be the VLV control on a bind operation).

Jim

>>> "John Liang" <[email-masked]> 12/5/00 11:47:36 AM >>>
HI there,

Thanks,
--
John Liang