Subject: Replication protocol element definitions

From: "Mangal Vithal Shriram" <[email-masked]>
Date: Mon, 19 Feb 2001 02:41:14 -0700

Hi,
I have been working on LDUP. I have studied a LDUP replication update protocol document. I have some questions on the definitions of StartReplicationResponse  and EndReplicationResponse.

The StartReplicationResponse extended operations are defined as follws

StartReplicationResponse::=[APPLICATION 23] SEQUENCE {
              requestName        [0]LDAPOID,
              requestValue         [1]OCTET STRING
}

reuestValue::=SEQUENCE {
             responseCode                      LDUPResponseCode,
             replicaUpdateVector          Attribute
}

Actually LDAP extended operation response should have APPLICATION  tag  24. and the context tag of requestName and requestValue should be 10 and 11 resply. 

If you don't change this tag LDAP client will not understand this reponse unless you change currently availabe LDAP sdk library API 

So to  preserve a LDAP operations definitions can't we change the definitions of  StartReplicatioRequest  and EndReplicationRequest to LDAP extended reponse. 

Expecting a early response.

Thanks and Regard
mangal

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 19 Feb 2001 16:25:50 -0800

>I have been working on LDUP. I have studied a LDUP replication update protocol document. I have some questions on the definitions of StartReplicationResponse  and EndReplicationResponse.

These definitions should be written in terms of
the ASN.1 provided in RFC 2251.

Kurt