Subject: RE: several counts (Was: WG Last Call on the LDAPv3 Directory Replication I-D)

From: "Mark Brown (REDMOND)" <[email-masked]>
Date: Tue, 20 Feb 2001 19:01:22 -0800

If the concept of "passive data" becomes one of the
characteristics that defines when it is OK for two
LDAP directory servers to replicate via LDUP, then
directory implementors will be forced to pay attention
to the concept. The guarantee that "passive data" won't
abuptly turn to "active data" will be made by the directory
implementor. If the directory implementor lies, and
LDUP replication causes security or corruption problems
as a result, the directory implementor will be in hot
water with the person who bought his server.

Similarly, if some attribute is passive in one DS
and active in another, then clearly the two shouldn't
replicate via LDUP.

We require some way to characterize what directories
can sensibly replicate and what directories can not.
"Passive data" (or "userApplication") is a well-defined 
proposal. If you have a better proposal you should
make it, but we need some characterization because the
requirement is not going away.

--mark

-----Original Message-----
From: John Strassner [mailto:[email-masked]]
Sent: Tuesday, February 20, 2001 2:47 PM
To: Paul Leach
Cc: Kurt D. Zeilenga; John Strassner; [email-masked]
Subject: RE: several counts (Was: WG Last Call on the LDAPv3 Directory
Replication I-D)

Thanks for providing a better definition, but I still don't see how we
can 
use this one. There's no guarantee, for instance, that what is at one 
moment in time "passive" data won't change to "active data" soon 
thereafter. This means that the data can't be consistently nor 
deterministically characterized as either "passive" or "active". Plus,
data 
of a particular type or use may be active in one replica and passive in 
another. There are yet more variations that we could consider, but I
think 
that these are plenty for now.

If you can solve these and related problems, please respond. Otherwise, 
let's just drop the use of the term.

thanks,
John

At 02:19 AM 2/20/2001 -0800, Paul Leach wrote:

> > -----Original Message-----
> > From: Kurt D. Zeilenga [mailto:[email-masked]]
> > Sent: Monday, February 19, 2001 3:03 PM
> > To: John Strassner
> > Cc: [email-masked]
> > Subject: Re: several counts (Was: WG Last Call on the LDAPv3
Directory
> > Replication I-D)
> >
> > >Second, please stop using the term "passive data" as no one
> > on this list has defined it in an unambiguous and
> > satisfactory manner. It is impossible to consider using LDUP
> > in this fashion until a definition for this term that we can
> > all agree with is offered and agreed to.
> >
> > I agree.  I believe we should use the term "userApplication"
> > attribute.
> > This is well defined.
>
>Well, I used "passive data" recently, and I don't know if
>"userApplication" is at all related.
>
>What I mean by "passive data" is this: An attribute may be said to be
>"passive data" when
>a write to the attribute followed by a read of the same attribute
>returns exactly the data written, and no other attribute's value is
>affected.
>
>An attribute that is not "passive data" is "active data". A directory
>may be LDAP compliant and still contain active data. Two different
>directory implementations may therefore be LDAP compliant yet implement
>different forms of active data (different attributes may be active, for
>example). However, issues have been raised about the ability to
>replicate active data, between directories that implement their active
>data differently, and hence on the viability of the requirement that
>LDUP be able to replicate any LDAP compliant directory.

---

From: Jerry Combs <[email-masked]>
Date: Tue, 20 Feb 2001 20:10:44 -0800

In most implementations there are no attributes that meet your definition of
"passive". Any write normally results in changes to operational attributes
such as modificationTimeStamp or lastModifiedBy. I fail to see the value of
the distinction between "active" and "passive" data.