Subject: draft-ietf-ldup-subentry-08.txt (with attachment, this time)

From: "Ed Reed" <[email-masked]>
Date: Fri, 06 Apr 2001 09:41:43 -0600

Please publish the attached (really!) revised draft.

Abstract:

This document describes an administrative model for LDAP, 
 and an object class called ldapSubEntry and a control 
 ldapSubentriesControl (to control the visibility of entries 
 of type ldapSubEntry) that are to be used by directory 
 servers claiming support for the administrative model 
 defined here. 

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 796 7065
http://www.Reed-Matthews.COM

---

From: "Albert Langer" <[email-masked]>
Date: Mon, 9 Apr 2001 03:59:21 +1000

I am opposed to adoption of an administrative model for LDAP via
what was originally supposed to be a subentry specification for LDUP.

The administrative model has already been standardized by X.500 and
any "simplification" of it should be undertaken very carefully
based on a thorough understanding. Such work should be done in
LDAP-EXT or a new WG and only after close liaison with relevant
X.500 WGs has been established (LUDP should also be involved in
liaison but it clearly affects both X.500 and LDAP without
regard to replication).

The overview of the X.500 model within the subentry draft is
itself sufficient demonstration that LDUP lacks the expertize
to do this work, as it is clearly wrong and has remained so
after errors were pointed out.

Current discussions indicate complete confusion about elementary
matters like the purpose and function of Naming Context which
must be understood for namespace management and name resolution in
a distributed directory, even without regard to further complications
in relation to replicated areas.

Since LDUP has not been chartered to do this work I formally
request that it be withdrawn from the sub-entry draft and
submitted separately as an individual submission.

Recently Ed responded re UUIDs:

"Tim - it's within the proper scope of draft-ietf-ldup-infomod.  ;-)"

There is currently no such document. I drew Ed's attention to this
privately prior to the recent IETF. In my view he should fix that
before undertaking to redesign the X.500 administrative model.

(BTW That is also a response to Kurt's correct suggestion that I should
refresh MDCR to solicit discussion. After careful consideration I
do not wish to solicit discussion of MDCR while the WG remains in its
current state, but am simply making the text available for anyone
who wants to look by having placed it in the list archives.)

Ed should publish a revised architecture draft with whatever
the conclusions are from his recent discussions with Steve, so
that if we get a final call on requirements as has been formally
requested by the editors, it will be possible to figure out what
they are talking about concerning their objections (or conclude
that they do not know themselves) rather than being delayed.

PS I am in broad agreement with many of Ed's comments in recent
messages concerning the need for (floating or failover) single masters
for various aspects such as schema management and namespace management.

I again recommend study of the method used in Active Directory.

Also agree with substance of Kurt's comments:

vvvvvvvvvvvvv
It seems many of the concepts of which LDUP is based upon
just cannot be described using LDAP/X.500 terminology.  That
is, it seems quite difficult to describe a system supporting
multiple-master replication using models designed for
single-master.

>So - what does LDUP need to do or say?

Well, I think the group needs to slash a few requirements.
First, I'd eliminate multiple-master fractional replication.
Then, I'd start examining the question "who is authoritative
over an entry?" because until you answer this, you cannot
design the administrative model.
^^^^^^^^^^^^^^

However my conclusion would be, as perhaps Kurt was
hinting, that LDUP needs to understand and then fit
in with LDAP/X.500 concepts rather than adopting an
indescribable architecture.

Do not agree with earlier remark in same message that:

"Naming contexts are just one part of the administrative
model [...]"

(though I agree broadly with the omitted point actually
being made).

Naming Contexts are part of the distribution model, which
LDUP still has no real understanding of, despite it's
importance for understanding replication issues.

My view on what LDUP needs to do is start by publishing
tutorial material and working it's way towards a glossary
to get some common understanding of basic concepts.

First however it needs to do some summing up of how we
got where we are and have people assigned to perform
essential functions for Facilitator, Secretary, and
Consultant familiar with IETF architecture and standards
process as the WG co-chairs are still plainly AWOL and
have still not been replaced.

Meanwhile I don't see much point in discussing issues
on which there are no I-Ds as well no point in publishing
WG I-Ds (as opposed to individual submissions) on subjects
for which we have no charter.

Either somebody actually does something to get LDUP
functional as an IETF WG or it will continue just
drifting aimlessly.

At this stage I do not feel any obligation to respond
to bits and pieces of the drifting and will simply,
follow the discussions without participating (except
at final calls) until something is done.

I do believe there is some obligation to speak up
during discussions on the list rather than wait until
final call, but at present this seems to me a waste
of time and effort. So I am just generically putting
on record that I *have* spoken up and did not agree
with whatever was being discussed prior to whatever
it is that may or may not be submitted as an I-D
to a final call and will just review whatever
documents somebody claims are "final" each time I see
yet another "final" version.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Ed Reed
Sent: Saturday, April 07, 2001 1:42 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; Ed Reed; [email-masked]
Subject: draft-ietf-ldup-subentry-08.txt (with attachment, this time)

Abstract:

=================
Ed Reed
Reed-Matthews, Inc.
+1 801 796 7065